Yayımlanan form şablonuna yeni bir SharePoint kitaplığına gitme

Önemli : Bu makale makine çevisidir. Bkz. yasal uyarı. Bu makalenin İngilizce sürümüne buradan ulaşabilirsiniz.

Bu makalede

Genel bakış

Başlamadan önce

Form şablonunuzu çalışan bir kopyasını alma

Adım 1: form şablonuna yeni belge kitaplığına yayımlama

Adım 2: Kopyalama ve varolan formları Yeniden Bağla

Genel Bakış

Bir form şablonunu kullanıcıların doldurabilmesi için bir belge kitaplığına yayımladıktan sonra, bu form şablonunu başka bir form kitaplığına taşımanız gerekebilir. Örneğin form şablonunuzu daha fazla kapasiteye sahip bir sunucuya taşıyarak daha fazla kullanıcının formları aynı anda doldurabilmesini sağlamanız gerekebilir. Bazı kullanıcılar özgün belge kitaplığında depolanan form şablonunuzu esas alan formları önceden doldurmuş olabilir. Form şablonunuzu yeni bir belge kitaplığına taşıdığınızda, varolan formları da taşımak istersiniz. Ayrıca, eski belge kitaplığını arşivlemeden veya silmeden önce söz konusu varolan formların yeni belge kitaplığında çalıştığından emin olmalısınız.

İpucu : Yayımlanmış form şablonlarını yeni belge kitaplığına taşımadan önce kullanıcıları formlarının yeni belge kitaplığına taşındığı konusunda bilgilendiren bir plan oluşturun. Kullanıcıların yeni belge kitaplığını yeni formları depolamak veya varolan formları değiştirmek için kullanmalarını istiyorsunuz. Plan, özgün belge kitaplığını arşivleme veya silme işlemini de kapsamalıdır.

Bir form şablonunu ve varolan formlarını yeni belge kitaplığına taşımak için ilk olarak form şablonunuzun çalışma kopyasını yeni belge kitaplığına yayımlamanız gerekir. Çalışma kopyası, bilgisayarınızda veya Microsoft Visual SourceSafe gibi bir sürüm denetim programında depolanan örnektir.

İpucu : Form şablonunuzun çalışma kopyası yoksa, bir kopyasını özgün belge kitaplığından bilgisayarınıza kopyalayarak çalışma kopyası olarak kullanabilirsiniz.

Çalışma kopyasını yeni belge kitaplığına kopyaladıktan sonra, tüm formları eski belge kitaplığından yeni belge kitaplığına kopyalamanız ve ardından yeni belge kitaplığındaki formları yeni yayımlanmış form şablonuna yeniden bağlamanız gerekir.

Form şablonunu taşımanızdan dolayı herhangi bir değişiklik yapmanız gerekirse, bu değişiklikleri form şablonunu yayımlamadan önce yapın. Örneğin bu form şablonunu esas alan formların kullandığı dış veri kaynağının konumu, form şablonunun taşınmasından dolayı değişebilir. Bu durumda form şablonunu yayımlamadan önce form şablonundaki veri bağlantısını dış veri kaynaklarındaki yeni konum ile değiştirmeniz gerekir. Veri bağlantılarını değiştirme hakkında daha fazla bilgi için Ayrıca bkz. bölümünde yer alan bağlantıları takip edebilirsiniz.

Not : Form şablonunu yayımlama form şablonunu kaydetme aynı değildir. Form şablonunu yayımlama, Yayımlama Sihirbazı'nı yayımlama konumu ve böylece kullanıcılar bu form şablonunu temel alan formlar açabilirler işleme yönergeleri form şablonuna ekler. Form şablonunu kaydettiğinizde, form şablonunu bir kopyasını bilgisayarınıza bir dosyayı kaydettiğinizde, yaptığınız gibi kaydediyorsanız. Form şablonunuzu dolduracağı kullanıcılarınız için kullanılabilir yapmak istediğinizde, her zaman Yayımlama Sihirbazı'nı kullanmalısınız.

Sayfanın Başı

Başlamadan önce

Form şablonunu ve bunu esas alan varolan tüm formları yeni belge kitaplığına taşımadan önce aşağıdakilere ihtiyacınız olacaktır:

  • Form şablonunun çalışma kopyası    Bu, form şablonunun değiştireceğiniz ve ardından yeni belge kitaplığına yayımlayacağınız kopyasıdır. Çalışma kopyasını bilgisayarınızda veya Visual SourceSafe gibi bir sürüm denetim programında depolayabilirsiniz.

  • Yeni dış veri kaynaklarının konumları    Form şablonunu esas alan formlarda değiştirilmiş dış veri kaynakları kullanılıyorsa, dış veri kaynaklarının yeni konumlarına ihtiyacınız olacaktır. Sizin ve kullanıcıların dış veri kaynaklarını kullanmaya yönelik gerekli izinlere sahip olduğunuzu yöneticinize danışarak doğrulayın. Form şablonu bir dış veri kaynağına bağlanmak üzere veri bağlantı dosyasındaki ayarları kullanıyorsa, veri bağlantı dosyasının dış veri kaynağının yeni konumu ile güncelleştirildiğini doğrulayın.

  • Windows SharePoint Services 3.0 çalıştıran sunucuda uygun haklar    Bir form şablonunu yayımlamak ve varolan formları eski belge kitaplığından yeni belge kitaplığına kopyalamak için uygun haklara sahip olmanız gerekir. Bu haklara sahip olup olmadığınızı yöneticinize danışın.

Sayfanın Başı

Form şablonunuzun bir çalışma kopyasını alma

Belge kitaplığına veya paylaşılan ağ konumuna yayımlanan form şablonunu değiştirmek istiyorsanız ve form şablonunuzun bir çalışma kopyası yoksa, form şablonunuzun çalışma kopyasını, yayımlama konumundan bilgisayarınıza kaydedebilirsiniz.

İpucu : Form şablonlarınızın çalışma kopyalarını yönetmek için, Microsoft Visual SourceSafe gibi bir sürüm denetim programı kullanabilirsiniz.

Form şablonunun kopyasını belge kitaplığından bilgisayarınıza kaydetme

  1. Web tarayıcısında, form şablonunun yayımlanmış olduğu belge kitaplığını açın.

  2. Ayarlar menüsünde Ayarlar'ı ve ardından Form Kitaplığı Ayarları'nı tıklatın.

  3. Genel Ayarlar'ın altında Gelişmiş ayarlar'ı tıklatın.

  4. Belge Şablonu bölümünde Şablonu Düzenle'yi tıklatın.

    Form şablonu Microsoft Office InfoPath'te açılır.

  5. Microsoft Office InfoPath iletişim kutusunda Evet'i tıklatın.

  6. Dosya menüsünde Farklı Kaydet'i tıklatın.

  7. Microsoft Office InfoPath iletişim kutusunda Tamam'ı tıklatın.

  8. Farklı Kaydet iletişim kutusunda, form şablonunun kopyasını kaydetmek istediğiniz yere girin ve ardından Kaydet'i tıklatın.

Form şablonunun kopyasını paylaşılan ağ klasöründen bilgisayarınıza kaydetme

  1. Dosya menüsünde Form şablonu tasarla'yı tıklatın.

  2. Form şablonu aç'ın altında Bilgisayarım Üzerinde'yi tıklatın.

  3. Yayımlanan form şablonunun paylaşılan ağ klasörüne göz atın, form şablonunu tıklatın ve ardından 'ı tıklatın.

  4. Dosya menüsünde Farklı Kaydet'i tıklatın.

  5. Microsoft Office InfoPath iletişim kutusunda Tamam'ı tıklatın.

  6. Farklı Kaydet iletişim kutusunda, form şablonunun çalışma kopyasını kaydetmek üzere özgün yayımlama konumu dışında bir konum seçin ve ardındanKaydet'i tıklatın.

Sayfanın Başı

1. Adım: Form şablonunu yeni belge kitaplığına yayımlama

  1. Form şablonunun çalışma kopyasını tasarım modunda açın.

  2. Dosya menüsünde, Yayımla'ya tıklayın.

  3. Yayımlama Sihirbazı'nda InfoPath Forms Services olsun veya olmasın bir SharePoint sunucusuna seçeneğini, ardından İleri'yi tıklatın.

  4. SharePoint veya InfoPath Forms Services sitenizin konumun girin kutusuna form şablonunuzu taşımak istediğiniz yeni belge kitaplığını içeren SharePoint sitesinin konumunu yazın ve İleri'yi tıklatın.

  5. Sihirbazın bir sonraki sayfasında, Belge Kitaplığı seçeneğini ve ardından İleri'yi tıklatın.

  6. Yeni belge kitaplığı oluştur seçeneğini ve ardından İleri'yi tıklatın.

  7. Sihirbazın bir sonraki sayfasında, yeni belge kitaplığı için bir ad ve açıklama yazıp İleri'yi tıklatın.

  8. Belge kitaplığının varsayılan görünümünde sütun olarak görüntülenmesini istediğiniz alanları form şablonundan seçin.

    Nasıl mı?

    1. Ekle'yi tıklatın.

    2. Belge kitaplığına sütun olarak eklemek istediğiniz alanı seçin ve sonra aşağıdakilerden birini yapın:

      • Sütun adı kutusuna sütun için bir ad yazın.

      • Site sütun grubu listesinde site sütununu seçin, Sütun adı listesinde ad seçin ve sonra Tamam'ı tıklatın.

        Not : Verileri belge kitaplığında görüntülemek üzere yinelenen alan seçtiyseniz, İşlev listesindeki bir değeri tıklatarak alanı belge kitaplığında nasıl görüntülemek istediğinizi tanımlayabilirsiniz. Alandaki ilk değeri, alandaki son değeri veya alanın kaç kez yinelendiğini gösteren sayıyı görüntülemeyi seçebileceğiniz gibi, tüm alanların birleştirilip birleştirilmeyeceğini de seçebilirsiniz.

    3. Tamam'ı tıklatın.

    Belge kitaplığında verilerin sütunlar halinde görüntülenmesi hakkında daha fazla bilgi için Ayrıca bkz. bölümündeki bağlantıları takip edebilirsiniz.

  9. İleri'yi tıklatın.

  10. Sihirbazın bir sonraki sayfasında, gösterilen bilgileri doğrulayın ve Yayımla'yı tıklatın.

  11. Belge kitaplığını açmak ve bu form şablonunu esas alan formu doldurma sürecini sınamak için Bu belge kitaplığını aç onay kutusunu işaretleyin ve ardından Kapat'ı tıklatın.

    Belge kitaplığı bir Web tarayıcısında açılacaktır. Liste araç çubuğunda Yeni seçeneğini tıklattığınızda, Microsoft Office InfoPath'te bu form şablonunu esas alan bir form açılacaktır.

Form şablonunu yeni belge kitaplığına yayımladıktan sonra form şablonunun eski halini esas alan formları eski belge kitaplığından yeni belge kitaplığına yapıştırabilirsiniz. Varolan formları yapıştırdıktan sonra, bu formlar ile yeni form şablonu arasında yeniden bağlantı kurabilirsiniz. Varolan formları bağlamazsanız kullanıcılar bu formları açamayabilir.

Sayfanın Başı

2. Adım: Varolan formları kopyalama ve yeniden bağlama

Bu yordamda her iki belge kitaplığının da Windows SharePoint Services 3.0 çalıştıran bir sunucuda bulunduğu varsayılmaktadır.

  1. Eski belge kitaplığını Web tarayıcısında açın.

  2. Görünüm menüsünden Explorer Görünümü'nü tıklatın.

  3. CTRL tuşunu basılı tutun, taşımak istediğiniz formları seçin ve bu formlardan birini sağ tıklatın.

  4. Internet Explorer iletişim kutusunda Evet seçeneğini ve ardından kısayol menüsünde Kopyala seçeneğini tıklatın.

  5. Yeni belge kitaplığını açın.

  6. Bir Görünüm Seç altında Explorer Görünümü'nü tıklatın.

  7. Klasör penceresinde boş alanı sağ tıklatın.

  8. Internet Explorer iletişim kutusunda Evet seçeneğini ve ardından kısayol menüsünde Yapıştır'ı tıklatın.

  9. Görünüm menüsünden Belgeleri Yeniden Bağla'yı tıklatın.

  10. Yeniden Bağla sütununda, yeni form şablonuna bağlamak istediğiniz her formun onay kutusunu işaretleyin.

  11. Liste araç çubuğunda Seçili Belgeleri Yeniden Bağla'yı tıklatın.

Varolan formlarınızı yeni form şablonuna yeniden bağladıktan sonra, Kullanıcılar yeni belge kitaplığına kopyaladığınız formları değiştirebilir veya yeni yayımlanan form şablonunu esas alan yeni formları doldurabilir.

Sayfanın Başı

Not : Makine Çevirisi Yasal Uyarısı: Bu makale, insan müdahalesi olmadan bir bilgisayar sistemi tarafından çevrilmiştir. Microsoft bu makine çevirilerini İngilizce bilmeyen kullanıcıların Microsoft ürünleri, hizmetleri ve teknolojileriyle ilgili içeriklerden yararlanmasına yardımcı olmak için sunar. Bu makale makine çevirisi olduğundan sözcük, cümle dizilimi ve gramer hataları içerebilir.

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×