YADA işlevi

Mantıksal işlevlerden biri olan YADA işlevini, bir testteki koşullardan herhangi birinin DOĞRU olup olmadığını saptamak için kullanın.

Örnek

YADA işlevinin kullanım örnekleri.

YADA işlevi, bağımsız değişkenlerinden herhangi biri DOĞRU olarak değerlendirilirse DOĞRU'yu döndürür ve tüm bağımsız değişkenleri YANLIŞ olarak değerlendirilirse YANLIŞ'ı döndürür.

YADA işlevinin yaygın kullanımlarından biri de, mantıksal test yapan diğer işlevlerin kullanışlılığını artırmaktır. Örneğin EĞER işlevi, bir mantıksal test gerçekleştirir ve test DOĞRU olarak değerlendirildiğinde bir değeri, YANLIŞ olarak değerlendirildiğinde de başka bir değeri döndürür. YADA işlevini, EĞER işlevinin mantıksal_sınama bağımsız değişkeni olarak kullanarak, tek bir koşul yerine birden fazlasını test edebilirsiniz.

Söz dizimi

YADA(mantıksal1, [mantıksal2], …)

YADA işlevinin söz diziminde aşağıdaki bağımsız değişkenler bulunur:

Bağımsız Değişken

Açıklama

Mantıksal1

Gerekli. Test etmek istediğiniz ve DOĞRU veya YANLIŞ olarak değerlendirilebilecek ilk koşul.

Mantıksal2, ...

İsteğe bağlı. Test etmek istediğiniz ve DOĞRU veya YANLIŞ olarak değerlendirilebilecek ek koşullar; en çok 255 koşul bulunabilir.

Notlar

  • Bağımsız değişkenlerin DOĞRU veya YANLIŞ gibi mantıksal değerleri veya mantıksal değerler içeren dizileri veya başvuruları değerlendirmeleri gerekir.

  • Bir dizi veya başvuru bağımsız değişkeni metin veya boş hücreler içeriyorsa, bu değerler dikkate alınmaz.

  • Belirtilen aralık mantıksal değer içermiyorsa, YADA işlevi #DEĞER! hata değerini döndürür.

  • Bir dizide bir değerin olup olmadığını görmek için YADA dizi formülü kullanabilirsiniz. Dizi formülü girmek için, CTRL+SHIFT+ENTER'a basın.

Örnekler

YADA işlevinin kendi başına ve EĞER ile kullanımına yönelik örnekleri aşağıda bulabilirsiniz.

YADA işlevinin EĞER işleviyle birlikte kullanılmasının örnekleri.

Formül

Açıklama

=YADA(A2>1,A2<100)

A2 hücresinin değeri 1’den büyükse YA DA 100’den küçükse DOĞRU değerini görüntüler, bunun dışındaki durumlarda YANLIŞ değerini görüntüler.

=EĞER(YA DA(A2>1,A2<100),A3,"Değer aralığın dışında")

A3 hücresindeki değer 1’den büyük YA DA 100’den küçükse, bu değeri görüntüler. Değilse, "Değer aralığın dışında" iletisini görüntüler.

=EĞER(YA DA(A2<0,A2>50),A2,"Değer aralığın dışında")

A2 hücresindeki değer 0’dan küçükse YA DA 50’den büyükse, bu değeri görüntüler. Değilse, iletiyi görüntüler.

Satış Komisyonu hesaplama

Burada, EĞER ve YADA işlevlerini kullanarak satış elemanlarının komisyon almaya hak kazanıp kazanmadığını hesaplamamız gereken oldukça yaygın bir senaryo verilmiştir.

Satış komisyonunu hesaplamak için EĞER ve YADA işlevlerini kullanma örneği.
  • =EĞER(YADA(B14>=$B$4,C14>=$B$5),B14*$B$6,0) - EĞER Toplam Satış değeri Satış Hedefinden büyük veya ona eşitse (>=) YADA Hesaplar Hesap Hedefinden büyük veya ona eşitse (>=), Toplam Satışı Komisyon Yüzdesi ile çarp; değilse 0 döndür.

Daha fazla yardım mı gerekiyor?

Sorularınızı Excel Teknoloji Topluluğu’ndaki uzmanlara sorabilir, Yanıt topluluğu’ndan destek alabilir ya da Excel için UserVoice platformuna yeni bir özellik veya iyileştirme önerisi sunabilirsiniz.

İlgili Konular

Video: Gelişmiş EĞER işlevleri
Formülde iç içe geçen işlevler kullanmayı öğrenin
EĞER işlevi
VE işlevi
DEĞİL işlevi
Excel formüllerine genel bakış
Bozuk formülleri önleme
Formüllerdeki hataları saptamak için hata denetimini kullanma
Windows için Excel 2016’da klavye kısayolları
Mac için Excel 2016’da klavye kısayolları
Mantıksal işlevler (başvuru)
Excel işlevleri (alfabetik sıraya göre)
Excel işlevleri (kategoriye göre)

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×