Windows için Excel 'de çalışma kitabını SharePoint sitesine yayımlama

Bir çalışma kitabını Microsoft SharePoint kitaplığında yayımlayabilirsiniz ve böylece kişiler bilgisayarlarında Excel yüklü olmasına gerek kalmadan çalışma kitabını web tarayıcısında görüntüleyebilir veya düzenleyebilirler. Yayımlama aslında kaydetme ile aynı işlemdir; ancak kişiler çalışma kitabını tarayıcıda açtıklarında görebilecekleri öğeleri denetlemenize izin veren bazı yerleşik seçenekler sunar.

Bir çalışma kitabını merkezi bir SharePoint sitesine kaydetme veya yayımlama gibi bir uygulamanın kuruluşunuz çapında benimsenmesi, aynı çalışma kitabının biraz farklı sürümlerinin e-posta ile gönderildiğinde kuruluşunuzun her yanında ortaya çıkmamasını sağlamanıza yardımcı olabilir.

Bazı yayımlama seçeneklerini ayarlayarak, çalışma kitabınızın grafikler gibi belirli bölümlerini vurgulayabilir veya diğer bölümlerinin tarayıcıda görüntülenmesini engelleyebilirsiniz. Örneğin, bir grafiği gösterebilir, ancak temelini oluşturan verileri gizleyebilirsiniz. Ya da görmesi gereken kişilere yalnızca belirli çalışma sayfalarını gösterirken, diğer çalışma sayfalarını gizleyebilirsiniz.

Bu makalede, Windows için Excel 'den bir çalışma kitabını nasıl yayımlayacağınız ve bir çalışma kitabı veya çalışma kitabı verilerinin bir SharePoint sayfasındaki Excel Web Access Web bölümüne bağlanması konusu yer almıyor.

Çalışma kitabını bir SharePoint sitesinde yayımladığınızda tüm çalışma kitabı SharePoint'e kaydedilir. Gerekli SharePoint izinlerine sahip bir kullanıcı gerek tarayıcıda gerekse Excel masaüstü programında tüm çalışma kitabını görüntüleyebilir ve verileriyle çalışabilir.

SharePoint'te Web için Office dağıtılırsa, verilerinizin tarayıcıda görüntülenmesi ve üzerinde çalışılması, Excel masaüstü programında verilerinizle çalışmaya çok benzeyebilir. Aslında, Excel masaüstü programından farklı olarak tarayıcı kılavuzunda aynı anda birden fazla kullanıcı çalışma kitabını düzenleyebilir. Çalışma kitabını tarayıcıda görüntülediğinizde Excel Online’te düzenle düğmesi görünüyorsa, Web için Office'in kullanılmaya hazır olduğunu anlayabilirsiniz.

Çalışma Kitabını Düzenle menüsünde Excel Online’da Düzenle

Çalışma kitabını hazırlama

Çalışma kitabını yayımlamadan önce, yalnızca tarayıcıda görünmesini istediğiniz çalışma sayfalarını veya öğeleri seçmeyi tercih edebilirsiniz. Bu modda nelerin görüntülenebilir olacağını sınırlayabilseniz de, çalışma kitabının tüm içeriğinin yine de SharePoint sunucusuna kaydedileceğini unutmayın.

Grafikler veya Özet Tablolar gibi diğer öğelere ek olarak çalışma sayfalarının tamamını bir öğe olarak dahil etmek istiyorsanız, çalışma sayfasının tamamını adlandırılmış bir aralık olarak tanımlayın. Çalışma sayfasının tamamını seçin ve sonra adlandırılmış bir aralık tanımlayın. Bu adlandırılmış aralık daha sonra siz yayımlamaya hazır olduğunuzda Yayımlama Seçenekleri iletişim kutusunda kullanılabilir bir öğe olarak görüntülenir.

Kullanıcıların başka bir hücredeki formülle çalışmak için hücreye değer girebilmelerini isterseniz, çalışma kitabını yayımlamadan önce bu hücreyi Excel'de tanımlı bir ad olarak ayarlayın. Daha sonra, Tarayıcı Görünümü Seçenekleri iletişim kutusundaki Parametreler sekmesinde bu tanımlı adı bir parametre olarak ekleyebilirsiniz.

Örneğin, aşağıda tanımlı adı "Oran" olan bir D2 hücresi gösterilmektedir. Tarayıcıda, bir kullanıcı Parametreler bölmesindeki Oran kutusuna 5,625 değerini girer ve Uygula'ya tıklar. Daha sonra bu değer D2 hücresinde görünür ve A2 hücresindeki formül D2'deki değeri kullanır. Formülün sonucu yeniden hesaplanır ve A2 hücresinde 1.151,31 TL olarak gösterilir.

Bölmeye bir parametre girildiğinde bu değer D2 hücresinde kullanılır

Not: Excel tablosu için dilimleyiciler oluşturur ve tablo ve dilimleyicileri içeren hücre aralığı için bir ad tanımlarsanız, tanımlı aralığı yayımlamanız durumunda tarayıcıda tabloya filtre uygulamak için dilimleyicileri kullanamazsınız. Tabloyu ya da tüm çalışma sayfasını veya çalışma kitabını yayımlarsanız, dilimleyiciler tarayıcıda olması beklendiği gibi çalışır.

Çalışma kitabını yayımlama

  1. Dosya sekmesine tıklayın, Farklı Kaydet'e tıklayın ve sonra da SharePoint'e tıklayın.

  2. SharePoint klasörünüzü geçerli, en sonveya daha eskialtında görüyorsanız, istediğiniz klasörü tıklatın.

    Farklı Kaydet iletişim kutusu görüntülenir.


    Yoksa, Gözat'a tıklayın, SharePoint sitesinin web adresini girin ve ardından çalışma kitabınızı yayımlamak istediğiniz klasöre gidin.

    Bir SharePoint klasörüne veya Gözat'a tıklayın
  3. Çalışma kitabından yayımlamak üzere tek tek çalışma sayfalarını veya öğeleri seçmek için, Tarayıcı Görünümü Seçenekleri'ne tıklayın.

    Farklı Kaydet iletişim kutusunda, Tarayıcı Görüntüleme Seçenekleri’ne tıklayın

    Göster sekmesini ve Parametreler sekmesini görürsünüz.

  4. Doğrudan çalışma sayfasının tamamını yayımlamak istiyorsanız, Kaydet'e tıklayın. Bunun dışındaki durumlarda, aşağıdakilerden birini yapın:

    • Tarayıcıda çalışma kitabının tamamını göstermek için, Göster sekmesinde, liste kutusundan Tüm Çalışma Kitabı seçimini yapın.

    • Tarayıcıda yalnızca belirli çalışma sayfalarını göstermek için, Göster sekmesinde, liste kutusundan Sayfalar seçimini yapın ve sonra tarayıcıda gizli olmasını istemediğiniz sayfaların onay kutularını temizleyin.

      Varsayılan olarak tüm sayfalar seçilir. Onay kutularından bazılarının işaretini kaldırdıktan sonra tüm sayfaları kısa sürede görünür hale getirmek için Tüm Sayfalar onay kutusunu seçin.

    • Tarayıcıda yalnızca belirli öğeleri göstermek için (adlandırılmış aralıklar, grafikler, tablolar veya PivotTable'lar gibi), Göster sekmesinde, liste kutusundan Çalışma Kitabındaki Öğeler seçimini yapın ve sonra göstermek istediğiniz öğelerin onay kutularını seçin.

    • Parametreler sekmesinde, kullanıcılar tarayıcıda çalışma kitabını görüntülediğinde düzenlenebilir hücreleri belirtmek için kullanmak istediğiniz tanımlı adları ekleyin ve ardından Tamam'a tıklayın.

  5. Çalışma kitabını kaydedin.

Notlar: 

  • Aynı ada (grafik ve temel veri tablosu gibi) sahip öğeleri seçerseniz, tarayıcıda bu öğelerden yalnızca biri kullanılabilir. Tüm öğeleri göstermek için, çalışma kitabındaki her öğenin benzersiz bir adı olduğundan emin olun.

  • Tabloları Tasarım sekmesinin Özellikler grubunda, PivotTable'ları Seçenekler sekmesinin PivotTable grubunda ve grafikleri ya da PivotChart'ları Düzen sekmesinin Özellikler grubunda yeniden adlandırabilirsiniz. Adlandırılmış aralıklar gibi diğer yinelenen öğeler, Formüller sekmesinin Tanımlı Adlar grubunda yeniden adlandırılabilir.

SharePoint'te Web için Office dağıtılırsa, verilerinizin tarayıcıda görüntülenmesi ve üzerinde çalışılması, Excel masaüstü programında verilerinizle çalışmaya çok benzeyebilir. Aslında, Excel masaüstü programından farklı olarak tarayıcı kılavuzunda aynı anda birden fazla kullanıcı çalışma kitabını düzenleyebilir. Çalışma kitabını tarayıcıda görüntülediğinizde Excel Online’te düzenle düğmesi görünüyorsa, Web için Office'in kullanılmaya hazır olduğunu anlayabilirsiniz.

Çalışma Kitabını Düzenle menüsünde Excel Online’da Düzenle

Daha fazla bilgi için Excel ve Excel Hizmetleri 'nde çalışma kitabı kullanma arasındaki farklarmakalesine bakın.

Çalışma kitabını hazırlama

Çalışma kitabını yayımlamadan önce, yalnızca tarayıcıda görünmesini istediğiniz çalışma sayfalarını veya öğeleri seçmeyi tercih edebilirsiniz. Bu modda nelerin görüntülenebilir olacağını sınırlayabilseniz de, çalışma kitabının tüm içeriğinin yine de SharePoint sunucusuna kaydedileceğini unutmayın.

Grafikler veya Özet Tablolar gibi diğer öğelere ek olarak çalışma sayfalarının tamamını bir öğe olarak dahil etmek istiyorsanız, çalışma sayfasının tamamını adlandırılmış bir aralık olarak tanımlayın. Çalışma sayfasının tamamını seçin ve sonra adlandırılmış bir aralık tanımlayın. Bu adlandırılmış aralık daha sonra siz yayımlamaya hazır olduğunuzda Yayımlama Seçenekleri iletişim kutusunda kullanılabilir bir öğe olarak görüntülenir.

Kullanıcıların başka bir hücredeki formülle çalışmak için hücreye değer girebilmelerini isterseniz, çalışma kitabını yayımlamadan önce bu hücreyi Excel'de tanımlı bir ad olarak ayarlayın. Daha sonra, Tarayıcı Görünümü Seçenekleri iletişim kutusundaki Parametreler sekmesinde bu tanımlı adı bir parametre olarak ekleyebilirsiniz.

Örneğin, aşağıda tanımlı adı "Oran" olan bir D2 hücresi gösterilmektedir. Tarayıcıda, Kullanıcı Parametreler bölmesindeki kutuya bir 5,625 değeri girer ve Uygula'yı tıklatır. Daha sonra bu değer D2 hücresinde görünür ve A2 hücresindeki formül D2'deki değeri kullanır. Formülün sonucu yeniden hesaplanır ve A2 hücresinde 1.151,31 TL olarak gösterilir.

Aralıkları tanımlama hakkında bilgi için Excel Yardımı 'na bakın.

Bölmeye bir parametre girildiğinde bu değer D2 hücresinde kullanılır

Not: Excel tablosu için dilimleyiciler oluşturur ve tablo ve dilimleyicileri içeren hücre aralığı için bir ad tanımlarsanız, tanımlı aralığı yayımlamanız durumunda tarayıcıda tabloya filtre uygulamak için dilimleyicileri kullanamazsınız. Tabloyu ya da tüm çalışma sayfasını veya çalışma kitabını yayımlarsanız, dilimleyiciler tarayıcıda olması beklendiği gibi çalışır.

Çalışma kitabını yayımlama

  1. > SharePoint>farklı kaydet 'e tıklayın.

  2. SharePoint klasörünüzü geçerli klasör veya son klasörleraltında görüyorsanız, istediğiniz klasörü tıklatın. Aksi takdirde, Gözat 'ı tıklatın ve SharePoint sitesinin Web adresini girin. Ardından, çalışma kitabını yayımlamak istediğiniz klasöre gidin. Farklı Kaydet iletişim kutusu görüntülenir.

  3. Çalışma kitabından yayımlamak üzere tek tek çalışma sayfalarını veya öğeleri seçmek için, Tarayıcı Görünümü Seçenekleri'ne tıklayın. Bir göster sekmesi ve Parametreler sekmesi görürsünüz. Doğrudan çalışma sayfasının tamamını yayımlamak istiyorsanız, Kaydet'e tıklayın. Bunun dışındaki durumlarda, aşağıdakilerden birini yapın:

    • Tarayıcıda çalışma kitabının tamamını göstermek için, Göster sekmesinde, liste kutusundan Tüm Çalışma Kitabı seçimini yapın.

    • Tarayıcıda yalnızca belirli çalışma sayfalarını göstermek için, göster sekmesinde, liste kutusunda Sayfalar 'ı seçin ve ardından tarayıcıda gizli olmasını istemediğiniz sayfaların kutularının işaretini kaldırın.

      Varsayılan olarak tüm sayfalar seçilir. Bazı kutuların işaretini kaldırdıktan sonra tüm sayfaları hemen görüntülenebilir hale getirmek için tüm sayfalar onay kutusunu seçin.

    • Tarayıcıda yalnızca belirli öğeleri (adlandırılmış aralıklar, grafikler, tablolar veya PivotTable 'Lar gibi) göstermek için, göster sekmesinde, liste kutusunda çalışma kitabındaki öğeler 'i seçin ve göstermek istediğiniz öğelerin kutularını işaretleyin.

    • Parametreler sekmesinde, kullanıcılar çalışma kitabını tarayıcıda görüntülerken düzenlenebilecek hücreleri belirtmek için kullanmak istediğiniz tanımlı adları ekleyin. Sonra iletişim kutusunu kapatmak için Tamam 'ı tıklatın.

  4. Çalışma kitabını kaydedin.

Notlar: 

  • Aynı ada (grafik ve temel veri tablosu gibi) sahip öğeleri seçerseniz, tarayıcıda bu öğelerden yalnızca biri kullanılabilir. Tüm öğeleri göstermek için, çalışma kitabındaki her öğenin benzersiz bir adı olduğundan emin olun.

  • Aynı ada (grafik ve temel veri tablosu gibi) sahip öğeleri seçerseniz, tarayıcıda bu öğelerden yalnızca biri kullanılabilir. Tüm öğeleri göstermek için, çalışma kitabındaki her öğenin benzersiz bir adı olduğundan emin olun.

  • Tabloları Tasarım sekmesinin Özellikler grubunda, PivotTable'ları Seçenekler sekmesinin PivotTable grubunda ve grafikleri ya da PivotChart'ları Düzen sekmesinin Özellikler grubunda yeniden adlandırabilirsiniz. Adlandırılmış aralıklar gibi diğer yinelenen öğeler, Formüller sekmesinin Tanımlı Adlar grubunda yeniden adlandırılabilir.

  • Tabloları Tasarım sekmesinin Özellikler grubunda, PivotTable'ları Seçenekler sekmesinin PivotTable grubunda ve grafikleri ya da PivotChart'ları Düzen sekmesinin Özellikler grubunda yeniden adlandırabilirsiniz. Adlandırılmış aralıklar gibi diğer yinelenen öğeler, Formüller sekmesinin Tanımlı Adlar grubunda yeniden adlandırılabilir.

Excel Web Access Web bölümleri hakkında daha fazla bilgi için, Excel Web Access Web bölümünde çalışma kitabı görüntülememakalesine bakın.

Bir çalışma kitabını SharePoint sunucusuna yayımladığınızda, çalışma kitabının tüm içeriği sunucuya kaydedilir ve çalışma kitabını Excel masaüstü programında açarsanız görüntülenebilir ve kullanılabilir. Office Web Apps, SharePoint Server 'da dağıtılırsa, Web tarayıcısında verilerinizi görüntüleme ve bunlarla çalışma, Excel masaüstü programındaki verilerinizle çalışma gibi olabilir. Aslında, Office Web Apps dağıtıldığında, çalışma kitabının düzenlenmesi de tarayıcı kılavuzunda olasıdır. Bir çalışma kitabını tarayıcıda görüntülediğinizde tarayıcıda Düzenle düğmesi görünüyorsa, bu, Office Web Apps 'in kullanılabildiği anlamına gelir.

Tarayıcıda Düzenle düğmesi

Daha fazla bilgi için Excel ve Excel Hizmetleri 'nde çalışma kitabı kullanma arasındaki farklarmakalesine bakın.

Çalışma kitabını hazırlama

Çalışma kitabını yayımlamadan önce, tarayıcıda Düzenle düğmesine tıklayarak düzenleme etkinleştirilmemişse tarayıcıda görünür olmasını istediğiniz çalışma sayfalarını veya öğeleri seçmek için fırsat ( yayınlama seçenekleri iletişim kutusunda) olur. Bu modda nelerin görüntülenebileceğinizi seçebilmenize rağmen, çalışma kitabının tüm içeriğinin SharePoint sunucusuna kaydedilmeye devam eder.

Grafikler veya Özet Tablolar gibi diğer öğelere ek olarak çalışma sayfalarının tamamını bir öğe olarak dahil etmek istiyorsanız, çalışma sayfasının tamamını adlandırılmış bir aralık olarak tanımlayın. Çalışma sayfasının tamamını seçin ve sonra adlandırılmış bir aralık tanımlayın. Bu adlandırılmış aralık daha sonra siz yayımlamaya hazır olduğunuzda Yayımlama Seçenekleri iletişim kutusunda kullanılabilir bir öğe olarak görüntülenir.

Bir tarayıcıda çalışma sayfasını görüntülerken kullanıcıların formüle parametre sağlamasına izin vermek istiyorsanız, bir hücreyi tanımlı ad olarak ayarlayın. Bu tanımlı adı, Yayımlama seçenekleri Iletişim kutusundaki Parametreler sekmesinde parametre olarak ekleyebilirsiniz.

Örneğin, tarayıcıdaki çalışma sayfasını gösteren aşağıdaki grafikte, D2 hücresinin tanımlı ad oranı vardır. Tarayıcıda, bir Kullanıcı Parametreler bölmesindeki kutuya bir 5,625 değeri girdikten sonra Uygula'ya tıklamıştır. Daha sonra bu değer D2 hücresinde görünür ve A2 hücresindeki formül D2'deki değeri kullanır. Formülün sonucu yeniden hesaplanır ve A2 hücresinde 1.151,31 TL olarak gösterilir.

Tarayıcıda bir parametre kullanma

Aralıkları tanımlama hakkında bilgi için Excel Yardımı 'na bakın.

Çalışma kitabını yayımlama

  1. Dosya sekmesini ve sonra da Kaydet ve Gönder'i tıklatın.

  2. SharePoint 'e kaydet 'etıklayın.
    Not   SharePoint 'e kaydet komutu kullanılamıyorsa, farklı kaydet komutunu kullanarak çalışma kitabını SharePoint sitesine kaydetmeye devam edebilirsiniz. Yayımlama seçenekleri iletişim kutusu kullanılamaz. Ayrıca, çalışma kitabını bir SharePoint kitaplığından doğrudan karşıya yükleyebilirsiniz. Kullanıcılar, doğrudan çalışma kitabının kaydedildiği siteye giderek tarayıcıda çalışma kitabının içeriğini görüntüleyebilir ve düzenleyebilir.

    Farklı Kaydet komutu

  3. Çalışma kitabında yayınlanacak tek tek çalışma sayfalarını veya öğeleri seçmek istiyorsanız Yayımlama seçenekleri düğmesine tıklayın. Aksi takdirde, tüm çalışma kitabını yayımlamak istiyorsanız doğrudan 4.
    Göster sekmesinde aşağıdakileri yapın:

    • Tarayıcıda çalışma kitabının tamamını göstermek için, liste kutusundan tüm çalışma kitabı 'nı seçin.

    • Tarayıcıda yalnızca belirli çalışma sayfalarını göstermek için, liste kutusunda Sayfalar 'ı seçin ve görünür yapmak istemediğiniz sayfaların onay kutularını temizleyin.
      Not    varsayılan olarak tüm sayfalar seçilidir. Bazı onay kutularını temizledikten sonra tüm sayfaları hemen görüntülenebilir hale getirmek için, tüm sayfalar onay kutusunu seçebilirsiniz.

    • Tarayıcıda yalnızca belirli öğeleri (adlandırılmış aralıklar, grafikler, tablolar veya PivotTable 'Lar gibi) göstermek için, liste kutusunda çalışma kitabındaki öğeler 'i seçin ve sonra da göstermek istediğiniz öğelerin denetim kutularını seçin.
      Not aynı ada (grafik ve temel veri tablosu gibi) sahip öğeleri seçerseniz, tarayıcıda bu öğelerden yalnızca biri kullanılabilir. Tüm öğeleri göstermek için, çalışma kitabındaki her öğenin benzersiz bir adı olduğundan emin olmalısınız. Tabloları Tasarım sekmesinin Özellikler grubunda, PivotTable'ları Seçenekler sekmesinin PivotTable grubunda ve grafikleri ya da PivotChart'ları Düzen sekmesinin Özellikler grubunda yeniden adlandırabilirsiniz. Adlandırılmış aralıklar gibi yinelenen öğeler, tanımlı adlar grubundaki formüller sekmesinde yeniden adlandırılabilir.
      Çalışma sayfaları veya öğeler seçme

    • Parametreler sekmesinde, kullanıcılar çalışma kitabını tarayıcıda görüntülerken düzenlenebilecek hücreleri belirtmek için kullanmak istediğiniz tanımlı adları ekleyin. Sonra iletişim kutusunu kapatmak için Tamam 'ı tıklatın.
      Parametreleri ayarlama

  4. Çalışma Kitabınızı yayımlamak için bir konum seçin.
    Geçerli konum, en son konumlarveya seçebileceğiniz konumlar altında kayıtlı sunucu konumları var. Böyle bir konum yoksa veya yeni bir konuma kaydetmek istiyorsanız, konumlaraltında, konuma Gözat'ı çift tıklatın.

  5. Farklı kaydet iletişim kutusunda, SharePoint sitesinin Web adresini girin ve sonra da çalışma kitabınızı kaydetmek istediğiniz siteye veya kitaplığa göz atın.

  6. Şimdiye kadar tek tek çalışma sayfalarını veya öğeleri seçmediyseniz veya parametre ayarlamak için Yayımlama seçenekleri düğmesine tıklayın.

  7. Dosya adı kutusunda, çalışma kitabı için önerilen adı kabul edin veya isterseniz yeni bir ad yazın.

  8. Yayımlama işlemi tamamlandıktan hemen sonra çalışma kitabı içeriğini tarayıcı penceresinde görüntülemek için, tarayıcıda Excel Ile aç iletişim kutusunun seçili olduğundan emin olun.

  9. Kaydet'e tıklayın.

Not:  Bu sayfanın çevirisi otomasyon aracılığıyla yapılmıştır ve bu nedenle hatalı veya yanlış dil bilgisi kullanımları içerebilir. Amacımız, bu içeriğin sizin için faydalı olabilmesini sağlamaktır. Bu bilgileri yararlı bulup bulmadığınızı bizimle paylaşır mısınız? Kolayca başvurabilmek için İngilizce makaleye buradan ulaşabilirsiniz.

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×