Windows için Excel 2016'da çalışma kitabını SharePoint kitaplığında yayımlama

Önemli : Bu makale makine çevisidir. Bkz. yasal uyarı. Bu makalenin İngilizce sürümüne buradan ulaşabilirsiniz.

Bir çalışma kitabını Microsoft SharePoint kitaplığında yayımlayabilirsiniz ve böylece kişiler bilgisayarlarında Excel yüklü olmasına gerek kalmadan çalışma kitabını web tarayıcısında görüntüleyebilir veya düzenleyebilirler. Yayımlama aslında kaydetme ile aynı işlemdir; ancak kişiler çalışma kitabını tarayıcıda açtıklarında görebilecekleri öğeleri denetlemenize izin veren bazı yerleşik seçenekler sunar.

Bir çalışma kitabını merkezi bir SharePoint sitesine kaydetme veya yayımlama gibi bir uygulamanın kuruluşunuz çapında benimsenmesi, aynı çalışma kitabının biraz farklı sürümlerinin e-posta ile gönderildiğinde kuruluşunuzun her yanında ortaya çıkmamasını sağlamanıza yardımcı olabilir.

Bazı yayımlama seçeneklerini ayarlayarak, çalışma kitabınızın grafikler gibi belirli bölümlerini vurgulayabilir veya diğer bölümlerinin tarayıcıda görüntülenmesini engelleyebilirsiniz. Örneğin, bir grafiği gösterebilir, ancak temelini oluşturan verileri gizleyebilirsiniz. Ya da görmesi gereken kişilere yalnızca belirli çalışma sayfalarını gösterirken, diğer çalışma sayfalarını gizleyebilirsiniz.

Bu makalede, Windows için Excel 2016'dan çalışma kitabının nasıl yayımlanacağı gösterilir. Makale, çalışma kitabını veya çalışma kitabı verilerini SharePoint sayfasında Excel Web Access Web Bölümü'ne bağlama konusunu kapsamaz.

Çalışma kitabını bir SharePoint sitesinde yayımladığınızda tüm çalışma kitabı SharePoint'e kaydedilir. Gerekli SharePoint izinlerine sahip bir kullanıcı gerek tarayıcıda gerekse Excel masaüstü programında tüm çalışma kitabını görüntüleyebilir ve verileriyle çalışabilir.

SharePoint'te Office Online dağıtılırsa, verilerinizin tarayıcıda görüntülenmesi ve üzerinde çalışılması, Excel masaüstü programında verilerinizle çalışmaya çok benzeyebilir. Aslında, Excel masaüstü programından farklı olarak tarayıcı kılavuzunda aynı anda birden fazla kullanıcı çalışma kitabını düzenleyebilir. Çalışma kitabını tarayıcıda görüntülediğinizde Excel Online’te düzenle düğmesi görünüyorsa, Office Online'in kullanılmaya hazır olduğunu anlayabilirsiniz.

Çalışma Kitabını Düzenle menüsünde Excel Online’da Düzenle

Çalışma kitabını hazırlama

Çalışma kitabını yayımlamadan önce, yalnızca tarayıcıda görünmesini istediğiniz çalışma sayfalarını veya öğeleri seçmeyi tercih edebilirsiniz. Bu modda nelerin görüntülenebilir olacağını sınırlayabilseniz de, çalışma kitabının tüm içeriğinin yine de SharePoint sunucusuna kaydedileceğini unutmayın.

Grafikler veya Özet Tablolar gibi diğer öğelere ek olarak çalışma sayfalarının tamamını bir öğe olarak dahil etmek istiyorsanız, çalışma sayfasının tamamını adlandırılmış bir aralık olarak tanımlayın. Çalışma sayfasının tamamını seçin ve sonra adlandırılmış bir aralık tanımlayın. Bu adlandırılmış aralık daha sonra siz yayımlamaya hazır olduğunuzda Yayımlama Seçenekleri iletişim kutusunda kullanılabilir bir öğe olarak görüntülenir.

Kullanıcıların başka bir hücredeki formülle çalışmak için hücreye değer girebilmelerini isterseniz, çalışma kitabını yayımlamadan önce bu hücreyi Excel'de tanımlı bir ad olarak ayarlayın. Daha sonra, Tarayıcı Görünümü Seçenekleri iletişim kutusundaki Parametreler sekmesinde bu tanımlı adı bir parametre olarak ekleyebilirsiniz.

Örneğin, aşağıda tanımlı adı "Oran" olan bir D2 hücresi gösterilmektedir. Tarayıcıda, bir kullanıcı Parametreler bölmesindeki Oran kutusuna 5,625 değerini girer ve Uygula'ya tıklar. Daha sonra bu değer D2 hücresinde görünür ve A2 hücresindeki formül D2'deki değeri kullanır. Formülün sonucu yeniden hesaplanır ve A2 hücresinde 1.151,31 TL olarak gösterilir.

Bölmeye bir parametre girildiğinde bu değer D2 hücresinde kullanılır

Not : Excel tablosu için dilimleyiciler oluşturur ve tablo ve dilimleyicileri içeren hücre aralığı için bir ad tanımlarsanız, tanımlı aralığı yayımlamanız durumunda tarayıcıda tabloya filtre uygulamak için dilimleyicileri kullanamazsınız. Tabloyu ya da tüm çalışma sayfasını veya çalışma kitabını yayımlarsanız, dilimleyiciler tarayıcıda olması beklendiği gibi çalışır.

Çalışma kitabını yayımlama

  1. Dosya sekmesine tıklayın, Farklı Kaydet'e tıklayın ve sonra da SharePoint'e tıklayın.

  2. Geçerli, en sonveya eskialtında SharePoint klasörünüzü görürseniz, istediğiniz klasörü tıklatın.

    Farklı Kaydet iletişim kutusu görüntülenir.


    Aksi takdirde, Gözat' ı tıklatın, SharePoint sitesinin web adresini girin ve sonra çalışma kitabını yayımlamak istediğiniz klasöre göz atın.

    Bir SharePoint klasörüne veya Gözat'a tıklayın
  3. Çalışma kitabından yayımlamak üzere tek tek çalışma sayfalarını veya öğeleri seçmek için, Tarayıcı Görünümü Seçenekleri'ne tıklayın.

    Farklı Kaydet iletişim kutusunda, Tarayıcı Görüntüleme Seçenekleri’ne tıklayın

    Göster sekmesini ve Parametreler sekmesini görürsünüz.

  4. Doğrudan çalışma sayfasının tamamını yayımlamak istiyorsanız, Kaydet'e tıklayın. Bunun dışındaki durumlarda, aşağıdakilerden birini yapın:

    • Tarayıcıda çalışma kitabının tamamını göstermek için, Göster sekmesinde, liste kutusundan Tüm Çalışma Kitabı seçimini yapın.

    • Tarayıcıda yalnızca belirli çalışma sayfalarını göstermek için, Göster sekmesinde, liste kutusundan Sayfalar seçimini yapın ve sonra tarayıcıda gizli olmasını istemediğiniz sayfaların onay kutularını temizleyin.

      Varsayılan olarak tüm sayfalar seçilir. Onay kutularından bazılarının işaretini kaldırdıktan sonra tüm sayfaları kısa sürede görünür hale getirmek için Tüm Sayfalar onay kutusunu seçin.

    • Tarayıcıda yalnızca belirli öğeleri göstermek için (adlandırılmış aralıklar, grafikler, tablolar veya PivotTable'lar gibi), Göster sekmesinde, liste kutusundan Çalışma Kitabındaki Öğeler seçimini yapın ve sonra göstermek istediğiniz öğelerin onay kutularını seçin.

    • Parametreler sekmesinde, kullanıcılar tarayıcıda çalışma kitabını görüntülediğinde düzenlenebilir hücreleri belirtmek için kullanmak istediğiniz tanımlı adları ekleyin ve ardından Tamam'a tıklayın.

  5. Çalışma kitabını kaydedin.

Notlar : 

  • Aynı ada sahip öğeleri (örn. bir grafik ve temel veri tablosu) seçerseniz, bu öğelerden yalnızca biri tarayıcıda kullanılabilir olur. Tüm öğeleri göstermek için, çalışma kitabındaki her öğenin benzersiz bir ada sahip olduğundan emin olun.

  • Tabloları Tasarım sekmesinin Özellikler grubunda, PivotTable'ları Seçenekler sekmesinin PivotTable grubunda ve grafikleri ya da PivotChart'ları Düzen sekmesinin Özellikler grubunda yeniden adlandırabilirsiniz. Adlandırılmış aralıklar gibi diğer yinelenen öğeler, Formüller sekmesinin Tanımlı Adlar grubunda yeniden adlandırılabilir.

Not : Makine Çevirisi Yasal Uyarısı: Bu makale, insan müdahalesi olmadan bir bilgisayar sistemi tarafından çevrilmiştir. Microsoft bu makine çevirilerini İngilizce bilmeyen kullanıcıların Microsoft ürünleri, hizmetleri ve teknolojileriyle ilgili içeriklerden yararlanmasına yardımcı olmak için sunar. Bu makale makine çevirisi olduğundan sözcük, cümle dizilimi ve gramer hataları içerebilir.

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×