Visio ile Web sitenizi denetim altına alma

Önemli : Bu makale makine çevisidir. Bkz. yasal uyarı. Bu makalenin İngilizce sürümüne buradan ulaşabilirsiniz.

Bir Web sitesinin günlük işlemlerini yönetiyorsanız, sitenin genel yapısını ve akışını gösteren net bir resme sahip olmanın, geliştirme değişikliklerini izlemenin ve bozulan köprüleri izleyip onarmanın çok önemli olduğunu bilirsiniz. Tüm bu görevleri ve daha fazlasını Microsoft Office Visio Professional'da bulunan Web Sitesi Haritası araçlarıyla yapabilirsiniz.

Ne yapmak istiyorsunuz?

Sitenizin içeriğini eşleme

Sitenizi hataları otomatik olarak denetleme

Sitenize değişiklikleri izleme

Sitenizin içeriğinin haritasını oluşturma

Sitenizin yönetimi geçerli durumunun çözümlenmesiyle başlar. Sitenizi eşlediğinizde, sitenizin durumunu ve içeriğini gösteren güncel bir grafik sunum oluşturursunuz.

Sitedeki bağlantıların gerçek hiyerarşik yapısını gösteren bir Web sitesi haritası

Site haritasındaki her şekil Web sitenizdeki bir bağlantıyı gösterir ve her şekil bağlantı türü ve yeri hakkında bilgiler içerir. Bir şekli sağ tıklatarak, doğrudan şekilden Web konumuna gidebilirsiniz.

  1. Visio'da, Dosya menüsünde, Yeni'nin üzerine gidin, Yazılım ve Veritabanı'nın üzerine gidin ve Web Sitesi Haritası'nı tıklatın.

  2. Site Haritası Oluştur iletişim kutusunda, aşağıdakilerden biri için bir site adresi girin:

    • Bir HTTP sunucusu için, Adres kutusuna, eşlemek istediğiniz Web sitesinin adresini girin.

    • Bir ağ sunucusu veya yerel sabit disk sürücüsü için, Gözat'ı tıklatın, site haritanızın kökünde olmasını istediğiniz dosyaya gidin ve 'ı tıklatın.

  3. Site Haritası Oluştur iletişim kutusunda, düzey sayısı üst sınırı ve bulunacak bağlantı sayısı ayarlarını gözden geçirmek için Ayarlar'ı tıklatın.

  4. Ayarları değiştirmek için, aşağıdakilerden birini yapın:

    • Düzen sekmesinde, kaç düzey bulunmasını istediğiniz ya da çizimin Sıkıştırılmış Ağaç mı yoksa Akış Çizelgesi mi göstereceği gibi Web sitesi haritasının düzen stilini değiştirin.

    • Uzantılar sekmesinde, eşlemek istediğiniz dosya türlerini (.doc, .jpg veya .exe gibi) seçin.

    • Protokoller sekmesinde, eşlemek istediğiniz protokolleri (mailto, ftp veya NNTP gibi) seçin.

    • Öznitelikler sekmesinde, bağlantılar için aramak istediğiniz HTML özniteliklerini (HREF, SRC veya CODE gibi) seçin.

    • Gelişmiş sekmesinde, arama ölçütünüzü daha da geliştirecek seçenekleri belirleyin.

    • Tamam'ı tıklatın.

  5. Site Haritası Oluştur iletişim kutusunda, Tamam'ı tıklatın.

  6. Site haritasını kaydetmek için, Dosya menüsünden Kaydet'i tıklatın.

Sayfanın Başı

Sitenizde otomatik olarak hata denetimi yapma

Sitenizin bağlantılarının etkin ve hatasız durumda kalmasını sağlamak en önemli Web sitesi yönetim görevidir.

Sitenizi eşlediğinizde, Visio belirtmiş olduğunuz parametreler içindeki her bağlantıyı izler ve karşılaştığı hataları kaydeder. Hata içeren bağlantılar site haritasında, Filtre penceresinde ve Liste penceresinde kırmızı X karakterleri bulunan şekiller olarak görünür. Bu pencereleri göremiyorsanız, Web Sitesi Haritası menüsünde, Pencereler'in üzerine gelin ve Liste Penceresi veya Filtre Penceresi'ni tıklatın. Çalışmanızı izleyip gerekli onarımları yapmanıza yardımcı olması için, bozuk bağlantıları ve ilişkili hataları içeren bir listeyi hızlı şekilde oluşturabilirsiniz.

Site yapısını gösteren bir Web sitesi haritası; kırmızı X içeren şekiller bozuk bağlantıları gösterir

Sitenizdeki hata içeren bağlantıların raporunu oluşturma

  1. Hata raporu oluşturmak istediğiniz site haritasını açın.

  2. Web Sitesi Haritası menüsünde, Raporlar'ın üzerine gelin, Web Sitesi Haritası Hatalı Bağlantılar'ı tıklatın ve sonra Çalıştır'ı tıklatın.

  3. Bilgilerin ne tür dosyaya (Excel veya XML gibi) kaydedilmesini istediğinizi seçin ve Tamam'ı tıklatın.

    Visio, köprü hataları bulunan tüm bağlantıları listeleyen bir rapor oluşturur.

  4. Raporunuz Microsoft Office Excel gibi Visio dışında bir programda açılırsa, rapora ad verip kaydedin.

Bozuk bağlantıları düzeltme

Bazı bozuk bağlantıların nedeni zaman aşımı hatalarıdır. Bu hataları çözmek için, bağlantıyı sağ tıklatın ve Yenile veya Üst Öğeyi Yenile'yi tıklatın.

Diğer bozuk bağlantılarsa Site Bulunamadı, Erişim Engellendi veya Parola Gerekiyor hatalarından ya da 404 veya Dosya Bulunamadı hata iletisini tetikleyebilen yanlış dosya adlarından, yanlış dosya konumlarından ve eksik dosyalardan kaynaklanır. Bunların tümünün Web sitenizde düzeltilmesi gerekir.

Web siteniz ve Web sitesi haritanız dinamik olarak bağlantılı değildir; bunlardan birinin değiştirilmesi diğerini otomatik olarak etkilemez. Web sitesindeki bozuk bir bağlantıyı düzelttikten sonra, bozuk bağlantıyı gösteren şekli sağ tıklatıp Köprüyü Yenile'yi tıklatarak site haritasını güncelleştirebilirsiniz. Kırmızı X yok olur.

Sayfanın Başı

Sitenizdeki değişiklikleri izleme

Siteniz üzerinde çalışan bir çok yazılım geliştirici varsa, bunların çalışmalarını izlemek kısa zamanda tam günlük bir görev haline gelebilir. Web Sitesi Haritası karşılaştırma raporuyla, sitenizin iki sürümünü karşılaştırarak, belirli bir dönemde yapılan değişikliklerin niceliğini belirleyebilirsiniz. Bu rapor iki sürümü karşılaştırır ve farkların listesini hazırlar. Haritalardan yalnızca birinde görünen bağlantıları tanımlamakla kalmaz, aynı zamanda, her iki haritada bulunan aşağıdaki bağlantı değişikliklerini de listeler:

  • Hata durumu

  • Dosya başlığı

  • Dosya boyutu

  • Dosya değiştirilme tarihi

Örneğin, her hafta site üzerinde yapılan çalışmaların niceliğini belirlemek istediğinizi düşünelim. Siteyi hafta başında ve sonra hafta sonunda yine eşlemeniz yeterlidir. Sonra da iki haritayı karşılaştırarak bir değişiklik raporu oluşturursunuz. Ayrıca, Web sitesi projenizin hedefe uygun ilerleyip ilerlemediğini görmek için, raporu, hafta için planlanan bir çalışma zamanlamasıyla karşılaştırabilirsiniz.

Web sitesi haritalarını karşılaştırma

  1. Web sitenizin en yeni haritasını açın.

  2. Web Sitesi Haritası menüsünde, Önceki belgeyle karşılaştır'ı tıklatın.

  3. Karşılaştırmada kullanmak istediğiniz Web sitesi haritasına gidin, dosyayı seçin ve 'ı tıklatın.

    Visio iki haritayı karşılaştırır ve farkları listeleyen bir HTML raporu oluşturur.

  4. Rapora ad verip kaydedin.

Sayfanın Başı

Not : Makine Çevirisi Yasal Uyarısı: Bu makale, insan müdahalesi olmadan bir bilgisayar sistemi tarafından çevrilmiştir. Microsoft bu makine çevirilerini İngilizce bilmeyen kullanıcıların Microsoft ürünleri, hizmetleri ve teknolojileriyle ilgili içeriklerden yararlanmasına yardımcı olmak için sunar. Bu makale makine çevirisi olduğundan sözcük, cümle dizilimi ve gramer hataları içerebilir.

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×