Veritabanı Modeli (Varlık İlişkisi diyagramı olarak da bilinir) oluşturma

Veritabanı Modeli (Varlık İlişkisi diyagramı olarak da bilinir) oluşturma

Veritabanı Modeli Diyagramı şablonuyla ilişkisel veya nesne ilişkisel modelleme kavramlarını kullanarak yeni bir model oluşturabilir veya var olan bir veritabanını tersine mühendislik işlemiyle bir modele dönüştürebilirsiniz. SQL92 ve önceki standartlara dayalı veritabanları modellemek için Varlık İlişkisi kalıbını kullanın. SQL99 ve sonraki standartlara dayalı veritabanları modellemek için türler üzerinde çalışmaya yönelik ek şekiller içeren Nesne İlişkisel kalıbını kullanın.

Veritabanı modeli örneği

Veritabanı Modeli Diyagramı şablonuyla ilişkisel veya nesne ilişkisel modelleme kavramlarını kullanarak yeni bir model oluşturabilir veya var olan bir veritabanını tersine mühendislik işlemiyle bir modele dönüştürebilirsiniz. SQL92 ve önceki standartlara dayalı veritabanları modellemek için Varlık İlişkisi kalıbını kullanın. SQL99 ve sonraki standartlara dayalı veritabanları modellemek için türler üzerinde çalışmaya yönelik ek şekiller içeren Nesne İlişkisel kalıbını kullanın.

Bu makale, bir veritabanı modelini oluşturmayı ve modeli oluşturduktan sonra bununla neler yapabileceğinizi açıklamaktadır.

Veritabanı modeli özelliklerini bulamıyor musunuz?

Veritabanı modeli özelliği, Microsoft Visio’nun tüm sürümlerinde yoktur. Bu makaledeki yordamlarda açıklanan özellikleri bulamıyorsanız büyük olasılıkla bu özellikleri içermeyen bir Visio sürümüne sahipsiniz.

  • Microsoft Visio Standard, Veritabanı Modeli Diyagramı şablonunu içermez.

  • Microsoft Visio Professional ve Premium sürümleri, Veritabanı Modeli Diyagramı şablonu için tersine mühendislik özelliklerini (Visio’da model oluşturmak için var olan bir veritabanını kullanma) destekler ancak ileri mühendislik özelliğini (SQL kodu oluşturmak için bir Visio veritabanı modelini kullanma) desteklemez.

  1. Veritabanı modeli diyagramınızı başlatmak için şunlardan birini yapın:

    Sıfırdan yeni bir model diyagramı oluşturma

    Başlangıç noktası olarak kullanmak istediğiniz var olan bir veritabanınız yoksa boş bir Veritabanı Modeli ile başlayıp kendi tablolarınızı ve ilişkilerinizi ekleyebilirsiniz.

    1. Dosya sekmesine tıklayın.

    2. Yeni’ye tıklayın, Yazılım ve Veritabanı’na tıklayın ve sonra Veritabanı Modeli Diyagramı’na çift tıklayın.

    3. Veritabanı sekmesinin Yönet grubunda Görüntüleme Seçenekleri’ne tıklayın.

    4. Veritabanı Belge Seçenekleri iletişim kutusunda kullanmak istediğiniz simge kümesi ile diğer tablo ve ilişki seçeneklerini belirleyin, sonra Tamam’a tıklayın.

    Başlangıç noktası olarak var olan bir veritabanını kullanma

    Daha iyi anlamak veya yeni bir model için başlangıç noktası olarak kullanmak üzere modellemek istediğiniz bir veritabanınız varsa veritabanının şemasını veya yapısını ayıklamak ve yeni bir model oluşturmak için Tersine Mühendislik Sihirbazı’nı kullanabilirsiniz.

    Sihirbazı başlatmadan önce:

    1. Microsoft Excel çalışma kitabına tersine mühendislik işlemi uyguluyorsanız sihirbazı başlatmadan önce çalışma kitabını açmanız ve sütun başlıklarını içeren hücre grubunu (veya aralığını) adlandırmanız gerekir. Birden fazla çalışma sayfası kullanmak istiyorsanız her bir çalışma sayfasında sütun hücreleri grubunu isimlendirmeniz yeterlidir. Bu aralıklar sihirbazda tablolar olarak ele alınır. Hücre aralığını adlandırma hakkında daha fazla bilgi edinmek için Excel yardımındaki Adlandırılmış hücre başvurularını veya aralıklarını tanımlama başlıklı konuya bakın.

    2. En iyi sonuçları elde etmek için Tersine Mühendislik Sihirbazı’nı çalıştırmadan önce varsayılan sürücünüzü tersine mühendislik işlemi uygulamak istediğiniz hedef veritabanı olarak ayarlayın. Bu adım, sihirbazın yerel veri türlerini doğru bir şekilde eşlemesini ve sihirbazın ayıkladığı tüm kodların Kod penceresinde doğru bir şekilde gösterilmesini sağlar.

    3. Dosya sekmesine tıklayın.

    4. Yeni’ye tıklayın, Yazılım ve Veritabanı’na tıklayın ve sonra Veritabanı Modeli Diyagramı’na çift tıklayın.

    5. Veritabanı sekmesinin Model grubunda Tersine Mühendislik’e tıklayın.

    6. Tersine Mühendislik Sihirbazı’nın ilk ekranında şunları yapın:

      1. Veritabanı yönetim sisteminizin (DBMS) veritabanı sürücüsünü seçin. Visio veritabanı sürücüsünü henüz belirli bir ODBC veri kaynağıyla ilişkilendirmediyseniz Kurulum’a tıklayın.

        Not: Excel çalışma sayfasına tersine mühendislik işlemi uyguluyorsanız ODBC Genel Sürücü’yü seçin.

      2. Güncelleştirdiğiniz veritabanının veri kaynağını seçin. Var olan veritabanı için henüz bir veri kaynağı oluşturmadıysanız şimdi oluşturmak için Yeni’ye tıklayın.

        Yeni bir kaynak oluşturduğunuzda adı Veri Kaynakları listesine eklenir.

      3. İstediğiniz ayarları yaptığınızda İleri’ye tıklayın.

    7. Herhangi bir sürücüye özel iletişim kutusundaki yönergeleri izleyin.

      Örneğin, Veri Kaynağını Bağla iletişim kutusunda kullanıcı adı ve parolayı yazın ve Tamam’a tıklayın.

      Not: ODBC Genel Sürücü’yü kullanıyorsanız tersine mühendislik işlemi yapılan bilgilerin eksik olabileceğini belirten bir hata iletisi alabilirsiniz. Çoğu durumda bu bir sorun değildir; Tamam’a tıklayın ve sihirbaza devam edin.

    8. Ayıklamak istediğiniz bilgi türünün onay kutularını işaretleyin ve sonra İleri’ye tıklayın.

      Not: Sihirbazın ayıklayabildiği öğe türleri tüm veritabanı yönetim sistemleri tarafından desteklenmediğinden bazı öğeler kullanılamayabilir. (Bu öğeler soluk gösterilir.)

    9. Ayıklamak istediğiniz tabloların (ve varsa görünümlerin) onay kutularını işaretleyin veya hepsini ayıklamak için Tümünü Seç’e tıklayın ve sonra İleri’ye tıklayın.

      Not: Excel çalışma sayfasına tersine mühendislik işlemi uyguluyorsanız ve bu listede bir şey görmüyorsanız büyük olasılıkla çalışma sayfanızdaki sütun başlıklarını içeren hücre aralığını adlandırmanız gerekmektedir.

    10. Saklı Yordamlar onay kutusunu işaretlediyseniz ayıklamak istediğiniz yordamları seçin veya hepsini ayıklamak için Tümünü Seç’e tıklayın ve sonra İleri’ye tıklayın.

    11. Tersine mühendislik işlemi yapılan öğelerin geçerli sayfaya otomatik olarak eklenmesini isteyip istemediğinizi seçin.

      Not: Tersine mühendislik işlemi yapılan öğelerin Tablolar ve Görünümler penceresinde listelenmesine ek olarak sihirbazın çizimi otomatik olarak oluşturmasını seçebilirsiniz. Çizimin otomatik olarak oluşturulmamasına karar verirseniz veritabanı modelini kendiniz bir araya getirmek için öğeleri Tablolar ve Görünümler penceresinden çizim sayfanıza sürükleyebilirsiniz.

    12. İstediğiniz bilgileri ayıkladığınızı doğrulamak için seçimlerinizi gözden geçirin ve sonra Son’a tıklayın.

      Sihirbaz, seçilen bilgileri ayıklar ve Çıktı penceresinde ayıklama işlemine ilişkin notlar gösterir.

    Var olan bir modeli içeri aktarma ve iyileştirme

    Var olan bir VisioModeler veya PLATINUM ERwin modeliniz varsa Visio veritabanı modeli diyagramı oluşturmak için bunu içeri aktarabilirsiniz. Bu özellik yalnızca VisioModeler 2.0 ve sonraki sözlük modeli (.imd) dosyaları ve PLATINUM ERwin 2.6, 3.0 ve 3.52 .erx dosyalarıyla sınırlıdır.

    1. Dosya sekmesine tıklayın.

    2. Yeni’ye tıklayın, Yazılım ve Veritabanı’na tıklayın ve sonra Veritabanı Modeli Diyagramı’na çift tıklayın.

    3. Veritabanı sekmesinin Model grubunda İçeri Aktar’a tıklayın ve sonra model türüne tıklayın.

    4. İçeri aktarmak istediğiniz modelin yolunu ve dosya adını yazın veya model dosyasının konumunu belirlemek için Gözat düğmesine tıklayın ve sonra ’a tıklayın.

    5. İçeri Aktar iletişim kutusunda Tamam’a tıklayın.

      Visio dosyayı içeri aktarır ve Çıktı penceresinde ilerleme durumunu gösterir. İçeri aktarılan tablolar, Tablolar ve Görünümler penceresinde gösterilir.

    6. Tablolar ve Görünümler penceresinde, modellemek istediğiniz tabloları seçin ve sonra bunları çizim sayfasına sürükleyin.

  2. Veritabanı modeli diyagramını oluşturduktan sonra diyagramı iyileştirme işine geçersiniz. Tablolar ve görünümler ekleyebilir, bunları özelleştirebilir, ilişkiler oluşturabilir ve sütunları ve veri türlerini özelleştirebilirsiniz.

    Tablolar

    Diyagramınızda tablo oluşturmak için Varlık şeklini kullanın.

    1. Varlık İlişkisi veya Nesne İlişkisel kalıptan çizime bir Varlık şekli sürükleyin.

    2. Veritabanı Özellikleri penceresini açmak için şekle çift tıklayın.

    3. Kategoriler altında Tanım’a tıklayın ve tablo için bir ad yazın.

    4. Kategoriler altında Sütunlar’a tıklayın, bir ad yazın ve veri türünü seçin.

    5. Boş değer içeremeyen sütunlar için Gerekli onay kutusunu işaretleyin.

    6. Veritabanı tablosunda her bir satırı benzersiz bir şekilde tanımlayan sütunlar için PK (birincil anahtar) onay kutusunu işaretleyin.

    7. Kategoriler altında Dizinler, Tetikleyiciler, Denetim veya Genişletilmiş’e tıklayarak bu isteğe bağlı öğeleri oluşturun.

    Sütunlar

    Veri türleri ve birincil anahtarlar dahil olmak üzere sütunlara özellikler eklemek veya sütunların özelliklerini değiştirmek için Veritabanı Özellikleri penceresini kullanın.

    1. Diyagramınızdaki tabloya çift tıklayın.

    2. Veritabanı Özellikleri penceresinde, Kategoriler altında Sütunlar’a tıklayın.

    3. İlk boş Fiziksel Ad hücresine tıklayın ve bir ad yazın.

    4. Bir sütunun veri türünü değiştirmek için sütunun Veri Türü alanına tıklayın ve sonra listeden bir veri türü seçin veya listeye türü yazın. Örneğin, decimal(8,2) veya char(30) yazabilirsiniz.

    5. Boş değerleri engellemek için Gerekli onay kutusunu işaretleyin.

    6. Sütunun birincil anahtar olduğunu belirtmek için PK onay kutusunu işaretleyin.

    7. Sütunlar kategorisine tıkladığınızda görüntülenenlere ek olarak daha fazla sütun özelliği görmek için sütunu seçin ve Düzenle’ye tıklayın.

    İlişkiler

    İlişkiler, veritabanlarının bir tablodaki satırı ilişkili bir tablodaki bir satırla eşleştirmesine izin vermek için birincil ve yabancı anahtarlar kullanır. Bu ilişkileri diyagramınızda gösterebilirsiniz. Ek olarak bunların kardinalitelerini ayarlayabilir (bire çok gibi) ve kardinaliteyi göstermek için Crow's feet, İlişkisel veya IDEF1X gösterimini seçebilirsiniz. Veritabanı Modeli Diyagramı şablonundaki bu gösterimlerle çoka çok ilişkileri gösteremezsiniz.

    1. Tablolar arasında ilişki oluşturma:

      1. Diyagramda her iki tablonun göründüğünden emin olun. Modele tersine mühendislik işlemini var olan bir veritabanından gerçekleştirdiyseniz tabloların birini veya her ikisini Tablolar ve Görünümler penceresinden çizim sayfasına sürüklemeniz gerekebilir.

      2. İlişkinin birincil anahtar tarafı için istediğiniz tabloya çift tıklayın.

      3. Veritabanı Özellikleri penceresinde, Kategoriler altında Sütunlar’a tıklayın.

      4. Kılavuzda, tablodaki her bir satırı benzersiz bir şekilde tanımlamak için, kullanmak istediğiniz sütuna tıklayın ve birincil anahtar olarak ayarlamak üzere PK onay kutusunu işaretleyin.

      5. Nesne İlişkisel veya Varlık İlişkisi kalıbından İlişki şeklini sayfadaki boş bir alana sürükleyip bırakın.

      6. Üst ucunu üst tablonun olduğu tabloya bağlayın.

      7. Diğer ucunu alt tabloya bağlayın.

        İkinci tablo henüz birincil anahtar ile aynı ada sahip bir sütun içermiyorsa modelci bunu ikinci tabloya yabancı anahtar olarak ekler.

        Not: İlişki çizgileri kaybolursa Veritabanı sekmesinin Yönet grubunda Görüntüleme Seçenekleri’ne tıklayın. İlişkiler sekmesindeki Göster’in altında İlişkiler onay kutusunu işaretleyin.

    2. İlişkinin kardinalitesini ayarlayın:

      1. İlişkiye çift tıklayın.

      2. Veritabanı Özellikleri penceresinde, Kategoriler’in altında Diğer’e tıklayın.

      3. Kardinalite altında ilişkiye en uygun olan kardinaliteyi seçin. Bire çok ilişkiler için en iyi seçenek Sıfır veya daha fazla ya da Bir veya daha fazla’dır. Bire bir ilişkiler için en iyi seçenek Sıfır veya bir ya da Tam olarak bir’dir.

  3. Diyagramınıza başka iyileştirmeler (dizinler, denetim koşulları ve tetikleyiciler oluşturma gibi) yapmak için şunları yapabilirsiniz:

    Dizin oluşturma

    Dizinler, bir sorgu çalıştırdığınızda veritabanınızın performansını veya hızını iyileştirir.

    1. Veritabanı modeli diyagramını açın.

    2. Dizin eklemek istediğiniz tabloya çift tıklayın ve Veritabanı Özellikleri penceresinde, Kategoriler listesinde Dizinler’e tıklayın.

    3. Yeni’ye tıklayın.

    4. Dizin Oluştur iletişim kutusunda dizin için bir ad yazın ve sonra Tamam’a tıklayın.

    5. Dizin Türü listesinde benzersiz veya benzersiz olmayan bir dizin oluşturmak için bir seçeneği belirleyin.

    6. Kullanılabilir Sütunlar listesinde bu dizine eklemek istediğiniz her bir sütunun adını seçin ve sonra Ekle > öğesine tıklayın.

    7. Dizinlenmiş Sütunlar listesinde artan sıralama düzenine sahip bir dizin oluşturmak için Asc onay kutusunu işaretleyin veya azalan sıralama düzenine sahip bir dizin oluşturmak için onay kutusunun işaretini kaldırın.

      Veritabanı modeli diyagramı güncelleştirilir.

    Görünüm oluşturma

    Görünümü kaydedilmiş bir sorgu olarak düşünebilirsiniz. Aynı bilgilere birden çok tablodan sürekli olarak erişmeniz gerekiyorsa veya verileri kullanıcılara asıl tabloları değiştirmelerine izin vermeden göstermek istiyorsanız görünümler oldukça kullanışlıdır.

    Varlık İlişkisi veya Nesne İlişkisel kalıbından bir Görünüm şeklini çizim sayfasına sürükleyin.

    Tablolar ve görünümler için genişletilmiş özellikler ayarlama

    Veritabanı yönetim sisteminize (DBMS) dayalı olarak nerede depolandıklarını belirlemek için tablolar veya görünümler için genişletilmiş özellikler ayarlayabilirsiniz.

    Genişletilmiş özelliklerini ayarlamak istediğiniz tablo veya görünüme çift tıklayın ve Veritabanı Özellikleri penceresinde, Kategoriler listesinde Genişletilmiş‘e tıklayın.

    Denetim koşulu oluşturma

    Sütuna girilen verilerin belirli bir değer aralığında olduğundan emin olmak için denetim koşullarını kullanın. Örneğin, “Yaş” adlı bir sütundaki verilerin 65’ten fazla olmasını gerektiren bir denetim koşulu oluşturabilirsiniz.

    1. Veritabanı Özellikleri penceresini açmak için tabloya çift tıklayın.

    2. Kategoriler altında Sütunlar’a tıklayın ve denetim koşulunu eklemek istediğiniz sütuna tıklayın.

    3. Düzenle’ye tıklayın.

    4. Sütun Özellikleri iletişim kutusunun Denetim sekmesinde istediğiniz kısıtlamaları girin.

      Denetim koşulu, Yerel kod altında Kod penceresine eklenir.

    Saklı yordamlar ve kullanıcı tanımlı işlevler oluşturma

    Aynı eylemleri tekrarlayarak gerçekleştirmek üzere yeniden kullanabileceğiniz kod paketleri oluşturmak için saklı yordamları ve kullanıcı tanımlı işlevleri kullanın. İkisi arasındaki en büyük fark, kullanıcı tanımlı işlev bir değer döndürürken saklı yordamın kodu bir değer döndürmeden yürütmesidir.

    1. Veritabanı sekmesinin Göster/Gizle grubunda Kod penceresini açmak için Kod onay kutusunu işaretleyin.

    2. Genel Kod’a tıklayın ve sonra Yeni’ye tıklayın.

    3. Kod Düzenleyicisi’nin Özellikler sekmesinde, oluşturmak istediğiniz türdeki koda tıklayın ve kod için bir ad yazın.

    4. Gövde sekmesinde kodu yazın ve Tamam’a tıklayın.

    Tetikleyici oluşturma

    Tetikleyiciler, tetikleyicide belirttiğiniz SQL kodunun veritabanında belirli bir olay gerçekleştiğinde çalışmasını sağlar.

    1. Veritabanı Özellikleri penceresini açmak için tabloya çift tıklayın.

    2. Kategoriler altında Tetikleyiciler’e tıklayın ve sonra Ekle’ye tıklayın.

    3. Özellikler sekmesinde tetikleyici için bir ad yazın.

    4. Gövde sekmesinde kodu yazın ve Tamam’a tıklayın.

      Tetikleyici, Yerel kod altındaki Kod penceresine eklenir.

Bu makale, bir veritabanı modelini oluşturmayı ve modeli oluşturduktan sonra bununla neler yapabileceğinizi açıklamaktadır. Hızlı başlangıç için Dosya menüsünde Yeni’nin üzerine gelin, Yazılım ve Veritabanı’nın üzerine gelin ve sonra Veritabanı Modeli Diyagramı’na tıklayın.

Veritabanı modeli özelliklerini bulamıyor musunuz?

Büyük olasılıkla Microsoft Office Visio sürümünüz aradığınız özellikleri içermiyor. Hangi Visio sürümüne sahip olduğunuzu öğrenmek için Yardım menüsünde Microsoft Office Visio Hakkında’ya tıklayın. Sürüm adı, iletişim kutusundaki metnin en üst satırında yer alır.

  • Microsoft Office Visio Standard, Veritabanı Modeli Diyagramı şablonunu içermez.

  • Microsoft Office Visio Professional, Veritabanı Modeli Diyagramı şablonu için tersine mühendislik özelliklerini (Visio’da model oluşturmak için var olan bir veritabanını kullanma) destekler ancak ileri mühendislik özelliğini (SQL kodu oluşturmak için bir Visio veritabanı modelini kullanma) desteklemez.

  • Hem tersine hem ileri mühendislik dahil olmak üzere tüm veritabanı modelleme özelliklerini Visio for Enterprise Architects’te bulabilirsiniz. Visio for Enterprise Architects; Visual Studio Professional ve Visual Studio Team System rol tabanlı sürümleriyle kullanılabilen MSDN Premium Aboneliği’nde yer alır.

  1. Veritabanı modeli diyagramınızı başlatmak için şunlardan birini yapın:

    Sıfırdan yeni bir model diyagramı oluşturma

    Başlangıç noktası olarak kullanmak istediğiniz var olan bir veritabanınız yoksa boş bir Veritabanı Modeli ile başlayıp kendi tablolarınızı ve ilişkilerinizi ekleyebilirsiniz.

    1. Dosya menüsünde Yeni’nin üzerine gelin, Yazılım ve Veritabanı’nın üzerine gelin ve sonra Veritabanı Modeli Diyagramı’na tıklayın.

    2. Veritabanı menüsünde Seçenekler’in üzerine gelin ve sonra Belge’ye tıklayın.

    3. Veritabanı Belge Seçenekleri iletişim kutusunda kullanmak istediğiniz simge kümesi ile diğer tablo ve ilişki seçeneklerini belirleyin, sonra Tamam’a tıklayın.

    Başlangıç noktası olarak var olan bir veritabanını kullanma

    Daha iyi anlamak veya yeni bir model için başlangıç noktası olarak kullanmak üzere modellemek istediğiniz bir veritabanınız varsa veritabanının şemasını veya yapısını ayıklamak ve yeni bir model oluşturmak için Tersine Mühendislik Sihirbazı’nı kullanabilirsiniz.

    Not: Sihirbazı başlatmadan önce:

    1. Microsoft Office Excel çalışma kitabına tersine mühendislik işlemi uyguluyorsanız sihirbazı başlatmadan önce çalışma kitabını açmanız ve sütun başlıklarını içeren hücre grubunu (veya aralığını) adlandırmanız gerekir. Birden fazla çalışma sayfası kullanmak istiyorsanız her bir çalışma sayfasında sütun hücreleri grubunu isimlendirmeniz yeterlidir. Bu aralıklar sihirbazda tablolar olarak ele alınır. Hücre aralığını adlandırma hakkında daha fazla bilgi edinmek için Microsoft Office Excel yardımdaki Adlandırılmış hücre başvurularını veya aralıklarını tanımlama başlıklı konuya bakın.

    2. En iyi sonuçları elde etmek için Tersine Mühendislik Sihirbazı’nı çalıştırmadan önce varsayılan sürücünüzü tersine mühendislik işlemi uygulamak istediğiniz hedef veritabanı olarak ayarlayın. Bu adım, sihirbazın yerel veri türlerini doğru bir şekilde eşlemesini ve sihirbazın ayıkladığı tüm kodların Kod penceresinde doğru bir şekilde gösterilmesini sağlar.

    3. Dosya menüsünde Yeni’nin üzerine gelin, Yazılım ve Veritabanı’nın üzerine gelin ve sonra Veritabanı Modeli Diyagramı’na tıklayın.

    4. Veritabanı menüsünde Tersine Mühendislik’e tıklayın.

    5. Tersine Mühendislik Sihirbazı’nın ilk ekranında şunları yapın:

      1. Veritabanı yönetim sisteminizin (DBMS) Microsoft Office Visio veritabanı sürücüsünü seçin. Visio veritabanı sürücüsünü henüz belirli bir ODBC veri kaynağıyla ilişkilendirmediyseniz Kurulum’a tıklayın.

        Not: Excel çalışma sayfasına tersine mühendislik işlemi uyguluyorsanız ODBC Genel Sürücü’yü seçin.

      2. Güncelleştirdiğiniz veritabanının veri kaynağını seçin. Var olan veritabanı için henüz bir veri kaynağı oluşturmadıysanız şimdi oluşturmak için Yeni’ye tıklayın.

        Yeni bir kaynak oluşturduğunuzda adı Veri Kaynakları listesine eklenir.

      3. İstediğiniz ayarları yaptığınızda İleri’ye tıklayın.

    6. Herhangi bir sürücüye özel iletişim kutusundaki yönergeleri izleyin.

      Örneğin Veri Kaynağını Bağla iletişim kutusuna bir kullanıcı adı ile parola yazın ve Tamam’a tıklayın. Veri kaynağınız parola korumalı değilse Tamam’a tıklayın.

      Not: ODBC Genel Sürücü’yü kullanıyorsanız tersine mühendislik işlemi yapılan bilgilerin eksik olabileceğini belirten bir hata iletisi alabilirsiniz. Çoğu durumda bu bir sorun değildir; Tamam’a tıklayın ve sihirbaza devam edin.

    7. Ayıklamak istediğiniz bilgi türünün onay kutularını işaretleyin ve sonra İleri’ye tıklayın.

      Not: Sihirbazın ayıklayabildiği öğe türleri tüm veritabanı yönetim sistemleri tarafından desteklenmediğinden bazı öğeler kullanılamayabilir. (Bu öğeler soluk gösterilir.)

    8. Ayıklamak istediğiniz tabloların (ve varsa görünümlerin) onay kutularını işaretleyin veya hepsini ayıklamak için Tümünü Seç’e tıklayın ve sonra İleri’ye tıklayın.

      Not: Excel çalışma sayfasına tersine mühendislik işlemi uyguluyorsanız ve bu listede bir şey görmüyorsanız büyük olasılıkla çalışma sayfanızdaki sütun başlıklarını içeren hücre aralığını adlandırmanız gerekmektedir.

    9. 5. adımda Saklı Yordamlar onay kutusunu işaretlediyseniz ayıklamak istediğiniz yordamları seçin veya tümünü ayıklamak için Tümünü Seç’e tıklayın ve sonra İleri’ye tıklayın.

    10. Tersine mühendislik işlemi yapılan öğelerin geçerli sayfaya otomatik olarak eklenmesini isteyip istemediğinizi seçin.

      Not: Tersine mühendislik işlemi yapılan öğelerin Tablolar ve Görünümler penceresinde listelenmesine ek olarak sihirbazın çizimi otomatik olarak oluşturmasını seçebilirsiniz. Çizimin otomatik olarak oluşturulmamasına karar verirseniz veritabanı modelini kendiniz bir araya getirmek için öğeleri Tablolar ve Görünümler penceresinden çizim sayfanıza sürükleyebilirsiniz.

    11. İstediğiniz bilgileri ayıkladığınızı doğrulamak için seçimlerinizi gözden geçirin ve sonra Son’a tıklayın.

      Sihirbaz, seçilen bilgileri ayıklar ve Çıktı penceresinde ayıklama işlemine ilişkin notlar gösterir.

    Var olan bir modeli içeri aktarma ve iyileştirme

    Var olan bir VisioModeler veya PLATINUM ERwin modeliniz varsa Visio veritabanı modeli diyagramı oluşturmak için bunu içeri aktarabilirsiniz. Bu özellik yalnızca VisioModeler 2.0 ve sonraki sözlük modeli (.imd) dosyaları ve PLATINUM ERwin 2.6, 3.0 ve 3.52 .erx dosyalarıyla sınırlıdır.

    1. Dosya menüsünde Yeni’nin üzerine gelin, Yazılım ve Veritabanı’nın üzerine gelin ve sonra Veritabanı Modeli Diyagramı’na tıklayın.

    2. Veritabanı menüsünde İçeri Aktar’ın üzerine gelin ve sonra İçeri Aktar: <model türü> seçeneğini belirleyin.

    3. İçeri aktarmak istediğiniz modelin yolunu ve dosya adını yazın veya model dosyasının konumunu belirlemek için Gözat düğmesine tıklayın ve sonra ’a tıklayın.

    4. İçeri Aktar iletişim kutusunda Tamam’a tıklayın.

      Visio dosyayı içeri aktarır ve Çıktı penceresinde ilerleme durumunu gösterir. İçeri aktarılan tablolar, Tablolar ve Görünümler penceresinde gösterilir.

    5. Tablolar ve Görünümler penceresinde, modellemek istediğiniz tabloları seçin ve sonra bunları çizim sayfasına sürükleyin.

  2. Veritabanı modeli diyagramını oluşturduktan sonra diyagramı iyileştirme işine geçersiniz. Tablolar ve görünümler ekleyebilir, bunları özelleştirebilir, ilişkiler oluşturabilir ve sütunları ve veri türlerini özelleştirebilirsiniz.

    Tablolar

    Diyagramınızda tablo oluşturmak için Varlık şeklini kullanın.

    1. Varlık İlişkisi veya Nesne İlişkisel kalıptan çizime bir Varlık şekli sürükleyin.

    2. Veritabanı Özellikleri penceresini açmak için şekle çift tıklayın.

    3. Kategoriler altında Tanım’a tıklayın ve tablo için bir ad yazın.

    4. Kategoriler altında Sütunlar’a tıklayın, bir ad yazın ve veri türünü seçin.

    5. Boş değer içeremeyen sütunlar için Gerekli onay kutusunu işaretleyin.

    6. Veritabanı tablosunda her bir satırı benzersiz bir şekilde tanımlayan sütunlar için PK (birincil anahtar) onay kutusunu işaretleyin.

    7. Kategoriler altında Dizinler, Tetikleyiciler, Denetim veya Genişletilmiş’e tıklayarak bu isteğe bağlı öğeleri oluşturun.

    Sütunlar

    Veri türleri ve birincil anahtarlar dahil olmak üzere sütunlara özellikler eklemek veya sütunların özelliklerini değiştirmek için Veritabanı Özellikleri penceresini kullanın.

    1. Diyagramınızdaki tabloya çift tıklayın.

    2. Veritabanı Özellikleri penceresinde, Kategoriler altında Sütunlar’a tıklayın.

    3. İlk boş Fiziksel Ad hücresine tıklayın ve bir ad yazın.

    4. Bir sütunun veri türünü değiştirmek için sütunun Veri Türü alanına tıklayın ve sonra listeden bir veri türü seçin veya listeye türü yazın. Örneğin, decimal(8,2) veya char(30) yazabilirsiniz.

    5. Boş değerleri engellemek için Gerekli onay kutusunu işaretleyin.

    6. Sütunun birincil anahtar olduğunu belirtmek için PK onay kutusunu işaretleyin.

    7. Sütunlar kategorisine tıkladığınızda görüntülenenlere ek olarak daha fazla sütun özelliği görmek için sütunu seçin ve Düzenle’ye tıklayın.

    İlişkiler

    İlişkiler, veritabanlarının bir tablodaki satırı ilişkili bir tablodaki bir satırla eşleştirmesine izin vermek için birincil ve yabancı anahtarlar kullanır. Bu ilişkileri diyagramınızda gösterebilirsiniz. Ek olarak bunların kardinalitelerini ayarlayabilir (bire çok gibi) ve kardinaliteyi göstermek için Crow's feet, İlişkisel veya IDEF1X gösterimini seçebilirsiniz. Veritabanı Modeli Diyagramı şablonundaki bu gösterimlerle çoka çok ilişkileri gösteremezsiniz.

    1. Tablolar arasında ilişki oluşturma:

      1. Diyagramda her iki tablonun göründüğünden emin olun. Modele tersine mühendislik işlemini var olan bir veritabanından gerçekleştirdiyseniz tabloların birini veya her ikisini Tablolar ve Görünümler penceresinden çizim sayfasına sürüklemeniz gerekebilir.

      2. İlişkinin birincil anahtar tarafı için istediğiniz tabloya çift tıklayın.

      3. Veritabanı Özellikleri penceresinde, Kategoriler altında Sütunlar’a tıklayın.

      4. Kılavuzda, tablodaki her bir satırı benzersiz bir şekilde tanımlamak için, kullanmak istediğiniz sütuna tıklayın ve birincil anahtar olarak ayarlamak üzere PK onay kutusunu işaretleyin.

      5. Nesne İlişkisel veya Varlık İlişkisi kalıbından İlişki şeklini sayfadaki boş bir alana sürükleyip bırakın.

      6. Üst ucunu üst tablonun olduğu tabloya bağlayın.

      7. Diğer ucunu alt tabloya bağlayın.

        İkinci tablo henüz birincil anahtar ile aynı ada sahip bir sütun içermiyorsa modelci bunu ikinci tabloya yabancı anahtar olarak ekler.

        Not: İlişki çizgileri kaybolursa, Veritabanı menüsünde Seçenekler’in üzerine gelin ve Belge’ye tıklayın. İlişkiler sekmesindeki Göster’in altında İlişkiler onay kutusunu işaretleyin.

    2. İlişkinin kardinalitesini ayarlayın:

      1. İlişkiye çift tıklayın.

      2. Veritabanı Özellikleri penceresinde, Kategoriler’in altında Diğer’e tıklayın.

      3. Kardinalite altında ilişkiye en uygun olan kardinaliteyi seçin. Bire çok ilişkiler için en iyi seçenek Sıfır veya daha fazla ya da Bir veya daha fazla’dır. Bire bir ilişkiler için en iyi seçenek Sıfır veya bir ya da Tam olarak bir’dir.

  3. Diyagramınıza başka iyileştirmeler (dizinler, denetim koşulları ve tetikleyiciler oluşturma gibi) yapmak için şunları yapabilirsiniz:

    Dizin oluşturma

    Dizinler, bir sorgu çalıştırdığınızda veritabanınızın performansını veya hızını iyileştirir.

    1. Veritabanı modeli diyagramını açın.

    2. Dizin eklemek istediğiniz tabloya çift tıklayın ve Veritabanı Özellikleri penceresinde, Kategoriler listesinde Dizinler’e tıklayın.

    3. Yeni’ye tıklayın.

    4. Dizin Oluştur iletişim kutusunda dizin için bir ad yazın ve sonra Tamam’a tıklayın.

    5. Dizin Türü listesinde benzersiz veya benzersiz olmayan bir dizin oluşturmak için bir seçeneği belirleyin.

    6. Kullanılabilir Sütunlar listesinde bu dizine eklemek istediğiniz her bir sütunun adını seçin ve sonra Ekle > öğesine tıklayın.

    7. Dizinlenmiş Sütunlar listesinde artan sıralama düzenine sahip bir dizin oluşturmak için Asc onay kutusunu işaretleyin veya azalan sıralama düzenine sahip bir dizin oluşturmak için onay kutusunun işaretini kaldırın.

      Veritabanı modeli diyagramı güncelleştirilir.

    Görünüm oluşturma

    Görünümü kaydedilmiş bir sorgu olarak düşünebilirsiniz. Aynı bilgilere birden çok tablodan sürekli olarak erişmeniz gerekiyorsa veya verileri kullanıcılara asıl tabloları değiştirmelerine izin vermeden göstermek istiyorsanız görünümler oldukça kullanışlıdır.

    Varlık İlişkisi veya Nesne İlişkisel kalıbından bir Görünüm şeklini çizim sayfasına sürükleyin.

    Tablolar ve görünümler için genişletilmiş özellikler ayarlama

    Veritabanı yönetim sisteminize (DBMS) dayalı olarak nerede depolandıklarını belirlemek için tablolar veya görünümler için genişletilmiş özellikler ayarlayabilirsiniz.

    Genişletilmiş özelliklerini ayarlamak istediğiniz tablo veya görünüme çift tıklayın ve Veritabanı Özellikleri penceresinde, Kategoriler listesinde Genişletilmiş’e tıklayın.

    Denetim koşulu oluşturma

    Sütuna girilen verilerin belirli bir değer aralığında olduğundan emin olmak için denetim koşullarını kullanın. Örneğin, “Yaş” adlı bir sütundaki verilerin 65’ten fazla olmasını gerektiren bir denetim koşulu oluşturabilirsiniz.

    1. Veritabanı Özellikleri penceresini açmak için tabloya çift tıklayın.

    2. Kategoriler altında Sütunlar’a tıklayın ve denetim koşulunu eklemek istediğiniz sütuna tıklayın.

    3. Düzenle’ye tıklayın.

    4. Sütun Özellikleri iletişim kutusunun Denetim sekmesinde istediğiniz kısıtlamaları girin. Seçimleriniz hakkında daha fazla bilgi edinmek için bkz. Sütun ve Alan Özellikleri iletişim kutusu (Denetim sekmesi).

      Denetim koşulları, Yerel kod altında Kod penceresine eklenir.

    Saklı yordamlar ve kullanıcı tanımlı işlevler oluşturma

    Aynı eylemleri tekrarlayarak gerçekleştirmek üzere yeniden kullanabileceğiniz kod paketleri oluşturmak için saklı yordamları ve kullanıcı tanımlı işlevleri kullanın. İkisi arasındaki en büyük fark, kullanıcı tanımlı işlev bir değer döndürürken saklı yordamın kodu bir değer döndürmeden yürütmesidir.

    1. Veritabanı menüsünde Görünüm’ün üzerine gelin ve Kod penceresini açmak için Kod’a tıklayın.

    2. Genel Kod’a tıklayın ve sonra Yeni’ye tıklayın.

    3. Kod Düzenleyicisi’nin Özellikler sekmesinde, oluşturmak istediğiniz türdeki koda tıklayın ve kod için bir ad yazın.

    4. Gövde sekmesinde kodu yazın ve Tamam’a tıklayın.

    Tetikleyici oluşturma

    Tetikleyiciler, tetikleyicide belirttiğiniz SQL kodunun veritabanında belirli bir olay gerçekleştiğinde çalışmasını sağlar.

    1. Veritabanı Özellikleri penceresini açmak için tabloya çift tıklayın.

    2. Kategoriler altında Tetikleyiciler’e tıklayın ve sonra Ekle’ye tıklayın.

    3. Özellikler sekmesinde tetikleyici için bir ad yazın.

    4. Gövde sekmesinde kodu yazın ve Tamam’a tıklayın.

      Tetikleyici, Yerel kod altındaki Kod penceresine eklenir.

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×