VE işlevi

Mantıksal işlevlerden biri olan VE işlevini, bir testteki tüm koşullardan DOĞRU olup olmadığını saptamak için kullanın.

Örnek

VE işlevinin örnekleri

VE işlevi, tüm bağımsız değişkenleri DOĞRU olarak değerlendirilirse DOĞRU'yu döndürür; bir ya da daha fazla bağımsız değişkeni YANLIŞ olarak değerlendirilirse YANLIŞ'ı döndürür.

VE işlevinin yaygın bir kullanımı, mantıksal sınamalar gerçekleştiren diğer işlevlerin kullanım alanını genişletmektir. Örneğin, EĞER işlevi mantıksal bir sınama yapar ve sınama DOĞRU olarak değerlendirilirse bir değer ve YANLIŞ olarak değerlendirilirse başka bir değer verir. EĞER işlevinin mantıksal_sınama bağımsız değişkeni olarak VE işlevi kullanılırsa, tek bir koşul yerine birçok farklı koşulu sınayabilirsiniz.

Söz dizimi

VE(mantıksal1, [mantıksal2], ...)

VE işlevinin söz diziminde aşağıdaki bağımsız değişkenler bulunur:

Bağımsız Değişken

Açıklama

Mantıksal1

Gerekli. Test etmek istediğiniz ve DOĞRU veya YANLIŞ olarak değerlendirilebilecek ilk koşul.

Mantıksal2, ...

İsteğe bağlı. Test etmek istediğiniz ve DOĞRU veya YANLIŞ olarak değerlendirilebilecek ek koşullar; en çok 255 koşul bulunabilir.

Notlar

  • Bağımsız değişkenler, DOĞRU veya YANLIŞ gibi mantıksal değerler oluşturmalı veya mantıksal değerler içeren diziler veya başvurular olmalıdır.

  • Bir dizi veya başvuru bağımsız değişkeni metin veya boş hücreler içeriyorsa, bu değerler dikkate alınmaz.

  • Belirlenen aralık hiçbir mantıksal değer içermiyorsa, VE işlevi #DEĞER! hatasını döndürür.

Örnekler

VE’nin kendi başına ve EĞER işleviyle birlikte kullanımına yönelik örnekleri aşağıda bulabilirsiniz.

EĞER işlevlerini VE ile kullanma örnekleri

Formül

Açıklama

=VE(A2>1,A2<100)

A2 hücresinin değeri 1’den büyükse VE 100’den küçükse DOĞRU değerini görüntüler, bunun dışındaki durumlarda YANLIŞ değerini görüntüler.

=EĞER(VE(A2<A3,A2<100),A2,"Değer aralık dışında")

A2 hücresindeki değer A3'ten küçükse VE 100’den küçükse, bu değeri görüntüler. Değilse, "Değer aralığın dışında" iletisini görüntüler.

=EĞER(VE(A3>1,A3<100),A3,"Değer aralık dışında")

A3 hücresindeki değer 1’den büyükse VE 100’den küçükse, bu değeri görüntüler. Değilse, iletiyi görüntüler. İstediğiniz herhangi bir iletiyi yazabilirsiniz.

Prim Hesaplaması

Burada, EĞER ve VE kullanarak satış personelinin prime hak kazanıp kazanmadığını hesaplamamız gereken oldukça yaygın bir senaryo verilmiştir.

EĞER ve VE işlevleriyle Satış Primi hesaplama örnekleri.  E14 hücresindeki formül: =EĞER(VE(B14>=$B$7,C14>=$B$5),B14*$B$8,0)
  • =EĞER(VE(B14>=$B$7,C14>=$B$5),B14*$B$8,0) - EĞER Toplam Satış değeri Satış Hedefinden büyük veya ona eşitse (>=) VE Hesaplar Hesap Hedefinden büyük veya ona eşitse (>=), Toplam Satışı Prim Yüzdesi ile çarpın; değilse 0 döndürün.

Daha fazla yardım mı gerekiyor?

Sorularınızı Excel Teknoloji Topluluğu’ndaki uzmanlara sorabilir, Yanıt topluluğu’ndan destek alabilir ya da Excel için UserVoice platformuna yeni bir özellik veya iyileştirme önerisi sunabilirsiniz.

Ayrıca Bkz:

EĞER işlevinin kullanımı hakkında video izleyin

Formülde iç içe geçen işlevler kullanmayı öğrenin

EĞER işlevi

YADA işlevi

DEĞİL işlevi

Excel formüllerine genel bakış

Bozuk formülleri önleme

Formüllerdeki hataları saptamak için hata denetimini kullanma

Windows için Excel 2016’da klavye kısayolları

Mac için Excel 2016’da klavye kısayolları

Mantıksal işlevler (başvuru)

Excel işlevleri (alfabetik sıraya göre)

Excel işlevleri (kategoriye göre)

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×