VE, YADA ve DEĞİL işlevlerini EĞER ile kullanma

EĞER işlevi, bir koşulu test edip Doğru veya Yanlış sonucunu döndürerek, bir değerle beklediğiniz değer arasında mantıksal karşılaştırma yapmanıza olanak tanır.

  • =EĞER(Bir şey Doğru ise, bir şey yap, değilse başka bir şey yap)

Birden fazla koşulu test etmek istiyorsanız ve tüm koşulların Doğru ya da Yanlış olması gerekiyorsa (VE); koşullardan yalnızca birinin Doğru veya Yanlış olması gerekiyorsa (YADA) veya koşulun ölçütlerinize uyup uymadığını denetlemek istiyorsanız (DEĞİL) ne yapmalısınız? Bu işlevlerin üçü de tek başına kullanılabilir, ancak çoğunlukla EĞER işlevleriyle birlikte kullanılırlar.

Koşullar Doğru veya Yanlış ise, birden fazla hesaplama yapabilmek için EĞER işlevini VE, YADA veya DEĞİL ile kullanın.

Söz Dizimi

  • EĞER(VE()) - EĞER(VE(mantıksal1, [mantıksal2], ...), eğer_doğruysa_değer, [eğer_yanlışsa_değer]))

  • EĞER(YADA()) - EĞER(YADA(mantıksal1, [mantıksal2], ...), eğer_doğruysa_değer, [eğer_yanlışsa_değer]))

  • EĞER(DEĞİL()) - EĞER(DEĞİL(mantıksal1), eğer_doğruysa_değer, [eğer_yanlışsa_değer]))

Bağımsız değişken adı

Açıklama

mantıksal_sınama (gerekli)

Sınamak istediğiniz koşul.

eğer_doğruysa_değer (gerekli)

Mantıksal_sınama sonucu DOĞRU ise döndürülmesini istediğiniz değer.

eğer_yanlışsa_değer (isteğe bağlı)

Mantıksal_sınama sonucu YANLIŞ ise döndürülmesini istediğiniz değer.

VE, YADA ve DEĞİL işlevlerinin ayrı ayrı nasıl yapılandırılacağıyla ilgili genel bilgiler aşağıda açıklanmıştır. Her birini EĞER deyimiyle birleştirdiğinizde şu şekilde okunurlar:

  • VE – =EĞER(VE(Bir şey Doğru ise, Başka bir şey de Doğru’dur), Eğer Doğruysa Değer, Eğer Yanlışsa Değer)

  • VE – =EĞER(YADA(Bir şey Doğru ise, Başka bir şey de Doğru’dur), Eğer Doğruysa Değer, Eğer Yanlışsa Değer)

  • VE – =EĞER(DEĞİL(Bir şey Doğru’dur), Eğer Doğruysa Değer, Eğer Yanlışsa Değer)

Örnekler

Sık kullanılan iç içe EĞER(VE()), EĞER(YADA()) ve EĞER(DEĞİL()) deyimlerinin örneklerini aşağıda görebilirsiniz. VE ve YADA işlevleri 255 ayrı koşulu destekleyebilir. Ancak karmaşık ve iç içe formüllerin oluşturulması, test edilmesi ve denetlenmesi zor olacağından, birkaç işlevden fazlasının kullanılması önerilmez. DEĞİL işlevi yalnızca bir koşul alır.

EĞER ile birlikte VE, YADA ve DEĞİL işlevlerini kullanarak sayısal değer hesaplama ve metin değerlendirme örnekleri

Formüller, mantıklarına göre şu şekilde yazılır:

Formül

Açıklama

=EĞER(VE(A2>0,B2<100),DOĞRU,YANLIŞ)

EĞER A2 (25) 0’dan büyükse, VE B2 (75) 100’den küçükse, DOĞRU değerini döndür, aksi halde YANLIŞ değerini döndür. Bu durumda, iki koşul da doğru olduğu için DOĞRU döndürülür.

=EĞER(VE(A3="Kırmızı",B3="Yeşil"),DOĞRU,YANLIŞ)

Eğer A3 (“Mavi”) = “Kırmızı”, VE B3 (“Yeşil”), “Yeşil”e eşitse DOĞRU değerini döndür, aksi halde YANLIŞ değerini döndür. Bu durumda, yalnızca ilk koşul doğru olduğu için YANLIŞ döndürülür.

=EĞER(YADA(A4>0,B4< 50),DOĞRU,YANLIŞ)

EĞER A4 (25) 0’dan büyükse, YADA B4 (75) 50’den küçükse DOĞRU değerini döndür, aksi halde YANLIŞ değerini döndür. Bu durumda, yalnızca ilk koşul DOĞRU’dur ancak YADA işlevi sadece tek bağımsız değişkenin doğruluğunu gerektirdiğinden, formül DOĞRU döndürür.

=EĞER(YADA(A5=”Kırmızı”,B5=”Yeşil”),DOĞRU,YANLIŞ)

EĞER A5 (“Mavi”) “Kırmızı”ya eşitse, YADA B5 (“Yeşil”) “Yeşil”e eşitse DOĞRU döndür, aksi halde YANLIŞ döndür. Bu durumda, ikinci bağımsız değişken Doğru olduğu için formül DOĞRU döndürür.

=EĞER(DEĞİL(A6>50),DOĞRU,YANLIŞ)

EĞER A6 (25) 50’den büyük DEĞİL ise, DOĞRU döndür, büyükse YANLIŞ döndür. Bu durumda, 25, 50’den büyük olmadığından formül DOĞRU döndürür.

=EĞER(DEĞİL(A7="Kırmızı"),DOĞRU,YANLIŞ)

EĞER A7 (“Mavi”) “Kırmızı”ya eşit DEĞİL ise DOĞRU döndür, eşitse YANLIŞ döndür.

Tüm örneklerde gösterildiği gibi, ilgili koşullar girildikten sonra koşulun kapatma paranteziyle bitirilmesi gerekir. Böylece, kalan Doğru/Yanlış bağımsız değişkenleri, dıştaki EĞER deyiminin bir parçası olarak kalır. Örneklerde DOĞRU/YANLIŞ yerine döndürülecek Metin Temelli değerler ya da Sayısal değerlerler de girebilirsiniz.

VE, YADA ve DEĞİL işlevlerinin tarih hesaplama için nasıl kullanılacağını gösteren örnekler aşağıda verilmiştir.

EĞER ile birlikte VE, YADA ve DEĞİL işlevlerini kullanarak tarih hesaplama örnekleri

Formüller, mantıklarına göre şu şekilde yazılır:

Formül

Açıklama

=EĞER(A2>B2,DOĞRU,YANLIŞ)

EĞER A2 B2’den büyükse DOĞRU döndür, aksi halde YANLIŞ döndür. 03/12/14, 01/01/14’ten büyük olduğu için formül DOĞRU döndürür.

=EĞER(VE(A3>B2,A3<C2),DOĞRU,YANLIŞ)

EĞER A3 B2’den büyükse VE A3 C2’den küçükse DOĞRU döndür, aksi halde YANLIŞ döndür. Bu durumda, iki bağımsız değişken de doğru olduğu için formül DOĞRU döndürür.

=EĞER(YADA(A4>B2,A4<B2+60),DOĞRU,YANLIŞ)

EĞER A4 B2’den büyükse YADA A4 B2+60’tan küçükse DOĞRU döndür, aksi halde YANLIŞ döndür. Bu durumda, ilk bağımsız değişken doğrudur ancak ikincisi yanlıştır. YADA işlevi bağımsız değişkenlerden yalnızca birinin doğru olmasını gerektirdiğinden formül DOĞRU döndürür. Formül sekmesindeki Formülü Değerlendir Sihirbazı’nı kullanarak Excel’in formülü nasıl hesapladığını görebilirsiniz.

=EĞER(DEĞİL(A5>B2),DOĞRU,YANLIŞ)

EĞER A5 B2’den büyük değilse, DOĞRU döndür, büyükse YANLIŞ döndür. Bu durumda, A5, B2’den büyük olduğu için formül YANLIŞ döndürür.

Formülü Değerlendir Sihirbazı örneği

Koşullu Biçimlendirme ile VE, YADA ve DEĞİL kullanma

Formül seçeneğiyle Koşullu Biçimlendirme ölçütü ayarlamak için VE, YADA ve DEĞİL işlevlerini de kullanabilirsiniz. Bu işlemi yaptığınızda, EĞER işlevini yok sayarak doğrudan VE, YADA ve DEĞİL’i kullanabilirsiniz.

Giriş sekmesinde Koşullu Biçimlendirme > Yeni Kural'a tıklayın. Sonra, “Biçimlendirilecek hücreleri belirlemek için formül kullan” seçeneğini kullanarak formülünüzü girin ve seçtiğiniz biçimi uygulayın.

Formül yöntemini gösteren Koşullu Biçimlendirme > Kural Düzenle iletişim kutusu

Daha önce verilen Tarihler örneği kullanıldığında, formüller şöyle olur:

VE, YADA ve DEĞİL işlevlerini Koşullu Biçimlendirme testleri için kullanma örneği


Formül

Açıklama

=A2>B2

A2, B2'den büyükse hücreyi biçimlendir, değilse hiçbir şey yapma.

=VE(A3>B2,A3<C2)

A3, B2’den büyükse VE A3, C2’den küçükse hücreyi biçimlendir, aksi halde hiçbir şey yapma.

=YADA(A4>B2,A4<B2+60)

A4, B2’den büyükse YADA A4, B2 artı 60’tan küçükse hücreyi biçimlendir, aksi halde hiçbir şey yapma.

=DEĞİL(A5>B2)

A5, B2'den büyük DEĞİL ise hücreyi biçimlendir, büyükse hiçbir şey yapma. Bu durumda A5, B2’den büyük olduğu için YANLIŞ sonucu döndürülür. Formül =DEĞİL(B2>A5) olarak değiştirilirse, DOĞRU döndürülür ve hücre biçimlendirilir.

Not : Formülü Koşullu Biçimlendirmeye eşittir işareti (=) koymadan girmek, sık yapılan bir hatadır. Bunu yaparsanız Koşullu Biçimlendirme iletişim kutusu, formüle eşittir işareti ve tırnak işaretleri ekler: ="VEYA(A4>B2,A4<B2+60)". Bu durumda, formülün düzgün çalışması için tırnak işaretlerinin kaldırılması gerekir.

Sayfanın Başı

Daha fazla yardım mı gerekiyor?

Sorularınızı Excel Teknoloji Topluluğu’ndaki uzmanlara sorabilir, Yanıt topluluğu’ndan destek alabilir ya da Excel için UserVoice platformuna yeni bir özellik veya iyileştirme önerisi sunabilirsiniz.

Ayrıca Bkz:

EĞER işlevinin kullanımı hakkında video izleyin

Formülde iç içe geçen işlevler kullanmayı öğrenin

EĞER işlevi

VE işlevi

YADA işlevi

DEĞİL işlevi

Excel formüllerine genel bakış

Bozuk formülleri önleme

Formüllerdeki hataları saptamak için hata denetimini kullanma

Windows için Excel'de klavye kısayolları

Mac için Excel'de klavye kısayolları

Mantıksal işlevler (başvuru)

Excel işlevleri (alfabetik sıraya göre)

Excel işlevleri (kategoriye göre)

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×