UML kullanım durumu diyagramı oluşturma

Önemli : Bu makale makine çevisidir. Bkz. yasal uyarı. Bu makalenin İngilizce sürümüne buradan ulaşabilirsiniz.

Visio, birleştirilmiş model dili (UML) kullanım örneği diyagramları oluşturmak için kullanabilirsiniz. Birleştirilmiş model dili (UML) yazılım modelleri çizmek için standart bir yoludur.

"Kullanım durumu diyagramı sistem sınırı tanımlama ve bunu dışındaki aktör kullan nasıl etkilediğini durumlarda içeren"

Açıklama balonu 1 sistem sınırı tanımlama sistemine iç veya dış değerlendirilir belirler.

Açıklama Balonu 2 Bir aktör dış nesne tarafından çalan bir rol temsil eder. Bir nesneye birkaç rolü yürütme ve bu nedenle, birkaç aktör tarafından temsil edilir.

belirtme çizgisi 3 iletişim ilişkisi katılım aktör, kullanım durumu gösterilmektedir.

Adım 4 kullanım durumu bir aktör bir işlemi tamamlamak için bir sistem kullandığında gerçekleşen olayları kümesidir. Normalde, kullanım durumu görece daha büyük bir işlem veya değil, bir tek tek adım hareket olur.

  1. Dosya sekmesinde, Yeni'ninüzerine gelin ve sonra boş bir diyagramı açın.

  2. Diğer şekiller ' i tıklatın > yazılım ve veritabanı > yazılım > UML Kullanım durumu.

    Kullanım durumu diyagramı oluşturma

  3. Kullanım durumu diyagramı içinde bir alt göstermek için

    1. Alt Şekil çizim sayfasına sürükleyin. Alt tüm sisteminizi veya önemli bir bileşeni gösterebilir.

    2. Alt şekli çift tıklatın ve sonra için yeni bir ad yazın veya varolan bir adı silmek için Sil tuşuna basın. Çizim sayfasındaki şekli dışını tıklatın.

    3. Alt yeniden boyutlandırmak için şekli seçin ve sonra bir seçim tutamacını sürükleyin.

  4. Kullanım durumu şablonundan kullanım durumu şekilleri sürükleyin ve bunları alt sınırı yerleştirin ve sonra Aktör şekiller için alt sınırı dışına sürükleyin.

  5. Bağlayıcı şekiller arasındaki ilişkileri durumları ve aktör kullanma göstermek için kullanın. Beş bağlayıcılar vardır:

    • İlişkilendirme: bir kullanım örneği için aktör arasındaki ilişkiyi gösterir.

    • Bağımlılık: bir kullanım örneği bağımlılık başka bir bilgisayara sahip olduğunu gösterir.

    • Gerçekleştirme: Genel kullanım örneğinin hedeflere ulaşmak için belirli bir şekilde bir kullanım örneği gösterir.

    • Ekle: kullanım durumu küçük adımlara nasıl bozuk gösterir.

    • Uzat: bir kullanım durumu işlevselliği diğerine eklediği gösterilmektedir.

    Örnek: bir aktör ve kullanım örneği arasında bir ilişki belirtmek için

    1. Bir kullanım durumu diyagramıiçinde bir ilişkilendirme bağlayıcı şekli çizim sayfasına sürükleyin.

    2. Bir uç noktasını ilişkilendirme şeklin Aktör şekil üzerinde bir bağlantı noktasına tutkallayın. Diğer uç bir Kullanım örneği şekil üzerinde bir bağlantı noktasına tutkallayın.

  6. Diyagramı kaydedin.

Ayrıca bkz.

Büyük/küçük harf diyagramları kullanma hakkında daha fazla bilgi (ve büyük/küçük harf diyagramları oluşturmak için Microsoft Visual Studio kullanmaya yönelik yordamları kullanın), için Git UML kullanma örneği diyagramları: başvuru.

  1. Dosya sekmesinde, Yeni'ninüzerine gelin.

  2. Şablon kategorilerialtında yazılım ve veritabanı'nıtıklatın.

    Yazılım ve veritabanı seçin

  3. UML modeli diyagramı' na tıklayın. Boş bir çizim sayfası görüntülenir.

    UML modeli diyagramı seçin

  4. Ağaç görünümünde, kullanım durumu diyagramı ekleyin ve ardından Yeni'ninüzerine gelin istediğiniz alt sistem veya pakete sağ tıklayın ve Büyük/küçük harf diyagramı kullanın'ıtıklatın.

    Kullanım durumu diyagramı tıklatın

    Boş bir sayfa görüntülenir ve en üstteki kalıbı UML Kullanım durumu kalıbı olur. Diyagram temsil eden bir simge için ağaç görünümünü eklenir.

    Kullanım durumu için ağaç görünümü eklenir

    Not : Ağaç görünümü görünür durumda değilse, UML sekmesinde, Göster/Gizle grubunda Modeli Gezgini'niseçin.

  5. Kullanım durumu diyagramı bir Sistem sınırını göstermek için

    1. Sistem sınırını Şekil çizim sayfasına sürükleyin.

      Sistem kenarlığı seçin

    2. Sistem sınırını şekli çift tıklatın ve sonra sistem için yeni bir ad yazın veya var olan bir adı silmek için Sil tuşuna basın. Çizim sayfasındaki şekli dışını tıklatın.

    3. Sistem sınırını yeniden boyutlandırmak için, şekli seçin ve bir seçim tutamacını sürükleyin.

  6. Kullanım durumu şablonundan kullanım durumu şekilleri sürükleyin ve bunları sistem sınırı yerleştirin ve sonra Aktör şekiller için sistem sınırı dışına sürükleyin.

  7. Communicates şekilleri aktör kullanım örnekleri arasındaki ilişkileri göstermek için kullanın.

    Bir aktör ve kullanım örneği arasında bir ilişki göstermek için

    1. kullanım durumu diyagramı, bir İlişki kurar şeklini çizim sayfasına sürükleyin.

    2. Bir uç noktasını Bitiş noktası resmi, yeşil kare içinde artı simgesi Aktör şekil üzerinde bir bağlantı noktası Bağlantı noktası görüntüsü - mavi X Communicates şeklinin tutkallayın. Diğer uç bir Kullanım örneği şekil üzerinde bir bağlantı noktasına tutkallayın.

    3. Bilgi akışını belirten bir ok eklemek isterseniz, aşağıdakileri yapın:

      • İlişki kurar şeklini çift tıklatın, ardından, İlişki altından, düzenlemek istediğiniz ucu tıklatın ve Özellikler öğesini tıklatın.

      • İlişki Ucu kategorisinde, IsNavigable kutusunu işaretleyin, Tamam düğmesini, sonra yeniden Tamam düğmesini tıklatın.

      • İletişim Kurar şeklini sağ tıklatın ve Şekil Görüntüleme Seçenekleri seçeneğini tıklatın. Uç seçenekleri altında, Uç gezilebilirliği seçimini yapın ve Tamam düğmesini tıklatın.

  8. Kullanım durumları arasında ilişkiler belirtmek için Kullanımlar ve Genişletir şekillerini kullanın.

    İki kullanım örnekleri arasındaki kullanımlar ilişkisini göstermek için

    1. kullanım durumu diyagramı, bir Kullanımlar ilişkisi şeklini çizim sayfasına sürükleyin.

    2. Ucu bir kullanım örneği davranışını kullanan Büyük/küçük harf kullanma şekli bir bağlantı noktası Bağlantı noktası görüntüsü - mavi X için olmadan kullanan uç tutkallayın.

    3. Kullanımlar uç noktasını kullanılmakta olan kullanım durumu üzerindeki bir bağlama noktasına tutkallayın (ok başıyla birlikte).

    4. UML Genelleştirme Özellikleri iletişim kutusunu açmak için Kullanımlar şeklini çift tıklatın. Özellik değerleri ekleyin ve Tamam düğmesini tıklatın.

    Göstermek için bir genişletir iki kullanım örnekleri arasındaki ilişki

    1. kullanım durumu diyagramı, bir Genişletir şeklini çizim sayfasına sürükleyin.

    2. Uzantısı sağlayarak kullanımı kabının Bağlantı noktası görüntüsü - mavi X gelin ucu bir bağlantı olmadan Extends uç noktası Bitiş noktası resmi, yeşil kare içinde artı simgesi tutkallayın.

    3. Genişletir uç noktasını taban kullanım durumu üzerindeki bir bağlantı noktasına ok başıyla birlikte tutkallayın.

    4. UML Genelleştirme Özellikleri iletişim kutusunu açmak için Genişletir şeklini çift tıklatın. Özellik değerlerini ekleyin ve Tamam düğmesini tıklatın.

  9. Herhangi bir şekli çift tıklatarak (Sistem Sınırı şekli dışında) ad, öznitelikler, işlemler ve diğer özellik değerleri ekleyebileceğiniz UML Özellikleri iletişim kutusunu açın.

  10. Diyagramı kaydedin.

  1. Dosya menüsünde Yeni'ninüzerine gelin, yazılım ve veritabanıüzerine gelin ve sonra UML modeli diyagramı' na tıklayın.

    Yazılım ve veritabanı seçin

  2. İçinde ağaç görünümüpaket veya kullanım durumu diyagramıdahil, Yeni'ninüzerine gelin ve sonra Kullanım durumu diyagramıtıklatın istediğiniz alt sağ tıklatın.

    Selece kullanım durumu diyagramı

    Boş bir sayfa görüntülenir ve en üstteki kalıbı UML Kullanım durumu kalıbı olur. Diyagram temsil eden bir simge için ağaç görünümünü eklenir.

    Not : Ağaç görünümü görünmüyorsa, UML menüsünde Görünüm komutunun üzerine gelin ve Model Gezgini komutunu tıklatın.

  3. Kullanım durumu diyagramı içinde sistem sınırı belirtmek için

    1. Sistem sınırı Şekil çizim sayfasına sürükleyin.

      Büyük/küçük harf kalıp kullanma

    2. Sistem sınırı şekli çift tıklatın ve sonra sistemi için yeni bir ad yazın veya varolan bir adı silmek için Sil tuşuna basın. Çizim sayfasındaki şekli dışını tıklatın.

    3. Sistem sınırını yeniden boyutlandırmak için, şekli seçin ve bir seçim tutamacını sürükleyin.

  4. Kullanım durumu şablonundan kullanım durumu şekilleri sürükleyin ve bunları sistem sınırı yerleştirin ve sonra Aktör şekiller için sistem sınırı dışına sürükleyin.

  5. Communicates şekilleri aktör kullanım örnekleri arasındaki ilişkileri göstermek için kullanın.

    Bir aktör ve kullanım örneği arasında bir ilişki belirtmek için

    1. kullanım durumu diyagramı, bir İlişki kurar şeklini çizim sayfasına sürükleyin.

    2. Bir uç noktasını Bitiş noktası resmi, yeşil kare içinde artı simgesi Aktör şekil üzerinde bir bağlantı noktası Bağlantı noktası görüntüsü - mavi X Communicates şeklinin tutkallayın. Diğer uç bir Kullanım örneği şekil üzerinde bir bağlantı noktasına tutkallayın.

    3. Bilgi akışını belirten bir ok eklemek isterseniz, aşağıdakileri yapın:

      • İlişki kurar şeklini çift tıklatın, ardından, İlişki altından, düzenlemek istediğiniz ucu tıklatın ve Özellikler öğesini tıklatın.

      • İlişki Ucu kategorisinde, IsNavigable kutusunu işaretleyin, Tamam düğmesini, sonra yeniden Tamam düğmesini tıklatın.

      • İletişim Kurar şeklini sağ tıklatın ve Şekil Görüntüleme Seçenekleri seçeneğini tıklatın. Uç seçenekleri altında, Uç gezilebilirliği seçimini yapın ve Tamam düğmesini tıklatın.

  6. Kullanım durumları arasında ilişkiler belirtmek için Kullanımlar ve Genişletir şekillerini kullanın.

    İki kullanım örnekleri arasındaki kullanımlar ilişkisini göstermek için

    1. kullanım durumu diyagramı, bir Kullanımlar ilişkisi şeklini çizim sayfasına sürükleyin.

    2. Ucu bir kullanım örneği davranışını kullanan Büyük/küçük harf kullanma şekli bir bağlantı noktası Bağlantı noktası görüntüsü - mavi X için olmadan kullanan uç tutkallayın.

    3. Kullanımlar uç noktasını kullanılmakta olan kullanım durumu üzerindeki bir bağlama noktasına tutkallayın (ok başıyla birlikte).

    4. UML Genelleştirme Özellikleri iletişim kutusunu açmak için Kullanımlar şeklini çift tıklatın. Özellik değerleri ekleyin ve Tamam düğmesini tıklatın.

    Belirtmek için bir genişletir iki kullanım örnekleri arasındaki ilişki

    1. kullanım durumu diyagramı, bir Genişletir şeklini çizim sayfasına sürükleyin.

    2. Uzantısı sağlayarak kullanımı kabının Bağlantı noktası görüntüsü - mavi X gelin ucu bir bağlantı olmadan Extends uç noktası Bitiş noktası resmi, yeşil kare içinde artı simgesi tutkallayın.

    3. Genişletir uç noktasını taban kullanım durumu üzerindeki bir bağlantı noktasına ok başıyla birlikte tutkallayın.

    4. UML Genelleştirme Özellikleri iletişim kutusunu açmak için Genişletir şeklini çift tıklatın. Özellik değerlerini ekleyin ve Tamam düğmesini tıklatın.

  7. Herhangi bir şekli çift tıklatarak (Sistem Sınırı şekli dışında) ad, öznitelikler, işlemler ve diğer özellik değerleri ekleyebileceğiniz UML Özellikleri iletişim kutusunu açın.

  8. Diyagramı kaydedin.

Not : Makine Çevirisi Yasal Uyarısı: Bu makale, insan müdahalesi olmadan bir bilgisayar sistemi tarafından çevrilmiştir. Microsoft bu makine çevirilerini İngilizce bilmeyen kullanıcıların Microsoft ürünleri, hizmetleri ve teknolojileriyle ilgili içeriklerden yararlanmasına yardımcı olmak için sunar. Bu makale makine çevirisi olduğundan sözcük, cümle dizilimi ve gramer hataları içerebilir.

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×