Tablo ilişkileri kılavuzu

Önemli : Bu makale makine çevisidir. Bkz. yasal uyarı. Bu makalenin İngilizce sürümüne buradan ulaşabilirsiniz.

Veri fazlalık (yinelenen verileri) kaldırmak için iyi veritabanı tasarımının hedeflerin biridir. Bu hedefe ulaşmak için böylece her olgunun yalnızca bir kez temsil edilen birçok konu tabanlı tablolara verilerinizi bölün. Ardından bölünmüş bilgileri birlikte geri getirmek hangi yollarla ile erişilmesine — ilişkili tablolarda sık kullanılan alanlar koyarak bunu. Bu adımı uygulamak için doğru Bununla birlikte, bırakmalı ilk tablolarınız arasında ilişkilerini anlama ve sonra bu ilişkiler, veritabanınızdaki belirtin.

Daha fazla bilgi için veritabanı tasarımında temel bilgilerbaşlıklı makaleye bakın.

Bu makalede, bir web veritabanında ilişkiler kapsamaz. İlişkiler penceresi Web veritabanlarında desteklemez. Bir web veritabanında ilişkiler oluşturmak için arama alanlarını kullanın. Daha fazla bilgi için Web'de paylaşmak üzere bir veritabanı oluşturmamakalesine bakın.

Bu makalede

Giriş

Tablo ilişkilerinin türleri

Neden tablo ilişkileri oluşturulur?

Bilgi tutarlılığını anlama

Tablo ilişkilerini görüntüleme

Tablo ilişkisi oluşturma

Tablo ilişkisini silme

Tablo ilişkisini değiştirme

Bilgi tutarlılığını zorunlu kılma

Giriş

Bir tabloyu veritabanınızda için her konu oluşturduktan sonra bu bilgileri geri birlikte yeniden gerektiğinde getirmek hangi yollarla ile Access sağlamanız gerekir. İlişkili tablolarda sık kullanılan alanlar getirerek ve, tablolar arasındaki ilişkileri tanımlayarak bunu. Ardından, sorguları, formları ve aynı anda birkaç tablodan alınan bilgileri görüntüleyen raporlar oluşturabilirsiniz. Örneğin, burada gösterildiği form birkaç tablodan alınan bilgileri içerir:

Bir defada beş tablodan alınan ilişkili bilgileri görüntüleyen siparişler formu

1. Bu formdaki bilgilere kaynaklık edenler: Müşteriler tablosu...

2. ...Siparişler tablosu...

3. ...Ürünler tablosu...

4. ...ve Sipariş Ayrıntıları tablosu.

Fatura Adresi kutusundaki müşteri adı, Müşteriler tablosundan, Sipariş No ve Sipariş Tarihi değerleri, Siparişler tablosundan; Ürün adı, Ürün tablosundan; Birim Fiyatı ve Miktar değerleri de Sipariş Ayrıntıları tablosundan alınır. Bu tablolar, içlerindeki bilgilerin forma getirilmesi için çok çeşitli şekilde birbirine bağlanır.

Önceki örnekte, aynı sipariş hakkındaki bilgiyi göstermek için bu tabloların alanları koordine edilmelidir. Bu koordinasyon, tablo ilişkileri kullanılarak gerçekleştirilir. Tablo ilişkisi anahtar alanlardaki veriler eşleştirilerek çalışır — genellikle adı iki tablo da aynı olan bir alan. Çoğu durumlarda, bu eşleştirme alanları, bir tablodan her kayıt için benzersiz bir tanımlayıcı sunan birincil anahtar ve diğer tablodaki yabancı anahtardır. Örneğin, Çalışanlar ve Siparişler tablolarındaki ÇalışanNo alanları arasında bir tablo ilişkisi oluşturularak, çalışanlar sorumlu oldukları siparişlerle ilişkilendirilebilir.

Çalışanlar tablosunda birincil anahtar ve Siparişler tablosunda ikinci anahtar olarak kullanılan ÇalışanNo.

1. ÇalışanNo her iki tabloda görünür — birincil anahtar olarak ...

2. ... ve yabancı anahtar olarak.

Sayfanın Başı

Tablo ilişkilerinin türleri

Üç tür tablo ilişkisi vardır.

  • Bir-çok ilişkisi

    Bir sipariş izleme, müşteriler ve Siparişler tablosunu içeren veritabanını göz önünde bulundurun. Müşteri Siparişlerini herhangi bir sayıda yerleştirebilirsiniz. Müşteriler tablosunda gösterilen herhangi bir müşteri için olabileceğini Siparişler tablosunda gösterilen birçok siparişler de onu izler. Müşteriler tablosu ve Siparişler tablosunda arasındaki ilişkiyi, bu nedenle, bir-çok ilişkisi olan.

    Veritabanı tasarımınızı bir-çok ilişkisini göstermek için ilişkinin "bir" tarafında birincil anahtarı atın ve ilişkinin "çok" tarafındaki tablo için bir ek alanı veya alanları ekleyin. Yeni alan ekleme Örneğin, bu durumda, — Müşteriler tablosundaki Kimlik alanını — siparişler için tablo ve Müşteri Kimliği adlandırın Access sonra müşteri kimliği numarasını Siparişler tablosunda her sipariş için doğru müşteri bulmak için kullanabilirsiniz.

  • Çok-çok ilişkisi

    Ürünler tablosunu ve Siparişler tablosu arasında ilişki göz önünde bulundurun. Tek bir sipariş birden fazla ürün ekleyebilirsiniz. Öte yandan, tek bir ürün birçok siparişte görünebilir. Bu nedenle, Siparişler tablosunun her kaydın olabilir birçok kaydı Products tablosundaki. Ayrıca, Products tablosundaki her kaydın olabilir birçok kaydı Siparişler tablosunda. Herhangi bir ürünü olabilir birçok siparişler ve herhangi bir sipariş için olabilir birçok ürün, çünkü bu türde bir ilişkinin çok-çok ilişkisi adı verilir. Tablolarınız arasında varolan çok-çok ilişkileri algılayabilmesi için dikkat edin, ilişkinin her iki tarafına dikkate almanız önemlidir.

    Çok-çok ilişkisi göstermek üzere, genellikle kesişme tablosu adı verilen ve çok-çok ilişkisini iki adet bir-çok ilişkisine bölen üçüncü bir tablo oluşturmanız gerekir. İki tablonun her birinden birincil anahtarı üçüncü tabloya eklersiniz. Bunun sonucunda, üçüncü tablo ilişkinin her yinelenişini veya örneğini kaydeder. Örneğin, Siparişler tablosu ve Ürünler tablosu, Sipariş Ayrıntıları tablosuna iki adet bir-çok ilişkisi oluşturularak tanımlanan çok-çok ilişkisine sahiptir. Bir siparişte pek çok ürün olabilir ve her ürün pek çok siparişte yer alabilir.

  • Bir-bir ilişkisi

    Bir-bir ilişkisi ilk tablodaki her kaydın ikinci tabloda yalnızca eşleşen bir kayıt bulunabilir ve ikinci tablodaki her kaydın ilk tablodaki eşleşen tek bir kayıt olabilir. Bu yolla ilgili bilgileri aynı tabloda en sık depolandığı için bu türde bir ilişkinin yaygın değildir. Bir-bir ilişkisi, güvenlik nedenleriyle tablonun bölümünü ayırmak veya yalnızca bir alt kümesini ana tablo için geçerli olan bilgileri saklamak için birçok alanları içeren bir tablo bölmek için kullanabilirsiniz. Böyle bir ilişki tanımladığınızda, her iki tabloda ortak bir alan paylaşmaları gerekir.

Sayfanın Başı

Neden tablo ilişkileri oluşturulur?

İlişkiler penceresini kullanarak veya Alan listesi bölmesinden alan sürükleme, tablo ilişkileri açıkça oluşturabilirsiniz. Access veritabanı nesnesini kullanmayı gerektiğinde tabloları birleştirmenin çok öğrenmek için tablo ilişkileri kullanır. Formları, sorguları ve raporlar gibi diğer veritabanı nesnelerini oluşturmadan önce neden tablo ilişkileri oluşturmalıyım çeşitli nedenleri vardır.

  • Tablo ilişkileri sorgu tasarımlarınıza bilgi sağlar

    Birden çok tablodaki kayıtları ile çalışmak için çoğunlukla tabloları birleştiren bir sorgu oluşturmanız gerekir. Sorgu, ikinci tablodaki bir yabancı anahtar alanı olan ilk tablonun birincil anahtar alanı değerleri eşleşen göre çalışır. Örneğin, her müşterinin siparişleri tüm liste satırları dönmek için Müşteri Kimliği alanına göre Siparişler tablosunda müşteriler tablosunu birleştiren bir sorgu oluşturun. İlişkiler penceresinde, katılmak için alanları el ile belirtebilirsiniz. Bununla birlikte, tablolar arasında tanımlı bir ilişkinin zaten varsa, tablo ilişkisi dayanan varsayılan katıl erişim sağlar. Ayrıca, Access Sorgu sihirbazlar birini kullanıyorsanız, zaten bilinçli seçimleri sunma ve uygun varsayılan değerlerle özellik ayarları önceden için tanımladığınız tablo ilişkileri toplar bilgileri kullanır.

  • Tablo ilişkileri form ve rapor tasarımlarınıza bilgi sağlar

    Form veya raporu tasarlarken, Access, zaten bilinçli seçimleri sunma ve uygun varsayılan değerlerle özellik ayarları önceden için tanımladığınız tablo ilişkileri toplar bilgileri kullanır.

  • Tablo ilişkileri, veritabanınızda başı boş kayıtlar oluşmasını önlemek amacıyla, üzerinde bilgi tutarlılığını yürürlüğe koyabileceğiniz temeli oluşturur. Başıboş kayıt, var olmayan başka bir kayda başvuru içeren kayıttır — örneğin, var olmayan bir müşteri kaydına başvuruda bulunan bir sipariş kaydı gibi.

    Bir veritabanı tasarladığınızda, her birinin birincil anahtar olan bilgilerinizi, tablolara bölme. Daha sonra bu birincil anahtarlar başvuran ilgili tablolara yabancı anahtarlar ekleyin. Yabancı anahtar birincil anahtar çiftler tablo ilişkileri ve çok tablolu sorgular temelini. Bu nedenle, yabancı anahtar birincil anahtarı başvuruları eşitlenmiş kalır, önemlidir. Bilgi tutarlılığını eşitlenmiş kalmasını başvurular ve tablo ilişkileri bağımlı sağlamaya yardımcı olur.

Sayfanın Başı

Bilgi tutarlılığını anlama

Bir veritabanı tasarladığınızda, bilgilerinizi tablolara veri fazlalık en aza indirmek için birçok konu tabanlı bölün. Birimlerin getirmek verileri ilgili tablolara sık kullanılan alanlar koyarak yeniden bir araya anlamına gelir ile erişim sağlar. Örneğin, bir-çok ilişkisi temsil etmek üzere "bir" tablosundaki birincil anahtarı atın ve bunu "çok" tabloya başka bir alan ekleyin. Verileri birlikte geri getirmek için Access değeri "çok" tabloda yer alan ve "bir" tablodaki karşılık gelen değeri arar. Bu yolla "çok" tablodaki değerleri "bir" tablodaki karşılık gelen değerleri başvuru.

Nakliyeciler ve Siparişler arasında bir-çok ilişkisi bulunduğunu ve bir Nakliyeciyi silmek istediğinizi düşünelim. Silmek istediğiniz nakliyecinin Siparişler tablosunda siparişleri varsa, Nakliyeci kaydını sildiğinizde bu siparişler "başı boş" kalır. Siparişler yine nakliyeci kimliği içerir, ancak kimlik, başvuruda bulunduğu kayıt artık var olmadığı için geçersiz olur.

Bilgi tutarlılığının amacı, sahipsiz öğeler oluşmasını önleyerek ve başvuruları eşitlenmiş durumda tutarak, hiçbir zaman kuramsal durumlar oluşmamasını sağlamaktır.

Tablo ilişkisi için etkinleştirerek bilgi tutarlılığını zorunlu kılma (adım adım yönergeler için bilgi tutarlılığını zorla bakın). Zorlanan sonra Access bu tablo ilişkisi için bilgi tutarlılığını ihlal herhangi bir işlem reddeder. Bu başvuru ve hedef başvurunun kaldırma silmeleri hedefini değiştirme her iki güncelleştirme Access reddeder anlamına gelir. Bununla birlikte, Siparişler tablosunda sipariş içeren bir gönderen için birincil anahtarı değiştirmek için mükemmel bir şekilde geçerli gerek olabilir mümkündür. Böyle durumlarda, gerçekten aradığınızı etkilenen satırların tümünü tek bir işlemi kapsamında otomatik olarak güncelleştirmek Access içindir. Böylece, böylece veritabanınızı tutarsız bir durumda güncelleştirme bazı satırlar ve bazı değil ile kaldığını değil güncelleştirme tam olarak tamamlandığına erişim sağlar. Bu nedenle, ilişkili alanları art arda Güncelleştir seçeneği Access destekler. Bilgi tutarlılığını zorunlu kılma ve ilişkili alanları art arda güncelleştirme seçeneğini ve seçim sonra birincil anahtar güncelleştirme, Access, birincil anahtarı başvuran tüm alanları otomatik olarak güncelleştirir.

Ayrıca, geçerli satır silme gerek olabilir ve tüm ilişkili kayıtları mümkündür; Örneğin, gönderen kayıt ve bu gönderen için ilgili tüm siparişler. Bu nedenle, ilişkili kayıtları art arda silme seçeneği Access destekler. Bilgi tutarlılığına ve ilişkili kayıtları art arda silme seçeneğini belirtin ve sonra ilişkinin birincil anahtar tarafındaki bir kaydı silmek istediğinizde Access birincil anahtarı başvuruda bulunan tüm kayıtlar otomatik olarak siler.

Sayfanın Başı

Tablo ilişkilerini görüntüleme

Tablo ilişkileri görüntülemek için Veritabanı Araçları sekmesinde İlişkiler ' i tıklatın. İlişkiler penceresi açılır ve var olan tüm ilişkileri görüntüler. Hiçbir tablo ilişkileri henüz tanımlamış olduğunuz ve ilişkiler penceresi ilk kez açıyorsanız, Access penceresine bir tablo veya sorgudan eklemek ister.

İlişkiler penceresini açma

  1. Dosya sekmesinde 'ı tıklatın.

  2. iletişim kutusunda, veritabanını seçin ve açın.

  3. Veritabanı Araçları sekmesinin İlişkiler grubunda İlişkiler'i tıklatın.

  4. Veritabanı ilişkileri içeriyorsa, ilişkiler penceresi görünür. Veritabanı ilişkileri içermiyor ve ilişkiler penceresi ilk kez açıyorsanız, Tabloyu Göster iletişim kutusu görüntülenir. İletişim kutusunu kapatmak için Kapat ' ı tıklatın.

  5. Tasarım sekmesinde, İlişkiler grubunda, Tüm İlişkiler'i tıklatın.

    Bu tüm tanımlı ilişkileri veritabanınızda görüntüler. Gezinti Seçenekleri iletişim kutusunda Gizli Nesneleri Göster onay kutusunu seçmediyseniz (tablolar için Gizli onay kutusunu tablo özellikleri iletişim kutusunda seçili) gizli tablolar ve ilişkilerinin gösterilmez olduğunu unutmayın.

Tablo ilişkiler, İlişkiler penceresinde tablolar arasında çizilen ilişki çizgileriyle gösterilir. Bilgi tutarlılığının zorunlu olmadığı bir ilişki, kendisini destekleyen ortak alanlar arasında ince bir çizgi olarak görünür. Çizgisini tıklatarak ilişkiyi seçtiğinizde, çizgi kalınlaşarak seçili olduğunu gösterir. Bu ilişki için bilgi tutarlılığını zorunlu kılarsanız, çizgi her iki uçta daha kalın görünür. Ayrıca, çizginin ilişkinin bir tarafındaki kalın kısmında 1 sayısı ve çizginin diğer taraftaki kalın kısmında sonsuzluk simgesi () görünür.

İlişkiler penceresi etkin olduğunda, Şerit üzerinde aşağıdaki komutlar arasından seçim yapabilirsiniz:

Tasarım sekmesinde, Araçlar grubunda:

  • İlişkileri Düzenle    İlişkileri Düzenle iletişim kutusunu açar. Bir ilişki çizgisini seçtiğinizde, tablo ilişkisini değiştirmek için İlişkileri Düzenle'yi tıklatabilirsiniz. Ayrıca ilişki çizgisini de çift tıklatabilirsiniz.

  • Düzeni Temizle    İlişkiler penceresinde tüm tabloları ve ilişkileri görüntüden kaldırır. Bu komutun tabloları ve ilişkileri silmediğini, yalnızca gizlediğini unutmayın.

  • İlişkiler Raporu    Veritabanınızdaki tabloları ve ilişkileri gösteren bir rapor oluşturur. Rapor yalnızca, İlişkiler penceresinde gizli olmayan tabloları ve ilişkileri gösterir.

Tasarım sekmesinde, İlişkiler grubunda:

  • Tabloyu Göster    İlişkiler penceresinde görüntülemek üzere tablo ve sorgular seçebileceğiniz Tabloyu Göster iletişim kutusunu açar.

  • Tabloyu Gizle    Seçili tabloyu İlişkiler penceresinde gizler.

  • Doğrudan İlişkiler    Seçili tablonun tüm ilişkilerini ve ilişkili tablolarını İlişkiler penceresinde görünmüyorsa görüntüler.

  • Tüm İlişkiler    Veritabanınızdaki tüm ilişkileri ve ilişkili tabloları İlişkiler penceresinde görüntüler. Gezinti Seçenekleri iletişim kutusunda Gizli Nesneleri Göster seçili olmadıkça, gizli tabloların (Özellikler iletişim kutusunda Gizli onay kutusu seçili olan tablolar) ve bunların ilişkilerinin görünmeyeceğini unutmayın.

  • Kapat    İlişkiler penceresini kapatır. İlişkiler penceresinin düzeninde herhangi bir değişiklik yaptıysanız, bu değişiklikleri kaydetmek isteyip istemediğiniz sorulur.

Sayfanın Başı

Tablo ilişkisi oluşturma

İlişkiler penceresini kullanarak veya Alan Listesi bölmesinden bir çalışma sayfasına alan sürükleyerek tablo ilişkisi oluşturabilirsiniz. Tablolar arasında bir ilişki oluşturduğunuzda, ortak alanların aynı adı taşıması zorunlu olmasa da genellikle böyle olur. Bunun yerine, bu alanların aynı veri türüne sahip olması gerekir. Bununla birlikte, birincil anahtar alanı bir Otomatik Sayı alanıysa, her iki alanın AlanBoyutu özelliği aynı olduğu takdirde yabancı anahtar alanı bir Sayı alanı olabilir. Örneğin, her iki alanının AlanBoyutu özelliği Uzun Tamsayı olduğunda, bir Otomatik Sayı alanıyla bir Sayı alanını eşleştirebilirsiniz. Her iki ortak alan Sayı alanı olduğu takdirde, aynı AlanBoyutu özelliği ayarına sahip olmaları gerekir.

İlişkiler penceresini kullanarak tablo ilişkisi oluşturma

  1. Dosya sekmesinde 'ı tıklatın.

  2. iletişim kutusunda, veritabanını seçin ve açın.

  3. Veritabanı Araçları sekmesinin İlişkiler grubunda İlişkiler'i tıklatın.

  4. Henüz herhangi bir ilişki tanımlamadıysanız, Tabloyu Göster iletişim kutusu otomatik olarak görüntülenir. Görüntülenmezse, Tasarım sekmesinde, İlişkiler grubunda, Tabloyu Göster'i tıklatın.

Tabloyu Göster iletişim kutusu veritabanındaki tüm tablo ve sorguları görüntüler. Yalnızca tabloları görüntülemek için, Tablolar'ı tıklatın. Yalnızca sorguları görüntülemek için, Sorgular'ı tıklatın. Hem tabloları, hem sorguları görüntülemek için, Her İkisi'ni tıklatın.

  1. Bir veya daha fazla tabloyu veya sorguyu seçip Ekle'yi tıklatın. İlişkiler penceresine tablo ve sorgu eklemeniz bittiğinde, Kapat'ı tıklatın.

  2. Bir tablodan bir alanı (genellikle birincil anahtarı) diğer tablodaki ortak alana (yabancı anahtar) sürükleyin. Birden fazla alanı sürüklemek için, CTRL tuşunu basılı tutarak her alanı tıklatın ve sonra da sürükleyin.

İlişkileri Düzenle iletişim kutusu görüntülenir.

  1. Görünen alan adlarının, ilişkinin ortak alanları olduğunu doğrulayın. Yanlış alan adı varsa, alan adını tıklatıp listeden yeni bir alan seçin.

Bilgi tutarlılığını zorunlu kılmak için, Bilgi Tutarlılığına Zorla onay kutusunu seçin. Bilgi tutarlılığı hakkında daha fazla bilgi için, Bilgi tutarlılığını anlama ve Bilgi tutarlılığını zorunlu kılma bölümlerine bakın.

  1. Oluştur'u tıklatın.

    İki tablo arasına ilişki çizgisi çizilir. Bilgi Tutarlılığına Zorla onay kutusunu seçtiyseniz, çizgi her iki uçta daha kalın görünür. Ayrıca, yalnızca Bilgi Tutarlılığına Zorla onay kutusunu seçtiyseniz, çizginin ilişkinin bir tarafındaki kalın bölümü üzerinde 1 sayısı ve çizginin diğer taraftaki kalın bölümü üzerinde sonsuzluk simgesi () görünür.

    Notlar : 

    • Bir-bir ilişkisi oluşturma    Sık kullanılan alanlar (genellikle birincil anahtar ve yabancı anahtar alanlarını) her ikisi de benzersiz bir dizine sahip olmanız gerekir. Başka bir deyişle, bu alanlar için dizin özelliği Evet (yineleme yok)olarak ayarlanmalıdır. Her iki alan benzersiz bir dizin varsa, Access bir-bir ilişkisi oluşturur.

    • Bir - çok ilişkisi oluşturmak için    İlişkinin "bir" tarafındaki (genellikle birincil anahtar) alanı, benzersiz bir dizine sahip olmanız gerekir. Başka bir deyişle, bu alanın sıralı özelliği Evet (yineleme yok)olarak ayarlanmalıdır. Gereken "çok" tarafındaki alanı olmayan benzersiz bir dizine sahip olmalıdır. Dizin olabilir, ancak yinelenenleri izin vermesi gerekir. Bu, bu alanın sıralı özelliği Hayırya da Evet (yineleme var)için ayarlanmalıdır anlamına gelir. Bir alanda benzersiz bir dizin bulunur ve diğer desteklemez, Access bir-çok ilişkisi oluşturur.

Alan Listesi bölmesini kullanarak tablo ilişkisi oluşturma

Alan listesi bölmesinden sürükleyerek veri sayfası görünümünde açık olan varolan bir tablonun bir alan ekleyebilirsiniz. Alan listesi bölmesi de diğer tablolardaki kullanılabilir alanlar ve ilişkili tablolardaki kullanılabilir alanlar gösterir. Bir "diğer" (ilişkisiz) tablodan bir alanı sürükleyin ve sonra Arama Sihirbazı'nı tamamlamak açtığınızda, yeni bir-çok ilişkisi Alan listesi Bölmesi'nde tablo ve alan sürüklenen tablo arasında otomatik olarak oluşturulur. Access tarafından oluşturulan bu ilişki, varsayılan olarak bilgi tutarlılığını zorunlu değil. Bilgi tutarlılığını zorunlu kılmak için ilişkiyi düzenlemelisiniz. Daha fazla bilgi için bir tablo ilişkisini değiştirme bölümüne bakın.

Veri Sayfası görünümünde tablo açma

  1. Dosya sekmesinde 'ı tıklatın.

  2. iletişim kutusunda, veritabanını seçin ve açın.

  3. Gezinti Bölmesi'nde, alanı eklemek ve ilişki oluşturmak istediğiniz tabloyu sağ tıklatın ve sonra 'ı tıklatın.

Alan Listesi bölmesini açma

  • ALT+F8 tuşlarına basın.

    Alan Listesi bölmesi görüntülenir.

Alan listesi bölmesi, veritabanınızdaki tüm diğer tablolar gösterir kategoriler halinde gruplandırılır. Veri Sayfası görünümünde tablo ile çalışırken, Access alanları Alan listesi Bölmesi'nde iki kategorisi birini görüntüler: ilişkili tablolardaki kullanılabilir alanlar ve diğer tablolardaki kullanılabilir alanlar. İlk kategori tüm birlikte çalıştığınız tabloyla ilişkisi olan tablolar listeler. İkinci Kategori tüm ile tablonuzun ilişki yok tabloları listeler.

Alan Listesi bölmesinde, bir tablo adının yanındaki artı işaretini (+) tıklattığınızda o tablodaki tüm kullanılabilir alanların listesini görürsünüz. Tablonuza alan eklemek için Alan Listesi bölmesinden istediğiniz alanı Veri Sayfası görünümündeki tabloya sürükleyin.

Alan Listesi bölmesinden alan ekleme ve ilişki oluşturma

  1. Alan Listesi bölmesinde, Diğer tablolardaki kullanılabilir alanlar altında, bir tablodaki alanların listesini görüntülemek için tablo adının yanındaki artı işaretini (+) tıklatın.

  2. İstediğiniz alanı Alan Listesi bölmesinden Veri Sayfası görünümünde açık olan tabloya sürükleyin.

  3. Ekleme satırı görüntülendiğinde, alanı konuma bırakın.

    Arama Sihirbazı başlatılır.

  4. Arama Sihirbazı'nı tamamlamak için yönergeleri izleyin.

    Alan, Veri Sayfası görünümündeki tabloda görüntülenir.

Bir "diğer" (ilişkisiz) tablodan bir alanı sürükleyin ve sonra Arama Sihirbazı'nı tamamlamak açtığınızda, yeni bir-çok ilişkisi tablosu Alan listesi ve alan sürüklenen tablosu arasında otomatik olarak oluşturulur. Access tarafından oluşturulan bu ilişki, varsayılan olarak bilgi tutarlılığını zorunlu değil. Bilgi tutarlılığını zorunlu kılmak için ilişkiyi düzenlemelisiniz. Daha fazla bilgi için bir tablo ilişkisini değiştirme bölümüne bakın.

Sayfanın Başı

Tablo ilişkisini silme

Tablo ilişkisi kaldırmak için İlişkiler penceresinde ilişki çizgisini silmeniz gerekir. İlişki çizgisini işaret eden imleci dikkatle getirin ve sonra çizgiyi tıklatın. İlişki çizgisi seçildiğinde daha kalın görünür. İlişki çizgisini seçiliyken, DELETE tuşuna basın. Etkin olduğunda ilişki kaldırdığınızda, sonra da o ilişkiyi bilgi tutarlılığını desteği kaldırmanız olduğunu unutmayın. Sonuç olarak, Access bir ilişkinin "çok" tarafındaki sahipsiz kayıtlarının oluşturulması artık otomatik olarak engellenir.

  1. Veritabanı Araçları sekmesinin İlişkiler grubunda İlişkiler'i tıklatın.

İlişkiler penceresi görünür. Henüz herhangi bir ilişkilerini tanımladınız olmayan ve bu İlişkiler penceresini açmakta olduğunuz ilk kez ise, Tabloyu Göster iletişim kutusu görüntülenir. İletişim kutusu görüntülenirse, Kapat' ı tıklatın.

  • Tasarım sekmesinde, İlişkiler grubunda, Tüm İlişkiler'i tıklatın.

İlişki içeren tüm tablolar ilişki çizgileriyle birlikte görüntülenir.

  1. Silmek istediğiniz ilişkinin ilişki çizgisini tıklatın. İlişki çizgisi seçildiğinde daha kalın görünür.

  2. DELETE tuşuna basın.

    –veya–

Sağ tıklatıp Sil'i tıklatın.

  1. Access Seçili ilişkiyi veritabanınızdan sürekli olarak silmek istediğinizden emin misiniz? iletisini görüntüleyebilir. Bu onaylama iletisi görüntülenirse Evet'i tıklatın.

Not : Tablo ilişkisinde yer alan tablolardan herhangi biri kullanılıyorsa (başka bir kişi veya işlem tarafından ya da form gibi açık bir veritabanı nesnesinde) ilişkiyi silemezsiniz. İlişkiyi kaldırabilmeniz için, önce bu tabloları kullanan açık nesne varsa kapatmanız gerekir.

Sayfanın Başı

Tablo ilişkisini değiştirme

Bir tablo ilişkisini değiştirmek için, ilişkiyi İlişkiler penceresinde seçip düzenlersiniz. İmleci dikkatle, ilişki çizgisini gösterecek şekilde konumlayın ve çizgiyi tıklatarak seçin. İlişki çizgisi seçildiğinde daha kalın görünür. İlişki çizgisi seçiliyken çizgiyi çift tıklatın veya Tasarım sekmesindeki Araçlar grubunda İlişkileri Düzenle'yi tıklatın. İlişkileri Düzenle iletişim kutusu görüntülenir.

İlişkileri Düzenle iletişim kutusunda değişikliklerinizi yapma

  1. Veritabanı Araçları sekmesinin İlişkiler grubunda İlişkiler'i tıklatın.

İlişkiler penceresi görünür. Henüz herhangi bir ilişkilerini tanımladınız olmayan ve bu İlişkiler penceresini açmakta olduğunuz ilk kez ise, Tabloyu Göster iletişim kutusu görüntülenir. İletişim kutusu görüntülenirse, Kapat' ı tıklatın.

  • Tasarım sekmesinde, İlişkiler grubunda, Tüm İlişkiler'i tıklatın.

  • İlişki içeren tüm tablolar ilişki çizgileriyle birlikte görüntülenir.

  • Değiştirmek istediğiniz ilişkinin ilişki çizgisini tıklatın. İlişki çizgisi seçildiğinde daha kalın görünür.

  • İlişki çizgisini çift tıklatın.

  • Değişikliklerinizi yapın ve Tamam'ı tıklatın.

    İlişkileri Düzenle iletişim kutusu tablo ilişkilerini düzenlemenize olanak sağlar. Özellikle, ilişkinin her iki tarafındaki tablo veya sorguları veya her iki taraftaki alanları değiştirebilirsiniz. Ayrıca birleştirme türünü ayarlayabilir veya bilgi tutarlılığını zorunlu kılabilir ve bir basamaklama seçeneği belirleyebilirsiniz. Birleştirme türü ve nasıl ayarlanacağı konusunda daha fazla bilgi için Birleştirme türünü ayarlama bölümüne bakın. Bilgi tutarlılığını zorunlu kılma ve basamaklama seçeneği belirleme konusunda daha fazla bilgi için Bilgi tutarlılığını zorunlu kılma bölümüne bakın.

Birleştirme türünü ayarlama

Tablo ilişkisi tanımladığınızda, ilişki hakkında bilgiler, sorgu tasarımlarınıza bilgi sağlar. Ve iki tablo arasında ilişki tanımlama sonra bu tabloları kullanan bir sorgu oluşturun, örneğin, Access otomatik olarak eşleşen alanlar İlişkiler penceresinde belirtilen alanları temel varsayılan seçer. Sorgunuzda bu ilk baştaki varsayılan değerleri geçersiz kılabilirsiniz, ancak doğru olması için ilişki tarafından sağlanan değerler sık sık kanıtlamak. Eşleşen ve birlikte birden fazla tablodan veri getirmeden yaptığınız herhangi sık en basit veritabanlarını dışındaki tüm olduğundan, ilişkiler oluşturarak varsayılanları ayarlama zamanı olabilir kaydetme ve yararlı.

Çok tablolu sorgular, ortak alanlardaki değerleri eşleştirerek birden fazla tablodaki bilgileri birleştirir. Eşleştirmeyi ve birleştirmeyi gerçekleştiren işleme birleştirme denir. Örneğin müşteri siparişlerini görüntülemek istediğinizi düşünelim. Müşteriler tablosu ile Siparişler tablosunu Müşteri Kimliği alanından birleştiren bir sorgu oluşturursunuz. Sorgu sonucu, yalnızca ilgili bir eşleşme bulunan satırların müşteri bilgilerini ve sipariş bilgilerini içerir.

Her ilişki için belirttiğiniz değerleri birleştirme türünü biridir. Birleştirme türünü Access'e hangi kayıtların bir sorgu sonucunda ekleneceğini belirtir. Örneğin, Müşteriler tablosu ve Siparişler tablosundaki Müşteri Kimliği temsil eden genel alanların birleştiren bir sorgu yeniden göz önünde bulundurun Varsayılan birleştirme türünü (iç birleştirme denir) kullanarak, sorgu yalnızca müşteri satırları ve sık kullanılan alanlar (birleştirilen alanların olarak da adlandırılır) eşit olduğu sırada satırları getirir.

Bununla birlikte, tüm Müşterileri (henüz hiç sipariş vermeyenleri de) dahil etmek istediğinizi düşünelim. Bunu yapmak için, iç birleştirme olan birleştirme türünü, sol dış birleştirme adı verilen birleştirme olarak değiştirmeniz gerekir. Sol dış birleştirme, ilişkinin sol tarafında bulunan tablodaki satırların tümünü ve sağdaki tablodan da yalnızca eşleşenleri döndürür. Sağ dış birleştirmeyse, sağdaki satırların tümünü ve soldakinden de yalnızca eşleşenleri döndürür.

Not : Bu durumda "sol" ve "sağ" deyimleri, tabloların İlişkiler penceresindeki değil İlişkileri Düzenle iletişim kutusundaki konumlarını ifade eder.

Bu ilişkideki tabloları birleştirmeye yarayan bir sorgudan en çok hangi sonucu almak istediğinizi düşünerek birleştirme türünü buna göre ayarlamanız gerekir.

Birleştirme türünü ayarlama

  1. İlişkileri Düzenleiletişim kutusunda, Birleştirme Türü'nü tıklatın.

    Birleştirme Özellikleri iletişim kutusu görüntülenir.

  2. Seçiminizi tıklatın ve sonra Tamam'ı tıklatın.

Kullandıkları, birleştirme türünü birleştirme özellikleri iletişim kutusunda görüntülenen üç seçenek (Müşteriler ve Siparişler tablolarını kullanarak) aşağıdaki tabloda gösterilmiştir ve mı yoksa tüm satırları veya eşleşen satırları her tablo için eklenmiştir.

Seçim

Sağ birleştirme

Sol tablo

Sağ tablo

1. Yalnızca her iki tablodan birleştirilen alanların eşit olduğu satırları içerir.

İç birleştirme

Eşleşen satırlar

Eşleşen satırlar

2. 'Müşteriler' tablosundan TÜM kayıtları ve 'Siparişler' tablosundan yalnızca birleştirilen alanların eşit olduğu kayıtları içerir.

Sol dış birleştirme

Tüm satırlar

Eşleşen satırlar

3. 'Siparişler' tablosundan TÜM kayıtları ve 'Müşteriler' tablosundan yalnızca birleştirilen alanların eşit olduğu kayıtları içerir.

Sağ dış birleştirme

Eşleşen satırlar

Tüm satırlar

2 veya 3 numaralı seçeneği belirlediğinizde ilişki çizgisinde bir ok görünür. Bu ok ilişkinin yalnızca eşleşen satırları gösteren tarafını işaret eder.

Birleştirme Özellikleri iletişim kutusunda değişiklik yapma

  1. Veritabanı Araçları sekmesinin İlişkiler grubunda İlişkiler'i tıklatın.

İlişkiler penceresi görünür. Henüz herhangi bir ilişkilerini tanımladınız olmayan ve bu İlişkiler penceresini açmakta olduğunuz ilk kez ise, Tabloyu Göster iletişim kutusu görüntülenir. İletişim kutusu görüntülenirse, Kapat' ı tıklatın.

  • Tasarım sekmesinde, İlişkiler grubunda, Tüm İlişkiler'i tıklatın.

    İlişki içeren tüm tablolar ilişki çizgileriyle birlikte görüntülenir.

  • Değiştirmek istediğiniz ilişkinin ilişki çizgisini tıklatın. İlişki çizgisi seçildiğinde daha kalın görünür.

  • İlişki çizgisini çift tıklatın.

İlişkileri Düzenle iletişim kutusu görüntülenir.

  1. Birleştirme türü'ı tıklatın

  2. Birleştirme Özellikleri iletişim kutusunda, bir seçeneği tıklatın ve sonra Tamam'ı tıklatın.

  3. Varsa, ilişkide başka değişikliklerinizi de yapın ve Tamam'ı tıklatın.

Sayfanın Başı

Bilgi tutarlılığını zorunlu kılma

Bilgi tutarlılığını kullanarak amacı, sahipsiz kayıtları önlemek ve böylece artık bulunmayan diğer kayıtlara başvuruda kayıtlarınız yoksa eşitlenmiş başvuruları tutmak için olur. Sizin için bir tablo ilişkisi etkinleştirerek bilgi tutarlılığına. Zorlanan sonra Access bu tablo ilişkisi için bilgi tutarlılığını ihlal herhangi bir işlem reddeder. Access bir başvuru ve hedef başvurunun kaldırma silmeleri hedefini değiştirme güncelleştirmeleri reddeder. Böylece tüm ilişkili satırları buna göre değişir başvurusal güncelleştirmeleri ve silmeleri yaymak erişmesini, basamaklama seçeneklerini ayarlamabölümüne bakın.

Bilgi tutarlılığını etkinleştirme veya devre dışı bırakma

  1. İlişkiler penceresinde, değiştirmek istediğiniz ilişkinin ilişki çizgisini tıklatın. İlişki çizgisi seçildiğinde daha kalın görünür.

  2. İlişki çizgisini çift tıklatın.

İlişkileri Düzenle iletişim kutusu görüntülenir.

  1. Bilgi Tutarlılığına Zorla onay kutusunu seçin.

  2. Varsa, ilişkide başka değişikliklerinizi de yapın ve Tamam'ı tıklatın.

Bilgi tutarlılığını zorunlu kıldıktan sonra, aşağıdaki kurallar geçerli olur:

  • İlişkili bir tablonun birincil anahtar alanına gireceğiniz bir değer, birincil tablonun birincil anahtar alanında yoksa bu değeri giremezsiniz.  Bunu yaparsanız artık kayıtlar oluşur.

  • İlişkili tabloda eşleşen kayıtlar varsa birincil tablodan kayıt silemezsiniz. Örneğin Siparişler tablosunda bir çalışan için atanmış siparişler varsa Çalışanlar tablosundan bu çalışanın kaydını silemezsiniz. Bununla birlikte İlişkili Kayıtları Art Arda Sil onay kutusunu seçerek bir birincil kaydı ve tüm ilişkili kayıtları tek bir işlemle silmeyi seçebilirsiniz.

  • Bunu yapmanın nedenle sahipsiz kayıtları oluşturmayı tercih ederseniz, birincil tablodaki bir birincil anahtar değeri değiştiremezsiniz. Örneğin, çizgi bu sırada Sipariş Ayrıntıları tablosunda atanan öğeler varsa Siparişler tablosunda sipariş numarası değiştiremezsiniz. Bununla birlikte, bir birincil kaydı ve tüm ilişkili kayıtlar tek işlemde İlişkili alanları art arda güncelleştir onay kutusunu seçerek güncelleştirmek isteyebilirsiniz.

    Notlar : Bilgi tutarlılığını kılmakta güçlük çekiyorsanız, bilgi tutarlılığını zorunlu kılmak için aşağıdaki koşullar gereklidir dikkat edin:

    • Birincil tablodaki ortak alan birincil anahtar olmalı ya da benzersiz bir dizine sahip olmalıdır.

    • Ortak alanlar aynı veri türüne sahip olmalıdır. Bunun tek istisnası, bir Otomatik Sayı alanının, AlanBoyutu özellik ayarı Uzun Tamsayı olan bir Sayı alanıyla ilişkilendirilebilmesidir.

    • Her iki tabloda da aynı Access veritabanına bulunması gerekir. Bağlantılı tablolarda, bilgi tutarlılığını zorunlu yapamazsınız. Bununla birlikte, kaynak tablolar Access biçimindeyse, bunların depolanır ve bu veritabanının bilgi tutarlılığını etkinleştirin veritabanını açabilirsiniz.

Basamaklama seçeneklerini ayarlama

Geçerli bir değer bir ilişkinin "bir" tarafındaki değiştirmeye gerek sahip olduğunuz bir durumla karşılaşabilirsiniz. Bu durumda, tek bir işlemi kapsamında etkilenen tüm satırları otomatik olarak güncelleştirilecek erişiminiz olmalıdır. Veritabanınızı tutarsız bir sola değil, böylece bu şekilde, tam olarak güncelleştirme tamamlanana — bazı satır güncelleştirme ve bazı değil. Access bu sorun, ilişkili alanları art arda Güncelleştir seçeneği destekleyerek önlemenize yardımcı olur. Bilgi tutarlılığını zorunlu kılma ve ilişkili alanları art arda güncelleştirme seçeneğini ve seçim sonra birincil anahtar güncelleştirme, Access, birincil anahtarı başvuran tüm alanları otomatik olarak güncelleştirir.

Satır silme gerekebilir ve tüm ilişkili kayıtları — Örneğin, gönderen kayıt ve bu gönderen için ilgili tüm siparişler. Bu nedenle, ilişkili kayıtları art arda silme seçeneği Access destekler. Bilgi tutarlılığını zorunlu kılma ve ilişkili kayıtları art arda silme seçeneğini belirtin zaman, Access birincil anahtarı içeren kaydı sildiğinizde, birincil anahtarı başvuruda bulunan tüm kayıtlar otomatik olarak siler.

Art arda güncelleştirme ve/veya art arda silmeyi etkinleştirme veya devre dışı bırakma

  1. İlişkiler penceresinde, değiştirmek istediğiniz ilişkinin ilişki çizgisini tıklatın. İlişki çizgisi seçildiğinde daha kalın görünür.

  2. İlişki çizgisini çift tıklatın.

İlişkileri Düzenle iletişim kutusu görüntülenir.

  1. Bilgi Tutarlılığına Zorla onay kutusunu seçin.

  2. İlişkili Alanları Art Arda Güncelleştir veya İlişkili Kayıtları Art Arda Sil onay kutularından birini veya her ikisini seçin.

  3. Varsa, ilişkide başka değişikliklerinizi de yapın ve Tamam'ı tıklatın.

Not : Birincil anahtar OtomatikSayı alanıysa, OtomatikSayı alanındaki değeri değiştiremeyeceğiniz için, İlişkili Alanları Art Arda Güncelleştir onay kutusunu seçmenizin hiçbir etkisi olmayacaktır.

Sayfanın Başı

Not : Makine Çevirisi Yasal Uyarısı: Bu makale, insan müdahalesi olmadan bir bilgisayar sistemi tarafından çevrilmiştir. Microsoft bu makine çevirilerini İngilizce bilmeyen kullanıcıların Microsoft ürünleri, hizmetleri ve teknolojileriyle ilgili içeriklerden yararlanmasına yardımcı olmak için sunar. Bu makale makine çevirisi olduğundan sözcük, cümle dizilimi ve gramer hataları içerebilir.

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×