Site performansını ve kullanımını ölçmek için raporları kullanma

Önemli : Bu makale makine çevisidir. Bkz. yasal uyarı. Bu makalenin İngilizce sürümüne buradan ulaşabilirsiniz.

Site yönetmekle sorumluysanız, büyük olasılıkla aşağıdakiler gibi site hakkında ortak sorularla karşılaşırsınız:

  • Siteyi kaç kişi ziyaret ediyor?

  • Zaman içinde site trafiği nasıl değişti?

  • Siteyi en çok kimler kullanıyor?

  • Sitedeki trafik nereden geliyor?

  • Sitedeki en çok erişilen sayfalar ve kaynaklar hangileri?

  • Çalışma işleminde belgelerin ve diğer kaynakların nerede bulunduğunu nasıl öğrenebilirim?

Ayrıca, sitenin yöneticisi olarak düzenli olarak yanıtlanmasını istediğiniz sorular olabilir, örneğin:

  • Kullanılmadıkları veya eski oldukları için siteden kaldırılması gereken kaynaklar var mı?

  • Kullanıcılar farkına varıp bildirmeden önce sitedeki sorunları (bağlantısı olmayan dosyalar, yavaş sayfalar ve bozuk köprüler) nasıl bulabilirim ve onarabilirim?

Bu sorular zor görünebilir ama Microsoft Office SharePoint Designer 2007 uygulamasıyla ve Windows SharePoint Services 3.0 sitesiyle veya bir Microsoft Office SharePoint Server 2007 sitesiyle Office SharePoint Designer 2007 raporlarını kullanarak bu soruları kolayca yanıtlayabilirsiniz. Bu makale, site performansı ve kullanımını ölçmek için raporların nasıl kullanılacağını göstermektedir.

Önemli : Office SharePoint Designer 2007 uygulaması tarafından oluşturulan raporların verileri, siteye ev sahipliği yapan sunucuya kaydedilir. Sunucu yöneticileri, bu raporlara erişim verebilir veya erişimi engelleyebilir. İstediğiniz raporda veri bulunmuyorsa yardım almak için sunucu yöneticinize başvurun. Kullanım raporlarını çalıştırmak için, Kullanım Verilerini Görüntüleme izniniz olmalı ve sunucu yöneticisi, sunucuda kullanım verileri toplama özelliğini açmalıdır. Sunucuda kullanım verilerini toplama özelliği varsayılan olarak kapalıdır.

Ne yapmak istiyorsunuz?

Site Özeti raporu görüntüleme

Dosyalar hakkında raporlarını görüntüleme

Paylaşılan içerikle ilgili raporları görüntüleme

Sorunlar hakkında raporlarını görüntüleme

Kullanım Özeti raporu görüntüleme

Ayrıntılı kullanım raporlarını görüntüleme

Kullanım verileri sonuçlarınızı grafik

Rapor sıralama

Rapor filtre uygulama

Rapor kopyalama

Raporu kaydetme

Site Özeti Raporlarını görüntüleme

Site Özeti raporu, sitenize üst düzey bir genel bakış ve daha ayrıntılı raporlar için köprüler sunar. Örneğin, aşağıdaki şekildeki gibi bir Site Özeti raporu oluşturabilirsiniz.

Site Özeti raporu

Sitenizin Site Özeti raporunu oluşturmak için:

  1. Office SharePoint Designer 2007 uygulamasında raporu çalıştırmak istediğiniz siteyi açın.

  2. Site menüsünde Raporlar üzerine gelin ve sonra Site Özeti'ni tıklatın.

    Rapor oluşturulur.

Not : Daha ayrıntılı raporlara ulaşmak için Ad sütunundaki köprüleri tıklatabilirsiniz. Örneğin, Bozuk Köprüler raporuna doğrudan ulaşmak için Bozuk Köprüler'i tıklatın.

Sayfanın Başı

Dosyalar hakkındaki raporları görüntüleme

Tüm dosyaları, son eklenen dosyaları, son değiştirilen dosyaları veya eski dosyaları görüntüleyen raporlar oluşturabilirsiniz. Örneğin, sitenizin giriş sayfasındaki veya sitenizi tanıtan bir haber bültenindeki yeni içeriği vurgulamak istiyorsanız, yeni içeriğinizi hızlı bir şekilde tanımlamak için Son Eklenen Dosyalar raporunu kullanabilirsiniz. Bunun dışında, olası bir yükseltme veya kaldırma için gözden geçirilebilecek kadar eski dosyaları tanımlamak için Eski Dosyalar raporunu kullanabilirsiniz.

Dosyalar hakkındaki raporları çalıştırmak için ilk olarak son ve eski dosyaların tanımlarını belirleyin, ayrıca aylık raporda gösterilecek ayların sayısını belirleyin:

  1. Office SharePoint Designer 2007 uygulamasında raporu çalıştırmak istediğiniz Web sitesini açın.

  2. Araçlar menüsünde Uygulama Seçenekleri'ni tıklatın.

  3. Raporlar Görünümü sekmesini tıklatın.

    Rapor Görünümleri sekmesini gösteren Uygulama Seçenekleri iletişim kutusu

  4. "Son" dosyalar küçüktür kutusunda, son sayfayı tanımlayan gün sayısını girin.

  5. "Eski" dosyalar büyüktür kutusunda, eski sayfayı tanımlayan gün sayısını girin.

  6. Gösterilen ay sayısı kutusunda, raporlarda aylık olarak gösterilecek ay sayısını girin.

  7. Tamam'ı tıklatın.

    Artık, dosyaları çalıştırmaya hazırsınız.

  8. Site menüsünde sırasıyla Raporlar ve Dosyalar üzerine gelin ve sonra çalıştırmak istediğiniz raporu tıklatın.

    • Tüm Dosyalar     Sitedeki tüm dosyaların bir listesini görüntüler.

    • Son Eklenen Dosyalar     4. adımda belirttiğiniz gün sayısı içinde siteye eklenen dosyaların bir listesini görüntüler.

    • Son Değiştirilen Dosyalar     4. adımda belirttiğiniz gün sayısı içinde sitede değiştirilen dosyaların bir listesini görüntüler.

    • Eski Dosyalar     5. adımda belirttiğiniz gün sayısı tarafından "eski" olarak kabul edilen dosyaların bir listesini görüntüler.

    • Teslim Alma Durumu     Sitenizdeki dosyaların bir listesini her dosyanın geçerli Teslim Alma Durumu ile birlikte gösterir. (Bu rapor ayrıca Teslim Alan Kişi, Sürüm ve Kilitlenme Tarihi verilerini de içerir.)

      Raporlar görünümünde, dosyalar hakkındaki raporlar için, eski veya son dosyaların ayarlarını kolayca değiştirmek üzere listedeki seçenekleri tıklatabilirsiniz.

      Dosya süre filtresini gösteren Rapor görünümü

Sayfanın Başı

Paylaşılan içerik hakkındaki raporları görüntüleme

Paylaşılan içerikte, ana sayfalar, site tanımında eklenen özel ve diğer sayfalar ile stil sayfaları bağlantıları bulunabilir. Office SharePoint Designer 2007 uygulaması, paylaşılan içeriği bulmayı kolaylaştırır. Örneğin, Web sitenizin tüm sayfalarındaki bir logoyu değiştirmek istiyorsanız ve sayfa biçimini denetlemek için ana sayfaları kullanıyorsanız, logoyu değiştireceğiniz ana sayfaların tümünü bulmak için Ana Sayfalar raporunu kullanabilirsiniz. Ayrıca, sitenize uygulamak istediğiniz yazı tipindeki veya biçimdeki bir değişikliği yansıtmak için yükseltilmesi gereken tüm stil sayfalarını bulmak için Stil Sayfaları Bağlantıları raporunu kullanabilirsiniz.

  1. Office SharePoint Designer 2007 uygulamasında raporu çalıştırmak istediğiniz Web sitesini açın.

  2. Site menüsünde sırasıyla Raporlar ve Paylaşılan İçerik üzerine gelin ve sonra çalıştırmak istediğiniz raporu tıklatın.

    • Dinamik Web Şablonları     Sitedeki tüm sayfaların bir listesini, Dinamik Web Şablonu sütunu her sayfanın bir Dinamik Web Şablonu'na eklenip eklenmediğini (Eklenmişse, hangisi) gösterecek şekilde görüntüler.

    • Ana Sayfalar     Sitedeki tüm sayfaların bir listesini, Ana Sayfa sütunu her sayfanın bir ana sayfaya eklenip eklenmediğini (Eklenmişse, hangisi) gösterecek şekilde görüntüler.

    • Özelleştirilmiş Sayfalar     Sitedeki tüm sayfaların bir listesini, Özelleştirilmiş sütunu site tanımına bağlı sayfalardan herhangi birinin özelleştirilip özelleştirilmediğini gösterecek şekilde görüntüler.

    • Stil Sayfası Bağlantıları     Sitedeki tüm sayfaların bir listesini, Stil Sayfası Bağlantıları sütunu her sayfanın bir stil sayfasına eklenip eklenmediğini gösterecek şekilde görüntüler.

      Not : Stil sayfaları bağlantıları, statik stil sayfaları bağlantılarıdır (<link> etiketleri). Dinamik stil sayfaları bağlantıları Microsoft ASP.NET denetimleri (örneğin <SharePoint:CssLink>) tarafından oluşturulur ve bu raporda bulunmaz.

Sayfanın Başı

Sorunlar hakkındaki raporları görüntüleme

Sorunlar hakkındaki Office SharePoint Designer 2007 raporları, olası sorunları öngörmenize ve kullanıcılar etkilenmeden bu sorunları çözmenize yardımcı olur. Örneğin, yavaş sayfaları, bozuk köprüleri veya başka dosyalarla bağlantısı olmayan ve bu yüzden silinebilecek dosyaları bulmak için bu raporları kullanabilirsiniz. Sorunlar raporunu çalıştırmak için ilk olarak yavaş sayfaların nasıl tanımlanacağı ile ilgili tercihlerinizi belirleyin.

  1. Office SharePoint Designer 2007 uygulamasında raporu çalıştırmak istediğiniz Web sitesini açın.

  2. Araçlar menüsünde Uygulama Seçenekleri'ni tıklatın.

  3. Raporlar Görünümü sekmesini tıklatın.

    Rapor Görünümleri sekmesini gösteren Uygulama Seçenekleri iletişim kutusu

  4. "Yavaş Sayfalar" en az kutusunda, yavaş bir sayfanın ne kadar sürede yükleneceğini belirleyen saniye sayısını girin.

  5. Varsayılan bağlantı hızı kutusunda, kullanıcının ortalama bağlantı hızını kilobit/saniye (Kbps) olarak girin.

  6. Tamam'ı tıklatın.

    Artık, dosyaları çalıştırmaya hazırsınız.

  7. Site'yi tıklatın, sırasıyla Raporlar ve Sorunlar üzerine gelin ve sonra çalıştırmak istediğiniz raporu tıklatın.

    • Bağlantısı Olmayan Dosyalar     Sitedeki bağlantısı olmayan tüm dosyaların bir listesini görüntüler. Bu liste, kullanılmayan dosyaları bulmanıza ve siteden kaldırmanıza yardımcı olur. Office SharePoint Server 2007 sitelerindeki İçindekiler Web Tablosu gibi ASP.NET denetimleri tarafından oluşturulmuş bağlantıların bu liste tarafından dikkate alınmayacağını unutmayın.

    • Yavaş Sayfalar      3. adımda belirtilen tanıma ve 4. adımda belirtilen ortalama bağlantı hızına göre yavaş yüklenen olarak kabul edilen sitedeki sayfaların bir listesini görüntüler. Bu raporun, sayfanın yüklenmesi için gerekli süreyi yansıttığını unutmayın. Rapor, ASP.NET denetimleri tarafından oluşturulan dinamik içeriği dikkate almaz.

    • Köprüler     Sitedeki tüm köprülerin bir listesini görüntüler. Bu raporu çalıştırdıktan sonra bir iletişim kutusu, sitedeki köprüleri doğrulamak isteyip istemediğinizi sorar. Office SharePoint Designer 2007 uygulamasının devam etmesi ve her köprüyü doğrulaması için Evet'i tıklatın. Bu işlemin sonucu Tamam veya Bozuk olarak tanımlanmış bir köprüler listesidir. Bozuk olan köprülerden herhangi birini düzenlemek için ilgili köprüyü raporda tıklatın ve sonra Raporlar görünümündeki belge penceresinin sağ üst köşesinde beliren araç çubuğunda Köprü Düzenle'yi tıklatın.

      Not :  köprü düzenle iletişim kutusu

    • Bileşen Hataları     Geçerli olarak hataya neden olan tüm bileşenlerin — örneğin, Etkileşimli Düğmeler veya isabet sayacı (tüm öncekiler ve genelde webbot ve bot olarak bilinenler) — bir listesini görüntüler. Ekle menüsünde Web bileşenleri'ni tıklatarak Web bileşenlerinin bir listesini görüntüleyebilirsiniz.

Sayfanın Başı

Kullanım Özeti raporunu görüntüleme

Site kullanım raporları, site yöneticilerinin siteleri hakkında sorulardan acil olanları yanıtlamalarına yardımcı olur; örneğin, siteyi kaç kişinin ziyaret ettiği, en çok ziyaret edilen kaynaklar, siteyi en çok ziyaret eden kişiler ve ziyaretçilerin siteye nereden ulaştıkları gibi. Kullanım Özeti raporu, toplam ziyaret, sayfa isabetleri, yüklenen bayt miktarını ve daha daha fazlasının özetini içerir.

Kullanım Özeti raporu

Kullanım Özeti Raporu'nu çalıştırmak için aşağıdaki adımları izleyin:

  1. Office SharePoint Designer 2007 uygulamasında raporu çalıştırmak istediğiniz Web sitesini açın.

  2. Site menüsünde sırasıyla Raporlar ve Kullanım üzerine gelin ve sonra Kullanım Özeti'ni tıklatın.

    Rapor oluşturulur. Ayrıntılı raporları görüntülemek için Ad sütunundaki köprü eklenmiş öğelerden herhangi birini tıklatabilirsiniz.

Sayfanın Başı

Ayrıntılı kullanım raporlarını görüntüleme

Kullanıcıların, sitenize nasıl eriştiği hakkındaki soruları yanıtlamak için ayrıntılı kullanım raporlarını kullanabilirsiniz. Örneğin, önceki bölümde oluşturulan Kullanım Özeti raporu toplam isabet sayısını gösterse de Aylık Sayfa İsabetleri raporu ayrıntıları sitedeki her sayfanın isabet sayısını gösterir. Ayrıntılı Kullanım raporlarını çalıştırmak için gerekli adımlar aşağıda verilmiştir:

  1. Office SharePoint Designer 2007 uygulamasında raporu çalıştırmak istediğiniz Web sitesini açın.

  2. Site menüsünde sırasıyla Raporlar ve Kullanım üzerine gelin ve sonra çalıştırmak istediğiniz raporu tıklatın.

    • Aylık Özet     Sitenizdeki aylık Ziyaret, İsabet, Toplam İsabet ve Yükleme Boyutu sayısını özetler.

    • Haftalık Özet     Sitenizdeki haftalık Ziyaret, İsabet, Toplam İsabet ve Yükleme Boyutu sayısını özetler.

    • Günlük Özet     Sitenizdeki günlük Ziyaret, İsabet, Toplam İsabet ve Yükleme Boyutu sayısını özetler.

    • Aylık Sayfa İsabetleri     Web sitenizdeki her sayfa için aylık Toplam İsabet ve isabet sayısını özetler.

    • Haftalık Sayfa İsabetleri     Web sitenizdeki her sayfa için haftalık Toplam İsabet ve isabet sayısını özetler.

    • Günlük Sayfa İsabetleri     Web sitenizdeki her sayfa için günlük Toplam İsabet ve isabet sayısını özetler.

    • Ziyaret Eden Kullanıcılar     Seçili bir ayda siteyi ziyaret eden kullanıcı sayısını ve bunların toplam yüzdesini özetler.

    • İşletim Sistemleri     Seçili bir ayda siteyi ziyaret eden kullanıcı işletim sistemlerinin sayısını ve bunların toplam yüzdesini özetler.

    • Tarayıcılar     Seçili bir ayda siteyi ziyaret eden kullanıcı tarayıcıların sayısını ve bunların toplam yüzdesini özetler.

    • Başvuran Etki Alanları     Seçili bir ayda belirli bir etki alanından siteye yapılan ziyaret sayısını ve bunların toplam yüzdesini özetler.

    • Başvuran URL'ler     Seçili bir ayda belirli bir URL'den siteye yapılan ziyaret sayısını ve bunların toplam yüzdesini özetler.

    • Arama Dizeleri     Seçili bir ayda sitenin arama kutusuna yazılan arama dizelerinin sayısını ve bunların toplam yüzdesini listeler.

Sayfanın Başı

Kullanıcı verileri sonuçlarınızın grafiğini oluşturma

Kullanım verilerini grafik biçiminde gösteren bir çizimi kolayca oluşturabilirsiniz, böylece eğilimleri ve kullanım sıklıklarını belirlemek de kolaylaşır.

  1. Site menüsünde sırasıyla Raporlar ve Kullanım üzerine gelin ve sonra çalıştırmak istediğiniz raporu tıklatın.

  2. Belge penceresinin sağ üst köşesindeki araç çubuğunda, Grafik listesinde, oluşturmak istediğiniz grafiği, örneğin Sütun Grafiği'ni tıklatın.

    raporlar görünümünde grafikler listesini gösteren araç çubuğu

    Rapor yeni bir pencerede açılır.

    Kullanım verileri grafiği

    Not : Grafik verileri varsayılan olarak kullanım raporları ile birlikte oluşturulur. Raporu çalıştırmayı denediğinizde grafik verileri bulamıyorsanız Araçlarmenüsünde Uygulama Seçenekleri'ni ve Raporlar Görünümü sekmesini tıklatın ve sonra Kullanım raporu kaydedildiğinde grafik ekle onay kutusunun seçili olduğuna dikkat edin.

Sayfanın Başı

Raporu sıralama

Raporlar görünümünde, sütun başlıklarını tıklatarak bir raporu sıralayabilirsiniz.

Sayfanın Başı

Rapora filtre uygulama

Yalnızca istediğiniz bilgileri görmek için rapor sonuçlarını daraltabilirsiniz. Aşamalı bir filtre oluşturmak için tek bir sütuna veya birden çok sütuna filtre uygulayabilirsiniz.

  1. Site menüsünde Raporlar üzerine gelin ve sonra çalıştırmak istediğiniz raporu tıklatın.

  2. Filtre uygulama işleminde kullanmak istediğiniz sütuna ait başlığın yanındaki oku tıklatın ve sonra filtre uygulamak istediğiniz istediğiniz verileri tıklatın.

    Örneğin, dosya türüne göre filtre eklerken Tür sütun başlığının yanındaki oku tıklatabilir ve sonra raporda yalnızca bit eşlem dosyalarını göstermek için bmp'yi tıklatabilirsiniz.

    Filtre menüsünü gösteren Tür sütunu

  3. Birden fazla sütuna filtre uygulamak istiyorsanız her sütun için 2. adımı yineleyin.

  4. Sütunda özel bir filtre oluşturmak için sütun başlığının yanındaki oku tıklatın ve sonra (Özel)'i tıklatın. Arama ölçütlerinizi girin ve sonra Tamam'ı tıklatın.

    Örneğin, sitenizdeki tüm .bmp ve .gif resim dosyalarını tanımlamak için özel bir otomatik filtre kullanabilirsiniz.

    Özel Otomatik Filtre iletişim kutusu

  5. Herhangi bir sütundaki filtreyi temizlemek için ilgili sütun başlığının yanındaki oku tıklatın ve sonra (Tümü)'nü tıklatın.

Not : Siteyi kapattığınızda yeni uygulanan filtre ayarları kaydedilir. Yeni çalıştırılan bir raporda dosyaları bulamazsanız önceki oturumda uyguladığınız filtreler bu dosyaları gizliyor olabilir.

Rapordaki tüm filtreleri kaldırmak için herhangi bir sütun başlığını sağ tıklatın ve sonra kısayol menüsünde Filtreleri Kaldır'ı tıklatın.

Sayfanın Başı

Raporu kopyalama

Raporu çalıştırdıktan sonra sonuçları bir e-posta iletisine veya başka bir belgeye (örneğin bir Microsoft Excel çalışma sayfasına) kopyalayıp yapıştırmak isteyebilirsiniz. Site Özeti raporları dışındaki tüm raporları kopyalayabilirsiniz.

  1. Çalıştırdığınız rapordaki sütun başlıklarından herhangi birini sağ tıklatın ve sonra kısayol menüsünde Raporu Kopyala'yı tıklatın.

    rapor kopyalama komutu seçili ad sütunu

  2. Verileri, belgeye veya iletiye yapıştırın.

Sayfanın Başı

Raporu kaydetme

Microsoft Office Excel 2007 uygulamasını, sonuçları görüntülemek ve çözümlemek veya bunlardan özel çizimler ve grafikler oluşturmak için kullanmak istiyorsanız raporları kaydedebilirsiniz.

  1. Site menüsü'nde Raporlar üzerine gelin ve sonra çalıştırmak istediğiniz raporu tıklatın.

  2. Dosya menüsünde Kaydet'i tıklatın. Veya CTRL+S tuşlarına basın.

  3. Dosya adı kutusuna raporun adını yazın ve Kaydet'i tıklatın. Rapor, sitenize .htm dosyası olarak kaydedilir.

    excel'de açılmış rapor

  4. Raporu açmak için ilgili raporu çift tıklatın.

    Office Excel 2007 uygulamasında rapor açılır.

Sayfanın Başı

Not : Makine Çevirisi Yasal Uyarısı: Bu makale, insan müdahalesi olmadan bir bilgisayar sistemi tarafından çevrilmiştir. Microsoft bu makine çevirilerini İngilizce bilmeyen kullanıcıların Microsoft ürünleri, hizmetleri ve teknolojileriyle ilgili içeriklerden yararlanmasına yardımcı olmak için sunar. Bu makale makine çevirisi olduğundan sözcük, cümle dizilimi ve gramer hataları içerebilir.

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×