SharePoint listesinden Access formları ve raporları oluşturma

Önemli : Bu makale makine çevisidir. Bkz. yasal uyarı. Bu makalenin İngilizce sürümüne buradan ulaşabilirsiniz.

SharePoint listesinden formlar ve raporlar oluşturabilir ve bunları görünümler olarak kullanın. Access 2007 yüklü olan kullanıcılar SharePoint sitesinin bu formlar ve raporlar SharePoint listesinin Görünüm menüsünü kullanarak açabilirsiniz. Görünümünü varsayılan görünüm listesi için bir Access yapabilirsiniz.

Access 2007 kullanarak oluşturduğunuz görünümleri bir veritabanı dosyası Windows SharePoint Services sunucusunda depolanır. Ne zaman bir SharePoint listesini Access başlar, Access görünümünü açın ve form veya rapor görüntüler. SharePoint sitesinde veritabanı depolandığı için Görünüm sitenin diğer kullanıcılar tarafından açılabilir. Bir kullanıcı SharePoint sitesinde, görünüm kullanmak üzere Access görünümü içeren veritabanı dosyasının konumunu bilmeniz gerekmez. Ayrıca, kullanıcı hatta Access'i başlatın öğrenmek gerek yoktur; bu SharePoint site tarafından otomatik olarak işlenir.

Not : SharePoint sitesinde Access görünümünü oluşturması, kullanması veya değiştirmesi için kullanıcının bilgisayarında Access 2007 yüklü olmalıdır.

Ne yapmak istiyorsunuz?

SharePoint listesinin Access görünümünü oluşturma

Görünümünü varsayılan görünüm SharePoint listesi için bir Access yapma

SharePoint listesinin Access görünümünü kullanma

SharePoint listesinin Access görünümünü değiştirme

SharePoint listesinin Access görünümünü oluşturma

SharePoint listesinin Access görünümünü oluştururken Access otomatik olarak başlatılır. Access'te, görünümünüz için çeşitli form ve rapor şablonlarını temel alabilir ve görünümünüzü özelleştirebilirsiniz. Görünümünüzü SharePoint sitesinde yayımlamak yoluyla kolayca diğer kullanıcıların kullanımına sunabilirsiniz.

Not : SharePoint listesinin görünümünü oluşturmak için, varsayılan olarak Tasarım izin düzeyinin içinde bulunan Windows SharePoint Services Listeleri Yönetme izninizin olması gerekir.

Tarayıcınızda görüntülediğiniz SharePoint listesinin Access görünümünü oluşturmak için aşağıdaki yordamı kullanın.

  1. SharePoint sitesinin Görünüm menüsünde Aşağı açılır menü Görünüm Oluştur'u tıklatın.

  2. Görünüm Oluştur sayfasında Access Görünümü'nü tıklatın.

    Access başlatılır ve yeni görünümünüzü içerecek veritabanının yerel bir kopyasını kaydetmeniz istenir.

  3. Yerel Kopya Kaydet iletişim kutusunda, bilgisayarınızda kopyanın kaydedilmesini istediğiniz konuma göz atın, Dosya Adı kutusuna yerel kopya için bir ad yazın ve sonra Kaydet'i tıklatın.

    Access yerel kopyayı kaydeder ve açar, ardından Access Görünümü Oluştur iletişim kutusu gösterilir.

  4. Access Görünümü Oluştur iletişim kutusunda, oluşturmak istediğiniz görünüm türünü çift tıklatın.

    Access yeni görünümünüzü oluşturur ve bunu Düzen görünümünde açar.

  5. Yeni görünümünüzü Düzen görünümünde özelleştirebilir veya Tasarım görünümüne geçebilirsiniz.

    Düzen görünümünde, görünümünüzdeki denetimleri (etiketler ve alanlar gibi) yeniden boyutlandırabilir ve yeniden yerleştirebilir, ancak görünüme başka denetimler ekleyemezsiniz. Düzen görünümü, bitmiş görünümde değişikliklerinizin etkilerini kolayca görebilmeniz için bir veri önizlemesi sağlar.

    Tasarım görünümünde denetimleri yeniden boyutlandırabilir, yeniden yerleştirebilir ve görünümünüze başka denetimler ekleyebilirsiniz. Tasarım görünümü bir veri önizlemesi sağlamaz.

    Her istediğinizde Tasarım görünümüyle Düzen görünümü arasında geçiş yapabilirsiniz. Görünümünüze denetim eklemek için Tasarım görünümünü kullanırsanız, bunun ardından Düzen görünümüne geçebilir ve verilerin önizlemesine bakarak bu denetimleri yerleştirebilirsiniz.

  6. Özelleştirmelerinizi yaptıktan sonra, İleti Çubuğu'nda SharePoint Sitesinde Yayımla'yı tıklatın.

    araç çubuğu

    Web Sunucusuna Yayımla iletişim kutusu görüntülenir.

    İleti Çubuğu görüntülenmiyorsa, aşağıdaki işlemi yaparak görüntüleyin:

    • Veritabanı Araçları sekmesinin Göster/Gizle grubunda İleti Çubuğu'nu tıklatın.

  7. Varsayılan olarak, Access görünümü SharePoint sitesinin Paylaşılan Belgeler kitaplığında yer alan bir veritabanı dosyasına kaydeder ve bu site görünümü oluşturduğunuz listeyi içerir. Çoğu durumda bu sizin de tercih ettiğiniz konumdur, ancak Web Sunucusuna Yayımla iletişim kutusunun Kayıt yeri kutusunda başka bir kitaplık seçerek veritabanının depolanacağı belge kitaplığını değiştirebilirsiniz. Görünüme erişimi olanları ve kullanıcıların görünümü salt okunur modda mı yoksa düzenleme modunda mı açabileceklerini daha net bir şekilde denetlemek için bunu yapabilirsiniz. Ayrıca, SharePoint sitesinin Access görünümlerini yayımlamak için ayarlanmış belirli kitaplıkları olabilir ve bu durumda doğru kitaplığı seçmek için Kayıt yeri konumunu değiştirmeniz gerekebilir. 

    SharePoint sitesinin yöneticisi doğru kitaplığı seçmenize yardımcı olabilir.

  8. Access Web Sunucusuna Yayımla iletişim kutusunun Dosya Adı kutusunda veritabanı için bir ad sağlar. Bu ad, yerel kopya olarak kaydettiğiniz veritabanının adıyla aynıdır. İsterseniz adı değiştirebilirsiniz, ancak çoğunlukla önerilen adı kabul etmeniz iyi olur. Bu, hangi yerel veritabanının SharePoint sitesinde yayımladığınız veritabanına karşılık geldiğini anımsamanızı kolaylaştıracaktır. 

  9. Veritabanını SharePoint sitesine kaydetmek için Yayımla'yı tıklatın.

Sayfanın Başı

Görünümünü varsayılan görünüm SharePoint listesi için bir Access yapma

Görünümünü varsayılan görünüm için bir SharePoint listesini Access yaptığınızda, kullanıcıların liste açtığınızda bu kullanıcıların kendi bilgisayarlarında Access varsa, Access görünümü otomatik olarak açılır.

Önemli : Access görünümü yaparsanız, Access 2007'in yüklü değil liste ziyaretçilerin varsayılan görünüm liste kullanmanız mümkün olmayacaktır.

  1. SharePoint listesini açın, Ayarlar menüsünde Liste ayarları' nı tıklatın.

  2. Liste ayarları sayfasında, görünümler, varsayılan görünüm yapmak istediğiniz Access Görünüm adını tıklatın.

  3. Görünümü Düzenle sayfasında, bunu varsayılan görünüm yap ' ı seçin ve sonra da Tamam' ı tıklatın.

Sayfanın Başı

SharePoint listesinin Access görünümünü kullanma

SharePoint listesinin Access görünümünü kullanmak için, listenin Görünüm menüsünde Access görünümünü seçersiniz.

  • Görünüm menüsünde Aşağı açılır menü Access görünümünün adını tıklatın. Access başlatılır ve görünüm salt okunur modda gösterilir.

    Salt okunur modda görünümdeki verileri değiştirebilir ve görünümü yazdırabilirsiniz, ancak görünümün tasarımını değiştiremezsiniz. Görünümün tasarımını değiştirmek istiyorsanız, bu makalenin bir sonraki bölümüne (SharePoint listesinin Access görünümünü değiştirme) bakın.

Sayfanın Başı

SharePoint listesinin Access görünümünü değiştirme

Access görünümünün tasarımını değiştirmek için, Access görünümünü içeren veritabanının yerel bir kopyasını kaydeder ve değişiklikleri yaparsınız. Bundan sonra görünümün yerel kopyasını kullanabilir veya SharePoint sitesinde gerekli izinleriniz varsa yeni görünümü yayımlayabilirsiniz.

Not : Windows SharePoint Services izin düzeyiniz ne olursa olsun, Access görünümünün yerel kopyasında değişiklik yapabilirsiniz. Ancak değiştirdiğiniz görünümü SharePoint sitesinde yayımlayabilmek için, varsayılan olarak Tasarım izin düzeyinin içinde yer alan Windows SharePoint Services Listeleri Yönetme izninizin olması gerekir. Gereken izinlere sahip olup olmadığınızdan emin değilseniz, bunu saptamak için SharePoint site yöneticinize başvurun.

  1. Access görünümü açıkken, İleti Çubuğu'nda Farklı Kaydet'i tıklatın.

    İleti Çubuğu'nda Farklı Kaydet düğmesi

    Not : İleti Çubuğu görüntülenmiyorsa, aşağıdaki işlemi yaparak görüntüleyin:

    • Veritabanı Araçları sekmesinin Göster/Gizle grubunda İleti Çubuğu'nu tıklatın.

  2. Access görünümü ve tüm diğer açık nesneleri kapatmanızı istediğinde Evet'i tıklatın.

    Farklı Kaydet iletişim kutusu belirir.

  3. Kayıt yeri kutusunda yerel kopyayı kaydetmek istediğiniz konumu belirtin, Dosya adı kutusuna yerel kopya için bir ad yazın ve sonra Kaydet'i tıklatın.

    Access veritabanının yerel kopyasını kaydeder ve sonra bu kopyayı açar.

  4. Aşağıdakilerden birini yapın:

    • Yeni denetimler eklemeden görünümün düzenini değiştirmek için, Gezinti Bölmesi'nde görünümü sağ tıklatın ve sonra kısayol menüsünde Düzen Görünümü'nü tıklatın.

      Düzen görünümünde, görünümünüzdeki denetimleri (etiketler ve alanlar gibi) yeniden boyutlandırabilir ve yeniden yerleştirebilir, ancak görünüme başka denetimler ekleyemezsiniz. Düzen görünümü, bitmiş görünümde değişikliklerinizin etkilerini kolayca görebilmeniz için bir veri önizlemesi sağlar.

    • Görünümde denetim (etiket veya alan gibi) eklemek veya kaldırmak için, Gezinti Bölmesi'nde görünümü sağ tıklatın ve sonra kısayol menüsünde Tasarım Görünümü'nü tıklatın.

      Tasarım görünümünde denetimleri yeniden boyutlandırabilir, yeniden yerleştirebilir ve görünümünüze başka denetimler ekleyebilirsiniz. Tasarım görünümü bir veri önizlemesi sağlamaz.

      Not : Görünümü Tasarım görünümünde düzenlemeyi seçtiyseniz ve gözden geçirilmiş görünümü SharePoint sitesinde yayımlamayı planlıyorsanız, görünüme SharePoint listesinin parçası olmayan hiçbir alan eklemeyin.

  5. Her istediğinizde Tasarım görünümüyle Düzen görünümü arasında geçiş yapabilirsiniz. Görünümünüze denetim eklemek için Tasarım görünümünü kullanırsanız, bunun ardından Düzen görünümüne geçebilir ve verilerin önizlemesine bakarak bu denetimleri yerleştirebilirsiniz.

Değiştirilmiş Access görünümünü SharePoint sitesinde yayımlama

Görünümde değişiklik yapmayı bitirdikten sonra, SharePoint sitesi üzerinde Listeleri Yönetme izniniz varsa, aşağıdaki yordamı kullanarak değiştirilmiş görünümü yayımlayabilirsiniz.

Listeleri Yönetme iznini almak için SharePoint sitesinin yöneticisine başvurun.

  1. Görünümü veritabanının yerel kopyasına kaydedin.

  2. İleti Çubuğu'nda SharePoint Sitesinde Yayımla'yı tıklatın.

    araç çubuğu

    Not : Listeleri Yönetme izniniz yoksa İleti Çubuğu'nda SharePoint Sitesinde Yayımla düğmesi gösterilmez. İleti Çubuğu görüntülenmiyorsa, aşağıdaki işlemi yaparak görüntüleyin:

    • Veritabanı Araçları sekmesinin Göster/Gizle grubunda İleti Çubuğu'nu tıklatın.

  3. Web Sunucusuna Yayımla iletişim kutusunda Yayımla'yı tıklatın.

Sayfanın Başı

Not : Makine Çevirisi Yasal Uyarısı: Bu makale, insan müdahalesi olmadan bir bilgisayar sistemi tarafından çevrilmiştir. Microsoft bu makine çevirilerini İngilizce bilmeyen kullanıcıların Microsoft ürünleri, hizmetleri ve teknolojileriyle ilgili içeriklerden yararlanmasına yardımcı olmak için sunar. Bu makale makine çevirisi olduğundan sözcük, cümle dizilimi ve gramer hataları içerebilir.

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×