Sayı toplama

Depo envanterinin fiyat toplamını veya yıllık bütçe altındaki tüm bölümlerin toplam brüt kar marjını hesaplamak istediğinizi varsayalım. Sayı toplamanın birkaç yolu vardır.

Ne yapmak istiyorsunuz?

Bir hücredeki sayıları toplama

Bir satır veya sütundaki tüm ardışık sayıları toplama

Ardışık olmayan sayıları toplama

Örnek

Tek koşula dayalı sayı ekleme

Örnek

Sayıları birden çok koşulu temel alarak toplama

Örnek

Önceki örnekte işlevler nasıl kullanılır

Sayıları ayrı bir aralıkta saklanan ölçütü temel alarak toplama

Örnek

Koşullu Toplama Sihirbazına ne oldu?

Yalnızca benzersiz değerleri toplama

Örnek

Bir hücredeki sayıları toplama

Formülde + (artı işareti) aritmetik işlecini kullanın.

Örneğin, aşağıdaki formülü hücreye yazarsanız:

=5+10

Hücre aşağıdaki sonucu görüntüler:

15

Sayfanın Başı

Bir satır veya sütundaki tüm ardışık sayıları toplama

Bitişik bir dizi (diğer bir deyişle boş hücre olmayan) sayınız varsa Otomatik Toplam Düğme görüntüsü düğmesini kullanabilirsiniz.

  1. Sayılar sütunu altında veya sayılar satırı sağında bir hücreyi tıklatın.

  2. Giriş sekmesinde, Düzenleme grubunda Otomatik Toplam Düğme görüntüsü düğmesini tıklatıp ENTER tuşuna basın.

Sayfanın Başı

Ardışık olmayan sayıları toplama

Boş veya sayı yerine metin olan hücrelerin bulunduğu bir dizi sayınız varsa TOPLA işlevini bir formülde kullanın. Formülde kullanılan bir aralıkta yer alsalar bile, boş ve metin içeren hücreler yoksayılır.

Örnek

Örneği boş çalışma sayfasına kopyalarsanız anlamanız daha kolay olabilir.

Örnek kopyalama

  1. Boş bir çalışma kitabı veya çalışma sayfası oluşturun.

  2. Yardım konusundaki örneği seçin.

    Not    Satır veya sütun başlıklarını seçmeyin.

    Yardım'dan örnek seçme

    Yardım'dan örnek seçme

  3. CTRL+C tuşlarına basın.

  4. Çalışma sayfasında, A1 hücresini seçin ve CTRL+V tuşlarına basın.

  5. Sonuçları görüntüleme ve sonuçları döndüren formülleri görüntüleme arasında geçiş yapmak için, CTRL+` (kesme işareti) tuşlarına basın veya Formül Denetimi grubundaki Formüller öğesinde Formülleri Göster düğmesini tıklatın.

1

2

3

4

5

6

7

A

B

Satış elemanı

Fatura

Biber

15.000

Biber

9.000

Göktepe

8.000

Göktepe

20.000

Biber

5.000

Özmen

22.500

Formül

Açıklama (Sonuç)

=TOPLA(B2:B3,B5)

Biber'in iki faturasıyla Göktepe'nin bir faturasını toplar (44.000)

=TOPLA(B2;B5;B7)

Biber, Göktepe ve Özmen'in faturalarını teker teker toplar (57.500)

Not   TOPLA işlevinde 30'a ulaşan sayıda hücre ve aralık başvurusu birleşimi olabilir. Örneğin, =TOPLA(B2:B3,B5) formülünde bir aralık başvurusu (B2:B3), bir de hücre (B5) vardır.

Sayfanın Başı

Tek koşula dayalı sayı ekleme

Başka bir aralık değerine dayanana tek aralık için toplam değer oluşturmak amacıyla ETOPLA işlevini kullanabilirsiniz. Aşağıdaki örnekte yalnızca, Biber adlı satış elemanı için A sütunundaki (satış elemanı) değerle ilişkili B sütunundaki (Fatura) değerler için toplam oluşturmak isteyebilirsiniz.

Örnek

Örneği boş çalışma sayfasına kopyalarsanız anlamanız daha kolay olabilir.

Örnek kopyalama

  1. Boş bir çalışma kitabı veya çalışma sayfası oluşturun.

  2. Yardım konusundaki örneği seçin.

    Not    Satır veya sütun başlıklarını seçmeyin.

    Yardım'dan örnek seçme

    Yardım'dan örnek seçme

  3. CTRL+C tuşlarına basın.

  4. Çalışma sayfasında, A1 hücresini seçin ve CTRL+V tuşlarına basın.

  5. Sonuçları görüntüleme ve sonuçları döndüren formülleri görüntüleme arasında geçiş yapmak için, CTRL+` (kesme işareti) tuşlarına basın veya Formül Denetimi grubundaki Formüller öğesinde Formülleri Göster düğmesini tıklatın.

1

2

3

4

5

6

7

A

B

Satış elemanı

Fatura

Biber

15.000

Biber

9.000

Göktepe

8.000

Göktepe

20.000

Biber

5.000

Özmen

22.500

Formül

Açıklama (Sonuç)

=ETOPLA(A2:A7,"Biber",B2:B7)

Biber faturalarının toplamı (29000)

=ETOPLA(B2:B7,">=9000",B2:B7)

9.000'den büyük veya eşit yüksek faturaların toplamı (66500)

=ETOPLA(B2:B7,"<9000",B2:B7)

9.000'den küçük faturaların toplamı (13000)

ETOPLA işlevi aşağıdaki bağımsız değişkenleri kullanır

ETOPLA işlevi içeren formül

ETOPLA işlevi içeren formül

1. Değerlendirme aralığı: Ölçütlerinize uyan bir satır olup olmadığını belirlemek için bu hücreleri denetleyin.

2. Ölçütler: Değerlendirdiğiniz hücrelerin, toplama işleminde yer alacak satır için uyması gereken koşul.

3. Toplama aralığı: Koşula uyan satırı oluşturan hücrelerdeki sayıları toplar.

Sayfanın Başı

Sayıları birden çok koşulu temel alarak toplama

Bu görevi gerçekleştirmek için ETOPLA işlevini kullanın.

Örnek

Örneği boş çalışma sayfasına kopyalarsanız anlamanız daha kolay olabilir.

Örnek kopyalama

  1. Boş bir çalışma kitabı veya çalışma sayfası oluşturun.

  2. Yardım konusundaki örneği seçin.

    Not    Satır veya sütun başlıklarını seçmeyin.

    Yardım'dan örnek seçme

    Yardım'dan örnek seçme

  3. CTRL+C tuşlarına basın.

  4. Çalışma sayfasında, A1 hücresini seçin ve CTRL+V tuşlarına basın.

  5. Sonuçları görüntüleme ve sonuçları döndüren formülleri görüntüleme arasında geçiş yapmak için, CTRL+` (kesme işareti) tuşlarına basın veya Formül Denetimi grubundaki Formüller öğesinde Formülleri Göster düğmesini tıklatın.

1

2

3

4

5

6

7

8

9

10

11

A

B

C

D

Bölge

Satış elemanı

Tür

Satış

Güney

Biber

İçecekler

3571

Batı

Kocak

Süt ürünleri

3338

Doğu

Göktepe

İçecekler

5122

Kuzey

Göktepe

Süt ürünleri

6239

Güney

Özmen

Mamul mal

8677

Güney

Kocak

Et ürünleri

450

Güney

Kocak

Et ürünleri

7673

Doğu

Göktepe

Mamul mal

664

Kuzey

Kocak

Mamul mal

1500

Güney

Özmen

Et ürünleri

6596

Formül

Açıklama (Sonuç)

=ÇOKETOPLA(D2:D11,A2:A11,"Güney",C2:C11,"Et ürünleri")

Güney bölgesinde Et ürünleri satış toplamı (14719)

=TOPLA(EĞER((A2:A11="Güney")+(A2:A11="Doğu");D2:D11))

Güney veya Doğu bölgesinde satışlar toplamı (32753)

Not   Örnekteki ikinci formülün dizi formülü olarak girilmesi gerekir. Örneği boş bir çalışma sayfasına kopya ettikten sonra formül hücresini seçin. önce F2'ye, sonra da CTRL+ÜSTKRKT+ENTER'a tuşlarına birlikte basın. Formül dizi formülü olarak girilmemişse #DEĞER! hatası verir.

Önceki örnekte işlevler nasıl kullanılır

=ÇOKETOPLA(D2:D11,A2:A11,"Güney",C2:C11,"Et ürünleri")

ÇOKETOPLA işlevi, A sütununda "Güney", C sütununda da "Et ürünleri" değerinin bulunduğu satırları bulmak için ilk formülde kullanılır. Bu durum 7, 8 ve 11, satırlarda üç kez gerçekleşmektedir. İşlev önce, "Güney" değerini karşılayanları bulmak için bölgelerin bulunduğu A sütununa bakar. Ardından, "Et ürünleri" değerini karşılayanları bulmak için yiyecek türünün bulunduğu C sütununa bakar. Son olarak da, D2:D11 toplamı değerlerinin bulunduğu aralığa bakıp yalnızca bu iki koşulu karşılayan sütunun değerlerini toplar.

=TOPLA(EĞER((A2:A11="Güney")+(A2:A11="Doğu"),D2:D11))

TOPLA ve EĞER işlevlerini kullanan ikinci formül, A sütununda "Güney" veya "Doğu" değerlerinden birinin veya ikisinin de bulunduğu satırları bulmak amacıyla dizi formülü olarak girilmiştir (CTRL+ÜST KRKT+ENTER tuşlarına basılarak). Bu durum 2, 4, 6, 7, 8, 9 ve 11, satırlarda yedi kez gerçekleşmektedir. Bu formül dizi formülü olduğundan, değer eklemek için + işleci kullanılmadı; en az birinin eşleşmesinin gerektiği iki veya daha fazla koşulu denetlemek için kullanıldı. TOPLAişlevi bu ölçütleri karşılayan değerleri eklemek amacıyla kullanıldı.

Sayfanın Başı

Sayıları ayrı bir aralıkta saklanan ölçütü temel alarak toplama

Bu görevi gerçekleştirmek için VSEÇTOPLA işlevini kullanın.

Örnek

Örneği boş çalışma sayfasına kopyalarsanız anlamanız daha kolay olabilir.

Örnek kopyalama

  1. Boş bir çalışma kitabı veya çalışma sayfası oluşturun.

  2. Yardım konusundaki örneği seçin.

    Not    Satır veya sütun başlıklarını seçmeyin.

    Yardım'dan örnek seçme

    Yardım'dan örnek seçme

  3. CTRL+C tuşlarına basın.

  4. Çalışma sayfasında, A1 hücresini seçin ve CTRL+V tuşlarına basın.

  5. Sonuçları görüntüleme ve sonuçları döndüren formülleri görüntüleme arasında geçiş yapmak için, CTRL+` (kesme işareti) tuşlarına basın veya Formül Denetimi grubundaki Formüller öğesinde Formülleri Göster düğmesini tıklatın.

1

2

3

4

5

6

7

8

9

10

11

A

B

C

D

Bölge

Satış elemanı

Tür

Satış

Güney

Biber

İçecekler

3571

Batı

Kocak

Süt ürünleri

3338

Doğu

Göktepe

İçecekler

5122

Kuzey

Göktepe

Süt ürünleri

6239

Güney

Özmen

Mamul mal

8677

Güney

Kocak

Et ürünleri

450

Güney

Kocak

Et ürünleri

7673

Doğu

Göktepe

Mamul mal

664

Kuzey

Kocak

Mamul mal

1500

Güney

Özmen

Et ürünleri

6596

Bölge

Satış elemanı

Tür

Satış

Güney

Et ürünleri

Mamul mal

Formül

Açıklama (Sonuç)

=VSEÇTOPLA(A1:D11; "Satış"; A12:D13)

Güney bölgesinde Et ürünleri satış toplamı (14719)

=VSEÇTOPLA(A1:D11; "Satış"; A12:D14)

Güney bölgesinde Et ürünleri ve Mamul mal satışları toplamı (25560)

VSEÇTOPLA işlevi aşağıdaki bağımsız değişkenleri kullanır.

VSEÇTOPLA işlevi formülü

1. Değerlendirme aralığı: toplama yapmak istediğiniz liste.

2. Alan: toplanacak sütunun etiketi.

3. Ölçütler: Koşulları içeren hücre aralığı.

Sayfanın Başı

Koşullu Toplama Sihirbazına ne oldu?

Bu eklenti artık Excel 2010'da yoktur. Excel'in önceki sürümlerinde, belirli koşullara uyan değerler toplamını hesaplayan formülleri yazmanıza yardımcı olması amacıyla Koşullu Toplama Sihirbazı'nı kullanabilirdiniz. Bu işlevselliğin yerini,İşlev Ekle iletişim kutusu (Formüller sekmesi, İşlev Kitaplığı grubu) ve ÇOKETOPLA gibi varolan başka çalışma sayfası işlevleri ve bir formülde TOPLA ve EĞER işlevlerinin birlikte kullanılması almıştır. Verilerin sütunlarını veya satırlarını koşullu toplamak için bu işlevlerin kullanılması hakkında daha fazla bilgi için bu makalenin yukarıdaki satırlarında yer alan Sayıları birden çok koşulu temel alarak toplama bölümüne bakın.

Sayfanın Başı

Yalnızca benzersiz değerleri toplama

Bu görevi gerçekleştirmek için TOPLA, EĞER ve SIKLIK işlevlerini kullanın.

Aşağıdaki örnek şunları kullanır:

  • SIKLIK işlevi; bir aralıkta yer alan benzersiz değerleri tanımlamak için. Bu işlev, belirli bir değerin ilk geçtiği yerde, bu değerin yinelenme sayısına eşit bir sayı döndürür. Aynı değerin ilkinden sonraki her yinelenmesinde, bu işlev 0 (sıfır) döndürür.

  • EĞER işlevi; her doğru koşula 1 değeri atamak için.

  • TOPLA işlevi; benzersiz değerleri toplamak için.

İpucu    Bir işlevin adım adım değerlendirilmesini görmek için, formülün bulunduğu hücreyi seçin ve Formüller sekmesindeki Formül Denetleme grubunda Formül Değerlendir öğesini tıklatın.

Örnek

Örneği boş çalışma sayfasına kopyalarsanız anlamanız daha kolay olabilir.

Örnek kopyalama

  1. Boş bir çalışma kitabı veya çalışma sayfası oluşturun.

  2. Yardım konusundaki örneği seçin.

    Not    Satır veya sütun başlıklarını seçmeyin.

    Yardım'dan örnek seçme

    Yardım'dan örnek seçme

  3. CTRL+C tuşlarına basın.

  4. Çalışma sayfasında, A1 hücresini seçin ve CTRL+V tuşlarına basın.

  5. Sonuçları görüntüleme ve sonuçları döndüren formülleri görüntüleme arasında geçiş yapmak için, CTRL+` (kesme işareti) tuşlarına basın veya Formül Denetimi grubundaki Formüller öğesinde Formülleri Göster düğmesini tıklatın.

1

2

3

4

5

6

7

8

9

10

A

Veri

986

456

67

1

34

689

456

56

67

Formül

Açıklama (Sonuç)

=TOPLA(EĞER(SIKLIK(A2:A10,A2:A10)>0,A2:A10))

A2:A10 hücrelerindeki benzersiz değerleri toplar (2289)

Sayfanın Başı

İlgili Uygulamalar: Excel 2010



Bu bilgi yararlı oldu mu?

Evet Hayır

Özellikleri nasıl daha iyi hale getirebiliriz?

255 kalan karakter sayısı

Gizliliğinizi korumak için lütfen görüşlerinize iletişim bilgilerinizi eklemeyin. Şunu gözden geçirin: gizlilik ilkesi.

Görüşleriniz için teşekkür ederiz!

Destek kaynakları

Dili değiştir