#SAYI/0! hatasını düzeltme

Bir sayı sıfıra (0) veya değer içermeyen bir hücreye bölünürse, Excel #SAYI/0! hatasını görüntüler.

Belirti

Excel çalışma sayfasındaki bir veya birden çok hücrede #SAYI/0! hatasını görüntülüyor.

Nedenler

  • Açık olarak sıfırla (0) bölme gerçekleştiren bir formül girme - örneğin, =5/0.

  • Bölme işlemi yapan bir formül veya işlevde, bölen olarak boş veya sıfır içeren bir hücreye yönelik başvuru kullanma

  • #SAYI/0! hatasını veren bir işlevi veya formülü kullanan bir makroyu çalıştırma

Örnek

Örnek verilerini boş bir çalışma sayfasına kopyaladığınızda, A3, A4 ve A5 hücrelerindeki formüllerin tümü #SAYI/0! hatası döndürür.

Örneği nasıl kopyalayabilirim?

  1. Bu makaledeki örneği seçin. Örneği Excel Online'da kopyalıyorsanız, hücreleri teker teker kopyalayıp yapıştırın.
    Important: Satır veya sütun başlıklarını seçmeyin.

    Proje Sitesi Şablonu

    Yardım'dan örnek seçme

  2. CTRL+C tuşlarına basın.

  3. Boş bir çalışma kitabı veya çalışma sayfası oluşturun.

  4. Çalışma sayfasında, A1 hücresini seçin ve Ctrl+V tuşlarına basın. Excel Online'da çalışıyorsanız, kopyalayıp yapıştırma işlemini örnekteki her hücre için tekrarlayın.
    Important: Örneğin doğru çalışması için, çalışma sayfasının A1 hücresine yapıştırmalısınız.

  5. Sonuçları görüntüleme ve sonuçları döndüren formülleri görüntüleme arasında geçiş yapmak için Ctrl+` (kesme işareti) tuşlarına basın veya Formüller sekmesinde, Formül Denetleme grubunda Formülleri Göster düğmesini tıklatın.

Örneği boş bir çalışma sayfasına kopyaladıktan sonra, gereksinimlerinize göre uyarlama yapabilirsiniz.

1

2

3

4

5

A

1

0

=A1/0

=A1/A2

=BÖLÜM(A1,A2)

Çözüm

  • İşlevdeki veya formüldeki bölenin sıfır (0) veya boş olmadığından emin olun.

  • Formüldeki hücre başvurusunu sıfır veya boş değer içermeyen başka bir hücreyle değiştirin.

  • Formülde bölen olarak başvuruda bulunulan hücreye #YOK değerini girin.

    #YOK değerinin girilmesi bölen değerinin bulunmadığını belirtmek için #SAYI/0! olan formülün sonucu #YOK olarak değiştirilir.

  • EĞER çalışma sayfası işlevini kullanarak hata değerinin görüntülenmesini engelleyin. Bundan sonra, sonuç olarak 0 veya başka bir dize görüntüleyebilirsiniz.

    Örneğin, =A1/A2 formülü hata üretiyorsa, boş dize döndürmek için =EĞER(A2=0,"",A1/A2) formülünü veya 0 döndürmek için =EĞER(A2=0,0,A1/A2) formülünü kullanın.

İlgili Uygulamalar: Excel 2007



Bu bilgi yararlı oldu mu?

Evet Hayır

Özellikleri nasıl daha iyi hale getirebiliriz?

255 kalan karakter sayısı

Gizliliğinizi korumak için lütfen görüşlerinize iletişim bilgilerinizi eklemeyin. Şunu gözden geçirin: gizlilik ilkesi.

Görüşleriniz için teşekkür ederiz!

Destek kaynakları

Dili değiştir