Sık kullanılan formüllere örnekler

Önemli : Bu makale makine çevisidir. Bkz. yasal uyarı. Bu makalenin İngilizce sürümüne buradan ulaşabilirsiniz.

Aşağıdaki örnekleri bir liste veya kitaplığın hesaplanan sütunlarında kullanabilirsiniz Sütun başvuruları içermeyen öneklerden bir sütunun varsayılan değerini belirtmek için yararlanabilirsiniz.

Bu makalede

Koşullu formüller

Tarih ve saat formülleri

Matematik formülleri

Metin formülleri

Koşullu formüller

Aşağıdaki formülleri bir deyimin durumunu sınamak, Evet veya Hayır değerini döndürmek, Tamam veya Tamam değil gibi bir alternatif değeri sınamak veya boş bir değeri göstermek amacıyla boşluk veya tire işaretini belirtmek için kullanabilirsiniz.

Büyük veya başka bir numaraya küçük bir sayı olup olmadığını denetleme

Bu karşılaştırmayı yapmak için EĞER işlevini kullanın.

Sütun1

Sütun2

Formül

Açıklama (olası sonuç)

15000

9000

=[Sütun1]>[Sütun2]

Sütun1 Sütun2'den büyük mü? (Evet)

15000

9000

=EĞER([Sütun1]<=[Sütun2], "Tamam", "Tamam değil")

Sütun1, Sütun2'den küçük mü yoksa ona eşit mi? (Tamam değil)

Sütun içeriklerini karşılaştırma sonra mantıksal bir değer döndürür

Mantıksal bir değer sonucu için (Evet veya Hayır), VE, VEYA ve DEĞİL işlevlerini kullanın.

Sütun1

Sütun2

Sütun3

Formül

Açıklama (olası sonuç)

10

9

8

=VE([Sütun1]>[Sütun2], [Sütun1]<[Sütun3])

15, 9'dan büyük, 8'den küçük mü? (Hayır)

10

9

8

=VEYA([Sütun1]>[Sütun2], [Sütun1]<[Sütun3])

15 9'dan büyük, 8'den küçük mü? (Evet)

10

9

8

=DEĞİL([Sütun1]+[Sütun2]=24)

15 artı 9 24'e eşit değil mi? (Hayır)

Başka bir hesaplama sonucu veya Evet ve Hayır dışındaki değerler için EĞER, VE ve VEYA işlevlerini kullanın.

Sütun1

Sütun2

Sütun3

Formül

Açıklama (olası sonuç)

10

9

8

=EĞER([Sütun1]=15, "Tamam", "Tamam Değil")

Sütun1'deki değer 15'e eşitse, "Tamam"

10

9

8

=EĞER(VE([Sütun1]>[Sütun2], [Sütun1]<[Sütun3]), "Tamam", "Tamam Değil")

15 9'dan büyük, 8'den küçük ise, "Tamam" döndür. (Tamam değil)

10

9

8

=EĞER(VEYA([Sütun1]>[Sütun2], [Sütun1]<[Sütun3]), "Tamam", "Tamam değil")

15, 9'dan büyük ya da 8'den küçükse, "TAMAM"a dön. (TAMAM)

Sıfırları boşluk veya tire olarak görüntüleme

Sıfırı görüntülemek için basit bir hesaplama gerçekleştirin. Bir boşluk veya tire görüntülemek için EĞER işlevini kullanın.

C olumn1

Sütun2

Formül

Açıklama (olası sonuç)

10

10

=[Sütun1]-[Sütun2]

İkinci sayı birincisinden (0) çıkarılmıştır

10

9

=EĞER([Sütun1]-[Sütun2],"-",[Sütun1]-[Sütun2])

Değer sıfır bir tire döndürür (-)

Sütunlardaki hata değerlerini gizleme

Bir tireyi görüntülemek için, hata değerinin yerindeki #YOK, veya YOK için EHATALIYSA işlevini kullanın.

Sütun1

Sütun2

Formül

Açıklama (olası sonuç)

10

0

=[Sütun1]/[Sütun2]

Hata sonuçları (#DIV/0)

10

0

=EĞER(EHATALIYSA([Sütun1]/[Sütun2]),"YOK",[Sütun1]/[Sütun2])

Değer hatalı olduğunda YOK döndürür

10

0

=EĞER(EHATALIYSA([Sütun1]/[Sütun2]),"-",[Sütun1]/[Sütun2])

Değer hatalı olduğunda tire döndürür

Sayfanın Başı

Tarih ve zaman formülleri

Bir tarihe gün, ay veya yıl sayısı ekleme, iki tarih arasındaki farkları hesaplama ve zamanı ondalık değere dönüştürme gibi tarihe ve zamanı temel alan hesaplamaları yapmak için aşağıdaki formülleri kullanabilirsiniz.

Tarihleri toplama

Bir tarihe gün eklemek için toplama (+) işlecini kullanın.

Not : Tarihleri işlediğinizde,hesaplanan sütunun döndürme türü Tarih ve Zaman'a ayarlanmış olmalıdır.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

9/6/2007

3

=[Sütun1]+[Sütun2]

9/6/2007 (12/6/2007) tarihine 3 gün ekleyin

10/12/2008

54

=[Sütun1]+[Sütun2]

10/12/2008 (2/2/2009) tarihine 54 gün ekleyin

Bir tarihe ay eklemek için TARİH, YIL, AY ve GÜN işlevlerini kullanın.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

9/6/2007

3

=TARİH(YIL([Sütun1]),AY([Sütun2])+[Sütun2],GÜN([Sütun1]))

09.06.2007 (09.09.2007) tarihine 3 ay ekler

10/12/2008

25

=TARİH(YIL([Sütun1]),AY([Sütun1])+[Sütun2],GÜN([Sütun1]))

10.12.2008 (10.10.2011) tarihine 25 gün ekler

Bir tarihe yıl eklemek için TARİH, YIL, AY ve GÜN işlevlerini kullanın.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

9/6/2007

3

=TARİH(YIL([Sütun1])+[Sütun2],AY([Sütun1]),GÜN([Sütun1]))

9/6/2007 tarihine üç yıl ekler (6/9/2010)

10/12/2008

25

=TARİH(YIL([Sütun1])+[Sütun2],AY([Sütun1]),GÜN([Sütun1]))

10/12/2008 tarihine 25 yıl ekler (12/10/2033)

Bir tarihe gün, ay ve yıl bileşimi eklemek için TARİH, YIL, AY ve GÜN işlevlerini kullanın.

Sütun1

Formül

Açıklama (sonuç)

09.06.2007

=TARİH(YIL([Sütun1])+3,AY([Sütun1])+1,GÜN([Sütun1])+5)

9/6/2007 tarihine 3 yıl, 1 ay ve 5 gün ekler (14/7/2010)

10.12.2008

=TARİH(YIL([Sütun1])+1,AY([Sütun1])+7,GÜN([Sütun1])+5)

10/12/2008 tarihine 1 yıl, 7 ay ve 5 gün ekler (15/7/2010)

İki tarih arasındaki farkı hesaplama

Bu hesaplamayı yapmak için ETARİHLİ işlevini kullanın.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

01-Ocak-1995

15-Haz-1999

=ETARİHLİ([Sütun1], [Sütun2],"g")

İki tarih arasındaki gün sayısını (1626) döndürür

01-Ocak-1995

15-Haz-1999

=ETARİHLİ([Sütun1], [Sütun2],"ya")

Yıl bölümünü yok sayarak tarihler arasındaki ay sayısını döndürür (5)

01-Ocak-1995

15-Haz-1999

=ETARİHLİ([Sütun1], [Sütun2],"yg")

Yıl bölümünü yok sayarak tarihler arasındaki gün sayısını döndürür (165)

İki zaman arasındaki farkı hesaplama

Sonucu standart saat biçiminde (saat:dakika:saniye) göstermek için çıkarma işlecini (-) ve METİN işlevini kullanın. Bu yöntemin işe yaraması için saatler 24'ü, saniyeler ise 60'ı aşmamalıdır.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

09/06/2007 10:35

09/06/2007 15:30

=METİN([Sütun2]-[Sütun1],"s")

İki saat arasındaki saat farkı (4)

09.06.2007 10:35

09/06/2007 15:30

=METİN([Sütun2]-[Sütun1],"s:dd")

İki saat arasındaki saat ve dakika farkı (4:55)

09.06.2007 10:35

09/06/2007 15:30

=METİN([Sütun2]-[Sütun1],"s:dd:ss")

İki saat arasındaki saat, dakika, saniye farkı (4:55:00)

Sonucu tek bir saat birimini temel alan toplam olarak göstermek için TAMSAYI veya SAAT, DAKİKA ya da SANİYE işlevini kullanın.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

09/06/2007 10:35

10/06/2007 15:30

=TAMSAYI(([Sütun2]-[Sütun1])*24)

İki saat arasındaki toplam saat (28)

09.06.2007 10:35

10/06/2007 15:30

=TAMSAYI(([Sütun2]-[Sütun1])*1440)

İki saat arasındaki toplam dakika (1735)

09.06.2007 10:35

10/06/2007 15:30

=TAMSAYI(([Sütun2]-[Sütun1])*86400)

İki saat arasındaki toplam saniye (104100)

09.06.2007 10:35

10/06/2007 15:30

=SAAT([Sütun2]-[Sütun1])

Fark 24'ü aşmadığında, iki saat arasındaki saat (4)

09/06/2007 10:35

10/06/2007 15:30

=DAKİKA([Sütun2]-[Sütun1])

Fark 60 dakikayı aşmadığında, iki saat arasındaki dakika (55)

09/06/2007 10:35

10/06/2007 15:30

=SANİYE([Sütun2]-[Sütun1])

Fark 60'ı aşmadığında, iki saat arasındaki saniye (0)

Zaman dönüştürme

Saatleri standart saat biçiminden ondalık sayıya dönüştürmek için TAMSAYI işlevini kullanın.

Sütun1

Formül

Açıklama (sonuç)

10:35

=([Sütun1]-TAMSAYI([Sütun1]))*24

12:00:00'dan bu yana geçen saat sayısı (10,583333)

00:00:15

=([Sütun1]-TAMSAYI([Sütun1]))*24

12:00:00'dan bu yana geçen saat sayısı (12,25)

Saatleri ondalık sayıdan standart zaman biçimine (saat:dakika:saniye) dönüştürmek için bölme işlecini ve METİN işlevini kullanın.

Sütun1

Formül

Açıklama (sonuç)

23:58:00

=METİN(Sütun1/24, "ss:dd:ss")

12:00:00'dan bu yana geçen saat, dakika, saniye (00:59:55)

02:06:00

=METİN(Sütun1/24, "s:dd")

12:00:00'dan bu yana geçen saat ve dakika (00:05:00)

Jülyen tarihleri ekleme

Jülyen tarihi, geçerli yıl ile yıl başlangıcından bu yana geçen gün sayısının bileşimi anlamına gelmektedir. örneğin, 1 Ocak 2007, 2007001 ve 31 Aralık 2007, 2007365 olarak gösterilir. Bu biçim Jülyen takvimini temel almaz.

Bir tarihi Jülyen tarihine dönüştürmek için METİN ve TARİHDEĞERİ işlevlerini kullanın.

Sütun1

Formül

Açıklama (sonuç)

23/06/2007

=METİN([Sütun1],"yy")&METİN(([Sütun1]-TARİHDEĞERİ("1/1/"& METİN([Sütun1],"yy"))+1),"000")

2 basamaklı yılı içeren Jülyen biçiminde tarih (07174)

23/06/2007

=METİN([Sütun1],"yyyy")&METİN(([Sütun1]-TARİHDEĞERİ("1/1/"&METİN([Sütun1],"yy"))+1),"000")

Dört basamaklı yıl ile birlikte Jülyen biçiminde tarih (2007174)

Bir tarihi astronomide kullanılan Jülyen tarihine dönüştürmek için, 2415018.50 sabit sayısını kullanın. 1900 tarih sistemini kullanıyorsanız bu formül yalnızca 1/3/1901'den itibaren geçerlidir.

Sütun1

Formül

Açıklama (sonuç)

23/06/2007

=[Sütun1]+2415018.50

Astronomide kullanılan, Jülyen biçiminde tarih (2454274.50)

Tarihleri haftanın günü olarak gösterme

Tarihleri hafta içi gün olarak metin haline dönüştürmek için METİN ve HAFTAİÇİ işlevlerinden yararlanın.

Sütun1

Formül

Açıklama (olası sonuç)

19-Şub-2007

=METİN(HAFTAİÇİ([Sütun1]), "gggg")

Hafta içini hesaplar ve günün tam adını (Pazartesi) döndürür

3-Ocak-2008

=METİN(HAFTAİÇİ([Sütun1]), "ggg")

Tarih için hafta içi günü hesaplar ve günün kısaltılmış adını (Per) döndürür.

Sayfanın Başı

Matematiksel formüller

Sayıları toplama, çıkarma, çarpma ve bölme, ortalama ve ortanca sayıların hesaplanması, sayıların yuvarlanması ve değerlerin sayılması gibi çeşitli matematiksel hesaplamaları gerçekleştirmek için aşağıdaki formülleri kullanabilirsiniz.

Sayıları toplama

Bir satırda bulunan iki veya daha fazla sütuna sayı eklemek için toplama işlecini (+) veya TOPLA işlevini kullanın.

Sütun1

Sütun2

Sütun3

Formül

Açıklama (sonuç)

18

17

4

=[Sütun1]+[Sütun2]+[Sütun3]

Değerleri ilk üç sütuna ekler (15)

18

17

4

=TOPLA([Sütun1],[Sütun2],[Sütun3])

Değerleri ilk üç sütuna ekler (15)

18

17

4

=TOPLA(EĞER([Sütun1]>[Sütun2], [Sütun1]-[Sütun2], 10), [Sütun3])

Sütun1 Sütun2'den büyükse, farkı ve Sütun3'ü ekler. Veya 10 değerini ve Sütun3'ü ekler (5)

Sayıları çıkarma

Bir satırda bulunan iki veya daha fazla sütundaki sayıları çıkarmak için çıkarma işlecini (-) veya negatif sayılarda TOPLA işlevini kullanın.

Sütun1

Sütun2

Sütun3

Formül

Açıklama (sonuç)

15000

9000

-8000

=[Sütun1]-[Sütun2]

15000 'den 9000 çıkarır (6000)

15000

9000

-8000

=TOPLA([Sütun1], [Sütun2], [Sütun3])

Negatif değerler dahil olmak üzere ilk üç sütuna sayı ekler (16000)

Yüzde olarak iki sayı arasındaki farkı hesaplama

Çıkarma (-) ve bölme (/) işleçlerini ve MUTLAK işlevini kullanın.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

2342

2500

=([Sütun2]-[Sütun1])/MUTLAK([Sütun1])

Yüzde değişikliği (% 6,75 veya 0,06746)

Sayıları çarpma

Bir satırda bulunan iki veya daha fazla sütundaki sayıları çarpmak için çarpma işlecini (*) veya ÜRÜN işlevini kullanın.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

17

2

=[Sütun1]*[Sütun2]

İlk iki sütundaki sayıları çarpar (10)

17

2

=ÜRÜN([Sütun1], [Sütun2])

İlk iki sütundaki sayıları çarpar (10)

17

2

=ÜRÜN([Sütun1],[Sütun2],2)

İlk iki sütundaki sayıyla 2'yi çarpar (20)

Sayıları bölme

Bir satırda bulunan iki veya daha fazla sütundaki sayıları bölmek için bölme işlecini (/) kullanın .

Sütun1

Sütun2

Formül

Açıklama (sonuç)

15000

12

=[Sütun1]/[Sütun2]

15000'i 12'ye böler (1250)

15000

12

=([Sütun1]+10000)/[Sütun2]

15000 ile 10000'i toplar ve toplamı 12'ye böler (2083)

Sayıların ortalamasını hesaplama

Ortanca orta olarak da adlandırılır. Bir satırda bulunan iki veya daha fazla sütundaki sayıların ortalamasını hesaplamak için ORTALAMA işlevini kullanın.

Sütun1

Sütun2

Sütun3

Formül

Açıklama (sonuç)

18

17

4

=ORTALAMA([Sütun1], [Sütun2],[Sütun3])

İlk üç sütundaki sayıların ortalamasını hesaplar (5)

18

17

4

=ORTALAMA(EĞER([Sütun1]>[Sütun2], [Sütun1]-[Sütun2], 10), [Sütun3])

Sütun Sütun2'den büyükse, farkın ve Sütun3'ün ortalamasını hesaplayın. Veya 10 değerini ve Sütun3'ün ortalamasını hesaplayın (2.5)

Sayıların orta değerini hesaplama

Ortanca, sıralanmış bir aralıktaki sayıların ortasındaki değerdir. Bir sayı grubundaki ortanca değeri hesaplamak için ORTANCA işlevini kullanın.

A

B

C

D

E

F

Formül

Açıklama (sonuç)

10

7

9

27

0

4

=ORTANCA(A, B, C, D, E, F)

İlk 6 sütundaki sayıların ortancası (8)

Bir aralıktaki en küçük veya en büyük sayıyı hesaplama

Bir satırda bulunan iki veya daha fazla sütundaki en küçük veya en büyük sayıyı hesaplamak için MİN ve MAK işlevlerini kullanın.

Sütun1

Sütun2

Sütun3

Formül

Açıklama (sonuç)

10

7

9

=MİN([Sütun1], [Sütun2], [Sütun3])

En küçük sayı (7)

10

7

9

=MAK([Sütun1], [Sütun2], [Sütun3])

En büyük sayı (10)

Sayı değerleri

Sayısal değerleri saymak için SAY işlevini kullanın.

Sütun1

Sütun2

Sütun3

Formül

Açıklama (sonuç)

Elma

12.12.2007

=SAY([Sütun1], [Sütun2], [Sütun3])

Sayısal değerleri içeren sütunların sayısını sayar. Tarih ve saat, metin ve boş değerler dışarıda bırakılır (0)

$12

#BÖL/0!

1,01

=SAY([Sütun1], [Sütun2], [Sütun3])

Sayısal değerler içeren sütunları sayar, ancak hataları ve mantıksal değerleri dışlar (2)

Artırın veya bir sayıyı bir yüzde oranında azaltma

Bu hesaplamayı gerçekleştirmek için yüzde (%) işlecini kullanın.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

23

%3

=[Sütun1]*(1+% 5)

Sütun1'deki sayıyı % 5 oranında artırır (24,15)

23

%3

=[Sütun1]*(1+[Sütun2])

Sütun1'deki sayıyı Sütun2'deki yüzde değeri oranında artırır: % 3 (23,69)

23

%3

=[Sütun1]*(1-[Sütun2])

Sütun1'deki sayıyı Sütun2'deki yüzde değeri oranında azaltır: % 3 (22,31)

Bir sayıyı üssü yükseltmek

Bu hesaplamayı gerçekleştirmek için üs imlecini (^) veya KUVVET işlevini kullanın.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

17

2

=[Sütun1]^[Sütun2]

5'in karesini hesaplar (25)

17

3

=KUVVET([Sütun1], [Sütun2])

5'in küpünü hesaplar (125)

Bir sayıyı yuvarlama

Bir sayıyı yuvarlamak için YUKARIYUVARLA, TEK veya ÇİFT işlevini kullanın.

Sütun1

Formül

Açıklama (sonuç)

20,3

=YUKARIYUVARLA([Sütun1],0)

20,3'ü en yakın tamsayıya yukarı yuvarlar (21)

-5,9

=YUKARIYUVARLA([Sütun1],0)

-5,9 sayısını en yakın tam sayıya yukarı yuvarlar (-5)

12,5493

=YUKARIYUVARLA([Sütun1]0,2)

12,5493'ü, iki ondalık basamak içerecek biçimde yukarı yuvarlar (12,55)

20,3

=ÇİFT([Sütun1])

20,3'ü en yakın çift sayıya yukarı yuvarlar (22)

20,3

=TEK([Sütun1])

20,3'ü en yakın tek sayıya yukarı yuvarlar (21)

Bir sayıyı aşağı yuvarlamak için AŞAĞIYUVARLA işlevini kullanın.

Sütun1

Formül

Açıklama (sonuç)

20,3

=AŞAĞIYUVARLA([Sütun1],0)

20,3 sayısını en yakın tam sayıya aşağı yuvarlar (20)

-5,9

=AŞAĞIYUVARLA([Sütun1],0)

-5,9 sayısını en yakın tam sayıya aşağı yuvarlar (-6)

12,5493

=AŞAĞIYUVARLA([Sütun1]0,2)

12,5493 en yakın yüzdelik basamağa aşağı yuvarlar (12,54)

Bir sayıyı en yakın sayı veya kesre yuvarlamak için YUVARLA işlevini kullanın.

Sütun1

Formül

Açıklama (sonuç)

20,3

=YUVARLA([Sütun1],0)

20,3 sayısını aşağı yuvarlar, çünkü kesir kısmı ,5'ten küçüktür (20)

5,9

=YUVARLA([Sütun1],0)

5,9 sayısını yukarı yuvarlar, çünkü kesir kısmı ,5'ten büyüktür (6)

-5,9

=YUVARLA([Sütun1],0)

-5,9 sayısını aşağı yuvarlar, çünkü kesir kısmı -,5'ten küçüktür (-6)

1,25

=YUVARLA([Sütun1], 1)

Sayıyı, tek ondalık basamak içerecek biçimde yuvarlar. Yuvarlanacak bölüm 0,05'e eşit veya büyük olduğu için, sayı yukarı yuvarlanır (sonuç: 1,3)

30,452

=YUVARLA([Sütun1], 2)

Sayıyı, iki ondalık basamak içerecek biçimde yuvarlar. Yuvarlanacak bölüm (0,002) 0,005'ten küçük olduğu için, sayı aşağı yuvarlanır (sonuç: 30,45)

Sayıyı 0'ın üzerinde bir basamağa yuvarlamak için YUVARLA, YUKARIYUVARLA, AŞAĞIYUVARLA, TAMSAYI ve UZUNLUK işlevlerini kullanın.

Sütun1

Formül

Açıklama (sonuç)

5492820

=YUVARLA([Sütun1],3-UZUNLUK(TAMSAYI([Sütun1])))

Sayıyı 3 basamağa yuvarlar (5490000)

22230

=AŞAĞIYUVARLA([Sütun1],3-UZUNLUK(TAMSAYI([Sütun1])))

Alttaki sayıyı, solda anlamlı 3 basamak olacak biçimde aşağı yuvarlar (22200)

5492820

=YUKARIYUVARLA([Sütun1], 5-UZUNLUK(TAMSAYI([Sütun1])))

Üstteki sayıyı, solda anlamlı 6 basamak olacak biçimde yukarı yuvarlar (5492820)

Sayfanın Başı

Metin formülleri

Metin üzerinde değişiklikler yapmak, örneğin birden çok sütundan gelen değerleri birleştirmek veya birbirine eklemek, sütunların içeriklerini karşılaştırmak, karakter veya boşluk kaldırmak ve karakterleri yinelemek için aşağıdaki formülleri kullanabilirsiniz.

Metnin büyük/küçük harf değiştirme

Metindeki küçük/büyük harfleri değiştirmek için BÜYÜKHARF, KÜÇÜKHARF veya YAZIMDÜZENİ işlevini kullanın.

Sütun1

Formül

Açıklama (sonuç)

Attila Biber

=BÜYÜKHARF([Sütun1])

Metnin harflerini büyük harf olarak değiştirir (ATTİLA BİBER)

attila Biber

=KÜÇÜKHARF([Sütun1])

Metnin harflerini küçük harf olarak değiştirir (attila biber)

attila Biber

=YAZIMDÜZENİ([Sütun1])

Metnin harflerini yalnızca ilk harfler büyük olarak değiştirir (Attila Biber)

Adları ve soyadları bir araya getirme

Ad ve soyadı birleştirmek için ampersand işlecini (&) veya BİRLEŞTİR işlevini kullanın.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

Barış

Çetinok

=[Sütun1]&[Sütun2]

İki dizeyi (BarışÇetinok) birleştirir

Barış

Çetinok

=[Sütun1]&" "&[Sütun2]

İki dizeyi bir boşlukla ayrılacak şekilde (Barış Çetinok) birleştirir

Barış

Çetinok

=[Sütun2]&", "&[Sütun1]

İki dizeyi bir virgül ve bir boşlukla ayrılacak şekilde (Çetinok, Barış) birleştirir

Barış

Çetinok

=BİRLEŞTİR([Sütun2], ",", [Sütun1])

İki dizeyi bir virgülle ayrılacak şekilde (Çetinok,Barış) birleştirir

Metin ve sayıları farklı sütunlardan bir araya getirme

Metin ve sayıları birleştirmek için BİRLEŞTİR işlevini, ampersand işlecini (&) veya METİN işlevini ve ampersand işlecini kullanın.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

Barış

28

=[Sütun1]& &[Sütun2]&" adet " " sattı."

Yukarıdaki içeriği bir cümle olarak birleştirir (Barış 28 adet sattı.)

Oğuz

% 40

=[Sütun1]&" toplam satıştan "&METİN([Sütun2],"0%")&" oranında satış yaptı."

Yukarıdaki içeriği bir cümle olarak birleştirir (Oğuz toplam satıştan % 40 oranında satış yaptı.)

Not : METİN işlevi, temel alınan ,4 değeri yerine Sütun2 biçimlendirilmiş değerini ekler.

Barış

28

=BİRLEŞTİR([Sütun1]," adet ",[Sütun2]," sattı.")

Yukarıdaki içeriği bir cümle olarak birleştirir (Barış 28 adet sattı.)

Metni bir tarih veya saat birleştirme

Tarih veya saat içeren metni birleştirmek için METİN işlevini ve ampersand işlecini (&) kullanın.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

Faturalama Tarihi

05.06.2007

="Ekstre tarihi: "&METİN([Sütun2], "gg-aa-yyyy")

Tarih içeren metni birleştirir (Ekstre tarihi: 05.06.2007)

Faturalama Tarihi

05.06.2007

=[Sütun1]&" "&METİN([Sütun2], "gg-aa-yyyy")

Farklı sütunlardan gelen metin ve tarihi tek sütunda birleştirir (Faturalama Tarihi 05.06.2007)

Sütun içeriklerini karşılaştırma

Bir sütunu diğeriyle veya bir değerler listesiyle karşılaştırmak için ÖZDEŞ ve VEYA işlevlerini kullanın.

Sütun1

Sütun2

Formül

Açıklama (olası sonuç)

BD122

BD123

=ÖZDEŞ([Sütun1],[Sütun2])

İlk iki sütunun içeriğini karşılaştırır (Hayır)

BD122

BD123

=ÖZDEŞ([Sütun1], "BD122")

Sütun1'in içeriğiyle "BD122" dizesini karşılaştırır (Evet)

Bir sütun değerini veya bir kısmını belirli metinle eşleşip eşleşmediğini denetleme

Bir sütun değerinin veya bu değerin bir kısmının belirli bir metinle eşleşip eşleşmediğini denetlemek için, EĞER, BUL, ARA ve ESAYIYSA işlevlerini kullanın.

Sütun1

Formül

Açıklama (olası sonuç)

Biber

=EĞER([Sütun1]="Biber", "Tamam", "Tamam değil")

Sütun1'in Biber (Tamam) olup olmadığını denetler

Biber

=EĞER(ESAYIYSA(BUL("ı",[Sütun1])), "Tamam", "Tamam değil")

Sütun1'in ı harfi içerip içermediğini denetler (Tamam)

BD123

=ESAYIYSA(BUL("BD",[Sütun1]))

Sütun1'in BD içerip içermediğini denetler (Evet)

Boş olmayan sütunları sayma

Boş olmayan sütunları saymak için SAY işlevini kullanın.

Sütun1

Sütun2

Sütun3

Formül

Açıklama (sonuç)

Satışlar

19

=SAY([Sütun1], [Sütun2])

Boş olmayan sütunları sayar (2)

Satışlar

19

=SAY([Sütun1], [Sütun2], [Sütun3])

Boş olmayan sütunları sayar (2)

Metinden karakter kaldırma

Metindeki karakterleri kaldırmak için UZUNLUK, SOL ve SAĞ işlevlerini kullanın.

Sütun1

Formül

Açıklama (sonuç)

Vitamin A

=SOL([Sütun1],UZUNLUK([Sütun1])-2)

Soldan başlayarak 7 (9-2) karakter döndürür (Vitamin)

Vitamin B1

=SAĞ([Sütun1], UZUNLUK([Sütun1])-8)

Sağdan başlayarak 2 (10-8) karakter döndürür (B1)

Başlangıcı ve bir sütunun ucunu boşlukları kaldırma

Bir sütundaki boşlukları kaldırmak için KIRP işlevini kullanın.

Sütun1

Formül

Açıklama (sonuç)

 Merhabalar!

=KIRP([Sütun1])

Baştaki ve sondaki boşlukları kaldırır (Merhabalar!)

Bir sütundaki bir karakter yineleme

Sütun içindeki bir karakteri yinelemek için YİNELE işlevini kullanın.

Formül

Açıklama (sonuç)

=YİNELE(".".3)

Bir noktayı üç kere yineler (...)

=YİNELE("-";10)

Bir tireyi 10 kez yineler (----------)

Sayfanın Başı

Not : Makine Çevirisi Yasal Uyarısı: Bu makale, insan müdahalesi olmadan bir bilgisayar sistemi tarafından çevrilmiştir. Microsoft bu makine çevirilerini İngilizce bilmeyen kullanıcıların Microsoft ürünleri, hizmetleri ve teknolojileriyle ilgili içeriklerden yararlanmasına yardımcı olmak için sunar. Bu makale makine çevirisi olduğundan sözcük, cümle dizilimi ve gramer hataları içerebilir.

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×