ORTALAMA veya TOPLA işlevindeki #DEĞER! hatasını düzeltme

ORTALAMA veya TOPLA işlevi #DEĞER! hataları içeren hücrelere başvuruyorsa, formül #DEĞER! hatasıyla sonuçlanır.

ORTALAMA işlevinde #Değer! hatası

Hata değerlerini dikkate almamak için, başvuru aralığındaki hataları yoksayıp kalan "normal" değerlerle ortalamayı hesaplayacak bir formül oluşturacağız.

Bu senaryoya geçici bir çözüm olarak, belirtilen aralıkta hata olup olmadığını saptamak için ORTALAMA işlevini EĞER ve EHATALIYSA işlevleriyle birlikte kullanırız. Bu özel senaryo bir dizi formülü gerektirir:

=ORTALAMA(EĞER(EHATALIYSA(B2:D2),"",B2:D2))

Not : Bu bir Dizi formülüdür ve CTRL+SHIFT+ENTER ile girilmelidir. Excel formülü sizin için otomatik olarak küme ayracı {} içine alır. Bunları kendiniz girmeye çalışırsanız, Excel formülü metin olarak görüntüler.

#DEĞER! hatasını düzeltmek için ORTALAMA'da dizi işlevi

Not : Yukarıdaki işleve #DEĞER! için çalışmadığı gibi, #YOK, #BOŞ, #BÖL/0! ve diğerleri için de çalışmaz.

TOPLA işlevini de aynı şekilde kullanabilirsiniz:

=TOPLA(EĞER(EHATALIYSA(B2:D2),"",B2:D2))

İşlevlerle ilgili bir sorunuz mu var?

Excel topluluk forumuna bir soru gönderin

Excel’i geliştirmemize yardımcı olun

Excel'in sonraki sürümünü nasıl geliştirebileceğimiz konusunda önerileriniz var mı? Varsa, lütfen Excel User Voice forumundaki başlıkları gözden geçirin.

Ayrıca Bkz:

#DEĞER! hatasını düzeltme

ORTALAMA işlevi

TOPLA işlevi

Excel'deki formüllere genel bakış

Bozuk formülleri önleme

Formüllerdeki hataları saptamak için hata denetimini kullanma

Tüm Excel işlevleri (alfabetik)

Tüm Excel işlevleri (kategoriye göre)

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×