Microsoft Visual C++ 6.0 kaynak koduna ters mühendislik uygulama

  1. Visual C++'yı özelleştirme.

    how

    1. Visual C++'ta, Tools menüsünde, Customize öğesini tıklatın.

    2. Customize iletişim kutusunda, Add-Ins And Macro Files sekmesini tıklatın.

    3. Add-Ins And Macro Files listesinde, Visio UML Add-In öğesini seçin.

      Visio UML Add-In öğesi, yanında onay işaretiyle birlikte görüntülenir.

    4. Close öğesini tıklatın.

      Yüzen, beş düğmeli Visio UML Eklentisi araç çubuğu görüntülenir.

    5. Visual C++'ı her açtığınızda araç çubuğunun kullanılabilir olmasını istiyorsanız, araç çubuğu alanına sürükleyerek araç çubuğunu sabitleyin.

      İpucu : Her bir Visio UML Eklentisi araç çubuğu düğmesi için klavye kısayolları oluşturmak istiyorsanız, Araçlar menüsünde Özelleştir öğesini tıklatın, Klavye sekmesini tıklatın ve ardından Eklentiler kategorisini seçin.

      Ters mühendislik uygulamak istediğiniz sistem dosyalarını daha ayrıntılı belirtmek için (MFC, ATL veya Include), Visio UML Seçenekleri düğmesini UML Options button image tıklatın.

  2. Tarama Bilgisi dosyası oluşturma.

    how

    1. Visual C++'da, Project menüsünde, Settings öğesini tıklatın.

    2. Project Settings iletişim kutusunda, istediğiniz yapılandırma türünü seçin, C/C++ sekmesini tıklatın ve ardından Generate Browse Info öğesini seçin.

    3. Tarama Bilgisi dosyasının adını ve konumunu belirlemek için Browse Info sekmesini tıklatın, Build Browse Info File öğesini seçin ve ardından OK düğmesini tıklatın.

  3. Projeyi Visual C++'da oluşturun.

    Not : Projeye ters mühendislik uyguladıktan sonra Visual C++ projesinde değişiklik yaparsanız, değişiklikleri görmek için projeyi yeniden oluşturmanız ve ardından projeye Visio programınıza doğru ters mühendislik uygulamanız gerekir.

  4. Visual C++'da, Visio UML Eklentisi araç çubuğunda UML Modeline Tersine Mühendislik Uygula araç çubuğu düğmesini UML Reverse Engineer button image tıklatın.

    Visual C++ çalışma alanında birden fazla proje varsa, ters mühendislik uygulamak istediğiniz projeyi seçin (Projeyi Seç iletişim kutusunda), ardından Tamam düğmesini tıklatın.

    Proje hiyerarşisinde birden fazla tarama dosyası varsa, tarama dosyasını seçin (Gözatma Dosyasını Seç iletişim kutusunda), ardından Tamam düğmesini tıklatın.

    Tarama Bilgisi dosyasından sınıf bilgisini ayıklamak birkaç saniye sürebilir. Ayıklama tamamlandığında, Visio UML Model Diyagramı, boş statik yapı diyagramı çizim sayfası ve kaynak kodundaki sınıf tanımlarını yansıtan simgelerle doldurulmuş Model Gezgini öğesinde ağaç görünümüyle birlikte açılır.

  5. Visio UML Model Diyagramı öğesinde, modelin görünümünü temsil eden statik yapı diyagramı oluşturmak için ağaç görünümünden çizim sayfasına simgeler sürükleyin.

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×