Makro oluşturma veya çalıştırma

Word'de makrolar oluşturarak ve çalıştırarak sık kullanılan görevleri otomatik hale getirebilirsiniz. Makro, bir görevi otomatik olarak gerçekleştirmek için birlikte gruplandırıp tek bir komut haline getirdiğiniz bir dizi komut ve yönergedir.

Sık yaptığınız görevlerde zaman kazanmak için adımları bir makroda gruplayın. Önce makroyu kaydedin. Daha sonra Hızlı Erişim Araç Çubuğu'nda bir düğmeyi tıklatarak veya bir tuş birleşimine basarak makroyu çalıştırabilirsiniz. Bu sizin makroyu nasıl kurduğunuza bağlıdır.

  1. Görünüm > Makrolar > Makro Kaydet'i tıklatın.

    Makro Kaydet komutu

  2. Makro için bir ad yazın.

    Makro adı kutusu

  3. Oluşturduğunuz tüm yeni belgelerde bu makroyu kullanmak için Makronun saklanacağı yer kutusunda Tüm Belgeler (Normal.dotm) yazdığından emin olun.

    Makronun nereye depolanacağını seçmek için kutu

  4. Makronuzu bir düğmeyi tıklattığınızda çalıştırmak için Düğme'yi tıklatın.

    Makroyu bir düğmeye atamak için tıklayın

  5. Yeni makroyu tıklatın (Normal.YeniMakrolar.<makronuzun adı> gibi bir adı vardır) ve Ekle'yi tıklatın.

    Makro ve Ekle düğmesi

  6. Değiştir'i tıklatın.

    Hızlı Erişim Araç Çubuğu'nu Özelleştir kutusundaki Değiştir düğmesi

  7. Bir düğme görüntüsü seçin, istediğiniz adı yazın ve Tamam'ı iki kez tıklatın.

    Değiştir Düğmesi kutusundaki düğme seçenekleri

  8. Şimdi adımları kaydetme zamanı. Görevdeki her adım için komutları tıklatın veya tuşlara basın. Word tıklatmalarınızı ve tuş vuruşlarınızı kaydeder.

    Not : Makronuzu kaydederken metin seçmek için klavyeyi kullanın. Makrolar fareyle yapılan seçimleri kaydetmez.

  9. Kaydetmeyi durdurmak için Görünüm > Makrolar > Kaydı Durdur'u tıklatın.

    Kaydı Durdur komutu

Makronuzun düğmesi Hızlı Erişim Araç Çubuğu'nda görünür.

Hızlı Erişim Araç Çubuğu'ndaki Makro düğmesi

Makroyu çalıştırmak için düğmeyi tıklatın.

  1. Görünüm > Makrolar > Makro Kaydet'i tıklatın.

    Makro Kaydet komutu

  2. Makro için bir ad yazın.

    Makro adı kutusu

  3. Oluşturduğunuz tüm yeni belgelerde bu makroyu kullanmak için Makronun saklanacağı yer kutusunda Tüm Belgeler (Normal.dotm) yazdığından emin olun.

    Makronun nereye depolanacağını seçmek için kutu

  4. Makronuzu bir klavye kısayoluna bastığınızda çalıştırmak için Klavye'yi tıklatın.

    Makroyu bir klavye kısayoluna atamak için tıklayın

  5. Yeni kısayol tuşuna basın kutusuna bir tuş birleşimi yazın.

  6. O birleşimin daha önce başka bir öğeye atanmış olup olmadığını görmek için kontrol edin. Atanmışsa, farklı bir birleşim deneyin.

  7. Oluşturduğunuz tüm yeni belgelerde bu klavye kısayolunu kullanmak için Değişiklikleri kaydet kutusunda Normal.dotm yazdığından emin olun.

  8. Ata'yı tıklatın.

  9. Şimdi adımları kaydetme zamanı. Görevdeki her adım için komutları tıklatın veya tuşlara basın. Word tıklatmalarınızı ve tuş vuruşlarınızı kaydeder.

    Not : Makronuzu kaydederken metin seçmek için klavyeyi kullanın. Makrolar fareyle yapılan seçimleri kaydetmez.

  10. Kaydetmeyi durdurmak için Görünüm > Makrolar > Kaydı Durdur'u tıklatın.

    Kaydı Durdur komutu

Makroyu çalıştırmak için klavye kısayol tuşlarına basın.

Makro çalıştırmak için Hızlı Erişim Araç Çubuğu’ndaki düğmeye veya klavye kısayoluna basın ya da makroyu Makrolar listesinden çalıştırın.

  1. Görünüm > Makrolar > Makroları Görüntüle'yi tıklatın.

    Makroları Görüntüle komutu

  2. Makro adı altındaki listede çalıştırmak istediğiniz makroyu tıklatın.

  3. Çalıştır'ı tıklatın.

Bir belgedeki makroyu tüm yeni belgelerde kullanılabilir hale getirmek için Normal.dotm şablonuna ekleyin.

  1. Makroyu içeren belgeyi açın.

  2. Görünüm > Makrolar > Makroları Görüntüle'yi tıklatın.

    Makroları Görüntüle komutu

  3. Düzenleyici'yi tıklatın.

    Makroları Görüntüle kutusundaki Düzenleyici düğmesi

  4. Normal.dotm şablonuna eklemek istediğiniz makroyu tıklatın ve Kopyala'yı tıklatın.

  1. Dosya > Seçenekler > Şeridi Özelleştir'i tıklatın.

  2. Komutları seçin'in altında Makrolar'ı tıklatın.

  3. İstediğiniz makroyu tıklatın.

  4. Şeridi özelleştir'in altında, makroyu eklemek istediğiniz sekmeyi ve özel grubu tıklatın.

Bir özel grubunu yoksa, Yeni Grup'u tıklatın. Ardından Yeniden Adlandır'ı tıklatıp özel grubunuz için bir ad yazın.

  1. Ekle'yi tıklatın.

  2. Makro için bir resim seçmek ve istediğiniz adı yazmak için Yeniden Adlandır'ı tıklatın.

  3. İki kere Tamam'ı tıklatın.

  1. Geliştirici sekmesinin Kod grubunda Makrolar'a tıklayın.

  2. Makro adı kutusuna makronun adını yazın.

    Not : Yeni makroya yerleşik Word makrolarından birinin adını verirseniz, yerleşik makronun yerini yeni makro eylemleri alır. Yerleşik makro listesini görüntülemek için, Makro yeri listesinde Word Komutları'na tıklayın.

  3. Makro yeri listesinde içinde makroyu depolamak istediğiniz şablona veya belgeye tıklayın.

    Makronun tüm belgelerde kullanılabilmesini sağlamak için, Normal.dotm'ye tıkladığınızdan emin olun.

  4. Visual Basic Düzenleyicisi'ni açmak için Oluştur'a tıklayın.

Visual Basic Düzenleyicisi'ni açtıktan sonra, Visual Basic for Applications ile çalışma hakkında daha fazla bilgi edinmek isteyebilirsiniz. Daha fazla bilgi için, Yardım menüsünde Microsoft Visual Basic Yardımı'na tıklayın veya F1 tuşuna basın.

Bir dizi eylemi kaydedebilir veya Visual Basic Düzenleyicisi'ne Visual Basic for Applications kodu girerek sıfırdan makro yazabilirsiniz.

Not : Office Word 2007'de makrolarla çalışmak için, Geliştirici sekmesinin gösterilmesini sağlamalısınız.

  1. Microsoft Office Düğmesi Office düğmesi resmi ’ne ve sonra Word Seçenekleri’ne tıklayın.

  2. Popüler'i tıklatın.

  3. Word'le çalışmak için üst seçenekler'in altında Şeritte Geliştirici sekmesini göster onay kutusunu seçin.

    Not : Şerit, Microsoft Office Fluent kullanıcı arabiriminin bir bileşenidir.

  1. Geliştirici sekmesinin Kod grubunda Makro Kaydet'e tıklayın.

    Geliştirici sekmesindeki Kod grubu
  2. Makro adı kutusuna makronun adını yazın.

    Not : Yeni makroya yerleşik Office Word 2007 makrolarından birinin adını verirseniz, yerleşik makronun yerini yeni makro eylemleri alır. Yerleşik makro listesini görüntülemek için, Geliştirici sekmesinin Kod grubunda Makrolar'a tıklayın. Makro yeri listesinde Word Komutları'na tıklayın.

  3. Makronun saklanacağı yer kutusunda, içinde makroyu depolamak istediğiniz şablon veya belgeye tıklayın.

    Önemli : Makronun tüm belgelerde kullanılabilmesini sağlamak için, Normal.dotm'ye tıkladığınızdan emin olun.

  4. Açıklama kutusuna makro açıklamasını yazın.

  5. Aşağıdakilerden birini yapın:

    • Kaydetmeye başlayın    Makroyu Hızlı Erişim Araç Çubuğu'ndaki bir düğmeye veya bir kısayol tuşuna atamadan kaydetmeye başlamak için Tamam'a tıklayın.

    • Düğme oluşturun    Makroyu Hızlı Erişim Araç Çubuğu'ndaki bir düğmeye atamak için aşağıdakileri yapın:

      1. Düğme'ye tıklayın.

      2. Hızlı Erişim Araç Çubuğu'nu Özelleştir'in altında, makroyu hangi belge için Hızlı Erişim Araç Çubuğu'na eklemek istediğinizi belirtmek için belgeyi (veya tüm belgeleri) seçin.

        Önemli : Makronun tüm belgelerde kullanılabilmesini sağlamak için, Normal.dotm'ye tıkladığınızdan emin olun.

      3. Komutları seçin iletişim kutusunda, kaydettiğiniz makroya tıklayın ve sonra da Ekle'ye tıklayın.

      4. Düğmeyi özelleştirmek için Değiştir'e tıklayın.

      5. Simge'nin altında, düğmenizde kullanmak istediğiniz simgeye tıklayın.

      6. Görünen ad kutusunda, görüntülenmesini istediğiniz makro adını yazın.

      7. Makro kaydını başlatmak için Tamam'a iki kez tıklayın.

        Seçtiğiniz simge Hızlı Erişim Araç Çubuğu’nda görüntülenir. Yazdığınız ad, simgenin üzerine geldiğinizde görüntülenir.

    • Klavye kısayolu atayın    Makroyu bir klavye kısayoluna atamak için aşağıdakileri yapın:

      1. Klavye’ye tıklayın.

      2. Komutlar kutusunda, kaydettiğiniz makroya tıklayın.

      3. Yeni kısayol tuşuna basın kutusunda, istediğiniz tuş dizisine basın ve ardından Ata'ya tıklayın.

      4. Makro kaydını başlatmak için Kapat'a tıklayın.

  6. Makroya eklenmesini istediğiniz eylemleri gerçekleştirin.

    Not : Makroyu kaydederken, komut ve seçeneklere tıklamak için fareyi kullanabilirsiniz ama metin seçmek için kullanamazsınız. Metinleri klavyeyi kullanarak seçmelisiniz. Klavyeyi kullanarak metin seçme hakkında daha fazla bilgi için bkz. Metin seçme.

  7. Eylemlerinizin kaydını durdurmak için, Kod grubunda Kaydı Durdur'a tıklayın.

Makronun klavye kısayolunu değiştirme

  1. Microsoft Office Düğmesi'ne Office düğmesi resmi ve sonra Word Seçenekleri’ne tıklayın.

  2. Özelleştir’e tıklayın.

  3. Klavye kısayolları'nın yanında Özelleştir'e tıklayın.

  4. Kategoriler listesinde Makrolar'a tıklayın.

  5. Makrolar listesinde, değiştirmek istediğiniz makroya tıklayın.

  6. Yeni kısayol tuşuna basın kutusunda, seçmek istediğiniz tuş bileşimini yazın.

  7. Zaten başka bir görevi gerçekleştirmek için kullandığınız bir tuş bileşimini atamadığınızdan emin olmak için Geçerli tuşlar kutusunu denetleyin.

  8. Değişiklikleri kaydet listesinde, makronuzu çalıştırmak istediğiniz yerle eşleşen seçeneğe tıklayın.

    Önemli : Makronun tüm belgelerde kullanılabilmesini sağlamak için, Normal.dotm'ye tıkladığınızdan emin olun.

  9. Kapat'a tıklayın.

  1. Geliştirici sekmesinin Kod grubunda Makrolar'a tıklayın.

    Geliştirici sekmesindeki Kod grubu

  2. Makro adı'nın altındaki listede çalıştırmak istediğiniz makroya tıklayın.

  3. Çalıştır'a tıklayın.

  1. Geliştirici sekmesinin Kod grubunda Makrolar'a tıklayın.

    Geliştirici sekmesindeki Kod grubu

  2. Makro adı kutusuna makronun adını yazın.

    Not : Yeni makroya yerleşik Office Word 2007 makrolarından birinin adını verirseniz, yerleşik makronun yerini yeni makro eylemleri alır. Yerleşik makro listesini görüntülemek için, Makro yeri listesinde Word Komutları'na tıklayın.

  3. Makro yeri listesinde, içinde makroyu depolamak istediğiniz şablon veya belgeye tıklayın.

    Makronun tüm belgelerde kullanılabilmesini sağlamak için, Normal.dotm'ye tıkladığınızdan emin olun.

  4. Visual Basic Düzenleyicisi'ni açmak için Oluştur'a tıklayın.

Visual Basic Düzenleyicisi'ni açtıktan sonra, Visual Basic for Applications ile çalışma hakkında daha fazla bilgi edinmek isteyebilirsiniz. Daha fazla bilgi için, Yardım menüsünde Microsoft Visual Basic Yardımı'na tıklayın veya F1 tuşuna basın.

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×