Mac için Excel 2016’da hücrelerdeki karakterleri sayma

Hücrelerdeki karakterleri saymanız gerektiğinde, UZUNLUK işlevini kullanabilirsiniz. Bu işlev harfleri, rakamları, karakterleri ve tüm boşlukları sayar. Örneğin, "Bugün hava 38 derece; yüzmeye gideceğim" ifadesinin uzunluğu (tırnak işaretleri hariç) 39 karakter olup 31 harf, 2 rakam, 5 boşluk ve 1 noktalı virgülden oluşmaktadır.

  • İşlevi kullanmak için formül çubuğuna =UZUNLUK(hücre) girip Enter tuşuna basın. Bu örneklerde, hücre, B1 gibi, sayım yapmak istediğiniz hücredir.

  • Birden fazla hücredeki karakterleri saymak içinse, formülü girdikten sonra formülü kopyalayıp diğer hücrelere yapıştırın.

  • Birden fazla hücredeki toplam karakter sayısını bulmak için, UZUNLUK işleviyle birlikte TOPLAM işlevlerini kullanmak isteyebilirsiniz. Örneğin, =TOPLAM(UZUNLUK(hücre1);UZUNLUK(hücre2);UZUNLUK(hücre3)). Bu örnekte, UZUNLUK işlevi her bir hücredeki karakter sayısını bulurken, TOPLAM işlevi de bu sayımların toplamını alır.

  • Hücre içindeki belirli karakterleri saymak için UZUNLUK işlevini YERİNEKOY işlevi ile birlikte kullanın. Örneğin, bir hücre içinde kaç tane küçük Z bulunduğunu bulmak isterseniz şu formülü kullanırsınız: =UZUNLUK(hücre1)-UZUNLUK(YERİNEKOY (hücre1,"z",""))

Bir deneyin

Yeni bir Excel çalışma sayfasına aşağıdaki verileri yazın. A1 hücresinden başlatın.

Metin Dizeleri

Formüller

Hızlı kahverengi tilki

Hızlı kahverengi tilki atladı

Hızlı kahverengi tilki tembel köpeğin üstünden atladı

Bir hücredeki karakterleri sayma

  1. B2 hücresine tıklayın.

  2. Hücrenin içine =UZUNLUK(A2) formülünü girip Enter tuşuna basın.

Formül, A2 hücresindeki karakter sayısını 19 olarak bulur; tüm boşluklar da bu sayıya dahildir. Son noktadan sonra boşluklarınız varsa, formül sayıma bunları da dahil eder.

Birden çok hücredeki karakterleri sayma

  1. B2 hücresini kopyalamak için CONTROL + C tuşlarına basın.

  2. Formülü B3:B4 hücrelerine yapıştırmak için CONTROL + V tuşlarına basın

Böylece, formül B3 ve B4 hücrelerine kopyalanır ve her bir hücredeki karakter sayısı (26 ve 44) hesaplanır.

Karakter sayılarının toplamını hesaplama

  1. B6 hücresine tıklayın.

  2. Hücrenin içine =TOPLA(UZUNLUK(A2);UZUNLUK(A3);UZUNLUK(A4)) yazarak Enter tuşuna basın.

Böylece üç hücrenin her birindeki karakterler sayılır ve toplanır (89).

Hücre içindeki belirli karakterleri saymak için

  1. C4 hücresine tıklayın.

  2. Hücrenin içine =UZUNLUK(A4)-UZUNLUK(YERİNEKOY(A4,"z","")) formülünü girip Enter tuşuna basın.

Kısaca bu, A4 hücresindeki tüm küçük harf Z’leri sayar ve bu da 1’dir.

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×