Koşullu formüller oluşturma

Koşulların doğru veya yanlışlığını sınama ve ifadeler arasında mantıksal karşılaştırmalar yapma işlevlerine birçok görevde sık rastlanır. Koşullu formüller oluşturmak için VE, VEYA, DEĞİL ve EĞER işlevlerini kullanabilirsiniz.

Örneğin, EĞER işlevi aşağıdaki bağımsız değişkenleri kullanır.

EĞER işlevini içeren formül

EĞER işlevini kullanan formül

Düğme görüntüsü  mantıksal_sınama: denetlemek istediğiniz koşul.

Açıklama Balonu 2  eğer_doğruysa_değer: Koşul Doğru ise dönülecek değer.

Düğme görüntüsü  eğer_yanlışsa_değer: Koşul Yanlış ise dönülecek değer.

Formül oluşturma hakkında daha fazla bilgi için, bkz. Formül oluşturma veya silme.

Ne yapmak istiyorsunuz?

Sonuç olarak mantıksal bir değer (DOĞRU veya YANLIŞ) veren koşullu bir formül oluşturma

Başka bir hesaplama yapan ya da DOĞRU veya YANLIŞ dışında başka değerler veren bir koşullu formül oluşturma

Sonuç olarak mantıksal bir değer (DOĞRU veya YANLIŞ) veren koşullu bir formül oluşturma

Bu görevi yerine getirmek için aşağıdaki örnekte gösterildiği gibi VE, VEYA, DEĞİL işlevlerini ve işleçleri kullanın.

Örnek

Örneği boş çalışma sayfasına kopyalarsanız anlamanız daha kolay olabilir.

Örneği nasıl kopyalayabilirim?

  1. Bu makaledeki örneği seçin.

    Önemli : Satır veya sütun başlıklarını seçmeyin.

    Windows için Excel 2013'te Yardım’dan örnek seçme

    Yardım'dan örnek seçme

  2. CTRL+C tuşlarına basın.

  3. Excel’de boş bir çalışma kitabı veya çalışma sayfası oluşturun.

  4. Çalışma sayfasında A1 hücresini seçin ve CTRL+V tuşlarına basın.

Önemli : Örneğin düzgün olması için örneği çalışma sayfasının A1 hücresine yapıştırmalısınız.

  1. Sonuçları görüntüleme ile bu sonuçları döndüren formülleri görüntüleme arasında geçiş yapmak için CTRL+` (aksan) tuş bileşimine basın veya Formüller sekmesindeki Formül Denetimi grubunda Formülleri Göster düğmesini tıklatın.

Örneği boş bir çalışma sayfasına kopyaladıktan sonra, ihtiyaçlarınıza uyacak şekilde uyarlayabilirsiniz.

1

2

3

4

5

6

7



8



9


10


11



12

A

B

Veri.

15

9

8

Dişliler

Tuşlar

Formül

Açıklama (Sonuç)

=VE(A2>A3, A2<A4)

A2 hücresindeki değerin A3 hücresindeki değerden daha büyük olup olmadığını ve A2'deki değerin A4'teki değerden de daha küçük olup olmadığını saptar. (YANLIŞ)

=VEYA(A2>A3, A2<A4)

A2 hücresindeki değerin A3 hücresindeki değerden daha büyük olup olmadığını veya A2'deki değerin A4'teki değerden de daha küçük olup olmadığını saptar. (DOĞRU)

=DEĞİL(A2+A3=24)

A2 ve A3 hücrelerindeki değerlerin toplamının 24'e eşit olup olmadığını saptar. (YANLIŞ)

=DEĞİL(A5="Dişliler")

A5 hücresindeki değerin "Dişliler" değerine eşit olup olmadığını saptar (YANLIŞ)

=VEYA(A5<>"Dişliler",A6 = "Tuşlar")

A5 hücresindeki değerin "Dişliler" değerine eşit olup olmadığını veya A6 hücresindeki değerin "Tuşlar" değerine eşit olup olmadığını saptar. (DOĞRU)

Bu işlevleri kullanma hakkında bilgi için bkz. VE işlevi, VEYA işlevi ve DEĞİL işlevi.

Sayfanın Başı

Başka bir hesaplama yapan ya da DOĞRU veya YANLIŞ dışında başka değerler veren koşullu bir formül oluşturma

Bu görevi yerine getirmek için aşağıdaki örnekte gösterildiği gibi EĞER, VE, VEYA işlevlerini ve işleçleri kullanın.

Örnek

Örneği boş çalışma sayfasına kopyalarsanız anlamanız daha kolay olabilir.

Örneği nasıl kopyalayabilirim?

  1. Bu makaledeki örneği seçin.

Önemli : Satır veya sütun başlıklarını seçmeyin.

Windows için Excel 2013'te Yardım’dan örnek seçme

Yardım'dan örnek seçme

  1. CTRL+C tuşlarına basın.

  2. Excel’de boş bir çalışma kitabı veya çalışma sayfası oluşturun.

  3. Çalışma sayfasında A1 hücresini seçin ve CTRL+V tuşlarına basın.

Önemli : Örneğin düzgün olması için örneği çalışma sayfasının A1 hücresine yapıştırmalısınız.

  1. Sonuçları görüntüleme ile bu sonuçları döndüren formülleri görüntüleme arasında geçiş yapmak için CTRL+` (aksan) tuş bileşimine basın veya Formüller sekmesindeki Formül Denetimi grubunda Formülleri Göster düğmesini tıklatın.

Örneği boş bir çalışma sayfasına kopyaladıktan sonra, ihtiyaçlarınıza uyacak şekilde uyarlayabilirsiniz.

1

2

3

4

5

6

7


8



9



10



11




12



13



14




15



16

A

B

Veri.

15

9

8

Dişliler

Tuşlar

Formül

Açıklama (Sonuç)

=EĞER(A2=15, "TAMAM", "TAMAM değil")

A2 hücresindeki değer eşittir 15 ise "TAMAM"a dön. Aksi taktirde "Tamam değil"e dön. (TAMAM)

=EĞER(A2<>15, "TAMAM", "TAMAM değil")

A2 hücresindeki değer eşit değil 15 ise "TAMAM"a dön. Aksi taktirde "Tamam değil"e dön. (TAMAM değil)

=EĞER(DEĞİL(A2<=15), "TAMAM", "TAMAM değil")

A2 hücresindeki değer küçüktür veya eşittir 15 ise "TAMAM"a dön. Aksi takdirde "Tamam değil"e dön. (TAMAM değil)

=EĞER(A5<>"DİŞLİLER", "TAMAM", "TAMAM değil")

A5 hücresindeki değer eşit değil "DİŞLİLER" ise "TAMAM"a dön. Aksi taktirde "Tamam değil"e dön. (TAMAM değil)

=EĞER(VE(A2>A3, A2<A4), "TAMAM", "TAMAM değil")

A2 hücresindeki değer A3 hücresindeki değerden daha büyükse ve A2'deki değer A4'teki değerden de daha küçükse "Tamam"a dön. Aksi takdirde "Tamam değil"e dön. (Tamam değil)

=EĞER(VE(A2<>A3, A2<>A4), "TAMAM", "TAMAM değil")

A2 hücresindeki değer A3 hücresindeki değere eşit değilse ve A2'deki değer A4'teki değere de eşit değilse "Tamam"a dön. Aksi takdirde "Tamam değil"e dön. (Tamam)

=EĞER(YADA(A2>A3, A2<A4), "TAMAM", "TAMAM değil")

A2 hücresindeki değer A3 hücresindeki değerden daha büyükse ve A2'deki değer A4'teki değerden de daha küçükse "Tamam"a dön. Aksi takdirde "Tamam değil"e dön. (Tamam)

=EĞER(VEYA(A5<>"Dişliler", A6<>"Tuşlar"), "TAMAM", "TAMAM değil")

A5 hücresindeki değer "Dişliler"e eşit değilse veya A6'daki değer "Tuşlar"a eşit değilse, "TAMAM"a dön. Aksi taktirde "Tamam değil"e dön. (TAMAM değil)

=EĞER(YADA(A2<>A3, A2<>A4), "TAMAM", "TAMAM değil")

A2 hücresindeki değer A3 hücresindeki değere eşitse ve A2'deki değer A4'teki değere eşit değilse "Tamam"a dön. Aksi takdirde "Tamam değil"e dön. (Tamam)

Bu işlevleri kullanma hakkında bilgi için bkz. EĞER işlevi, VE işlevi ve VEYA işlevi.

Sayfanın Başı

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×