Koşula dayalı olarak sayı veya tarih sayma

Tek bir koşulu (eşittir, büyüktür, küçüktür, büyük veya eşittir, küçük veya eşittir gibi) karşılayan sayıları veya tarihleri saymak için EĞERSAY işlevini kullanın. Bir aralık dahilindeki sayıları veya tarihleri saymak için (9000'den büyük ve aynı zamanda 22500'den küçük gibi) ÇOKEĞERSAY işlevini kullanabilirsiniz. Alternatif olarak, TOPLA.ÇARPIM işlevi de kullanılabilir.

Örnek

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

A

B

Salesperson

INVOICE

Koç

15.000

Koç

9.000

Göktepe

8.000

Göktepe

20.000

Koç

5.000

Özmen

22.500

Formül

Açıklama (Sonuç)

=EĞERSAY(B2:B7;">9000")

EĞERSAY işlevi B2:B7 aralığında olup 9000'den büyük değerleri içeren hücreleri sayar (4)

=EĞERSAY(B2:B7;"<=9000")

EĞERSAY işlevi B2:B7 aralığında olup 9000'den küçük değerleri içeren hücreleri sayar (4)

=ÇOKEĞERSAY(B2:B7;">=9000";B2:B7;"<=22500")

ÇOKEĞERSAY işlevi (Excel 2007 ve sonraki sürümlerde kullanılabilir) B2:B7 aralığında olup 9000'e eşit veya daha büyük ve aynı zamanda 22500'e eşit veya daha küçük değerleri içeren hücreleri sayar (4)

=TOPLA.ÇARPIM((B2:B7>=9000)*(B2:B7<=22500))

TOPLA.ÇARPIM işlevi B2:B7 aralığında olup 9000'e eşit veya daha büyük ve aynı zamanda 22500'e eşit veya daha küçük değerleri içeren hücreleri sayar (4). ÇOKEĞERSAY işlevinin bulunmadığı Excel 2003 ve önceki sürümlerinde bu işlevi kullanabilirsiniz.

Tarih

11/3/2011

1/1/2010

31/12/2010

30/6/2010

Formül

Açıklama (Sonuç)

=EĞERSAY(B14:B17;">1/3/2010")

B14:B17 aralığındaki tarih değeri 1/3/2010'dan büyük olan hücreleri sayar (3).

=EĞERSAY(B14:B17;"31/12/2010")

B14:B17 aralığındaki 31/12/2010 tarihine eşit olan hücreleri sayar (1). Ölçütlerde eşittir işaretine gerek olmadığından, burada eşittir işareti eklenmemiştir (eşittir işaretini koyarsanız formül o şekilde de çalışır ("=31/12/2010").

=ÇOKEĞERSAY(B14:B17;">=1/1/2010";B14:B17;"<=31/12/2010")

B14:B17 aralığındaki tarih değeri 1/1/2010 ile 31/12/2010 arasında (bu tarihler dahil) olan hücreleri sayar (3).

=TOPLA.ÇARPIM((B14:B17>=TARİHSAYISI("1/1/2010"))*(B14:B17<=TARİHSAYISI("31/12/2010")))

B14:B17 aralığındaki tarih değeri 1/1/2010 ile 31/12/2010 arasında (bu tarihler dahil) olan hücreleri sayar (3). Bu örnek, ilk kez Excel 2007'de çıkan ÇOKEĞERSAY işlevinin yerine kullanılması için verilmiştir. TARİHSAYISI işlevi tarihleri sayısal birer değere dönüştürür ve böylece TOPLA.ÇARPIM işlevi bu değerlerle çalışabilir.

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×