KAYDIR işlevi

Bu makalede, Microsoft Excel'de KAYDIR işlevinin formül söz dizimi ve kullanımı açıklanmaktadır.

Açıklama

Bir hücre veya hücre aralığındaki belirtilen sütun ve satır sayısında bir aralığın başvurusunu verir. Verilen başvuru, bir tek hücre veya bir hücre aralığı olabilir. Verilecek satır veya sütun sayısını belirleyebilirsiniz.

Söz dizimi

KAYDIR(başv; satırlar; sütunlar; [yükseklik]; [genişlik])

KAYDIR işlevinin söz diziminde aşağıdaki bağımsız değişkenler bulunur:

  • Başvuru    Gerekli. Kaydırma için temel almak istediğiniz başvurudur. Başvuru, bir hücre veya komşu hücrelerin aralığına başvurmalıdır; tersi durumda KAYDIR işlevi #DEĞER! hata değeri verir.

  • Satırlar    Gerekli. Sol üst hücrenin başvuruda bulunmasını istediğiniz, yukarı veya aşağı doğru satır sayısıdır. Satır bağımsız değişkeni olarak 5'in kullanılması, başvurudaki sol üst hücrenin başvurunun beş satır altında olduğunu belirtir. Satırlar pozitif (başlangıç başvurusunun altında) veya negatif (başlangıç başvurusunun üstünde) olabilir.

  • Sütunlar    Gerekli. Sonuçtaki sol üst hücrenin başvuruda bulunmasını istediğiniz, sola veya sağa doğru sütun sayısıdır. Sütun bağımsız değişkeni olarak 5'in kullanılması, başvurudaki sol üst hücrenin başvurunun beş sütun sağında olduğunu belirtir. Sütunlar pozitif (başlangıç başvurusunun sağında) veya negatif (başlangıç başvurusunun solunda) olabilir.

  • Yükseklik    İsteğe bağlı. Verilen başvurunun sahip olmasını istediğiniz, satır sayısı içindeki yüksekliktir. Yükseklik pozitif bir sayı olmalıdır.

  • Genişlik    Gerekli. Verilen başvurunun sahip olmasını istediğiniz, sütun sayısı içindeki genişliktir. Genişlik pozitif bir sayı olmalıdır.

Açıklamalar

  • Satırlar ve sütunlar başvuruyu çalışma sayfası kenarına kaydırırsa, KAYDIR #BAŞV! hata değeri verir.

  • Yükseklik veya genişlik atlanırsa, başvurudaki yükseklik veya genişlikle aynı olduğu varsayılır.

  • KAYDIR gerçekten hücreleri taşımaz veya seçimi değiştirmez; yalnızca başvuru verir. KAYDIR bir başvuru bağımsız değişkeni bekleyen fonksiyonlarla birlikte kullanılabilir. Örneğin, TOPLA(KAYDIR(C2;1;2;3;1)) C2 hücresinin 2 sütun sağı ve 1 satır yukarısı olan 1-sütun ile 3-satır aralığının toplam değerini hesaplar.

Örnek

Aşağıdaki tabloda yer alan örnek verileri kopyalayın ve yeni bir Excel çalışma sayfasının A1 hücresine yapıştırın. Formüllerin sonuçları göstermesi için, bunları seçip F2 tuşuna basın ve sonra Enter tuşuna basın. Gerekirse, tüm verileri görmek için sütun genişliğini ayarlayabilirsiniz.

Formül

Açıklama

Sonuç

=KAYDIR(D3,3,-2,1,1)

B6 hücresindeki değeri görüntüler (4)

4

=TOPLA(KAYDIR(D3:F5,3,-2, 3, 3))

B6:C8 aralık değerlerini toplar

34

=KAYDIR(D3, -3, -3)

Çalışma sayfasındaki var olmayan bir aralığa başvuru olduğu için hata verir.

#BAŞV!

Veri

Veri

4

10

8

3

3

6

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×