InfoPath ve Excel kullanarak bir varlık izleyici çözümü oluşturma

Önemli : Bu makale makine çevisidir. Bkz. yasal uyarı. Bu makalenin İngilizce sürümüne buradan ulaşabilirsiniz.

Microsoft Office InfoPath, veri girmek ve toplamak için form şablonları oluşturmanıza olanak tanır. Microsoft Office Excel 2007, kullanıcıların verileri hesaplamasını, grafiklerini çizmesini ve çözümlemesini sağlar. Bu iki programı ve XML'yi kullanarak, şirketteki varlıkları izlemek için basit ancak etkili, kod içermeyen bir iş çözümünü kolayca oluşturabilirsiniz.

varlıkları izlemek için çözüme genel bakış

Bu makalede

Varlık İzleyici çözümü oluşturmaya giriş

1. Adım: Varlık İzleyici form şablonunu özelleştirme

2. Adım: Excel'de şema dosyasını eşleme ve tablo düzenini özelleştirme

3. Adım: PivotTable ve PivotChart özet raporu oluşturma

4. Adım: Kullanıcılardan varlık bilgilerini toplama

5. Adım: Formları Excel'e aktarma

Son düşünceler: SharePoint listesi veya Access veritabanı kullanmayı dikkate alma

Varlık İzleyici çözümü oluşturmaya giriş

XML verilerini InfoPath ve Excel arasında değiş tokuş edebilirsiniz. Infopath Dışarı Aktar komutu form verilerini Excel'e göndermek için basit ve rahat bir yol olsa da, size çok daha fazla esneklik sağlayacak başka bir yaklaşım benimseyebilirsiniz. Excel'de InfoPath XML şema dosyasını (.xsd) açıkça eşleyerek ve ardından InfoPath form dosyalarını (.xml) Excel'e aktararak, verilerinizi daha verimli bir şeklide yönetmenize ve çözümlemenize yardımcı olması için Excel'de verilerinizin düzenini özelleştirebilir ve özelliklerden daha iyi yararlanabilirsiniz.

Bu makalede, InfoPath Varlık İzleyici örnek form şablonunu kullanarak InfoPath, XML ve Excel'in birlikte çalışmasını nasıl sağlayabileceğinizi göstereceğiz. Kuruluşunuzun her yıl tüm çalışanların ofislerindeki valıkların envanterini çıkardığını düşünün. Ardından, gelecek yılın donanım bütçesinin nasıl ayrılacağına karar vermek için bir Excel raporu çalıştırılıyor. Aşağıdaki diyagram, bölümünüzde varlık verilerini nasıl toplayabileceğinizi, izleyebileceğinizi ve raporlayabileceğinizi gösteren bir genel bakış sağlar.

a

1. Varlık İzleyici form şablonu oluşturulur.

2. Şema dosyası Excel tablosuyla eşlenir ve tablo düzeni özelleştirilir.

3. Boş bir PivotTable ve PivotChart özet raporu oluşturulur.

4. Varlık İzleyici formu kullanılarak kullanıcılardan veriler toplanır.

5. Tüm form verileri Excel tablosuna aktarılır, PivotTable ve PivotChart raporları yenilenir.

Bu çözüm, aşağıdaki kullanıcı rollerini ve ürünleri kapsar:

Tam destek simgesi = Gerekli Destek yok simgesi = Gerekli değil

Yazılım Gereksinimleri

Roller

Office InfoPath 2007

Office Outlook 2007

Office Excel 2007

Çözüm Tasarımcısı

Tam destek simgesi

Tam destek simgesi

Tam destek simgesi

Karar Alan

Tam destek simgesi

Tam destek simgesi

Tam destek simgesi

Çalışanlar

Tam destek simgesi

Tam destek simgesi

Destek yok simgesi

Sayfanın Başı

1. Adım Varlık İzleyici form şablonunu özelleştirme

InfoPath'te yer alan Varlık İzleyici form şablonu, çalışanın ofisindeki her varlık, çalışanın bağlı olduğu bölüm, varlıkların kategorileri ve her varlığın ayrıntıları hakkındaki bilgileri toplamanızı sağlar. Bu çözümde, form tasarımcısı Office Outlook 2007 kullanarak form şablonunu karar vericinin e-posta hesabına gönderir.

varlık izleyicisi şablonu

1. Görev: Varlık İzleyici form şablonunu açma ve özelleştirme

İçinde bağlantılı resimlerin bulunduğu zengin metin kutusu denetimi içeren bir form şablonunu e-posta alıcıları listesine yayımlayamadığınızdan, Varlık İzleyici örnek şablon formunda küçük bir değişiklik yapmalısınız.

  1. Dosya menüsünde Form Şablonu Tasarla'ya tıklayın.

  2. Form Şablonu Tasarla iletişim kutusundaki Form şablonu aç'ın altında Örneği özelleştir'e tıklayın.

  3. Başlarken iletişim kutusunda Örnek - Varlık İzleyici'ye tıklayın ve sonra Form Görevleri'nin altında Bu formu tasarla'ya tıklayın.

  4. assetNotes denetimine sağ tıklayın, Zengin Metin Kutusu özelliklerinin üzerine gelin, Görüntü sekmesine tıklayın ve Kullanılabilir biçim'in altında Bağlı resimler onay kutusunu temizleyin.

2. Görev: Gönderme seçeneklerini tanımlama

Sonraki görev, Gönderme seçeneklerini tanımlayarak çalışanların benzersiz olarak adlandırılmış bir form dosyasını (.xml) karar vericinin e-posta hesabına ekli dosya biçiminde gönderebilmesini sağlamaktır.

  1. Araçlar menüsünde Gönderme Seçenekleri'ne tıklayın.

  2. Gönderme Seçenekleri iletişim kutusunda Kullanıcıların bu formu göndermesine izin ver onay kutusunu seçin.

  3. Form verilerini tek bir hedefe gönder'i tıklatın ve sonra listeden E-posta'yı tıklatın.

  4. Ekle'yi tıklatın.

    Veri Bağlantı Sihirbazı görüntülenir.

  5. Kime kutusuna, gönderilen tüm formları alacak olan karar vericinin diğer adını yazın.

  6. Benzersiz bir konu satırı belirtmek için, Konu kutusunda:

    • Formül Ekle düğme resmi öğesine tıklayın.

    • Aşağıdaki formülü yazın:

concat(my:employee/my:employeeName, my:employee/my:employeeDepartment)

  • Formülü Doğrula'ya tıklayın ve sonra da iki kez Tamam'a tıklayın.

  • Giriş kutusunda, uygun bir ileti yazın veya bu çözümle ilgili önemli yönergeleri ekleyin.

  • İleri'yi tıklatın.

  • Sihirbazın sonraki sayfasında Form verilerini ek olarak gönder'e tıklayın ve ardından Kullanıcıların formu açabilmesi için form şablonunu ekle onay kutusunu seçin.

    Bu, çalışanların ağ konumundan erişemedikleri durumlarda form şablonu dosyasına (.xsn) erişebilmelerini güvence altına alır.

  • Ek Adı kutusunda her form dosyasına (.xml) benzersiz bir dosya adı belirtmek için:

    1. Formül Ekle düğme resmi öğesine tıklayın.

    2. Konu satırındaki formülün aynısını yazın:

concat(my:employee/my:employeeName, my:employee/my:employeeDepartment)

  1. Formülü Doğrula'ya tıklayın ve sonra da iki kez Tamam'a tıklayın.

  • İleri'yi tıklatın.

  • Sihirbazın sonraki sayfasında, Bu veri bağlantısı için ad girin kutusuna söz konusu veri gönderme bağlantısı için açıklayıcı bir ad yazın.

  • Özet bölümünde bilgilerin doğruluğunu onaylayın ve Son'a tıklayın.

  • Formu, karar vericinin ve tüm çalışanların erişebildiği genel bir ağ klasörüne kaydedin.

Sayfanın Başı

2. Adım: Excel'de şema dosyasını eşleme ve tablo düzenini özelleştirme

InfoPath'le Excel arasındaki bağlantıyı ayarlamak için üç görevin yerine getirilmesi gerekir: Varlık İzleyici form şablonu için şema dosyasını ayıklama, Excel'de bu şema dosyasını eşleme ve içeri aktarılan tüm form verileri dosyalarını içerecek olan Excel tablosunun varsayılan düzenini özelleştirme.

1. Görev: InfoPath'ten şema dosyasını ayıklama

  1. InfoPath'te Varlık İzleyici form şablonu dosyasını açın.

  2. Araçlar menüsünde Bu Formu Tasarla'ya tıklayın.

  3. Dosya menüsünde Kaynak Dosyaları Farklı Kaydet'e tıklayın.

  4. Klasöre Gözat iletişim kutusunda, şema dosyasını depolamak istediğiniz klasörü seçin veya bunun için yeni klasör oluşturun.

Tüm kaynak dosyaların kaydedildiği klasörün konumunu ve şema dosyasının adını not alın (buradaki örnekte myschema.xsd). Bu dosya form XML verilerinin şema tanımını içerir.

2. Görev: InfoPath şema dosyasını Excel'de eşleme

  1. Yeni bir Excel dosyası oluşturun ve sonra bu dosyayı karar vericinin erişebileceği bir konuma kaydedin.

  2. Excel'de Geliştirici sekmesi görünür değilse, aşağıdakileri yapın:

    1. Microsoft Office Düğmesi'ne Office düğmesi resmi ve sonra da Excel Seçenekleri'ne tıklayın.

    2. Popüler kategorisindeki Excel ile çalışmak için üst seçenekler öğesinin altında Şeritte Geliştirici sekmesini göster onay kutusunu seçin ve Tamam'ı tıklatın.

      Not : Şerit, Microsoft Office Fluent kullanıcı arabiriminin bir bileşenidir.

  3. Geliştirici sekmesinin XML grubunda Kaynak'ı tıklatın.

    şeritte xml grubu

    XML Kaynağı görev bölmesi görüntülenir.

  4. XML Eşlemeleri'ne tıklayın ve ardından XML Eşlemeleri iletişim kutusunda Ekle'ye tıklayın.

  5. Windows Vista çalıştıran bilgisayarlarda    

    1. Adres çubuğunda, 1. Görev: InfoPath'ten şema dosyasını ayıklama bölümünün 2. adımında oluşturduğunuz myschema.xsd dosyasının sürücüsüne veya klasörüne tıklayın.

      Microsoft Windows XP çalıştıran bir bilgisayarda    

    2. Konum listesinde, 1. Görev: InfoPath'ten şema dosyasını ayıklama bölümünün 2. adımında oluşturduğunuz myschema.xsd dosyasını içeren sürücüye veya klasöre tıklayın.

  6. Dosyayı tıklatın ve sonra 'ı tıklatın.

  7. Birden Çok Kök iletişim kutusu görüntülendiğinde, myschema.xsd dosyasında tanımlanan assetTracking kök düğümüne tıklayın ve sonra da Tamam'a tıklayın.

    XML eşlemesi XML Kaynağı görev bölmesinde görüntülenir.

  8. Yinelenen bir XML öğesi olan ns1:asset düğüm öğesini, Excel tablosunun görüntülenmesini istediğiniz çalışma sayfası konumuna sürükleyin.

    inopath şema dosyasını Excel'e eşleme

3. Görev: Excel tablosunun düzenini özelleştirme

Varsayılan olarak, Excel XML öğesi adlarını tablonun sütun başlıkları olarak kullanır. Bununla birlikte, sütun üst bilgisi hücrelerini düzenleyerek sütun başlıklarını değiştirebilirsiniz.

  1. Varsayılan sütun üst bilgilerini değiştirmek için, Excel tablosu seçili durumdayken ns1:asset dize önekini bulun ve kaldırın. Örneğin, ns1:assetID dizesini ID yapın.

    excel tablo üst bilgilerini özelleştirme

  2. Sütun genişliğini ayarlamak için, Tümünü Seç düğmesine tıklayın ve ardından herhangi bir sütun başlığı sınırına çift tıklayın.

Sayfanın Başı

3. Adım: PivotTable ve PivotChart özet raporu oluşturma

Karar vericiler verileri çözümlemek, incelemek ve görselleştirmek için PivotTable ve PivotChart raporlarını kullanır. Bu senaryoda kullanmak istediğiniz PivotTable ve PivotChart raporlarını önceden ayarlamak, daha sonra karar vericinin tamamlanan verilerle raporu çalıştırmasını basit bir işlem haline getirir.

  1. Excel tablosunda bir hücre seçin.

  2. Ekle sekmesinin Tablolar grubunda Özet Tablo'ya ve sonra da Özet Tablo'ya tıklayın.

    Excel Şerit resmi

    Excel PivotTable Oluştur iletişim kutusunu görüntüler.

  3. PivotTable raporunu A1 hücresi ile başlayan yeni bir çalışma sayfasına yerleştirmek için, Yeni Çalışma Sayfası 'a ve sonra da Tamam'a tıklayın.

    Excel boş PivotTable raporunu belirtilen konuma ekler ve alanları ekleyebilmeniz, düzeni oluşturabilmeniz ve PivotTable raporunu özelleştirebilmeniz için PivotTable Alan Listesi'ni görüntüler.

  4. Verilerin çapraz tablo raporunu oluşturmak için, Kimlik alanını Değerler bölümüne, Bölüm alanını Sütun etiketleri bölümüne, Kategori alanını Sütun etiketleri bölümüne ve Atanan alanını Rapor Filtresi bölümüne sürükleyin.

  5. Özet Tablo raporunu tıklatın.

  6. Ekle sekmesinin Grafikler grubunda Çubuk grafik türüne tıklayın.

    Excel Şerit resmi

  7. 2-B Çubuk seçeneğinin altında Kümelenmiş Çubuk'u seçin.

  8. PivotChart raporunun boyutunu ve konumunu tercihlerinize göre ayarlayın.

boş pivottable ve pivotchart raporları

Sayfanın Başı

4. Adım: Kullanıcılardan varlık bilgilerini toplama

Artık form şablonu tüm çalışanlar tarafından doldurulmaya hazır olduğundan, formu yayımlamanız ve her çalışana göndermeniz gerekir. Her çalışan doldurulmuş formu gönderdiğinde, bunlar e-posta iletisine eklenmiş XML veri dosyaları (.xml) olarak karar vericinin e-posta hesabına gönderilir. Karar verici de tüm iletileri Outlook'ta özel bir InfoPath klasörüne taşıyabilir. Bu senaryoda, tüm kullanıcıların formu doldurması için belirli bir süre atamanız önerilir. Böylelikle, karar verici veri toplama işleminin son tarihine kadar tüm doldurulmuş formlarla raporu çalıştırabilir.

Varlık İzleyicisi formlara veri girme

  1. InfoPath'te, 1. Adım: Varlık İzleyici örnek form şablonunu tasarlama adımında kaydettiğiniz form şablonunu (.xsn) açın.

  2. Araçlar menüsünde Bu Formu Tasarla'ya tıklayın.

  3. Dosya menüsünde, Yayımla'ya tıklayın.

  4. Yayımlama Sihirbazı'nda E-posta alıcısı listesine seçeneğini tıklatın ve ardından İleri'yi tıklatın.

  5. Sihirbazın sonraki sayfasında, Form şablonu adı kutusuna form şablonu için bir ad yazın ve İleri'yi tıklatın. Form şablonu adı, e-posta iletisi alıcılarınıza gönderilen iletinin konu başlığında görüntülenir.

  6. İsteğe bağlı olarak, sihirbazın bir sonraki sayfasında e-posta iletilerinizin düzenlenmesine yardımcı olmak için Outlook klasörlerinizde görüntülenecek sütunlar oluşturabilirsiniz.

  7. İleri'yi tıklatın.

  8. Yayımla'yı tıklatın.

  9. Yayımlama Sihirbazı form şablonu yayımlamasını tamamladığında, formu içeren bir e-posta iletisi açılır.

  10. İletiyi doldurun, çalışanların adlarını yazın veya dağıtım listesi kullanın ve ardından iletiyi gönderin.

Outlook'ta, karar verici gönderilen tüm XML formlarını iki yoldan birini kullanarak düzenleyebilir:

  • İleti ilk kez açıldığında InfoPath Form klasörleri ileti kutusu görüntüleniyorsa, Form Klasörü Oluştur'a tıklayın.

  • Tüm ilgili InfoPath formlarını InfoPath klasörüne taşımak için Outlook'ta bir kural oluşturun.

    Daha fazla bilgi için kuralları kullanarak iletileri yönetmekonusuna bakın.

Sayfanın Başı

5. Adım: Formları Excel'e aktarma

2. ve 3. adımlarda zaten Excel çalışma kitabını oluşturduğunuzdan, karar vericinin form verilerini dışarı aktarması ve gözden geçirmesi kolay bir işlemdir. Karar vericinin xml dosyalarını (.xml) Outlook'tan dışarı aktarması, tüm form dosyalarını (.xml) Excel çalışma kitabına içeri aktarması ve sonra verileri yenilemesi yeterli olur.

1. Görev: Formları Outlook'tan bir Windows klasörüne aktarma

  1. Outlook'ta, çalışanlardan aldığınız formların tümünü içeren klasörü seçin ve sonra CTRL+A tuşlarına basarak tüm form e-posta iletilerini seçin.

  2. Seçime sağ tıklayın, InfoPath Eylemleri'nin üzerine gelin ve Formları Dışarı Aktar'a tıklayın.

  3. Formları Dışarı Aktar iletişim kutusunda bir klasör seçin ve Tamam'a basın.

2. Görev: Formları Excel'de içeri aktarma

  1. 2. Adım: Excel'de şema dosyasını eşle ve tablo düzenini özelleştir bölümünde oluşturduğunuz Excel çalışma kitabında, Excel tablosundaki eşlenmiş hücrelerden birini seçin.

  2. Geliştirici sekmesinin XML grubunda İçeri Aktar'a tıklayın.

    şeritte xml grubu

    XML İçeri Aktar iletişim kutusu görüntülenir.

  3. Windows Vista çalıştıran bilgisayarlarda    

  4. Aşağıdakilerden birini yapın:

    • Dosyalar bitişik sıralanıyorsa, SHIFT tuşunu basılı tutarak listede ilk dosyaya ve son dosyaya tıklayın.

    • Dosyalar bitişik sıralanmıyorsa, CTRL tuşunu basılı tutarak listede içeri aktarmak istediğiniz her dosyaya tıklayın.

  5. Al'ı tıklatın.

    excel içeri aktarılan veri tablosu

Varsayılan olarak, Excel eşlenen hücrelerde var olan tüm verilerin üzerine yazar; bu iş çözümünün istenen sonucu budur. Öte yandan, karar verici örneğin zamanlanan son tarihten önce ilerle durumunu ölçmek için verileri birkaç kez içeri aktarabilir.

Not : Excel'de, verileri eklemek için Yeni verileri varolan XML tablolarının sonuna ekle seçeneğini de kullanabilirsiniz (Geliştirici sekmesinin XML grubunda Eşleme Özellikleri'ne tıklayın); bu, diğer çözümler için uygun olabilir.

Daha fazla bilgi için içeri aktarma XML verilerini Excel Yardım konularına bakın ve ekleme veya eşlenmiş XML verilerin üzerine.

3. Görev: PivotTable ve PivotChart raporlarını yenileme

  • PivotTable raporunda bir hücreye tıklayın.

  • Seçenekler sekmesinin Veri grubunda Tümünü Yenile'nin yanındaki oka tıklayın ve ardından Yenile'ye tıklayın.

    .

Son pivottable ve pivotchart raporu

Şimdi Excel çalışma sayfası, gelecek yılın donanım bütçesini ayırmanıza yardımcı olması için ihtiyacınız olan verilerin tümünü ve özet raporlarını içerir. Kuşkusuz, gerekirse Excel çalışma kitabınızda başka çözümlemeler yapabilir, örneğin verileri sıralayabilir, filtreleyebilir veya koşullu olarak biçimlendirebilirsiniz.

Sayfanın Başı

Son düşünceler: SharePoint listesi veya Access veritabanı kullanmayı dikkate alma

Alternatif olarak, verileri InfoPath ile Excel arasında aktarmak için XML yerine SharePoint listesi veya Access veritabanı kullanmayı da dikkate alabilirsiniz.

SharePoint listesi kullanma

InfoPath'ten, salt okunur veri kaynağı olarak kolayca bir SharePoint listesi kullanabilirsiniz. Aşağıdaki iki işlemden birini yapabilirsiniz:

  • SharePoint listesinden verileri Excel'e aktarın; bu işlem, otomatik olarak Excel'de bir veri bağlantısı oluşturur.

  • Excel'den, SharePoint listesine açık bir veri bağlantısı oluşturun.

Veri bağlantısı oluşturulduktan sonra, güncel verileri almak için Excel'de verileri yenileyebilirsiniz.

Verileri eklemek ve güncelleştirmek için SharePoint listesini kullanabilir, listedeki bir öğeyi görüntülemek için InfoPath formunu kullanabilir (örneğin, en iyi dikey görüntülenebilen karmaşık veya uzun bir öğe) ve ardından verilerde başka çözümlemeler yapmak için Excel'i kullanabilirsiniz.

InfoPath, sharepoint listesi ve excel’i birleştirme

1. Tek bir öğeyi kolayca gözden geçirmek için InfoPath'te görüntüleyin.

2. Verileri SharePoint Listesinde ekleyin ve güncelleştirin.

3. Excel'le verileri yenileyin ve güncel rapor hazırlayın.

Daha fazla bilgi için bkz. SharePoint belge kitaplığına veya listesine veri bağlantısı ekleme ve SharePoint listesinden veri içeri aktarma.

Access veritabanı kullanma

InfoPath'ten, Access veritabanına bir okuma/yazma bağlantısı oluşturabilirsiniz. Excel'den, Access veritabanına açıkça bir veri bağlantısı oluşturabilir ve güncel verileri almak için bağlantıyı yenileyebilirsiniz. Hatta, bağlantının çalışma kitabı her açıldığında veya düzenli aralıklarla (örneğin, 5 dakikada bir) otomatik olarak yenilenmesini de tanımlayabilirsiniz.

Access veritabanını InfoPath'le Excel arasında aracı olarak kullanabilirsiniz. InfoPath formunu Access'e gönderdiğinizde, Access veritabanını güncelleştirirsiniz. Excel'de veri bağlantısını yenilediğinizde, güncelleştirilmiş verileri Access'ten alırsınız. Aslında, verileri dolaylı olarak InfoPath'ten Excel çalışma kitabına göndermiş olursunuz.

InfoPath, erişmek ve Excel'i birleştirme

1. Formu görüntüleyin ve Access veritabanına gönderin.

2. Verileri Access veritabanında depolayın.

3. Excel'le verileri yenileyin ve güncel rapor hazırlayın.

Daha fazla bilgi için bkz. Microsoft Access veritabanını temel alan bir form şablonu tasarlama.

İpucu : Doğrudan Access 2007'den bir InfoPath formu oluşturabileceğinizi biliyor muydunuz? Kullanıcılarınızın bilgisayarında Outlook 2007 ve InfoPath 2007 yüklüyse, E-posta iletileri aracılığıyla veri topla sihirbazını kullanarak Access 2007'den doğrudan farklı kullanıcıların verilerini toplayabilirsiniz. Daha fazla bilgi için, Access 2007 yardımında E-posta iletilerini kullanarak veri toplama konusuna bakın.

Sayfanın Başı

Not : Makine Çevirisi Yasal Uyarısı: Bu makale, insan müdahalesi olmadan bir bilgisayar sistemi tarafından çevrilmiştir. Microsoft bu makine çevirilerini İngilizce bilmeyen kullanıcıların Microsoft ürünleri, hizmetleri ve teknolojileriyle ilgili içeriklerden yararlanmasına yardımcı olmak için sunar. Bu makale makine çevirisi olduğundan sözcük, cümle dizilimi ve gramer hataları içerebilir.

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×