HATA.TİPİ işlevi

Bu makalede, Microsoft Excel'de HATA.TİPİ işlevinin formül sözdizimi ve kullanımı açıklanmaktadır.

Açıklama

Microsoft Excel'in hata değerlerinden birine karşılık gelen bir sayı veya hata yoksa #YOK hatasını verir. EĞER fonksiyonunda HATA.TİPİ'ni kullanarak hata tipini sınayabilir ve hata değeri yerine ileti gibi bir metin dizesi verebilirsiniz.

Söz dizimi

HATA.TİPİ(hata_değer)

HATA.TİPİ işlevinin söz diziminde aşağıdaki bağımsız değişkenler bulunur:

  • Hata_değer    Gerekli. Tanımlayıcı sayısını bulmak istediğiniz hata değeridir. Hata_değer gerçek hata değeri olabileceği halde, genellikle sınamak istediğiniz bir formülü içeren bir hücreye başvuru olacaktır.

Hata_değer

HATA.TİPİ sonucu

#BOŞ!

1

#SAYI/0!

2

#DEĞER!

3

#BAŞV!

4

#AD?

5

#SAYI!

6

#YOK

7

#VERİ_ALINIYOR

8

Diğerleri

#YOK

Örnek

Aşağıdaki tabloda yer alan örnek verileri kopyalayın ve yeni bir Excel çalışma sayfasının A1 hücresine yapıştırın. Formüllerin sonuçları göstermesi için, bunları seçip F2 tuşuna basın ve sonra Enter tuşuna basın. Gerekirse, tüm verileri görmek için sütun genişliğini ayarlayabilirsiniz.

Veri

#BOŞ!

#SAYI/0!

Formül

Açıklama

Sonuç

=HATA.TİPİ(A2)

#BOŞ! Hata(1) sayısı.

1

=EĞER(HATA.TİPİ(A3)<3;ELEMAN(HATA.TİPİ(A3);"Aralıklar kesişmiyor";"Bölen sıfır"))

A3 hücresinin içerdiği hata değerinin #BOŞ! veya #SAYI/0! hata değerlerinden hangisi olduğunu denetler. Bunlardan biriyse, bu iletilerden birini görüntülemek için ELEMAN çalışma sayfası fonksiyonlarındaki hata değeri numarası kullanılır, tersi durumda #YOK hata değeri verilir.

Bölen sıfır

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×