Hücrelerdeki karakterleri sayma

Hücrelerdeki karakterleri saymanız gerektiğinde, UZUNLUK işlevini kullanabilirsiniz. Bu işlev harfleri, rakamları, karakterleri ve tüm boşlukları sayar. Örneğin, "Bugün hava 38 derece; yüzmeye gideceğim" ifadesinin uzunluğu (tırnak işaretleri hariç) 39 karakter olup 31 harf, 2 rakam, 5 boşluk ve 1 noktalı virgülden oluşmaktadır.

  • İşlevi kullanmak için formül çubuğuna =UZUNLUK(hücre) girip Enter tuşuna basın. Bu örneklerde hücre, B1 gibi, sayım yapmak istediğiniz hücredir.

  • Birden fazla hücredeki karakterleri saymak içinse, formülü girdikten sonra dolgu tutamacını, hesaplamak istediğiniz hücreler boyunca sağa veya aşağı doğru sürükleyin.

Çalışma sayfasına birden fazla UZUNLUK işlevi girme

  • Birden fazla hücredeki toplam karakter sayısını bulmak için, UZUNLUK işleviyle birlikte TOPLA işlevlerini kullanmak isteyebilirsiniz. Örneğin, =TOPLA(UZUNLUK(hücre1);UZUNLUK(hücre2);UZUNLUK(hücre3)))). Bu örnekte, UZUNLUK işlevi her bir hücredeki karakter sayısını bulurken, TOPLA işlevi de bu sayımların toplamını alır.

Bir de kendiniz deneyin

UZUNLUK işlevinin nasıl kullanıldığını görmek için çalışma kitabındaki örnekleri kullanın.

Aşağıdaki tabloyu kopyalayın ve bir Excel çalışma kitabında A1 hücresine yapıştırın. A sütunundaki hücrelerde bulunan metnin uzunluğunu görmek için B2'den formülü B3:B4'e sürükleyin.

Metin Dizeleri

Formüller

Hızlı kahverengi tilki

=UZUNLUK(A2)

Hızlı kahverengi tilki atladı

Hızlı kahverengi tilki tembel köpeğin üstünden atladı.

Bir hücredeki karakterleri sayma

  1. Bu örnek çalışma kitabının ilk sayfasında (Sayfa1) B2 hücresini tıklatın.

  2. Hücrenin içine =UZUNLUK(A2) formülünü girip Enter tuşuna basın.

Formül, A1 hücresindeki karakter sayısını 45 olarak bulur; tüm boşluklar da bu sayıya dahildir. Son noktadan sonra boşluklarınız varsa, formül sayıma bunları da dahil eder.

Birden çok hücredeki karakterleri sayma

  1. Örnek çalışma kitabında B2 hücresine tıklayın.

  2. Hücrenin içine =UZUNLUK(A2) girin.

  3. Ctrl+C tuşlarına basarak B2 hücresini kopyalayın ve Ctrl+V tuşlarına basarak formülü B3:B4 hücrelerine yapıştırın.

Böylece, formül B3 ve B4 hücrelerine kopyalanır ve her bir hücredeki karakter sayısı (19, 26 ve 45) hesaplanır.

Karakter sayılarının toplamını hesaplama

  1. Örnek çalışma kitabında B6 hücresini tıklatın.

  2. Hücrenin içine =TOPLA(UZUNLUK(A2);UZUNLUK(A3);UZUNLUK(A4)) yazarak Enter tuşuna basın.

Böylece üç hücrenin her birindeki karakterler sayılır ve toplanır (90).

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×