Form verilerini e-posta iletisi içinde gönderme

Önemli : Bu makale makine çevisidir. Bkz. yasal uyarı. Bu makalenin İngilizce sürümüne buradan ulaşabilirsiniz.

Form şablonunuza, kullanıcıların form verilerini e-posta iletisi içinde göndermelerine olanak sağlayan ikinci bir veri gönderme bağlantısı ekleyebilirsiniz. Formun gönderildiği e-posta adreslerini, e-posta iletisinin konu satırını ve formun adını belirtmek için statik değerler, formdaki verilere dayalı değerler veya bir formül kullanabilirsiniz. Ayrıca formun e-posta iletisinin gövde metninde mi, yoksa iletinin eki olarak mı görünmesini istediğinizi de belirtebilirsiniz.

Form şablonunuzu, formu e-posta iletisine ek olarak katacak şekilde yapılandırırsanız, form şablonunu da e-posta iletisine ekleyebilirsiniz. Formu ve form şablonunu e-posta iletisine ek olarak koymakla, form şablonu bilgisayarlarının önbelleğine alınmamış olsa bile, e-posta alıcılarının formu Microsoft Office InfoPath'de açmalarına olanak sağlayabilirsiniz. Alıcıların ekleri açabilmeleri için, bilgisayarlarında InfoPath yüklü olmalıdır.

Kullanıcılar form verilerini e-posta iletisi içinde gönderdiklerinde, InfoPath form verilerini içeren bir e-posta iletisi oluşturur ve bu iletiyi, veri bağlantısını oluştururken belirttiğiniz e-posta alıcılarına gönderir. tamamlanan formları alan kişiler Microsoft Office Outlook 2007 kullanıyorsa, Gelen Kutularına, aldıkları tüm InfoPath formlarını içeren bir klasör ekleyebilir ve bu klasörü, formdaki verileri Outlook'ta sütunlar halinde görüntüleyecek şekilde yapılandırabilirler.

Veri gönderme bağlantısını ekledikten sonra, form şablonunuzu, kullanıcıların form verilerini göndermesine izin verecek şekilde yapılandırırsınız. Bunun sonucunda, kullanıcılar formu açtıklarında, InfoPath otomatik olarak Standart araç çubuğuna bir Gönder düğmesi ve Dosya menüsüne de bir Gönder komutu ekler. Ayrıca form şablonunuz için gönderme seçeneklerini de aşağıdaki yollardan özelleştirebilirsiniz:

  • Standart araç çubuğundaki Gönder düğmesinin ve Dosya menüsündeki Gönder komutunun üzerinde görünen metni değiştirme.

  • Standart araç çubuğundaki Gönder düğmesinin ve Dosya menüsündeki Gönder komutunun klavye kısayolunu değiştirme.

  • Formlarını gönderdiklerinde kullanıcılarınıza görüntülenecek özel iletiler oluşturma.

  • Kullanıcı formu gönderdikten sonra, formun açık kalmasını, formun kapanmasını veya başka boş bir form açılmasını belirtme.

Sayfanın Başı

Veri gönderme bağlantısı ekleme

  1. Araçlar menüsünde Gönderme Seçenekleri'ne tıklayın.

  2. Gönderme Seçenekleri iletişim kutusunda Kullanıcıların bu formu göndermesine izin ver onay kutusunu seçin.

  3. Form verilerini tek bir hedefe gönder'i tıklatın ve sonra listeden E-posta'yı tıklatın.

  4. Ekle'yi tıklatın.

  5. Veri Bağlantı Sihirbazı'nda ilgili kutulara, alıcıların e-posta adreslerini, e-posta iletisinde görüntülenmesini istediğiniz konuyu ve istediğiniz giriş metnini yazın ve İleri'yi tıklatın.

    İpucu : Ayrıca, Giriş kutusu dışında her kutunun değerini oluşturmak üzere bir alan belirtebilir veya formül kullanabilirsiniz.

    Nasıl?

    1. Formül Ekle düğme resmi öğesine tıklayın.

    2. Formül Ekle iletişim kutusunda, aşağıdakilerden birini yapın:

      • Formülde alan kullanmak için Alan veya Grup Ekle'yi tıklatın ve Alan veya Grup Seç iletişim kutusunda, kullanmak istediğiniz alanı tıklatın ve Tamam'ı tıklatın.

      • Formülde işlev kullanmak için İşlev Ekle'yi tıklatın ve İşlev Ekle iletişim kutusunda, kullanmak istediğiniz işlevi seçip Tamam'ı tıklatın.

        İpucu : İşlev için parametreler gerekiyorsa, İşlev Ekle iletişim kutusunda işlevi seçin, Tamam'ı tıklatın ve Formül Ekle iletişim kutusundaki Formül kutusunda, eklemiş olduğunuz işlevi çift tıklatın ve bir alan veya grubu tıklatın. İşlevlere ilgili daha fazla bilgi sağlayan bağlantıları Ayrıca Bkz: bölümünde bulabilirsiniz.

      • Formüle değer veya matematiksel işleç eklemek için, Formül kutusuna matematik işleminin değerini veya simgesini girin.

    İşlem

    Simge

    Toplama

    +

    Çıkarma

    -

    Çarpma

    *

    Bölme

    /

    • Not : Formülünüzde bölme (/) işleci varsa, bölme işlecinin önünde ve arkasında bir boşluk olmasına dikkat edin. Bölme işlecinin önünde ve arkasında boşluk olmazsa, InfoPath "/" simgesini bölme işleci yerine, XPath konum adımlarında kullanılan ayırıcı olarak yorumlayabilir.

    • Formülün doğru söz diziminde olup olmadığını denetlemek için, Formül Ekle iletişim kutusunda Formülü Doğrula seçeneğini tıklatın.

      Formüllerle ilgili daha fazla bilgi sağlayan bağlantıları Ayrıca Bkz: bölümünde bulabilirsiniz.

  6. Sihirbazın sonraki sayfasında, aşağıdakilerden birini yapın:

    1. Formu e-posta iletisinin gövde metninde görüntülemek için, Formun yalnızca etkin görünümünü gönder ve ek gönderme'yi tıklatın.

    2. Form verilerini e-posta iletisinin eki olarak göndermek için, Form verilerini ek olarak gönder'i tıklatın, Kullanıcıların formu açabilmesi için form şablonunu ekle onay kutusunu seçin ve Ek Adı kutusuna form için bir ad yazın. Her form adının benzersiz olması için bir alan belirtebilir veya formül kullanabilirsiniz.

      Nasıl?

      1. Formül Ekle düğme resmi öğesine tıklayın.

      2. Formül Ekle iletişim kutusunda, aşağıdakilerden birini yapın:

        • Formülde alan kullanmak için Alan veya Grup Ekle'yi tıklatın ve Alan veya Grup Seç iletişim kutusunda, kullanmak istediğiniz alanı tıklatın ve Tamam'ı tıklatın.

        • Formülde işlev kullanmak için İşlev Ekle'yi tıklatın ve İşlev Ekle iletişim kutusunda, kullanmak istediğiniz işlevi seçip Tamam'ı tıklatın.

          İpucu : İşlev için parametreler gerekiyorsa, İşlev Ekle iletişim kutusunda işlevi seçin, Tamam'ı tıklatın ve Formül Ekle iletişim kutusundaki Formül kutusunda, eklemiş olduğunuz işlevi çift tıklatın ve bir alan veya grubu tıklatın. İşlevlere ilgili daha fazla bilgi sağlayan bağlantıları Ayrıca Bkz: bölümünde bulabilirsiniz.

        • Formüle değer veya matematiksel işleç eklemek için, Formül kutusuna matematik işleminin değerini veya simgesini girin.

      İşlem

      Simge

      Toplama

      +

      Çıkarma

      -

      Çarpma

      *

      Bölme

      /

      • Not : Formülünüzde bölme (/) işleci varsa, bölme işlecinin önünde ve arkasında bir boşluk olmasına dikkat edin. Bölme işlecinin önünde ve arkasında boşluk olmazsa, InfoPath "/" simgesini bölme işleci yerine, XPath konum adımlarında kullanılan ayırıcı olarak yorumlayabilir.

      • Formülün doğru söz diziminde olup olmadığını denetlemek için, Formül Ekle iletişim kutusunda Formülü Doğrula seçeneğini tıklatın.

        Formüllerle ilgili daha fazla bilgi sağlayan bağlantıları Ayrıca Bkz: bölümünde bulabilirsiniz.

      Not : Form verilerini e-posta iletisi biçiminde alan kişilerin eki açabilmeleri için, bilgisayarlarında InfoPath yüklü olmalıdır.

  7. İleri'yi tıklatın.

  8. Sihirbazın sonraki sayfasında, Bu veri bağlantısı için ad girin kutusuna söz konusu veri gönderme bağlantısı için açıklayıcı bir ad yazın.

  9. Özet bölümünde bilgilerin doğruluğunu onaylayın ve Son'a tıklayın.

    1. Kullanıcılar formu doldururken Standart araç çubuğunda gösterilen Gönder düğmesinin ve Dosya menüsünde yer alan Gönder komutunu adını değiştirmek için, yeni adı Gönderme Seçenekleri iletişim kutusundaki Resim Yazısı kutusuna yazın.

      İpucu : Bu düğme ve komut için klavye kısayolu atamak istiyorsanız, yazın ve işareti (&) klavye kısayolu olarak kullanmak istediğiniz karakteri önce. Örneğin, ALT + B Gönder düğmesi ve komutu klavye kısayolu atamak için & Gönderyazın.

  10. Formunuzu dolduranların Gönder komutunu veya Standart araç çubuğundaki Gönder düğmesini kullanmasını istemiyorsanız, Gönder menü öğesini ve Gönder araç çubuğu düğmesini göster onay kutusunu temizleyin.

    1. Varsayılan olarak, kullanıcılar formu gönderdikten sonra InfoPath formu açık tutar ve formun başarılı bir şekilde gönderilip gönderilmediğini belirten bir ileti görüntüler. Bu varsayılan davranışı değiştirmek için Gelişmiş'i tıklatın ve aşağıdakilerden birini yapın:

      • Kullanıcı tamamlanmış bir formu gönderdikten sonra formu kapatmak veya yeni boş bir form oluşturmak için, Gönderdikten sonra listesinde istediğiniz seçeneği tıklatın.

      • Formun başarılı bir şekilde gönderilip gönderilmediğini belirtecek özel bir ileti oluşturmak için Özel iletiler kullan onay kutusunu seçin, sonra Başarılı olduğunda ve Hatalı olduğunda kutularına iletilerinizi yazın.

        İpucu : Formu gönderemeyen kullanıcılara ne yapacaklarını bildirmek için Hatalı olduğunda kutusuna yazacağınız iletiyi kullanın. Örneğin, kullanıcılara formlarını kaydetmelerini ve diğer yönergeler için başka birisine danışmalarını önerebilirsiniz.

      • Kullanıcılar formu gönderdikten sonra bir ileti görüntülenmesini istemiyorsanız, Başarı ve hata iletileri göster onay kutusunu temizleyin.

Sayfanın Başı

Not : Makine Çevirisi Yasal Uyarısı: Bu makale, insan müdahalesi olmadan bir bilgisayar sistemi tarafından çevrilmiştir. Microsoft bu makine çevirilerini İngilizce bilmeyen kullanıcıların Microsoft ürünleri, hizmetleri ve teknolojileriyle ilgili içeriklerden yararlanmasına yardımcı olmak için sunar. Bu makale makine çevirisi olduğundan sözcük, cümle dizilimi ve gramer hataları içerebilir.

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×