Form verilerini birçok yere gönderme

Önemli : Bu makale makine çevisidir. Bkz. yasal uyarı. Bu makalenin İngilizce sürümüne buradan ulaşabilirsiniz.

Form şablonunuzu, kullanıcıların Gönder düğmesini tıklattıklarında form verilerini birden fazla yere gönderebilecekleri şekilde tasarlayabilirsiniz.

Bu makalede

Genel bakış

Adım 1: Gönder veri bağlantılarını ekleme

Adım 2: gönderim izin vermek için form şablonunu yapılandırma

Genel Bakış

Kullanıcıların form verilerini birden fazla yere göndermelerine olanak sağlamak için, form şablonunuza, kullanıcıların formlarını göndermelerini istediğiniz yerlerin her biri için, veri göndermeye yarayan ikincil bir veri bağlantısı eklemeniz gerekir. tüm veri gönderme bağlantılarını ekledikten sonra, bir kural kullanarak, form şablonunuzu, kullanıcıların form verilerini göndermelerine olanak sağlayacak şekilde yapılandırırsınız. Bunun sonucunda, kullanıcılar formu doldururken, Microsoft Office InfoPath, Standart araç çubuğuna Gönder düğmesi ve Dosya menüsüne Gönder komutu ekler. InfoPath form verilerini, kuralda listelendikleri sırayla ikincil veri bağlantılarına gönderir. Kuralı, veri gönderme bağlantılarının tümünü aynı anda kullanacak şekilde yapılandıramazsınız.

Form şablonunu, kullanıcıların form verilerini göndermelerine olanak sağlayacak şekilde yapılandırırken, gönderme seçeneklerini de aşağıdaki şekilde özelleştirebilirsiniz:

  • Standart araç çubuğundaki Gönder düğmesinin ve Dosya menüsündeki Gönder komutunun üzerinde görünen metni değiştirme.

  • Standart araç çubuğundaki Gönder düğmesinin ve Dosya menüsündeki Gönder komutunun klavye kısayolunu değiştirme.

  • Formlarını gönderdiklerinde kullanıcılarınıza görüntülenecek özel iletiler oluşturma.

  • Form gönderildikten sonra, formun açık kalmasını, formun kapanmasını veya başka boş bir form açılmasını belirtme.

Sayfanın Başı

1. Adım: Veri gönderme bağlantılarını ekleme

Form şablonunu, kullanıcıların tamamlanan formlarını birden fazla yere göndermelerine olanak sağlayacak şekilde yapılandırmak için, gerekli veri gönderme bağlantılarını form şablonuna ekleyebilirsiniz. Aşağıdaki konumlara veri bağlantıları ekleyebilirsiniz:

  • Bir Web hizmeti

  • Microsoft Windows SharePoint Services çalıştıran bir sunucudaki belge kitaplığı

  • Bir e-posta iletisi

    Not : Kullanıcıların form verilerini e-posta iletisi içinde gönderebilmeleri için, bilgisayarlarında Microsoft Office Outlook yüklü olmalıdır.

Aşağıdaki yordamlarda, bu konumlara nasıl veri gönderme bağlantıları ekleneceği açıklanmaktadır.

Web Hizmetine veri gönderen veri bağlantısı ekleme

  1. Araçlar menüsünde Veri Bağlantıları'nı tıklatın.

  2. Veri Bağlantıları iletişim kutusunda Ekle'yi tıklatın.

  3. Veri Bağlantı Sihirbazı'nda sırasıyla Yeni bağlantı oluştur, Veri Gönder ve İleri'yi tıklatın.

  4. Sihirbazın bir sonraki sayfasında, Web hizmetine'yi ve ardından İleri'yi tıklatın.

  5. Sihirbazın bir sonraki sayfasında, kullanıcılarınızın formlarını gönderecekleri Web hizmetinin konumunu yazıp İleri'yi tıklatın.

    Web hizmetini bir Universal Description, Discovery, and Integration (UDDI) sunucusunda aramak isterseniz, UDDI'da Ara'yı tıklatın, arama yapmak istediğiniz UDDI sunucusunu girin, sağlayıcıya göre veya sağlanan hizmetlere göre arama yapmak istediğini belirtin, aranacak bir anahtar sözcük girin ve Ara'yı tıklatın. Anahtar sözcüğünüze uyan Web hizmetleri Arama sonucu listesinde görüntülenir.

  6. Sihirbazın sonraki sayfasında, İşlem seçin listesinde, form verilerini alacak olan Web hizmeti işlemini tıklatın ve İleri'yi tıklatın.

  7. Sihirbazın sonraki sayfasında, aşağıdakilerden birini yapın:

    Alan veya grup içindeki verileri gönderin

    1. Parametreler listesinde, formdan verileri alacak olan Web hizmeti parametresini tıklatın.

    2. Parametre seçenekleri'nde, Alan veya grup'u tıklatın.

    3. düğme görüntüsü Değiştir' i tıklatın.

    4. Alan veya grup seç iletişim kutusunda, verilerini göndermek istediğiniz alan veya grubu tıklatın ve ardından Tamam'ı tıklatın.

    5. Ekle kutusunda, alanın veya grubun yalnızca içeriğini ve varsa alt öğelerini göndermek için Yalnızca metin ve alt öğeler'ı tıklatın. Hem içeriği, hem de seçili alanı veya grubu göndermek için ise XML alt ağacı (seçili öğeyi de içerir) seçeneğini tıklatın.

    Formdaki verilerin tümünü Gönder

    1. Formun tamamı (İşleme yönergelerini içeren XML belgesi)'ni tıklatın.

    Verileri dize olarak gönder

    1. Verileri dize olarak gönder onay kutusunu seçin.

      Bu onay kutusunu genellikle dijital olarak imzalanmış verileri göndermek için kullanırsınız. Çoğu durumda, bu onay kutusu boş bırakılır.

  8. İleri'yi tıklatın.

  9. Sihirbazın sonraki sayfasında, Bu veri bağlantısı için ad girin kutusuna söz konusu veri gönderme bağlantısı için açıklayıcı bir ad yazın.

  10. Özet bölümünde bilgilerin doğruluğunu onaylayın ve Son'a tıklayın.

Belge kitaplığına veri gönderen veri bağlantısı ekleme

  1. Araçlar menüsünde Veri Bağlantıları'nı tıklatın.

  2. Veri Bağlantıları iletişim kutusunda Ekle'yi tıklatın.

  3. Veri Bağlantı Sihirbazı'nda sırasıyla Yeni bağlantı oluştur, Veri Gönder ve İleri'yi tıklatın.

  4. Sihirbazın bir sonraki sayfasında, SharePoint sitesindeki belge kitaplığına seçeneğini tıklatın, ardından İleri'yi tıklatın.

  5. Sihirbazın sonraki sayfasında, Belge Kitaplığı kutusuna, SharePoint belge kitaplığının konumunu yazın.

  6. Dosya adı kutusuna, belge kitaplığında formu tanımak için kullanılacak adı yazın. Her form adının benzersiz olması için bir formül de kullanabilirsiniz.

    Nasıl mı?

    1. Formül Ekle düğme resmi öğesine tıklayın.

    2. Formül Ekle iletişim kutusunda, aşağıdakilerden birini yapın:

      • Formülde alan kullanmak için Alan veya Grup Ekle'yi tıklatın ve Alan veya Grup Seç iletişim kutusunda, kullanmak istediğiniz alanı tıklatın ve Tamam'ı tıklatın.

      • Formülde işlev kullanmak için İşlev Ekle'yi tıklatın ve İşlev Ekle iletişim kutusunda, kullanmak istediğiniz işlevi seçip Tamam'ı tıklatın.

        İşlev için parametreler gerekiyorsa, İşlev Ekle iletişim kutusunda işlevi seçin, Tamam'ı tıklatın ve Formül Ekle iletişim kutusundaki Formül kutusunda, eklemiş olduğunuz işlevi çift tıklatın ve bir alan veya grubu tıklatın. İşlevlere ilgili daha fazla bilgi sağlayan bağlantıları Ayrıca Bkz: bölümünde bulabilirsiniz.

      • Formüle değer veya matematiksel işleç eklemek için, Formül kutusuna matematik işleminin değerini veya simgesini girin.

    İşlem

    Simge

    Toplama

    +

    Çıkarma

    -

    Çarpma

    *

    Bölme

    /

    • Not : Formülünüzde bölme (/) işleci varsa, bölme işlecinin önünde ve arkasında bir boşluk olmasına dikkat edin. Bölme işlecinin önünde ve arkasında boşluk olmazsa, InfoPath "/" simgesini bölme işleci yerine, XPath konum adımlarında kullanılan ayırıcı olarak yorumlayabilir.

    • Formül sözdiziminin doğru olup olmadığını denetlemek için, Formül Ekle iletişim kutusunda Formülü Doğrula'yı tıklatın.

      Formüllerle ilgili daha fazla bilgi sağlayan bağlantıları Ayrıca Bkz: bölümünde bulabilirsiniz.

  7. Belge kitaplığında aynı adla varolan formların üzerine yazmak için, Dosya varsa, üzerine yazmaya izin ver onay kutusunu seçin.

  8. İleri'yi tıklatın.

  9. Sihirbazın sonraki sayfasında, Bu veri bağlantısı için ad girin kutusuna söz konusu veri gönderme bağlantısı için açıklayıcı bir ad yazın.

  10. Özet bölümünde bilgilerin doğruluğunu onaylayın ve Son'a tıklayın.

E-posta iletisi içinde veri gönderen veri bağlantısı ekleme

  1. Araçlar menüsünde Veri Bağlantıları'nı tıklatın.

  2. Veri Bağlantıları iletişim kutusunda Ekle'yi tıklatın.

  3. Veri Bağlantı Sihirbazı'nda sırasıyla Yeni bağlantı oluştur, Veri Gönder ve İleri'yi tıklatın.

  4. Sihirbazın sonraki sayfasında, E-posta iletisi olarak öğesini, ardından İleri'yi tıklatın.

  5. Sihirbazın sonraki sayfasında, iletinin alıcılarının e-posta adreslerini, iletide görünmesini istediğiniz konuyu ve varsa, istediğiniz giriş metinlerini ilgili kutulara yazıp İleri'yi tıklatın. Giriş kutusu dışında her kutuda formül kullanabilirsiniz.

    Nasıl mı?

    1. Formül Ekle düğme resmi öğesine tıklayın.

    2. Formül Ekle iletişim kutusunda, aşağıdakilerden birini yapın:

      • Formülde alan kullanmak için Alan veya Grup Ekle'yi tıklatın ve Alan veya Grup Seç iletişim kutusunda, kullanmak istediğiniz alanı tıklatın ve Tamam'ı tıklatın.

      • Formülde işlev kullanmak için İşlev Ekle'yi tıklatın ve İşlev Ekle iletişim kutusunda, kullanmak istediğiniz işlevi seçip Tamam'ı tıklatın.

        İşlev için parametreler gerekiyorsa, İşlev Ekle iletişim kutusunda işlevi seçin, Tamam'ı tıklatın ve Formül Ekle iletişim kutusundaki Formül kutusunda, eklemiş olduğunuz işlevi çift tıklatın ve bir alan veya grubu tıklatın. İşlevlere ilgili daha fazla bilgi sağlayan bağlantıları Ayrıca Bkz: bölümünde bulabilirsiniz.

      • Formüle değer veya matematiksel işleç eklemek için, Formül kutusuna matematik işleminin değerini veya simgesini girin.

    İşlem

    Simge

    Toplama

    +

    Çıkarma

    -

    Çarpma

    *

    Bölme

    /

    • Not : Formülünüzde bölme (/) işleci varsa, bölme işlecinin önünde ve arkasında bir boşluk olmasına dikkat edin. Bölme işlecinin önünde ve arkasında boşluk olmazsa, InfoPath "/" simgesini bölme işleci yerine, XPath konum adımlarında kullanılan ayırıcı olarak yorumlayabilir.

    • Formül sözdiziminin doğru olup olmadığını denetlemek için, Formül Ekle iletişim kutusunda Formülü Doğrula'yı tıklatın.

      Formüllerle ilgili daha fazla bilgi sağlayan bağlantıları Ayrıca Bkz: bölümünde bulabilirsiniz.

  6. Sihirbazın sonraki sayfasında, aşağıdakilerden birini yapın:

    1. Formu e-posta iletisinin gövde metninde görüntülemek için, Formun yalnızca etkin görünümünü gönder ve ek gönderme'yi tıklatın.

    2. Form verilerini e-posta iletisinin eki olarak göndermek için form verileri ek olarak gönder' i tıklatın, kullanıcıların formu açabilmesi için form şablonunu Ekle onay kutusunu seçin ve sonra Ek ad kutusuna form için bir ad yazın. Ayrıca bir alan belirtin veya her form adının benzersiz olmasını sağlamak için formül kullanma. Form şablonunun otomatik olarak güvenlik düzeyini belirlemek için yapılandırılmış veya kısıtlı veya tam güven güvenlik düzeyini yapılandırılırsa bu seçenek yalnızca kullanılabilir olur.

      Nasıl mı?

      1. Formül Ekle düğme resmi öğesine tıklayın.

      2. Formül Ekle iletişim kutusunda, aşağıdakilerden birini yapın:

        • Formülde alan kullanmak için Alan veya Grup Ekle'yi tıklatın ve Alan veya Grup Seç iletişim kutusunda, kullanmak istediğiniz alanı tıklatın ve Tamam'ı tıklatın.

        • Formülde işlev kullanmak için İşlev Ekle'yi tıklatın ve İşlev Ekle iletişim kutusunda, kullanmak istediğiniz işlevi seçip Tamam'ı tıklatın.

          İşlev için parametreler gerekiyorsa, İşlev Ekle iletişim kutusunda işlevi seçin, Tamam'ı tıklatın ve Formül Ekle iletişim kutusundaki Formül kutusunda, eklemiş olduğunuz işlevi çift tıklatın ve bir alan veya grubu tıklatın. İşlevlere ilgili daha fazla bilgi sağlayan bağlantıları Ayrıca Bkz: bölümünde bulabilirsiniz.

        • Formüle değer veya matematiksel işleç eklemek için, Formül kutusuna matematik işleminin değerini veya simgesini girin.

      İşlem

      Simge

      Toplama

      +

      Çıkarma

      -

      Çarpma

      *

      Bölme

      /

      • Not : Formülünüzde bölme (/) işleci varsa, bölme işlecinin önünde ve arkasında bir boşluk olmasına dikkat edin. Bölme işlecinin önünde ve arkasında boşluk olmazsa, InfoPath "/" simgesini bölme işleci yerine, XPath konum adımlarında kullanılan ayırıcı olarak yorumlayabilir.

      • Formül sözdiziminin doğru olup olmadığını denetlemek için, Formül Ekle iletişim kutusunda Formülü Doğrula'yı tıklatın.

        Formüllerle ilgili daha fazla bilgi sağlayan bağlantıları Ayrıca Bkz: bölümünde bulabilirsiniz.

      Ek olarak gönderilen form verilerini alacak olan olan e-posta alıcılarının eki açabilmesi için bilgisayarında InfoPath yüklü olması gerekir.

  7. İleri'yi tıklatın.

  8. Sihirbazın sonraki sayfasında, Bu veri bağlantısı için ad girin kutusuna söz konusu veri gönderme bağlantısı için açıklayıcı bir ad yazın.

  9. Özet bölümünde bilgilerin doğruluğunu onaylayın ve Son'a tıklayın.

Sayfanın Başı

2. Adım: Form şablonunu göndermeye izin verecek şekilde yapılandırma

Gerekli ikincil veri bağlantılarını form şablonunuza ekledikten sonra, form şablonunu, kullanıcıların form verilerini göndermesine izin verecek şekilde yapılandırırsınız. Bunu yaptığınızda, kullanıcılar formu doldururken, InfoPath, Dosya menüsüne bir Gönder komutu ve Standart araç çubuğuna bir Gönder düğmesi ekler. Bundan sonra, kullanıcı Gönder düğmesini tıklattığında gerçekleştirilecek eylemi yapılandırabilirsiniz. Bu durumda, kullanıcı Dosya menüsündeki Gönder komutunu veya Standart araç çubuğundaki Gönder düğmesini tıklattığı zaman form verilerini veri gönderme bağlantılarının her birine gönderecek bir kural eklersiniz.

Aynı iletişim kutusunda, gönderme seçeneklerini yapılandırabilirsiniz.

  1. Araçlar menüsünde Gönderme Seçenekleri'ne tıklayın.

  2. Gönderme Seçenekleri iletişim kutusunda Kullanıcıların bu formu göndermesine izin ver onay kutusunu seçin.

    Bu onay kutusunu seçtiğinizde, InfoPath, kullanıcılar formu doldururken Standart araç çubuğuna Gönder düğmesini ve Dosya menüsüne de Gönder komutunu ekler.

  3. Kuralları kullanarak özel eylem gerçekleştir'i tıklatın ve sonra Kurallar'ı tıklatın.

  4. Form Gönderme Kuralları iletişim kutusunda, Ekle'yi tıklatın.

  5. Eylem Ekle'yi tıklatın.

  6. Eylem kutusunda, Veri bağlantısı kullanarak gönder'i tıklatın, Veri bağlantısı listesinde, bu gönderme eylemi için kullanmak istediğiniz veri bağlantısını tıklatın ve Tamam'ı tıklatın.

  7. Form şablonunuza eklediğiniz veri gönderme bağlantılarının her biri 5 ve 6 numaralı adımları yineleyin.

  8. Form şablonunuzdaki tüm veri gönderme bağlantıları için koşulları ekledikten sonra, iki kez Tamam'ı tıklatın.

    1. Kullanıcılar formu doldururken Standart araç çubuğunda gösterilen Gönder düğmesinin ve Dosya menüsünde yer alan Gönder komutunu adını değiştirmek için, yeni adı Gönderme Seçenekleri iletişim kutusundaki Resim Yazısı kutusuna yazın.

      Bu düğme ve komut için klavye kısayolu atamak istiyorsanız, yazın ve işareti (&) klavye kısayolu olarak kullanmak istediğiniz karakteri önce. Örneğin, ALT + B Gönder düğmesi ve komutu klavye kısayolu atamak için & Gönderyazın.

  9. Formunuzu doldurduklarında kullanıcıların Gönder komutunu veya Standart araç çubuğundaki Gönder düğmesini kullanmalarını engellemek için, Gönder menü öğesini ve Gönder araç çubuğu düğmesini göster onay kutusunu temizleyin.

    1. Varsayılan olarak, kullanıcılar formu gönderdikten sonra InfoPath formu açık tutar ve formun başarılı bir şekilde gönderilip gönderilmediğini belirten bir ileti görüntüler. Bu varsayılan davranışı değiştirmek için Gelişmiş'i tıklatın ve aşağıdakilerden birini yapın:

      • Kullanıcı tamamlanmış bir formu gönderdikten sonra formu kapatmak veya yeni boş bir form oluşturmak için, Gönderdikten sonra listesinde istediğiniz seçeneği tıklatın.

      • Formun başarılı bir şekilde gönderilip gönderilmediğini belirtecek özel bir ileti oluşturmak için Özel iletiler kullan onay kutusunu seçin, sonra Başarılı olduğunda ve Hatalı olduğunda kutularına iletilerinizi yazın.

        Formu gönderemeyen kullanıcılara ne yapacaklarını bildirmek için Hatalı olduğunda kutusuna yazacağınız iletiyi kullanın. Örneğin, kullanıcılara formlarını kaydetmelerini ve diğer yönergeler için başka birisine danışmalarını önerebilirsiniz.

      • Kullanıcılar formu gönderdikten sonra bir ileti görüntülenmesini istemiyorsanız, Başarı ve hata iletileri göster onay kutusunu temizleyin.

Sayfanın Başı

Not : Makine Çevirisi Yasal Uyarısı: Bu makale, insan müdahalesi olmadan bir bilgisayar sistemi tarafından çevrilmiştir. Microsoft bu makine çevirilerini İngilizce bilmeyen kullanıcıların Microsoft ürünleri, hizmetleri ve teknolojileriyle ilgili içeriklerden yararlanmasına yardımcı olmak için sunar. Bu makale makine çevirisi olduğundan sözcük, cümle dizilimi ve gramer hataları içerebilir.

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×