Form verilerini belge kitaplığına gönderme

Önemli : Bu makale makine çevisidir. Bkz. yasal uyarı. Bu makalenin İngilizce sürümüne buradan ulaşabilirsiniz.

Tüm kullanıcılarınızın formlarını, Microsoft Windows SharePoint Services çalıştıran bir sunucuda bulunan bir belge kitaplığında düzenli şekilde saklayabilirsiniz. Bu belge kitaplığında, kullanıcılar form şablonunuzu temel alan formları doldurabilir, tamamlanmış formlardaki verileri Microsoft Office Excel 2003 veya Microsoft Office Excel 2007 uygulamasına verebilir ve birkaç formun verilerini tek bir formda birleştirebilirler.

Kullanıcıların form şablonunuzu temel alan formları bir belge kitaplığına göndermelerine olanak sağlamak için, form şablonunuza, veri göndermeye yarayan ikincil bir veri bağlantısı ekleyebilirsiniz. Veri gönderme bağlantısını ekledikten sonra, form şablonunu, kullanıcılarınızın form verilerini belge kitaplığına göndermelerine izin verecek şekilde yapılandırabilirsiniz. Bunu yaptığınızda, Microsoft Office InfoPath formdaki Standart araç çubuğuna Gönder düğmesi ve Dosya menüsüne de Gönder komutu ekler. Ayrıca form şablonunuz için gönderme seçeneklerini de aşağıdaki yollardan özelleştirebilirsiniz:

  • Standart araç çubuğundaki Gönder düğmesinin ve Dosya menüsündeki Gönder komutunun üzerinde görünen metni değiştirme.

  • Standart araç çubuğundaki Gönder düğmesinin ve Dosya menüsündeki Gönder komutunun klavye kısayolunu değiştirme.

  • Formlarını gönderdiklerinde kullanıcılarınıza görüntülenecek özel iletiler oluşturma.

  • Form gönderildikten sonra, formun açık kalmasını, formun kapanmasını veya başka boş bir form açılmasını belirtme.

Veri gönderme bağlantısı ekleme

  1. Araçlar menüsünde Gönderme Seçenekleri'ne tıklayın.

  2. Gönderme Seçenekleri iletişim kutusunda Kullanıcıların bu formu göndermesine izin ver onay kutusunu seçin.

  3. Form verilerini tek bir hedefe gönder'i tıklatın ve sonra listeden SharePoint belge kitaplığı'nı tıklatın.

  4. Ekle'yi tıklatın.

  5. Veri Bağlantı Sihirbazı, Belge Kitaplığı kutusuna, SharePoint belge kitaplığının konumunu yazın.

  6. Dosya adı kutusuna, belge kitaplığında formu tanımak için kullanılacak adı yazın.

    İpucu : Her form adının benzersiz olması için bir formül de kullanabilirsiniz.

    Nasıl?

    1. Formül Ekle düğme resmi öğesine tıklayın.

    2. Formül Ekle iletişim kutusunda, aşağıdakilerden birini yapın:

      • Formülde alan kullanmak için Alan veya Grup Ekle'yi tıklatın ve Alan veya Grup Seç iletişim kutusunda, kullanmak istediğiniz alanı tıklatın ve Tamam'ı tıklatın.

      • Formülde işlev kullanmak için İşlev Ekle'yi tıklatın ve İşlev Ekle iletişim kutusunda, kullanmak istediğiniz işlevi seçip Tamam'ı tıklatın.

        İpucu : İşlev için parametreler gerekiyorsa, İşlev Ekle iletişim kutusunda işlevi seçin, Tamam'ı tıklatın ve Formül Ekle iletişim kutusundaki Formül kutusunda, eklemiş olduğunuz işlevi çift tıklatın ve bir alan veya grubu tıklatın. İşlevlere ilgili daha fazla bilgi sağlayan bağlantıları Ayrıca Bkz: bölümünde bulabilirsiniz.

      • Formüle değer veya matematiksel işleç eklemek için, Formül kutusuna matematik işleminin değerini veya simgesini girin.

    İşlem

    Simge

    Toplama

    +

    Çıkarma

    -

    Çarpma

    *

    Bölme

    /

    • Not : Formülünüzde bölme (/) işleci varsa, bölme işlecinin önünde ve arkasında bir boşluk olmasına dikkat edin. Bölme işlecinin önünde ve arkasında boşluk olmazsa, InfoPath "/" simgesini bölme işleci yerine, XPath konum adımlarında kullanılan ayırıcı olarak yorumlayabilir.

    • Formülün doğru söz diziminde olup olmadığını denetlemek için, Formül Ekle iletişim kutusunda Formülü Doğrula seçeneğini tıklatın.

      Formüllerle ilgili daha fazla bilgi sağlayan bağlantıları Ayrıca Bkz: bölümünde bulabilirsiniz.

  7. Belge kitaplığında aynı adla varolan formların üzerine yazmak için, Dosya varsa, üzerine yazmaya izin ver onay kutusunu seçin.

  8. İleri'yi tıklatın.

  9. Sihirbazın sonraki sayfasında, Bu veri bağlantısı için ad girin kutusuna söz konusu veri gönderme bağlantısı için açıklayıcı bir ad yazın.

  10. Özet bölümünde bilgilerin doğruluğunu onaylayın ve Son'a tıklayın.

    1. Kullanıcılar formu doldururken Standart araç çubuğunda gösterilen Gönder düğmesinin ve Dosya menüsünde yer alan Gönder komutunu adını değiştirmek için, yeni adı Gönderme Seçenekleri iletişim kutusundaki Resim Yazısı kutusuna yazın.

      İpucu : Bu düğme ve komut için klavye kısayolu atamak istiyorsanız, yazın ve işareti (&) klavye kısayolu olarak kullanmak istediğiniz karakteri önce. Örneğin, ALT + B Gönder düğmesi ve komutu klavye kısayolu atamak için & Gönderyazın.

  11. Formunuzu dolduranların Gönder komutunu veya Standart araç çubuğundaki Gönder düğmesini kullanmasını istemiyorsanız, Gönder menü öğesini ve Gönder araç çubuğu düğmesini göster onay kutusunu temizleyin.

    1. Varsayılan olarak, kullanıcılar formu gönderdikten sonra InfoPath formu açık tutar ve formun başarılı bir şekilde gönderilip gönderilmediğini belirten bir ileti görüntüler. Bu varsayılan davranışı değiştirmek için Gelişmiş'i tıklatın ve aşağıdakilerden birini yapın:

      1. Kullanıcı tamamlanmış bir formu gönderdikten sonra formu kapatmak veya yeni boş bir form oluşturmak için, Gönderdikten sonra listesinde istediğiniz seçeneği tıklatın.

      2. Formun başarılı bir şekilde gönderilip gönderilmediğini belirtecek özel bir ileti oluşturmak için Özel iletiler kullan onay kutusunu seçin, sonra Başarılı olduğunda ve Hatalı olduğunda kutularına iletilerinizi yazın.

        İpucu : Formu gönderemeyen kullanıcılara ne yapacaklarını bildirmek için Hatalı olduğunda kutusuna yazacağınız iletiyi kullanın. Örneğin, kullanıcılara formlarını kaydetmelerini ve diğer yönergeler için başka birisine danışmalarını önerebilirsiniz.

      3. Kullanıcılar formu gönderdikten sonra bir ileti görüntülenmesini istemiyorsanız, Başarı ve hata iletileri göster onay kutusunu temizleyin.

Sayfanın Başı

Not : Makine Çevirisi Yasal Uyarısı: Bu makale, insan müdahalesi olmadan bir bilgisayar sistemi tarafından çevrilmiştir. Microsoft bu makine çevirilerini İngilizce bilmeyen kullanıcıların Microsoft ürünleri, hizmetleri ve teknolojileriyle ilgili içeriklerden yararlanmasına yardımcı olmak için sunar. Bu makale makine çevirisi olduğundan sözcük, cümle dizilimi ve gramer hataları içerebilir.

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×