Formülde iç içe geçen işlevler kullanma

İşlev kullanılan bir formülde bağımsız değişkenlerden biri olarak işlev kullanılması içe içe kullanım olarak bilinir ve biz de bundan bahsederken iç içe geçen/kullanılan işlev diyeceğiz. Örneğin, EĞER işlevinin bağımsız değişkenlerinde ORTALAMA ve TOPLA işlevlerinin iç içe kullanıldığı aşağıdaki formül, bir grup sayının (G2:G5) toplamını ancak başka bir grup sayının (F2:F5) ortalamasının 50'den büyük olması koşuluyla almaktadır. Aksi takdirde 0 sonucunu verir.

iç içe geçen işlevler

1. ORTALAMA ve TOPLA işlevleri, EĞER işlevinin içinde iç içe geçirilir.

Bir formülde işlevleri en çok 64 düzeyde iç içe yerleştirebilirsiniz.

  1. Formülü girmek istediğiniz hücreyi tıklatın.

  2. Formüle işlevle başlamak için formül çubuğunda Resim yazısı 4  İşlev Ekle  Düğme resmi simgesini tıklatın.

    Excel, sizin için eşittir işareti (=) ekler.

  3. Veya kategori seçin kutusunda Tümü'nü seçin.

    İşlev kategorilerini iyi biliyorsanız bir kategori de seçebilirsiniz.

    Hangi işlevin kullanılacağından emin değilseniz, İşlev ara kutusuna yapmak istediğiniz işlemi açıklayan bir soru girebilirsiniz (örneğin, "sayıları toplama" girildiğinde TOPLAM işlevi getirilir).

    İpuçları : 

  4. Bağımsız değişken olarak başka bir işlev girmek için, istediğiniz bağımsız değişken kutusuna işlevi girin.

    İşlev Bağımsız Değişkenleri iletişim kutusunda görüntülenen formülün parçaları, bir önceki adımda seçtiğiniz işlevi yansıtır.

    EĞER'i tıklattıysanız, İşlev bağımsız değişkenleri iletişim kutusunda EĞER işlevinin bağımsız değişkenleri görüntülenir. Bir başka işlevi iç içe kullanmak için, bu işlevi bağımsız değişken kutusuna girebilirsiniz. Örneğin, EĞER işlevinin Eğer_doğruysa_değer kutusuna TOPLA(G2:G5) girebilirsiniz.

  5. Formülünüzü tamamlamak için gerekli başka bağımsız değişkenler varsa bunları da ekleyin.

    Hücre başvuruları yazmak yerine, başvuruda bulunmak istediğiniz hücreleri seçebilirsiniz. İletişim kutusunu küçültmek için düğme görüntüsü düğmesini tıklatın, başvuruda bulunmak istediğiniz hücreleri seçin ve ardından Düğme resmi düğmesini tıklatarak iletişim kutusunu yeniden genişletin.

    İpucu : İşlev ve bağımsız değişkenleri hakkında daha fazla bilgi için Bu işlev hakkında yardım ifadesini tıklatın.

  6. Formüle ilişkin bağımsız değişkenleri doldurduktan sonra Tamam'ı tıklatın.

Örnekler

Aşağıdaki örnekte, EĞER işlevleri kullanılarak sayısal test puanına harf notu atama gösterilmiştir.

Aşağıdaki tabloda yer alan örnek verileri kopyalayın ve yeni bir Excel çalışma sayfasının A1 hücresine yapıştırın. Formüllerin sonuçları göstermesi için, bunları seçip F2 tuşuna basın ve sonra Enter tuşuna basın. Gerekirse, tüm verileri görmek için sütun genişliğini ayarlayabilirsiniz.

Puan

45

90

78

Formül

Açıklama

Sonuç

'=EĞER(A2>89;"A";EĞER(A2>79;"B";EĞER(A2>69;"C";EĞER(A2>59;"D";"F"))))

A2 hücresindeki puana bir harf notu atamak için kademeli EĞER koşulları kullanır.

=EĞER(A2>89,"A",EĞER(A2>79,"B",EĞER(A2>69,"C",EĞER(A2>59,"D","F"))))

'=EĞER(A3>89,"A",EĞER(A3>79,"B", EĞER(A3>69,"C",EĞER(A3>59,"D","F"))))

A3 hücresindeki puana bir harf notu atamak için kademeli EĞER koşulları kullanır.

=EĞER(A3>89,"A",EĞER(A3>79,"B",EĞER(A3>69,"C",EĞER(A3>59,"D","F"))))

'=EĞER(A4>89,"A",EĞER(A4>79,"B", EĞER(A4>69,"C",EĞER(A4>59,"D","F"))))

A4 hücresindeki puana bir harf notu atamak için kademeli EĞER koşulları kullanır.

=EĞER(A4>89,"A",EĞER(A4>79,"B",EĞER(A4>69,"C",EĞER(A4>59,"D","F"))))

Sayfanın Başı

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×