Excel'de bir değerin hangi sıklıkta yinelendiğini sayma

Önemli : Bu makale makine çevisidir. Bkz. yasal uyarı. Bu makalenin İngilizce sürümüne buradan ulaşabilirsiniz.

Belirli bir metin veya sayı değerinin belirli bir hücre aralığında kaç kez yinelendiğini bulmak istediğinizi varsayalım. Örneğin:

  • A2:D20 gibi bir aralıkta 5, 6, 7, 6 sayı değerleri varsa, 6 iki kez yineleniyor demektir.

  • Sütunda "Biber", "Ilgaz", "Ilgaz", "Ilgaz" adları varsa, "Ilgaz" üç kez yineleniyordur.

Bir değerin hangi sıklıkta yinelendiğini saymanın birkaç yöntemi bulunmaktadır.

Ne yapmak istiyorsunuz?

Bir işlev kullanarak tek bir değerin kaç kez yinelendiğini sayma

ÇOKEĞERSAY işlevini kullanarak birden çok ölçüte göre sayma

BAĞ_DEĞ_SAY ve EĞER işlevlerini birlikte kullanarak ölçütlere göre sayma

TOPLA ve EĞER işlevlerini birlikte kullanarak birden çok metin veya sayı değerinin kaç kez yinelendiğini sayma

PivotTable raporu kullanarak birden çok değerin kaç kez yinelendiğini sayma

Bir işlev kullanarak tek bir değerin kaç kez yinelendiğini sayma

Bu görevi gerçekleştirmek için EĞERSAY işlevini kullanın.

Örnek

Aşağıdaki tabloda yer alan örnek verileri kopyalayın ve yeni bir Excel çalışma sayfasının A1 hücresine yapıştırın. Formüllerin sonuçları göstermesi için, bunları seçip F2 tuşuna basın ve sonra Enter tuşuna basın. Tüm verileri görmek için sütun genişliğini ayarlayın.

Satış Elemanı

Fatura

Biber

15.000

Biber

9.000

Göktepe

8.000

Göktepe

20.000

Biber

5.000

Koçak

22.500

Formül

Açıklama

Sonuç

=EĞERSAY(A2:A7,"Biber")

Biber'in girişlerinin sayısı (3)

=EĞERSAY(A2:A7,"Biber")

'=EĞERSAY(A2:A7,A4)

Göktepe'nin girişlerinin sayısı (2)

=EĞERSAY(A2:A7,A4)

'=EĞERSAY(B2:B7,"< 20000")

Değeri 20.000'in altında olan fatura değerlerinin sayısı (4)

=EĞERSAY(B2:B17,"< 20000")

'=EĞERSAY(B2:B7,">="&B5)

Değeri 20.000'e eşit veya bundan büyük olan fatura değerlerinin sayısı (2)

=EĞERSAY(B2:B7,">="&B5)

Bu işlevin kullanımı hakkında daha fazla bilgi edinmek için EĞERSAY işlevi konusuna bakın.

Sayfanın Başı

ÇOKEĞERSAY işlevini kullanarak birden çok ölçüte göre sayma

Excel 2007'de kullanılmaya başlanan ÇOKEĞERSAY işlevi, EĞERSAY işlevine benzemekle birlikte bu işlevden önemli bir farkı vardır: ÇOKEĞERSAY işlevi, birden fazla aralıkta bulunan hücrelere ölçüt uygulamanıza izin verir ve tüm ölçütlerin kaç kez karşılandığını sayar. ÇOKEĞERSAY işleviyle en çok 127 aralık/ölçüt çifti kullanabilirsiniz. İşlevin söz dizimi şuna benzer:

ÇOKEĞERSAY(ölçüt_aralığı1; ölçüt1; [ölçüt_aralığı2; ölçüt2];…)

Örnek

Çalışan Kimliği

Bölge No

Bölüm

20552

2

Satış

21268

2

Finans

23949

1

Yönetim

24522

4

Yönetim

28010

3

BT

29546

4

Satış

31634

3

BT

32131

1

BT

35106

4

Finans

40499

1

İK

42051

1

Satış

43068

2

İK

45382

2

Finans

47971

1

BT

Kaç tane çalışan Bölge 2'de ve Finans bölümünde yer alıyor?

'=ÇOKEĞERSAY(B2:B15,"2",C2:C15,"Finans")

=ÇOKEĞERSAY(B2:B15,"2",C2:C15,"Finans")

İlk ölçüt aralığı bölge numaraları, ikinci ölçüt aralığı ise bölüm adıdır. İlk ölçüt aralığına uygulanan ölçüt "2,", ikinci ölçüt aralığına uygulanan ölçüt ise "Finans" ölçütüdür. ÇOKEĞERSAY iki kriterin birden sağlanıp sağlanmadığını denetler.

Bu işlevi kullanarak birden çok aralıkla ve ölçütle sayma hakkında daha fazla bilgi edinmek için ÇOKEĞERSAY işlevi konusuna bakın.

Sayfanın Başı

BAĞ_DEĞ_SAY ve EĞER işlevlerini birlikte kullanarak ölçütlere göre sayma

Diyelim ki, belirli bir bölgede kaç satıcının belirli bir malı sattığını belirlemeniz gerekiyor veya bir satıcının belirli bir değerin üzerinde ne kadar satış yaptığını bilmek istiyorsunuz. EĞER ve BAĞ_DEĞ_SAY işlevlerini kullanabilirsiniz; yani, önce bir koşulu sınamak için EĞER işlevini kullanır ve sonra EĞER işlevinin sonucunun True olması koşuluyla hücreleri saymak için BAĞ_DEĞ_SAY işlevini kullanırsınız.

Örnekler

Bölge

Satış Elemanı

Tür

Satış

Güney

Biber

İçecekler

3571

Batı

Oktay

Süt ürünleri

3338

Doğu

Göktepe

İçecekler

5122

Kuzey

Göktepe

Süt ürünleri

6239

Güney

Koçak

Ürün

8677

Güney

Oktay

Et ürünleri

450

Güney

Oktay

Et ürünleri

7673

Doğu

Göktepe

Ürün

664

Kuzey

Oktay

Ürün

1500

Güney

Koçak

Et ürünleri

6596

Formül

Açıklama

Sonuç

=SAY(EĞER((A2:A11="Güney")*(C2:C11="Et ürünleri"),D2:D11))

Güney bölgesinde et ürünleri satışı sayısı (3)

=SAY(EĞER((A2:A11="Güney")*(C2:C11="Et ürünleri"),D2:D11))

=SAY(EĞER((B2:B11="Göktepe")*(D2:D11>=1000),D2:D11))

Göktepe'nin yaptığı 1000 TL'nin üzerindeki satışların sayısı (2)

=SAY(EĞER((B2:B11="Göktepe")*(D2:D11>=1000),D2:D11))

Not : 

  • Bu örnekteki formüller dizi formülleri olarak girilmelidir. Bu çalışma kitabını Excel masaüstü programında açtıysanız ve formülü değiştirmek ya da benzer bir formül oluşturmak istiyorsanız, F2'ye basın ve ardından, formülün istediğiniz sonuçları getirmesini sağlamak için Ctrl+Shift+Enter tuşlarına basın.

  • Bu formüllerin çalışması için, EĞER işlevinin ikinci bağımsız değişkeni bir sayı olmalıdır.

BAĞ_DEĞ_SAY işlevi sayı içeren hücre sayısını ve bağımsız değişkenler listesindeki sayıları sayar. EĞER işlevi belirttiğiniz koşul Doğru olarak değerlendirirse bir değer, aynı koşul Yanlış değerlendirirse de başka bir değer verir.

Bu işlevler hakkında daha fazla bilgi edinmek için BAĞ_DEĞ_SAY işlevi ve EĞER işlevi konularına bakın.

Sayfanın Başı

TOPLA ve EĞER işlevlerini birlikte kullanarak birden çok metin veya sayı değerinin kaç kez yinelendiğini sayma

Aşağıdaki örneklerde EĞER ve TOPLA işlevlerini birlikte kullanıyoruz. Önce EĞER işlevi belirli hücrelerdeki değerleri sınar ve sonra, sınama sonucu Doğru çıkarsa, TOPLA işlevi sınamayı geçen değerleri toplar.

Örnekler

Satış Elemanı

Fatura

Biber

15000

Biber

9000

Göktepe

8000

Göktepe

20000

Biber

5000

Koçak

22500

Formül

Açıklama

Sonuç

=TOPLA(EĞER((A2:A7="Biber")+(A2:A7="Koçak"),1,0))

Biber veya Koçak'ın faturalarının sayısı.

=TOPLA(EĞER((A2:A7="Biber")+(A2:A7="Koçak"),1,0))

=TOPLA(EĞER((B2:B7<9000)+(B2:B7>19000),1,0))

Tutarları daha az 9.000 TL'den veya 19,000 TL'den büyük olan faturaların sayısı.

=TOPLA(EĞER((B2:B7<9000)+(B2:B7>19000),1,0))

=TOPLA(EĞER(A2:A7="Biber",EĞER(B2:B7<9000,1,0)))

Biber'in tutarı 9.000 TL'den az olan faturalarının sayısı.

=TOPLA(EĞER(A2:A7="Biber",EĞER(B2:B7<9000,1,0)))

Not : Bu örnekteki formüller dizi formülleri olarak girilmelidir. Bu çalışma kitabını Excel masaüstü programında açtıysanız ve formülü değiştirmek ya da benzer bir formül oluşturmak istiyorsanız, F2'ye basın ve ardından, formülün istediğiniz sonuçları getirmesini sağlamak için Ctrl+Shift+Enter tuşlarına basın.

Sayfanın Başı

PivotTable raporu kullanarak birden çok değerin kaç kez yinelendiğini sayma

Toplamları görüntülemek ve benzersiz değerlerin yinelenmesini saymak için PivotTable raporu kullanabilirsiniz. PivotTable, büyük miktarda veriyi hızlı şekilde özetleme olanağı sağlayan etkileşimli bir yoldur. PivotTable kullanarak, sonuçlarınıza odaklanmak için veri düzeylerini genişletebilir ve daraltabilir ve ilgi alanlarınıza göre özet verilerden ayrıntılara ulaşabilirsiniz. Ayrıca, kaynak verilerin farklı özetlerini görmek amacıyla satırları sütunlara veya sütunları satırlara taşıyabilirsiniz ("özetleme").

Kaynak veri ve elde edilen PivotTable raporu örneği

1   Burada, çalışma sayfasına ait kaynak veri

2   PivotTable raporundaki Çey3 Golf özeti için kaynak değerleri

3   PivotTable raporunun tamamı

4   Kaynak veride bulunan C2 ve C8'deki kaynak değerlerin özeti

PivotTable raporu oluşturmak için

  1. Veriyi içeren sütunu seçin.
    Sütunun sütun başlığı olduğundan emin olun.

  2. Ekle sekmesinde, Tablolar grubunda PivotTable’a tıklayın.
    PivotTable Oluştur iletişim kutusu görüntülenir.

  3. Tablo veya aralık seçin seçeneğini tıklatın.

  4. Yeni Çalışma Sayfası seçeneğini tıklatıp A1 hücresinden başlayarak, PivotTable raporunu yeni bir çalışma sayfasına yerleştirin.

  5. Tamam'ı tıklatın.
    Gösterilen PivotTable alanı listesi ile belirttiğiniz konuma boş bir PivotTable raporu eklenir.

  6. PivotTable alan listesinin en üstündeki alan bölümünde, alan adını tıklatın ve ardından alanı PivotTable alan listesinin en altında bulunan düzen bölümündeki Satır Etiketleri kutusuna sürükleyin.

  7. PivotTable alan listesinin en üstündeki alan bölümünde, alan adına tıklayın ve ardından alanı PivotTable Alan Listesinin en altında bulunan düzen bölümündeki Değerler kutusuna sürükleyin.

Not : Verileriniz sayı içeriyorsa, PivotTable raporu girişleri saymaz, toplar. Topla özet işlevinden Say özet işlevine geçiş yapmak için, o sütunda bir hücre seçip Etkin Alan grubundaki Çözümle sekmesine tıklayın, Alan Ayarları seçeneğine tıklayın, Özetleme sekmesine tıklayın, Say seçeneğine tıklayın ve sonra Tamam seçeneğine tıklayın.

Sayfanın Başı

Not : Makine Çevirisi Yasal Uyarısı: Bu makale, insan müdahalesi olmadan bir bilgisayar sistemi tarafından çevrilmiştir. Microsoft bu makine çevirilerini İngilizce bilmeyen kullanıcıların Microsoft ürünleri, hizmetleri ve teknolojileriyle ilgili içeriklerden yararlanmasına yardımcı olmak için sunar. Bu makale makine çevirisi olduğundan sözcük, cümle dizilimi ve gramer hataları içerebilir.

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×