ETOPLA işlevi

ETOPLA işlevini, belirttiğiniz ölçüte uyan bir aralıkta yer alan değerlerin toplamını almak için kullanırsınız. Örneğin sayıların bulunduğu bir sütunda yalnızca 5'ten büyük olan değerlerin toplamını hesaplamak istediğinizi varsayalım. Şu formülü kullanabilirsiniz: =ETOPLA(B2:B25,">5")

Tarayıcınız video desteklemiyor. Microsoft Silverlight, Adobe Flash Player veya Internet Explorer 9’u yükleyin.

Bu video, Excel 2013'te sayıları toplama adlı eğitim kursunun bir bölümüdür.

İpuçları : 

  • İsterseniz, ölçütü bir aralığa uygulayıp farklı bir aralıkta bunlara karşılık gelen değerlerin toplamını alabilirsiniz. Örneğin, =ETOPLA(B2:B5, "Can", C2:C5) formülü yalnızca C2:C5 aralığında yer alan ve B2:B5 aralığındaki ilişkili hücrelerin "Can" değerine eşit olduğu değerlerin toplamını alır.

  • Birden çok ölçüt temelinde hücrelerin toplamını almak için bkz. ÇOKETOPLA işlevi.

Söz dizimi

ETOPLA(aralık; ölçüt; [toplam_aralığı])

ETOPLA işlevinin söz diziminde aşağıdaki bağımsız değişkenler bulunur:

  • aralık   Gereklidir. Ölçüte göre değerlendirilmesini istediğiniz hücre aralığı. Aralıklardaki hücrelerde numaralar veya adlar, diziler ya da sayı içeren başvurular bulunmalıdır. Boşluk ve metin değerleri yoksayılır. Seçilen aralık standart Excel biçiminde tarihler içerebilir (aşağıdaki örnekler).

  • ölçüt   Gereklidir. Hangi hücrelerin sayılacağını tanımlayan sayı, ifade, hücre başvurusu, metin ya da hangi hücrelerin toplanacağını tanımlayan bir işlev biçimindeki ölçüt. Örneğin, ölçüt 32, ">32", B5, "32", "elmalar" veya BUGÜN() olarak gösterilebilir.

    Önemli : Tüm metin ölçütleri ve mantıksal ya da matematiksel simge içeren ölçütler çift tırnak (") içine alınmalıdır. Ölçüt sayısal bir değerse, çift tırnak kullanmak gerekmez.

  • toplam_aralığı   İsteğe bağlı. Aralık bağımsız değişkeninde belirtilen hücrelerden farklı hücrelerin toplamını almak istiyorsanız, toplamı alınacak hücreler. Toplam_aralığı bağımsız değişkeni belirtilmezse, Excel aralık bağımsız değişkeninde belirtilen hücreleri toplar (bunlar, ölçütün uygulandığı hücrelerdir).

  • Ölçüt bağımsız değişkeni olarak soru işareti (?) ve yıldız işareti (*) gibi joker karakterler kullanabilirsiniz. Soru işareti tek karakterle eşleşirken yıldız işareti herhangi bir karakter dizisiyle eşleşir. Gerçek bir soru işaretini veya yıldız işaretini bulmak istiyorsanız, karakterden önce bir tilde işareti (~) koyun.

Açıklamalar

  • 255 karakterden uzun dizeleri #DEĞER! dizesiyle eşleştirecek şekilde kullandığınızda ETOPLA işlevi hatalı değerler verir.

  • Toplam_aralık bağımsız değişkeninin aralık bağımsız değişkeniyle aynı boyutta ve şekilde olması gerekmez. Toplanacak gerçek hücreler saptanırken, toplam_aralık içinde en sol üstte yer alan hücre başlangıç hücresi olarak alınır ve aralık bağımsız değişkeninin boyut ve şekline karşılık gelen hücreler eklenir. Örneğin:

Aralık aşağıdaki gibi

Ve toplam_aralığı aşağıdaki gibiyse

Gerçek hücreler aşağıdaki gibi olur

A1:A5

B1:B5

B1:B5

A1:A5

B1:B3

B1:B5

A1:B4

C1:D4

C1:D4

A1:B4

C1:C2

C1:D4

Bununla birlikte, ETOPLA işlevindeki aralık ve toplam_aralığı bağımsız değişkenleri aynı sayıda hücre içermezse, çalışma sayfasının yeniden hesaplanması beklenenden uzun sürebilir.

Örnekler

Örnek 1

Aşağıdaki tabloda yer alan örnek verileri kopyalayın ve yeni bir Excel çalışma sayfasının A1 hücresine yapıştırın. Formüllerin sonuçları göstermesi için, bunları seçip F2 tuşuna basın ve sonra Enter tuşuna basın. Gerekirse, tüm verileri görmek için sütun genişliğini ayarlayabilirsiniz.

Mülk Değeri

Komisyon

Veri

100.000,00 TL

7.000,00 TL

250.000,00 TL

200.000,00 TL

14.000,00 TL

300.000,00 TL

21.000,00 TL

400.000,00 TL

28.000,00 TL

Formül

Açıklama

Sonuç

=ETOPLA(A2:A5,">160000",B2:B5)

160.000'in üzerindeki mülk değerleri için komisyon toplamı.

63.000,00 TL

=ETOPLA(A2:A5,">160000")

160.000'in üzerindeki mülk değerlerinin toplamı.

900.000,00 TL

=ETOPLA(A2:A5,300000,B2:B5)

300.000'e eşit mülk değerleri için komisyon toplamı.

21.000,00 TL

=ETOPLA(A2:A5,">" & C2,B2:B5)

C2 hücresindeki değerden büyük mülk değeri için komisyonların toplamı.

49.000,00 TL

Örnek 2

Aşağıdaki tabloda yer alan örnek verileri kopyalayın ve yeni bir Excel çalışma sayfasının A1 hücresine yapıştırın. Formüllerin sonuçları göstermesi için, bunları seçip F2 tuşuna basın ve sonra Enter tuşuna basın. Gerekirse, tüm verileri görmek için sütun genişliğini ayarlayabilirsiniz.

Kategori

Yiyecek

Satışlar

Sebzeler

Karnabahar

2.300,00 TL

Sebzeler

Kereviz

5.500,00 TL

Meyveler

Portakal

800,00 TL

Tereyağı

400,00 TL

Sebzeler

Havuç

4.200,00 TL

Meyveler

Elma

1.200,00 TL

Formül

Açıklama

Sonuç

=ETOPLA(A2:A7,"Meyveler",C2:C7)

"Meyveler" kategorisindeki tüm besinlerin satışlarının toplamı.

2.000,00 TL

=ETOPLA(A2:A7,"Sebzeler",C2:C7)

"Sebzeler" kategorisindeki tüm besinlerin satışlarının toplamı.

12.000,00 TL

=ETOPLA(B2:B7,"ka*",C2:C7)

"Ka" ile başlayan tüm besinlerin (Karnabahar, Kayısı ve Kavun) satışlarının toplamı.

4.300,00 TL

=ETOPLA(A2:A7,"",C2:C7)

Kategorisi belirtilmemiş olan tüm besinlerin satışlarının toplamı.

400,00 TL

Sayfanın Başı

İşlevlerle ilgili bir sorunuz mu var?

Excel topluluk forumuna soru gönderin

Excel’i geliştirmemize yardımcı olun

Excel'in sonraki sürümünü nasıl geliştirebileceğimiz konusunda önerileriniz var mı? Varsa, lütfen Excel User Voice forumundaki başlıkları gözden geçirin.

Ayrıca Bkz:

ÇOKETOPLA işlevi birden çok ölçüte uyan tüm bağımsız değişkenleri toplar

TOPKARE işlevi birden çok değer üzerinde matematiksel karesini alma işlemini gerçekleştirdikten sonra değerleri toplar

EĞERSAY işlevi yalnızca tek bir ölçüte uyan değerleri sayar

ÇOKEĞERSAY işlevi yalnızca birden çok ölçüte uyan değerleri sayar

ÇOKEĞER işlevi (Office 365, Excel 2016 ve sonraki sürümleri)

Excel’deki formüllere genel bakış

Bozuk formülleri önleme

Formüllerdeki hataları saptamak için hata denetimini kullanma

Matematik ve Trigonometri İşlevleri

Excel işlevleri (alfabetik)

Excel işlevleri (Kategoriye göre)

Verileri hızla çözümlemek için ETOPLA, EĞERSAY ve ilişkili işlevleri kullanma (ücretsiz önizleme sürümü)

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×