ETOPLA/ÇOKETOPLA işlevindeki #DEĞER! hatasını düzeltme

Bu konu başlığı altında, ETOPLA ve ÇOKETOPLA işlevlerindeki #DEĞER! hatasının yaygın nedenleri ve bunların nasıl çözüleceği listelenir.

Sorun: Formül kapalı bir çalışma kitabındaki hücrelere başvuruyor

Kapalı bir çalışma kitabındaki hücreye veya aralığa başvuran ETOPLA/ÇOKETOPLA işlevleri #DEĞER! hatasıyla sonuçlanır.

Not: Bu, EĞERSAY, ÇOKEĞERSAY ve BOŞLUKSAY gibi çeşitli Excel işlevlerinde bilinen bir sorundur. Daha fazla bilgi için, ETOPLA, EĞERSAY ve BOŞLUKSAY işlevleri "#DEĞER!" hatası döndürüyor makalesine bakın.

Çözüm: Formülde belirtilen çalışma kitabını açın ve F9'a basarak formülü yenileyin.

Ayrıca, bir dizi formülünde TOPLA ve EĞER işlevlerini birlikte kullanarak bu sorundan kaçınabilirsiniz. Daha fazla bilgi için, ETOPLA, EĞERSAY ve BOŞLUKSAY işlevleri "#DEĞER!" hatası döndürüyor makalesine bakın.

Sorun: Ölçüt dizesi 255 karakteri aşıyor

255 karakterden uzun dizeleri eşleştirmeye çalıştığınızda, ETOPLA/ÇOKETOPLA işlevleri yanlış sonuçlar döndürür.

Çözüm: Mümkünse dizeyi kısaltın. Dizeyi kısaltamıyorsanız, değeri birden çok dizeye bölmek için BİRLEŞTİR işlevini veya Ve (&) işlecini kullanın. Örneğin:

=ETOPLA(B2:B12,"uzun dize"&"bir uzun dize daha")

Sorun: ÇOKETOPLA işlevinde, ölçüt_aralığı bağımsız değişkeni aralık_toplamı bağımsız değişkeniyle tutarlı değil.

ÇOKETOPLA işlevinde aralık bağımsız değişkenlerinin her zaman aynı olması gerekir. Bu, ölçüt_aralığı ve aralık_toplamı bağımsız değişkenlerinin aynı sayıda satıra ve sütuna başvurması gerektiği anlamına gelir.

Aşağıdaki örnekte, formülün Balıkesir'deki günlük Elma satışlarının toplamını döndürmesi bekleniyor. Öte yandan, aralık_toplamı (C2:C10) bağımsız değişkeni ölçüt_aralığı (A2:A12 & B2:B12) bağımsız değişkenleriyle aynı satır ve sütun sayısına karşılık gelmiyor. =ÇOKETOPLA(C2:C10,A2:A12,A14,B2:B12,B14) söz diziminin kullanılması #DEĞER! hatası döndürüyor.

Yanlış formül: =ÇOKETOPLA(C2:C10,A2:A12,A14,B2:B12,B14); burada C2:C10'un C2:C12 olması gerekir
ÇOKETOPLA işlevinde ölçüt_aralığı, aralık_toplamı ile tutarlı olmalıdır

Çözüm: Bu örnekte, aralık_toplamı bağımsız değişkenini C2:C12 olarak değiştirin ve formülü yeniden deneyin.

Not :  ETOPLA, farklı boyuttaki aralıkları kullanabilir.

İşlevlerle ilgili bir sorunuz mu var?

Excel topluluk forumuna bir soru gönderin

Excel’i geliştirmemize yardımcı olun

Excel'in sonraki sürümünü nasıl geliştirebileceğimiz konusunda önerileriniz var mı? Varsa, lütfen Excel User Voice forumundaki başlıkları gözden geçirin.

Ayrıca Bkz:

#DEĞER! hatasını düzeltme

ETOPLA işlevi

ÇOKETOPLA işlevi

Gelişmiş EĞER işlevi videoları

Excel'deki formüllere genel bakış

Bozuk formülleri önleme

Formüllerdeki hataları saptamak için hata denetimini kullanma

Tüm Excel işlevleri (alfabetik)

Tüm Excel işlevleri (kategoriye göre)

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×