ELEMAN işlevi

Bu makalede, Microsoft Excel'de ELEMAN işlevinin formül söz dizimi ve kullanımı açıklanmaktadır.

Açıklama

Değer bağımsız değişkenleri listesinden bir değer vermek için dizin_sayısını kullanır. Dizin sayısı temelinde en fazla 254 değer arasından birini seçmek için ELEMAN işlevini kullanın. Örneğin değer1'den değer7'ye kadar olan değerler haftanın günleriyse, 1 ve 7 arasındaki bir sayı dizin_sayısı olarak kullanıldığında, ELEMAN işlevi günlerin birini verir.

Söz dizimi

ELEMAN(dizin_sayısı, değer1, [değer2], ...)

ELEMAN işlevinin söz diziminde aşağıdaki bağımsız değişkenler bulunur:

  • Dizin_sayısı    Gerekli. Hangi değer bağımsız değişkeninin seçildiğini belirtir. Dizin_sayısı 1 ile 254 arasında bir sayı ya da 1 ile 254 arasında bir sayı içeren bir hücreye başvuru ya da formül olmalıdır.

    • Dizin_sayısı 1 ise, ELEMAN işlevi değer1'i verir; 2 ise, ELEMAN işlevi değer2'yi verir ve böyle devam eder.

    • Dizin_sayısı 1'den küçükse ya da listedeki en son değerin sayısından büyükse, ELEMAN işlevi #DEĞER! hata değerini verir.

    • Dizin_sayısı kesirli bir sayıysa, kullanılmadan önce en küçük tamsayıya yuvarlanır.

  • Değer1, değer2, ...     Değer1 gereklidir, izleyen değerler ise isteğe bağlıdır. Dizin_sayısı temelinde ELEMAN işlevinin bir değer ya da yapılacak bir işlem seçtiği 1 ile 254 arasındaki değer bağımsız değişkenidir. Bağımsız değişkenler sayı, hücre başvurusu, tanımlanmış ad, formül, makro işlevi ya da metin olabilir.

Açıklamalar

  • Dizin_sayısı bir dizi, ELEMAN işlevi çalışırken her değer değerlendirilir.

  • ELEMAN işlevinin değer bağımsız değişkenleri, tek tek değerler olabileceği gibi aralık başvuruları da olabilir.

    Örneğin:

=TOPLA(ELEMAN(2,A1:A10,B1:B10,C1:C10))

şu sonucu verir:

=TOPLA(B1:B10)

B1:B10 aralığındaki değerlere dayanarak tek bir değer verir.

ELEMAN işlevi ilk olarak değerlendirilir ve B1:B10 başvurusu verilir. Daha sonra bağımsız değişken olarak ELEMAN işlevinin sonucu olan B1:B10 kullanılarak TOPLA işlevi değerlendirilir.

Örnekler

Aşağıdaki tabloda yer alan örnek verileri kopyalayın ve yeni bir Excel çalışma sayfasının A1 hücresine yapıştırın. Formüllerin sonuçları göstermesi için, bunları seçip F2 tuşuna basın ve sonra Enter tuşuna basın. Gerekirse, tüm verileri görmek için sütun genişliğini ayarlayabilirsiniz.

Veri

 

1.

Çiviler

2.

Vidalar

3.

Somunlar

Bitti

Cıvatalar

Formül

Açıklama

Sonuç

=ELEMAN(2;A2;A3;A4;A5)

İkinci liste bağımsız değişkeninin değeri (A3 hücresinin değeri)

2.

=ELEMAN(4;B2;B3;B4;B5)

Dördüncü liste bağımsız değişkeninin değeri (B5 hücresinin değeri)

Cıvatalar

=ELEMAN(3;"Geniş";115;"dünya";8)

Üçüncü liste bağımsız değişkenin değeri

dünya

Örnek 2

Veri

23

45

12

10

Formül

Açıklama (Sonuç)

Sonuç

=TOPLA(A2:ELEMAN(2;A3;A4;A5))

A2:A4 aralığını toplar. ELEMAN işlevi, TOPLA işlevi için aralığın ikinci parçası olarak A4'ü verir.

80

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×