EĞERSAY işlevi

İstatistiksel işlevlerden biri olan EĞERSAY işlevini, bir ölçüte uyan hücre sayısını bulmak için kullanın; örneğin, bir müşteri listesinde bir şehrin kaç kez geçtiğini bulmak için kullanabilirsiniz.

Söz Dizimi

EĞERSAY(aralık, ölçüt)

Örneğin:

  • =EĞERSAY(A2:A5;"elmalar")

  • =EĞERSAY(A2:A5;A4)

Bağımsız değişken adı

Açıklama

Aralık    (gerekli)

Saymak istediğiniz hücre grubu. Aralık sayılar, diziler içerebilir veya sayı bulunan başvurular içerebilir. Boşluk ve metin değerleri yok sayılır.

Çalışma sayfasında aralıkları seçmeyi öğrenin.

Ölçüt    (gerekli)

Hangi hücrelerin sayılacağını belirleyen bir sayı, ifade, hücre başvurusu veya metin dizesidir.

Örneğin, 32 gibi bir sayı, ">32" gibi bir karşılaştırma, B4 gibi bir hücre veya "elmalar" gibi bir sözcük kullanabilirsiniz.

EĞERSAY yalnızca tek bir ölçüt kullanır. Birden fazla ölçüt kullanmak isterseniz ÇOKEĞERSAY’ı kullanın.

Örnekler

Bu örnekleri Excel’de kullanmak için verileri aşağıdaki tabloya kopyalayın ve yeni bir çalışma sayfasının A1 hücresine yapıştırın.

Veri

Veri

elmalar

32

portakallar

54

şeftaliler

75

elmalar

86

Formül

Açıklama

=EĞERSAY(A2:A5;"elmalar")

A2 ile A5 arasında yer alan ve elmalar sözcüğünü içeren hücreleri sayar. Sonuç 2’dir.

=EĞERSAY(A2:A5;A4)

A2 ile A5 arasındaki hücrelerde şeftali içeren hücreleri sayar (A4 içindeki ölçütü kullanarak). Sonuç 1’dir.

=EĞERSAY(A2:A5;A3)+EĞERSAY(A2:A5;A2)

A2 ile A5 arasındaki hücrelerde portakallar sözcüğünü içeren (A3'teki ölçütü kullanarak) ve elmalar sözcüğünü içeren (A2'deki ölçütü kullanarak) sayar. Sonuç 3’tür.

=EĞERSAY(B2:B5;">55"))

B2 ile B5 arasında yer alan ve 55'ten büyük bir değer içeren hücreleri sayar. Sonuç 2’dir.

=EĞERSAY(B2:B5;"<>"&B4)

B2 ile B5 arasında yer alan ve değeri 75'e eşit olmayan hücreleri sayar. Ve işareti (&), (<>) karşılaştırma işlecini (eşit değildir) ve B4’teki değeri birleştirerek şu şekilde görünür: =EĞERSAY(B2:B5,"<>75"). Sonuç 3’tür.

=EĞERSAY(B2:B5;">=32")-EĞERSAY(B2:B5;">85")

B2 ile B5 arasında yer alan ve değeri 32'ye eşit (=) veya bundan büyük (>) ya da 85'ten küçük (<) veya buna eşit (=) olan hücreleri sayar. Sonuç 3’tür.

=EĞERSAY(A2:A5,"*")

A2 ile A5 arasında yer alan ve metin içeren hücreleri sayar. Yıldız işareti (*), herhangi bir karakteri eşleştirmek için joker karakter olarak kullanılır. Sonuç 4’tür.

=EĞERSAY(A2:A5,"?????es")

A2 ile A5 arasında yer alan hücrelerde, tam olarak 7 karakter içeren ve “es” harfleriyle biten hücreleri sayar. Soru işareti (?), tek tek karakterleri eşleştirmek için joker karakter olarak kullanılır. Sonuç 2’dir.

Sık Karşılaşılan Sorunlar

Sorun

Nerede sorun çıktı?

Uzun dizeler için yanlış değer döndürdü.

255 karakterden uzun dizeleri eşleştirecek şekilde kullandığınızda EĞERSAY işlevi hatalı değerler verir.

255 karakterden uzun dizeleri eşleştirmek için BİRLEŞTİR işlevini veya birleştir işlecini (&) kullanın. Örneğin, =EĞERSAY(A2:A5,"uzun dize"&"başka bir uzun dize").

Bir değer beklediğiniz halde değer döndürülmedi.

Ölçüt bağımsız değişkenini tırnak içine aldığınızdan emin olun.

En iyi yöntemler

Bunu yapın

Neden?

EĞERSAY işlevinin metin dizelerindeki büyük ve küçük harfleri yok saydığını unutmayın.

Ölçütler büyük/küçük harfe duyarlı değildir. Başka bir deyişle, "elmalar" dizesi de "ELMALAR" dizesi de aynı hücreleri eşleştirir.

Joker karakterler kullanın.

Ölçütte soru işareti (?) ve yıldız işareti (*) gibi joker karakterler kullanılabilir. Soru işareti herhangi bir tek karakteri eşleştirir. Yıldız işareti bir dizi karakteri eşleştirir. Gerçek bir soru işaretini veya yıldız işaretini bulmak istiyorsanız, karakterden önce bir tilde işareti (~) koyun.

Örneğin, =EĞERSAY(A2:A5,"elma?") ifadesi, sonunda değişen bir harf bulunan "elma" sözcüğünün her tekrarını sayar.

Verilerinizde hatalı karakterler kullanılmadığından emin olun.

Metin değerlerini sayarken, verilerin başında boşluklar, sonunda boşluklar, tutarsız kullanılmış düz ve kıvrımlı tırnak işaretleri veya yazdırılamayan karakterler bulunmadığından emin olun. Bunlar varsa, EĞERSAY beklenmeyen bir değer verebilir.

Doğru sonuçlar almak için, hücrede tablo değerlerini izleyen sondaki boşlukları kaldırmanız gerekebilir. TEMİZ işlevini veya KIRP işlevini kullanmayı deneyin.

İlgili

İlgili Uygulamalar: Excel 2010, Excel Starter, Excel 2016 Preview, Excel 2007, Excel for Mac 2011, Excel 2013, Excel 2016 for Mac, Excel Online



Bu bilgi yararlı oldu mu?

Evet Hayır

Özellikleri nasıl daha iyi hale getirebiliriz?

255 kalan karakter sayısı

Gizliliğinizi korumak için lütfen görüşlerinize iletişim bilgilerinizi eklemeyin. Şunu gözden geçirin: gizlilik ilkesi.

Görüşleriniz için teşekkür ederiz!

Destek kaynakları

Dili değiştir