EĞERSAY işlevi

Bu makalede, Microsoft Office Excel'de EĞERSAYişlev formül sözdizimi ve kullanımı açıklanır.

Açıklama

EĞERSAY işlevi, bir aralıkta yer alan ve belirttiğiniz tek bir ölçüte uyan hücrelerin sayısını sayar. Örneğin, belirli bir harfle başlayan tüm hücreleri veya belirttiğiniz bir sayıdan daha küçük ya da daha büyük sayılar içeren tüm hücreleri sayabilirsiniz. Örneğin, A sütununda görev listesinin ve B sütununda da her göreve atanmış kişinin adının bulunduğu bir çalışma sayfanız olduğunu varsayalım. EĞERSAY işlevini kullanarak bir kişinin adının B sütununda kaç kez geçtiğini sayabilir, bu yolla söz konusu kişiye kaç görev atandığını saptayabilirsiniz. Örneğin:

=EĞERSAY(B2:B25,"Neşe")

Not   Birden çok ölçüt temelinde hücreleri saymak için bkz: ÇOKEĞERSAY işlevi.

Sözdizimi

EĞERSAY(aralık, ölçüt)

EĞERSAY işlevinin sözdizimi aşağıdaki bağımsız değişken içerir:

  • hücre    Gerekli. Numaralar veya adlar, diziler ya da sayı içeren başvurular da içinde olmak üzere sayılacak bir veya birden çok hücre. Boşluk ve metin değerleri göz ardı edilir.

  • ölçütler    Gerekli. hangi hücrelerin sayılacağını tanımlayan sayı, ifade, hücre başvurusu ya da metin dizesi. Örneğin, ölçüt 32, ">32", B4, "elmalar" veya "32" olarak gösterilebilir.

    Not   

    • Ölçütte,soru işareti (?) ve yıldız işareti (*) gibi joker karakterler kullanabilirsiniz. Soru işareti tek karakter bulurken, yıldız işareti bir dizi karakter bulur. Gerçek bir soru işaretini veya yıldız işaretini bulmak istiyorsanız, karakterden önce bir tilde işareti (~) koyun.  

    • Ölçütler büyük/küçük harfe duyarlı değildir; örneğin, "elmalar" dizesiyle "ELMALAR" dizesi aynı hücreleri eşleştirir.

Örnek 1: Sık kullanılan EĞERSAY formülleri

Örneğin, boş çalışma sayfasına kopyalarsanız anlamanız daha kolay olabilir.

Örneği nasıl kopyalayabilirim?

  1. Bu makaledeki örneği seçin. Örneği Excel Online'da kopyalıyorsanız, hücreleri teker teker kopyalayıp yapıştırın.
    Important: Satır veya sütun başlıklarını seçmeyin.

    Proje Sitesi Şablonu

    Yardım'dan örnek seçme

  2. CTRL+C tuşlarına basın.

  3. Boş bir çalışma kitabı veya çalışma sayfası oluşturun.

  4. Çalışma sayfasında, A1 hücresini seçin ve Ctrl+V tuşlarına basın. Excel Online'da çalışıyorsanız, kopyalayıp yapıştırma işlemini örnekteki her hücre için tekrarlayın.
    Important: Örneğin doğru çalışması için, çalışma sayfasının A1 hücresine yapıştırmalısınız.

  5. Sonuçları görüntüleme ve sonuçları döndüren formülleri görüntüleme arasında geçiş yapmak için Ctrl+` (kesme işareti) tuşlarına basın veya Formüller sekmesinde, Formül Denetleme grubunda Formülleri Göster düğmesini tıklatın.

Örneği boş bir çalışma sayfasına kopyaladıktan sonra, gereksinimlerinize göre uyarlama yapabilirsiniz.

1

2

3

4

5

6


7


8


9



10


11




12

A

B

C

Veri

Veri

elmalar

32

portakallar

54

şeftaliler

75

elmalar

86

Formül

Açıklama

Sonuç

=EĞERSAY(A2:A5,"elmalar")

A2 ile A5 arasında yer alan ve elmalar sözcüğünü içeren hücrelerin sayısı

2

=EĞERSAY(A2:A5,A4)

A2 ile A5 arasında yer alan ve şeftaliler sözcüğünü içeren hücrelerin sayısı

1

=EĞERSAY(A2:A5,A3)+EĞERSAY(A2:A5,A2)

A2 ile A5 arasında yer alan ve portakallar sözcüğünü içeren hücrelerin sayısı

3

=EĞERSAY(B2:B5,">55"))

B2 ile B5 arasında yer alan ve 55'ten büyük bir değer içeren hücrelerin sayısı

2

=EĞERSAY(B2:B5,"<>"&B4)

B2 ile B5 arasında yer alan ve değeri 75'e eşit olmayan hücrelerin sayısı

3

=EĞERSAY(B2:B5,">=32")-EĞERSAY(B2:B5,">85")

B2 ile B5 arasında yer alan ve değeri 32'ye eşit veya bundan büyük ya da 85'e eşit olan hücrelerin sayısı

3

Örnek 2: Joker karakterlerin kullanıldığı ve boş değerlerin işlendiği EĞERSAY formülleri

Örneğin, boş çalışma sayfasına kopyalarsanız anlamanız daha kolay olabilir.

Örneği nasıl kopyalayabilirim?

  1. Bu makaledeki örneği seçin. Örneği Excel Online'da kopyalıyorsanız, hücreleri teker teker kopyalayıp yapıştırın.
    Important: Satır veya sütun başlıklarını seçmeyin.

    Proje Sitesi Şablonu

    Yardım'dan örnek seçme

  2. CTRL+C tuşlarına basın.

  3. Boş bir çalışma kitabı veya çalışma sayfası oluşturun.

  4. Çalışma sayfasında, A1 hücresini seçin ve Ctrl+V tuşlarına basın. Excel Online'da çalışıyorsanız, kopyalayıp yapıştırma işlemini örnekteki her hücre için tekrarlayın.
    Important: Örneğin doğru çalışması için, çalışma sayfasının A1 hücresine yapıştırmalısınız.

  5. Sonuçları görüntüleme ve sonuçları döndüren formülleri görüntüleme arasında geçiş yapmak için Ctrl+` (kesme işareti) tuşlarına basın veya Formüller sekmesinde, Formül Denetleme grubunda Formülleri Göster düğmesini tıklatın.

Örneği boş bir çalışma sayfasına kopyaladıktan sonra, gereksinimlerinize göre uyarlama yapabilirsiniz.

1

2

3

4

5

6

7

8




9






10




11



12





13





14

A

B

C

Veri

Veri

elmalar

Evet

portakallar

HAYIR

şeftaliler

Hayır

elmalar

evet

Formül

Açıklama

Sonuç

=EĞERSAY(A2:A7,"*lar")

A2 ile A7 arasında yer alan ve "lar" harfleriyle biten hücrelerin sayısı

3

=EĞERSAY(A2:A7,"????lar")

A2 ile A7 arasında yer alan, "lar" harfleriyle biten ve tam olarak 7 harften oluşan hücrelerin sayısı

2

=EĞERSAY(A2:A7,"*")

A2 ile A7 arasında yer alan ve metin içeren hücrelerin sayısı

4

=EĞERSAY(A2:A7,"<>"&"*")

A2 ile A7 arasında yer alan ve hiçbir metin içermeyen hücrelerin sayısı

2

=EĞERSAY(B2:B7,"Hayır") / SATIRSAY(B2:B7)

B2 ile B7 arasında yer alan ve Hayır oyu içeren hücrelerin (boş hücreler de içinde) ortalama sayısı

0,333333333

=EĞERSAY(B2:B7,"Evet") / (SATIRSAY(B2:B7) -EĞERSAY(B2:B7, "<>"&"*"))

B2 ile B7 arasında yer alan ve Evet oyu içeren hücrelerin (boş hücreler hariç) ortalama sayısı

0,5

Not    Sayıyı yüzde olarak görüntülemek için, hücreyi seçin ve Sayfa sekmesinin Sayı grubunda Yüzde Stili'ni . tıklatın.

İlgili Uygulamalar: Excel 2007



Bu bilgi yararlı oldu mu?

Evet Hayır

Özellikleri nasıl daha iyi hale getirebiliriz?

255 kalan karakter sayısı

Gizliliğinizi korumak için lütfen görüşlerinize iletişim bilgilerinizi eklemeyin. Şunu gözden geçirin: gizlilik ilkesi.

Görüşleriniz için teşekkür ederiz!

Destek kaynakları

Dili değiştir