EĞERSAY/ÇOKEĞERSAY işlevindeki #DEĞER! hatasını düzeltme

Bu konu başlığı altında, EĞERSAY ve ÇOKEĞERSAY işlevlerindeki #DEĞER! hatasının yaygın nedenleri listelenir.

Sorun: Formül kapalı bir çalışma kitabındaki hücrelere başvuruyor

Kapalı bir çalışma kitabındaki hücreye veya aralığa başvuran EĞERSAY/ÇOKEĞERSAY işlevleri #DEĞER! hatasıyla sonuçlanır.

Not: Bu, ETOPLA, ÇOKETOPLA ve BOŞLUKSAY gibi çeşitli Excel işlevlerinde bilinen bir sorundur. Daha fazla bilgi için, ETOPLA, EĞERSAY ve BOŞLUKSAY işlevleri "#DEĞER!" hatası döndürüyor konusuna bakın.

Çözüm: Formülde belirtilen bağlantılı çalışma kitabını açın ve F9'a basarak formülü yenileyin.

Ayrıca, bir dizi formülünde TOPLA ve EĞER işlevlerini birlikte kullanarak bu sorundan kaçınabilirsiniz. Daha fazla bilgi için, ETOPLA, EĞERSAY ve BOŞLUKSAY işlevleri "#DEĞER!" hatası döndürüyor konusuna bakın.

Sorun: Dize 255 karakteri aşıyor

Çözüm: Mümkünse dizeyi kısaltın. Dizeyi kısaltamıyorsanız, değeri birden çok dizeye bölmek için BİRLEŞTİR işlevini veya Ve (&) işlecini kullanın. Örneğin,

  • =EĞERSAY(B2:B12,"uzun dize"&"başka bir uzun dize")

İşlevlerle ilgili bir sorunuz mu var?

Excel topluluk forumuna bir soru gönderin

Excel’i geliştirmemize yardımcı olun

Excel'in sonraki sürümünü nasıl geliştirebileceğimiz konusunda önerileriniz var mı? Varsa, lütfen Excel User Voice forumundaki başlıkları gözden geçirin.

Ayrıca Bkz:

#DEĞER! hatasını düzeltme

EĞERSAY işlevi

ÇOKEĞERSAY işlevi

EĞER işlevi: İç içe formüller ve hatalardan kaçınma

Gelişmiş EĞER işlevi videoları

Excel'deki formüllere genel bakış

Bozuk formülleri önleme

Formüllerdeki hataları saptamak için hata denetimini kullanma

Tüm Excel işlevleri (alfabetik)

Tüm Excel işlevleri (kategoriye göre)

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×