EĞERHATA işlevi

Bu makalede, Microsoft Excel'de EĞERHATA işlevinin formül söz dizimi ve kullanımı açıklanmaktadır.

Açıklama

Bir formül bir hatayı değerlendirirse belirttiğiniz bir değeri verir; aksi takdirde, formülün sonucunu verir. EĞERHATA işlevini formül hataları yakalamak ve işlemek için kullanın.

Söz Dizimi

EĞERHATA(değer, eğer_hataysa_değer)

EĞERHATA işlevinin söz diziminde aşağıdaki bağımsız değişkenler bulunur:

  • Değer    Gerekli. Hatayı denetleyen bağımsız değişkendir.

  • Eğer_hataysa_değer    Gerekli. Formül bir hatayı değerlendirirse, verilecek değerdir. Aşağıdaki hata türleri değerlendirilir: #YOK, #DEĞER!, #BAŞV!, #SAY/0!, #SAY!, #AD? veya #BOŞ!.

Notlar

  • Değer veya Eğer_hataysa_değer boş bir hücreyse, EĞERHATA bunu boş bir dize değeri ("") olarak algılar.

  • Değer bir dizi formülüyse, EĞERHATA işlevi değerde belirtilen aralıktaki her hücre için sonuç dizisini getirir. Aşağıda ikinci örneğe bakın.

Örnekler

Aşağıdaki tabloda yer alan örnek verileri kopyalayın ve yeni bir Excel çalışma sayfasının A1 hücresine yapıştırın. Formüllerin sonuçları göstermesi için, bunları seçip F2 tuşuna basın ve sonra Enter tuşuna basın. Gerekirse, tüm verileri görmek için sütun genişliğini ayarlayabilirsiniz.

Kota

Satılan Birimler

210

35

55

0

23

Formül

Açıklama

Sonuç

=EĞERHATA(A2/B2, "Hesaplama hatası")

İlk bağımsız değişkendeki formül hatasını denetler (210'u 35'e bölün), hata bulamaz ve sonra formülün sonucunu getirir

6

=EĞERHATA(A3/B3, "Hesaplama hatası")

İlk bağımsız değişkendeki formül hatasını denetler (55'i 0'a bölün), 0 hatası tarafından bir bölme bulur ve sonra eğer_hataysa_değer'i getirir

Hesaplama hatası

=EĞERHATA(A4/B4, "Hesaplama hatası")

İlk bağımsız değişkendeki formül hatasını denetler ("" değerini 23'e bölün), hata bulamaz ve sonra formülün sonucunu getirir.

0

Örnek 2

Kota

Satılan Birimler

Oran

210

35

6

55

0

Hesaplama hatası

23

0

Formül

Açıklama

Sonuç

=C2

d>Dizinin ilk öğesindeki ilk bağımsız değişkendeki formül hatasını denetler (A2/B2 veya 210'u 35'e bölün), hata bulamaz ve sonra formülün sonucunu getirir

6

=C3

Dizinin ikini öğesindeki ilk bağımsız değişkendeki formül hatasını denetler (A3/B3 veya 55'i 0'a bölün), 0 hatası tarafından bir bölme bulur ve sonra eğer_hataysa_değer'i getirir

Hesaplama hatası

=C4

Dizinin üçüncü öğesindeki ilk bağımsız değerdeki formül hatasını denetler (A4/B4 veya "" değerini 23'e bölün), hata bulamaz ve sonra formülün sonucunu getirir

0

Not: Örnekteki formülün bir dizi formülü olarak girilmesi gerekir. Örneği boş bir çalışma sayfasına kopyaladıktan sonra, C2:C4 aralığını seçin, F2 tuşuna basın ve sonra CTRL+ÜSTKRKT+ENTER tuşlarına basın.

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×