EĞER işlevi

EĞER işlevi Excel'in en popüler işlevlerinden biridir ve bir değerle beklediğiniz değer arasında mantıksal karşılaştırmalar yapmanıza olanak tanır. En basit biçimiyle EĞER işlevi şunu söyler:

  • EĞER(Bir şey Doğru ise, o zaman bir şey yap, değilse başka bir şey yap)

Dolayısıyla, EĞER deyiminin iki sonucu olabilir. İlk sonuç karşılaştırmanızın Doğru olması, ikinci sonuç da karşılaştırmanızın Yanlış olmasıdır.

Doğrudan birden fazla EĞER ifadesi kullanma konusuna geçmek isterseniz bkz.: Gelişmiş EĞER işlevleri: İç içe formüller ile çalışma ve çukurlardan kaçınma.

Bir koşul doğru olduğunda belirli bir değerin ve yanlış olduğunda başka bir değerin döndürülmesi için, mantıksal işlevlerden biri olan EĞER işlevini kullanın.

Söz dizimi

EĞER(mantıksal_sınama, eğer_doğruysa_değer, [eğer_yanlışsa_değer])

Örneğin:

  • =EĞER(A2>B2,"Bütçeyi Aşıyor","Tamam")

  • =EĞER(A2=B2,B4-A4,"")

Bağımsız değişken adı

Açıklama

mantıksal_sınama    (gerekli)

Sınamak istediğiniz koşul.

eğer_doğruysa_değer    (gerekli)

Mantıksal_sınama sonucu DOĞRU ise döndürülmesini istediğiniz değer.

eğer_yanlışsa_değer    (isteğe bağlı)

Mantıksal_sınama sonucu YANLIŞ ise döndürülmesini istediğiniz değer.

Basit EĞER örnekleri

D2 hücresindeki formül: =EĞER(C2="Evet",1,2)
  • =EĞER(C2=”Evet”,1,2)

Yukarıdaki örnekte, D2 hücresi şunu söylüyor: EĞER(C2 = Evet, o zaman 1 döndür, değilse 2 döndür)

D2 hücresindeki formül: =EĞER(C2=1,"EVET","HAYIR")
  • =EĞER(C2=1,”Evet”,”Hayır”)

Bu örnekte, D2 hücresindeki formül şunu söylüyor: EĞER(C2 = 1, o zaman Evet döndür, değilse Hayır döndür)

Gördüğünüz gibi, EĞER işlevi hem metinleri hem de değerleri karşılaştırmak için kullanılabilir. Ayrıca, hataları değerlendirmek için de kullanılabilir. Yapabilecekleriniz, bir öğenin başka bir öğeyle eşit olup olmadığına bakmak ve tek bir sonuç döndürmekle sınırlı değildir; matematiksel işleçler kullanabilir ve ölçütlerinize bağlı olarak ek hesaplamalar gerçekleştirebilirsiniz. Ayrıca, birkaç EĞER işlevini iç içe kullanarak birden çok karşılaştırma da yapabilirsiniz.

Not : Formüllerde metin kullanacaksanız, metni tırnak içine almalısınız (örneğin, “Metin”). Bunun tek özel durumu DOĞRU ve YANLIŞ sözcüklerini kullanmaktır; Excel bunları otomatik olarak anlar.

Nasıl başlanır

EĞER deyimini yazmaya başlamanın en iyi yolu ne yapmaya çalıştığınızı düşünmektir. Hangi karşılaştırmayı yapmaya çalışıyorsunuz? Çoğu zaman EĞER deyimini yazmak kafanızda mantığını düşünmek kadar basittir: “bu koşul karşılanırsa ne olur ve koşul karşılanmazsa ne olur?” Her zaman adımlarınız mantıksal bir şekilde ilerlediğinden emin olmak istersiniz, yoksa formül yapması gerektiğini düşündüğünüz şeyi yapmaz. Özellikle karmaşık (iç içe) EĞER deyimleri oluştururken bu önemlidir.

Diğer EĞER örnekleri

D2 hücresindeki formül: =EĞER(C2>B2,”Bütçeyi Aşıyor”,”Bütçe İçinde”)
  • =EĞER(C2>B2,”Bütçeyi Aşıyor”,”Bütçe İçinde”)

Yukarıdaki örnekte, D2 hücresindeki EĞER işlevi şunu söylüyor: EĞER(C2 B2'den Büyükse, o zaman “Bütçeyi Aşıyor” metnini döndür, değilse “Bütçe İçinde” metnini döndür)

E2 hücresindeki formül: =EĞER(C2>B2,C2-B2,"")
  • =EĞER(C2>B2,C2-B2,0)

Yukarıdaki çizimde, Metin sonucu yerine matematiksel bir hesaplama döndüreceğiz. Dolayısıyla E2'deki formül şunu söylüyor: EĞER(Gerçek Değeri Bütçelenen Değerinden Büyükse, o zaman Bütçelenen tutarı Gerçek tutardan çıkar, değilse hiçbir şey döndürme).

F7 hücresindeki formül: EĞER(E7=”Evet”,F5*0,0825,0)
  • =EĞER(E7=”Evet”,F5*0,0825,0)

Bu örnekte F7'deki formül şunu söylüyor: EĞER(E7 = “Evet”, o zaman F5 * %8,25'te Toplam Tutarı hesapla, değilse süresi geçmiş Satış Vergisi yoktur bu nedenle 0 döndür)

En İyi Yöntemler - Sabitler

Son örnekte, hem “Evet” sözcüğünün hem de Satış Vergi Oranının (0,0825) doğrudan formüle girildiğini gördünüz. Genellikle sabit değerleri (zaman içinde değişmesi gerekebilen değerler) doğrudan formüllere yazmak iyi bir yöntem değildir, çünkü gelecekte bunları bulmak ve değiştirmek zor olabilir. Sabitleri, açıkça görülebilecekleri ve kolayca bulunup değiştirilebilecekleri kendi hücrelerine yerleştirmek çok daha iyi olur. Bu örnekte sorun olmaz çünkü tek bir EĞER deyimi vardır ve Satış Vergi Oranı nadiren değişir. Değişse bile, formülde bu oran kolayca değiştirilebilir.

Hesaplama işleçleri

Formüllerde kullanabileceğiniz farklı hesaplama işleçleri hakkında daha fazla bilgi edinmek isterseniz (< küçüktür, > büyüktür, = eşittir, <> eşit değildir, vb.), şu makaleye bakın: Hesaplama işleçleri ve öncelik.

Hücrenin boş olup olmadığını denetlemek için EĞER kullanma

Bazen bir hücrenin boş olup olmadığını denetlemeniz gerekir; genel olarak bunun nedeni bir formülün girişi olmadan sonuç görüntülemesini istememenizdir.

E2 hücresindeki formül =EĞER(D2=1,"Evet",EĞER(D2=2,"Hayır","Belki"))

Burada EĞER işlevini EBOŞSA işleviyle birlikte kullanıyoruz:

  • =EĞER(EBOŞSA(D2),"Boş","Boş Değil")

Bu formül şunu söylüyor: EĞER(D2 boşsa, o zaman "Boş" döndür, değilse "Boş Değil" döndür). "Boş Değil" koşulu için de aynı şekilde kolayca kendi formülünüzü kullanabilirsiniz. Sonraki örnekte EBOŞSA yerine "" kullanıyoruz. "" temelde "hiçbir şey" anlamına gelir.

Hücrenin boş olup olmadığını denetleme - E2 hücresindeki formül: =EĞER(EBOŞSA(D2),"Boş","Boş Değil")
  • =EĞER(D3="","Boş","Boş Değil")

Bu formül şunu söylüyor: Eğer(D3 hiçbir şeyse, o zaman "Boş" döndür, değilse "Boş Değil" döndür). Burada, bağımlı bir hücre boşsa formülün hesaplama yapmasını önlemek için çok yaygın bir "" kullanım yöntemi örneği vardır:

  • =EĞER(D3="","",Formülünüz())

    EĞER(D3 hiçbir şeyse, o zaman hiçbir şey döndürme, değilse formülü hesapla).

İç içe EĞER örneği

Basit bir EĞER işlevinin yalnızca iki sonucu olurken (Doğru veya Yanlış), iç içe EĞER işlevlerinin 3 ile 64 arasında sonucu olabilir.

Boş hücre denetimi yapmak için "" kullanma - E3 hücresindeki formül: =EĞER(D3="","Boş","Boş Değil")
  • =EĞER(D2=1,”EVET”,EĞER(D2=2,”Hayır”,”Belki”))

Yukarıdaki çizimde, E2'deki formül şunu söylüyor: EĞER(D2 1'e eşitse o zaman “Evet” döndür, değilse EĞER(D2 2'ye eşitse o zaman “Hayır” döndür, değilse “Belki” döndür)). Formülün sonunda iki kapatma parantezi olduğuna dikkat edin. Her iki EĞER işlevini de kapatmak için bunlar gereklidir ve formülü iki kapatma parantezi olmadan girmeye çalışırsanız, Excel sizin için bunu düzeltmeyi dener.

Bir uyarı

Excel en çok 64 farklı EĞER işlevini iç içe kullanmanıza izin verse de, bunu yapmanız pek önerilmez. Neden?

  • Birden çok EĞER deyimini doğru oluşturmak için çok kapsamlı düşünmek ve mantığının sonuna kadar her koşulda doğru hesaplama yapabileceğinden emin olmak gerekir. EĞER deyimlerinizi iç içe %100 doğru yerleştirmezseniz, kullandığınız durumların %75'inde formül doğru çalışabilir ama %25'inde beklenmedik sonuçlar döndürür. Ne yazık ki, %25'e yakalanma ihtimaliniz vardır.

  • Birden çok EĞER deyiminin bakımı çok zor olabilir. Özellikle bir süre sonra geri gelip ne yaptığınızı anlamaya çalışırsanız veya daha da kötüsü başka birisi bunu anlamaya çalışırsa çok zorlanabilir.

  • Birden çok EĞER deyimi için birden çok açma ve kapatma parantezi () gerekir ve formülünüzün ne kadar karmaşık hale geldiğine bağlı olarak bunları yönetmek zor olabilir.

Sık karşılaşılan sorunlar

Sorun

Nerede sorun çıktı

Hücrede 0 (sıfır) var

Eğer_doğruysa_değer ve eğer_yanlışsa_değer bağımsız değişkenlerinden biri yoktur. Döndürülen doğru değeri görmek için, iki bağımsız değişkene de bağımsız değişken metni ekleyin veya bağımsız değişkene DOĞRU veya YANLIŞ ekleyin.

Hücrede #AD? var

Bu çoğunlukla formülde yazım hatası olduğu anlamına gelir.

İşlevlerle ilgili bir sorunuz mu var?

Excel topluluk forumuna soru gönderin

Excel’i geliştirmemize yardımcı olun

Excel'in sonraki sürümünü nasıl geliştirebileceğimiz konusunda önerileriniz var mı? Varsa, lütfen Excel User Voice forumundaki başlıkları gözden geçirin.

Ayrıca Bkz:

EĞER işlevinin kullanımını gösteren bir video izleyin

ÇOKEĞER işlevi (Office 365, Excel 2016 ve sonrası)

Gelişmiş EĞER işlevleri: İç içe formüllerle çalışma ve çukurlardan kaçınma

Eğitim videoları: Gelişmiş EĞER işlevleri

EĞERSAY işlevi, değerleri tek bir ölçüte dayalı olarak sayar

ÇOKEĞERSAY işlevi, değerleri birden çok ölçüte dayalı olarak sayar

ETOPLA işlevi, değerleri tek bir ölçüte dayalı olarak toplar

ÇOKETOPLA işlevi, değerleri birden çok ölçüte dayalı olarak toplar

VE işlevi

VEYA işlevi

DÜŞEYARA işlevi

Excel'deki formüllere genel bakış

Bozuk formüllerden kaçınma

Formüllerdeki hataları tespit için hata denetimini kullanma

Mantıksal işlevler

Excel işlevleri (alfabetik)

Excel işlevleri (kategoriye göre)

EĞER mantıksal testleri (ücretsiz önizleme)

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×