EĞER işlevi

Önemli : Bu makale makine çevisidir. Bkz. yasal uyarı. Bu makalenin İngilizce sürümüne buradan ulaşabilirsiniz.

Eğer işlevini Excel'in en popüler işlevlerinden biri olan ve bir değer arasındaki beklediğiniz mantıksal karşılaştırmalar yapma olanak tanır. En basit şekliyle, eğer işlevinin sonucu:

  • EĞER(Bir şey Doğru ise, o zaman bir şey yap, değilse başka bir şey yap)

Eğer deyimi iki sonuçları çalışabilmeniz için. İlk sonuç, karşılaştırma ikinci alanınızı karşılaştırma yanlış ise, doğru ise, olur.

Birden fazla Eğer deyimleri ile çalışmaya devam atlamayı istiyorsanız, bkz: Gelişmiş Eğer işlevleri - iç içe formüllerle çalışma ve sorunları önleme.

Bir koşul doğru olduğunda belirli bir değerin ve yanlış olduğunda başka bir değerin döndürülmesi için, mantıksal işlevlerden biri olan EĞER işlevini kullanın.

Söz dizimi

EĞER(mantıksal_sınama, eğer_doğruysa_değer, [eğer_yanlışsa_değer])

Örneğin:

  • =EĞER(A2>B2,"Bütçeyi Aşıyor","Tamam")

  • =EĞER(A2=B2,B4-A4,"")

Bağımsız değişken adı

Açıklama

mantıksal_sınama    (gerekli)

Sınamak istediğiniz koşul.

eğer_doğruysa_değer    (gerekli)

Mantıksal_sınama sonucu DOĞRU ise döndürülmesini istediğiniz değer.

eğer_yanlışsa_değer    (isteğe bağlı)

Mantıksal_sınama sonucu YANLIŞ ise döndürülmesini istediğiniz değer.

Basit EĞER örnekleri

D2 hücresindeki formül: =EĞER(C2="Evet",1,2)
  • =EĞER(C2=”Evet”,1,2)

Yukarıdaki örnekte, D2 hücresi şunu söylüyor: EĞER(C2 = Evet, o zaman 1 döndür, değilse 2 döndür)

D2 hücresindeki formül: =EĞER(C2=1,"EVET","HAYIR")
  • =EĞER(C2=1,”Evet”,”Hayır”)

Bu örnekte, D2 hücresindeki formül şunu söylüyor: EĞER(C2 = 1, o zaman Evet döndür, değilse Hayır döndür)

Gördüğünüz gibi Eğer işlevinin hem metin hem de değerleri değerlendirmek için kullanılabilir. Bu, hataları değerlendirmekiçin de kullanılabilir. Bir şey diğerine eşit ise ve tek bir sonuç döndürerek, ayrıca matematik işleçleri kullanın ve bağlı olarak, ölçütlerinizi ek hesaplamalar denetimini yalnızca sınırlı değildir. Ayrıca birden fazla Eğer işlevleri birlikte birden çok karşılaştırmaları gerçekleştirmek için yerleştirebilirsiniz.

Not : Formüllerde metin kullanmak için kullanacaksanız, tırnak işaretleri (örneğin, "metin") metni kaydır gerekir. Yalnızca bir durum TRUE veya FALSE, hangi Excel otomatik olarak anlayacağı kullanıyor.

Nasıl başlanır

Eğer deyimi yazmaya başlamak için en iyi ne, yapmanın çalıştığınız hakkında düşünmeye yoludur. Hangi karşılaştırma yapmak çalışıyorsunuz? Çoğu zaman, EĞER deyimi yazma olabilir, kafası mantık aracılığıyla düşünme kadar basit: "Bu değilse ne olacağını karşılaştırması koşul varsa ne olacağını?" Her zaman adımlarınız mantıksal ilerlemeyi izleyin, aksi durumda formülünüzü gerektiği düşüncelerinizi yapmayacağınızı emin olmak istersiniz. Karmaşık (iç içe) IF deyimleri oluşturduğunuzda, bu özellikle önemlidir.

Diğer EĞER örnekleri

D2 hücresindeki formül: =EĞER(C2>B2,”Bütçeyi Aşıyor”,”Bütçe İçinde”)
  • =EĞER(C2>B2,”Bütçeyi Aşıyor”,”Bütçe İçinde”)

Yukarıdaki örnekte, D2 hücresindeki EĞER işlevi şunu söylüyor: EĞER(C2 B2'den Büyükse, o zaman “Bütçeyi Aşıyor” metnini döndür, değilse “Bütçe İçinde” metnini döndür)

E2 hücresindeki formül: =EĞER(C2>B2,C2-B2,"")
  • =EĞER(C2>B2,C2-B2,0)

Bir metin sonuçları dönen yerine Yukarıdaki çizimde biz matematiksel hesaplama dönüş kullanacağınıza. E2 formülde söyleyen şekilde (gerçek bütçelenen ve ardından çıkarma gerçek miktardan Bütçelenen Tutar hiçbir şey aksi dönüş daha büyük olup olmadığını).

F7 hücresindeki formül: EĞER(E7=”Evet”,F5*0,0825,0)
  • =EĞER(E7=”Evet”,F5*0,0825,0)

Bu örnekte F7'deki formül şunu söylüyor: EĞER(E7 = “Evet”, o zaman F5 * %8,25'te Toplam Tutarı hesapla, değilse süresi geçmiş Satış Vergisi yoktur bu nedenle 0 döndür)

En İyi Yöntemler - Sabitler

Son örnekte, hem "Evet" ve satış vergisi formülün içine doğrudan girilen oranı (0.0825) bakın. Bu genellikle değişmez Sabitleri (kimi zaman değiştirmeniz gerekebilir değerler) doğrudan formüllerine getirmek için iyi bir uygulamadır değil çünkü bunlar bulma ve değiştirme gelecekte zor olabilir. Bunların out Aç olan ve kolayca bulunan ve değiştirilen kendi hücrelere sabitleri getirmek çok daha iyi. Bu durumda, tek bir Eğer işlevi yoktur ve satış vergisi oranının nadiren değiştirecek nedeniyle Tamam, olur. Gelir bile, formülde değiştirmek kolay olacaktır.

Hesaplama işleçleri

Formüllerde, kullanabileceğiniz farklı hesaplama işleçleri hakkında daha fazla bilgi edinmek istiyorsanız (< 'den küçük, > büyük, = eşittir, <> eşit değil çok, vb.), bu makaleye bakın: Hesaplama işleçleri ve öncelik.

Hücrenin boş olup olmadığını denetlemek için EĞER kullanma

Bazen bir hücrenin boş olup olmadığını denetlemeniz gerekir; genel olarak bunun nedeni bir formülün girişi olmadan sonuç görüntülemesini istememenizdir.

E2 hücresindeki formül =EĞER(D2=1,"Evet",EĞER(D2=2,"Hayır","Belki"))

Burada EĞER işlevini EBOŞSA işleviyle birlikte kullanıyoruz:

  • =EĞER(EBOŞSA(D2),"Boş","Boş Değil")

Hangi IF(D2 is blank, then return "Blank", otherwise return "Not Blank")diyor. Aynı zamanda "Boş değil" koşul için kendi formülünüzü gibi kolayca kullanabilirsiniz. Sonraki örnekte biz kullanmakta olduğunuz "" yerine EBOŞSA. "" Aslında "hiçbir şey" anlamına gelir.

Hücrenin boş olup olmadığını denetleme - E2 hücresindeki formül: =EĞER(EBOŞSA(D2),"Boş","Boş Değil")
  • =EĞER(D3="","Boş","Boş Değil")

Bu formül (D3 şey, sonra ", aksi halde" boş "boş" döndürmek istiyorsanız)diyor. Örneği kullanarak, yaygın bir yöntem burada "" bir formül bağımlı hücre boşsa, hesaplama yapma önlemek için:

  • =EĞER(D3="","",Formülünüz())

    EĞER(D3 hiçbir şeyse, o zaman hiçbir şey döndürme, değilse formülü hesapla).

İç içe EĞER örneği

Basit bir EĞER işlevinin yalnızca iki sonucu olurken (Doğru veya Yanlış), iç içe EĞER işlevlerinin 3 ile 64 arasında sonucu olabilir.

Boş hücre denetimi yapmak için "" kullanma - E3 hücresindeki formül: =EĞER(D3="","Boş","Boş Değil")
  • =EĞER(D2=1,”EVET”,EĞER(D2=2,”Hayır”,”Belki”))

Yukarıdaki çizimde, E2'deki formül şunu söylüyor: EĞER(D2 1'e eşitse o zaman “Evet” döndür, değilse EĞER(D2 2'ye eşitse o zaman “Hayır” döndür, değilse “Belki” döndür)). Formülün sonunda iki kapatma parantezi olduğuna dikkat edin. Her iki EĞER işlevini de kapatmak için bunlar gereklidir ve formülü iki kapatma parantezi olmadan girmeye çalışırsanız, Excel sizin için bunu düzeltmeyi dener.

Bir uyarı

Excel, farklı Eğer işlevleri en çok 64 iç içe geçirmeyin izin verir, ancak hiç Bunu yapmak için önerilir. Neden?

  • Birden fazla Eğer deyimleri düşünce düzgün oluşturma ve bunların mantığı son hücresindeyken her koşula aracılığıyla doğru şekilde hesaplayabilirsiniz emin olmak için çok gereklidir. % 100 doğru bir şekilde, IF deyimleri yerleştirmeyin varsa, sonra bir formül zaman % 75 çalışır, ancak zaman % 25 beklenmeyen sonuçlar döndürebilir. Ne yazık ki, büyük olasılıkla sizin % 25 yakalama ince.

  • Birden çok EĞER deyiminin bakımı çok zor olabilir. Özellikle bir süre sonra geri gelip ne yaptığınızı anlamaya çalışırsanız veya daha da kötüsü başka birisi bunu anlamaya çalışırsa çok zorlanabilir.

  • Birden çok EĞER deyimi için birden çok açma ve kapatma parantezi () gerekir ve formülünüzün ne kadar karmaşık hale geldiğine bağlı olarak bunları yönetmek zor olabilir.

Sık karşılaşılan sorunlar

Sorun

Nerede sorun çıktı

Hücrede 0 (sıfır) var

Eğer_doğruysa_değer ve eğer_yanlışsa_değer bağımsız değişkenlerinden biri yoktur. Döndürülen doğru değeri görmek için, iki bağımsız değişkene de bağımsız değişken metni ekleyin veya bağımsız değişkene DOĞRU veya YANLIŞ ekleyin.

Hücrede #AD? var

Bu çoğunlukla formülde yazım hatası olduğu anlamına gelir.

Daha fazla yardım mı gerekiyor?

Sorularınızı Excel Teknoloji Topluluğu’ndaki uzmanlara sorabilir, Yanıt topluluğu’ndan destek alabilir ya da Excel için UserVoice platformuna yeni bir özellik veya iyileştirme önerisi sunabilirsiniz.

Ayrıca bkz.

Video: Gelişmiş Eğer işlevleri

ÇOKEĞER işlevi (Office 365, Excel 2016 ve sonrası)

Gelişmiş Eğer işlevleri - iç içe formüllerle çalışma ve sorunları önleme

Eğitim videoları: Gelişmiş Eğer işlevleri

EĞERSAY işlevinin tek bir ölçüte dayalı olarak değerleri saymak

ÇOKEĞERSAY işlevini birden çok ölçüte dayalı olarak değerleri saymak

ETOPLA işlevi tek bir ölçüte dayalı olarak değerleri toplama

ÇOKETOPLA işlevini birden çok ölçüte dayalı olarak değerleri toplama

VE işlevi

YADA işlevi

DÜŞEYARA işlevi

Excel’deki formüllere genel bakış

Bozuk formülleri önleme

Formüllerdeki hataları saptamak için hata denetimini kullanma

Mantıksal işlevler

Excel işlevleri (alfabetik)

Excel işlevleri (kategoriye göre)

Not : Makine Çevirisi Yasal Uyarısı: Bu makale, insan müdahalesi olmadan bir bilgisayar sistemi tarafından çevrilmiştir. Microsoft bu makine çevirilerini İngilizce bilmeyen kullanıcıların Microsoft ürünleri, hizmetleri ve teknolojileriyle ilgili içeriklerden yararlanmasına yardımcı olmak için sunar. Bu makale makine çevirisi olduğundan sözcük, cümle dizilimi ve gramer hataları içerebilir.

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×