EĞER işlevi: İç içe formüller ve hatalardan kaçınma

EĞER işlevi: İç içe formüller ve hatalardan kaçınma

Önemli : Bu makale makine çevisidir. Bkz. yasal uyarı. Bu makalenin İngilizce sürümüne buradan ulaşabilirsiniz.

EĞER işlevi, bir koşulu test edip Doğru veya Yanlış sonucunu döndürerek, bir değerle beklediğiniz değer arasında mantıksal karşılaştırma yapmanıza olanak tanır.

  • =EĞER(Bir şey Doğru ise, bir şey yap, değilse başka bir şey yap)

Eğer deyimi iki sonuçları çalışabilmeniz için. İlk sonuç, karşılaştırma ikinci alanınızı karşılaştırma yanlış ise, doğru ise, olur.

EĞER deyimleri son derece sağlamdır ve çoğu elektronik tablo modelinin temelini oluşturur, ancak çoğu elektronik tablo sorununun temel sebebi de bunlardır. İdeal olarak bir EĞER deyiminin Erkek/Dişi, Evet/Hayır/Belki gibi basit koşullara uygulanması gerekir, ancak bazen 3’ten çok EĞER işlevini iç içe geçirmenizi* gerektirecek daha karmaşık senaryoları değerlendirmeniz gerekebilir.

* “İç içe geçirme”, birden çok işlevi tek bir formülde birleştirme uygulamasıdır.

Bir koşul doğru olduğunda belirli bir değerin ve yanlış olduğunda başka bir değerin döndürülmesi için, mantıksal işlevlerden biri olan EĞER işlevini kullanın.

Söz dizimi

EĞER(mantıksal_sınama, eğer_doğruysa_değer, [eğer_yanlışsa_değer])

Örneğin:

  • =EĞER(A2>B2,"Bütçeyi Aşıyor","Tamam")

  • =EĞER(A2=B2,B4-A4,"")

Bağımsız değişken adı

Açıklama

mantıksal_sınama   

(gerekli)

Sınamak istediğiniz koşul.

eğer_doğruysa_değer   

(gerekli)

Mantıksal_sınama sonucu DOĞRU ise döndürülmesini istediğiniz değer.

eğer_yanlışsa_değer   

(isteğe bağlı)

Mantıksal_sınama sonucu YANLIŞ ise döndürülmesini istediğiniz değer.

Açıklamalar

Excel, farklı Eğer işlevleri en çok 64 iç içe geçirmeyin izin verir, ancak hiç Bunu yapmak için önerilir. Neden?

  • Birden fazla Eğer deyimleri düşünce düzgün oluşturma ve bunların mantığı son hücresindeyken her koşula aracılığıyla doğru şekilde hesaplayabilirsiniz emin olmak için çok gereklidir. Formül % 100 doğru bir şekilde yerleştirmeyin varsa, sonra da zaman % 75 çalışır, ancak zaman % 25 beklenmeyen sonuçlar döndürebilir. Ne yazık ki, büyük olasılıkla sizin % 25 yakalama ince.

  • Birden fazla Eğer deyimleri korumak, özellikle ne zaman biraz zaman daha sonra geri dönün ve hangi, anlamanın deneyin veya daha kötü başka birinin denedikten yapmak son derece zor olabilir.

Sonu gelmeyecekmiş gibi büyüyen bir EĞER deyimiyle karşılaşırsanız, farenizi bir kenara koyup stratejinizi yeniden ele alma zamanınız gelmiştir.

Birden çok EĞER deyimi kullanarak iç içe geçirilmiş karmaşık bir EĞER deyimi oluşturmanın doğru yoluna bakalım ve Excel cephanesindeki başka bir araca geçme zamanının geldiğini nasıl anlayacağımızı açıklayalım.

Örnekler

Aşağıdaki örnekte, öğrencilerin test puanlarının harf notuna dönüştürülmesi için kullanılan standart sayılabilecek bir iç içe EĞER deyimi gösterilmektedir.

Karmaşık iç içe Eğer deyimi - E2’deki formül =EĞER(B2>97,"A+",EĞER(B2>93,"A",EĞER(B2>89,"A-",EĞER(B2>87,"B+",EĞER(B2>83,"B",EĞER(B2>79,"B-",EĞER(B2>77,"C+",EĞER(B2>73,"C",EĞER(B2>69,"C-",EĞER(B2>57,"D+",EĞER(B2>53,"D",EĞER(B2>49,"D-","F"))))))))))))
  • =EĞER(D2>89,"A",EĞER(D2>79,"B",EĞER(D2>69,"C",EĞER(D2>59,"D","F"))))

    Bu karmaşık iç içe EĞER deyimi, kolayca anlaşılabilecek bir mantığı izler:

  1. Test Puanı (D2 hücresi) 89’dan büyükse, öğrenci A alır

  2. Test Puanı 79’dan büyükse, öğrenci B alır

  3. Test Puanı 69’dan büyükse, öğrenci C alır

  4. Test Puanı 59’dan büyükse, öğrenci D alır

  5. Diğer durumlarda ise öğrenci F alır

Kadar bakım gerektiren kalmamaları için büyük olasılıkla bağıntı arasındaki puan test edin ve harf dereceleri değiştirecek, olmadığı için bu belirli güvenli oldukça örneğidir. Burada, ancak ne notlarını A + arasında bölmek için size gereken bir düşünce – A ve A - (vb.)? Artık, dört koşul Eğer deyimi 12 koşullar için yazılması gerekir! İşte ne formülünüz şimdi gibi görünebilir:

  • =EĞER(B2>97,"A+",EĞER(B2>93,"A",EĞER(B2>89,"A-",EĞER(B2>87,"B+",EĞER(B2>83,"B",EĞER(B2>79,"B-", EĞER(B2>77,"C+",EĞER(B2>73,"C",EĞER(B2>69,"C-",EĞER(B2>57,"D+",EĞER(B2>53,"D",EĞER(B2>49,"D-","F"))))))))))))

Hala işlevsel olarak doğru olduğundan ve beklendiği gibi çalışır, ancak yazmak için zaman alıyor ve uzun mı istediğinizi emin olmak için test etmek için. Başka bir glaring puan ve eşdeğer harf dereceleri el ile girmek aranızdaki sorunudur. Bir yazım hatası yanlışlıkla olur büyük olasılıkla nelerdir? Şimdi bu 64 katı daha karmaşık koşuldan yapmak istediğinizi varsayalım! Emin, mümkündür, ancak gerçekten kendiniz için çaba ve için noktayı gerçekten sabit olası hataları bu tür konusu istiyor musunuz?

İpucu : Excel'de her işlevi bir açma ve kapatma parantezi () gerektirir. Excel yardımcı olmak çalışır nereye Siz düzenlerken formülünüz farklı bölümlerini renklendirme unsurları şekil. Örneğin, yukarıdaki formülü düzenlemek için yazacaksanız, yaparken taşıma imleci bitiş parantezlerin her geçen ")", kendi karşılık gelen açma parantezi aynı renk kapatılır. Yeterli eşleşen parantez olup olmadığını hesaplama çalışırken bu özellikle karmaşık iç içe formüllerde yararlı olabilir.

Ek örnekler

Aşağıda, ulaşılan Gelir düzeyine bağlı olarak Satış Komisyonu hesaplama için kullanılan çok yaygın bir örnek verilmiştir.

D9 hücresindeki formül, EĞER(C9>15000,%20,EĞER(C9>12500,%17,5,EĞER(C9>10000,%15,EĞER(C9>7500,%12,5,EĞER(C9>5000,%10,0)))))
  • =EĞER(C9>15000,20%,EĞER(C9>12500,17.5%,EĞER(C9>10000,15%,EĞER(C9>7500,12.5%,EĞER(C9>5000,10%,0)))))

Formülde şu denmektedir: EĞER(C9 hücresi 15.000’den Büyükse %20 döndür, EĞER(C9 hücresi 12.500’den büyükse %17,5 döndür gibi...

Kendi çok benzer biçimde önceki notlarını örnek, bu formülü nasıl zor büyük IF deyimleri – korumak için olabilir mükemmel örneği durumdayken yeni Dengeleme düzeyleri eklemek ve büyük olasılıkla bile değiştirmek, kuruluşunuzun karar verdiyseniz gerekenler Varolan dolar veya yüzde değerleri? Çok sayıda çalışma alanınızı eller üzerinde sahip olmayı tercih!

İpucu : Uzun formülleri daha kolay okunmasını sağlamak için formül çubuğunda satır sonları ekleyebilirsiniz. Yalnızca yeni bir satıra kaydırmak istediğiniz metnin önüne ALT + ENTER tuşlarına basın.

Aşağıda mantığın yanlış sırayla verildiği bir komisyon senaryosu örneği verilmiştir:

D9 hücresindeki formül düzen dışıdır =EĞER(C9>5000,10%,EĞER(C9>7500,12.5%,EĞER(C9>10000,15%,EĞER(C9>12500,17.5%,EĞER(C9>15000,20%,0)))))

Neyin yanlış olduğunu görebilir miyim? Önceki örnekte için gelir karşılaştırmalar sırasını karşılaştırın. Bu bir giderek hangi yolu var mı? Sağdan, bunu altından yukarı (5.000 TL için 15.000 TL), değil diğer yönden olacaksa olmasıdır. Ancak, bu gibi büyük anlaşma neden olmalı? Formülün ilk değerlendirme için herhangi bir değer üzerinde 5.000 TL geçirmek yapamazsınız büyük anlaşma demektir. Diyelim ki gelir $12.500 var – Eğer deyimi % 10 5000'den büyük olduğundan, ve orada durdurur döndürür. Bunlar olumsuz etkisi buluncaya kadar çok durumların içinde bu türde hataları gözden kaçan gidin çünkü bu son derece sorunlu olabilir. Bazı önemli sorunları karmaşık iç içe geçmiş Eğer deyimleri ile haberiniz olmasını sağlamak, ne yapabilirsiniz? Çoğu durumda, eğer işlevinin karmaşık bir formülle oluşturmak yerine, DÜŞEYARA işlevini kullanabilirsiniz. DÜŞEYARA İŞLEVİNİkullanarak, ilk başvuru tablo oluşturmanız gerekir:

D2 hücresindeki formül =DÜŞEYARA(C2,C5:D17,2,DOĞRU)
  • =DÜŞEYARA(C2,C5:D17,2,DOĞRU)

Bu formül, C2 değeri C5:C17 aralıktaki aramak diyor. Değer bulunursa, sonra buna karşılık gelen sütun d aynı satırındaki dönüş değeri

D9 hücresindeki formül =DÜŞEYARA(B9,B2:C6,2,DOĞRU)
  • =DÜŞEYARA(B9,B2:C6,2,DOĞRU)

Benzer şekilde, bu formülü B2:B22 aralıktaki B9 hücresinin değeri arar. Değer bulunursa, sonra buna karşılık gelen sütun c aynı satırındaki dönüş değeri

Not : Bu VLOOKUPs her ikisi de biz approxiate eşleşme görünmesini istediğinizi anlamına gelen formüller sonundaki TRUE bağımsız değişkenini kullanın. Başka bir deyişle, tam değerleri arama tablosunda yanı sıra, aralarında giren herhangi bir değeri eşleştirir. Bu örnekte arama tabloları küçükten büyüğe ile artan sırada sıralanmış gerekir.

DÜŞEYARA çok daha fazla ayrıntı buradaiçinde kapsanan, ancak bu bir düzey 12, karmaşık iç içe geçmiş Eğer deyimi çok daha basit olduğundan emin! Daha az belirgin aynı zamanda başka avantajları vardır:

  • DÜŞEYARA başvuru tabloları açıkça görülebilir ve kolayca anlaşılabilir.

  • Tablo değerleri kolayca güncelleştirilebilir ve koşullarınız değişmediği sürece formülünüze hiç dokunmanız gerekmez.

  • Başkalarının başvuru tablonuzu görmesini ya da tabloyu etkileyecek işlemler yapmasını engellemek istiyorsanız tabloyu başka bir çalışma sayfasına koymanız yeterlidir.

Biliyor muydunuz?

Birden çok, değiştirebilir bir IFS işlevi iç içe Eğer ekstreleri ve tek bir işlevi artık yoktur. Bu nedenle ilk notlarını Örneğimiz yerine, hangi 4 iç içe Eğer işlevleri bulunur:

  • =EĞER(D2>89,"A",EĞER(D2>79,"B",EĞER(D2>69,"C",EĞER(D2>59,"D","F"))))

Tek bir ÇOKEĞER işlevi ile çok daha basit bir hale getirilebilir:

  • =ÇOKEĞER(D2>89,"A",D2>79,"B",D2>69,"C",D2>59,"D",DOĞRU,"F")

ÇOKEĞER işlevi çok kullanışlıdır, çünkü EĞER deyimleriyle ve parantezlerle uğraşmanıza gerek kalmaz.

Not : Bu özelliği kullanabilmek için Office 365 aboneliğiniz olmalıdır. Office 365 abonesiyseniz, Office'in en son sürümünü kullandığınızdan emin olun.

Office 365’i veya Excel’in en son sürümünü deneyin

Daha fazla yardım mı gerekiyor?

Sorularınızı Excel Teknoloji Topluluğu’ndaki uzmanlara sorabilir, Yanıt topluluğu’ndan destek alabilir ya da Excel için UserVoice platformuna yeni bir özellik veya iyileştirme önerisi sunabilirsiniz.

İlgili Konular

Video: Gelişmiş Eğer işlevleri
IFS işlevi (Office 365, Excel 2016 ve sonrası)
EĞERSAY işlevini tek bir ölçüte dayalı olarak değerleri saymak
ÇOKEĞERSAY işlevini çoklu dayalı olarak değerleri saymak Ölçüt
ETOPLA işlevi tek bir ölçüte dayalı olarak değerleri toplama
ÇOKETOPLA işlevini birden çok ölçüte dayalı olarak değerleri toplama
ve işlevi
yada işlevini
DÜŞEYARA işlevini
Excel'deki formüllere genel bakış
bozuk formülleri önleme
Formüllerdeki hataları saptamak için kullanım hata denetimini
mantıksal işlevler
Excel işlevleri (alfabetik)
Excel işlevleri (kategoriye göre)

Not : Makine Çevirisi Yasal Uyarısı: Bu makale, insan müdahalesi olmadan bir bilgisayar sistemi tarafından çevrilmiştir. Microsoft bu makine çevirilerini İngilizce bilmeyen kullanıcıların Microsoft ürünleri, hizmetleri ve teknolojileriyle ilgili içeriklerden yararlanmasına yardımcı olmak için sunar. Bu makale makine çevirisi olduğundan sözcük, cümle dizilimi ve gramer hataları içerebilir.

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×