Dosyayı SharePoint kitaplığında kullanıma alma ve iade etme

Önemli : Bu makale makine çevisidir. Bkz. yasal uyarı. Bu makalenin İngilizce sürümüne buradan ulaşabilirsiniz.

Microsoft Windows SharePoint Services sitesindeki kitaplıktan bir dosyayı kullanıma aldığınızda, siz dosyayı düzenlerken başkalarının bu dosyada değişiklik yapamamasını sağlamış olursunuz. Dosya kullanıma alındığında, dosyayı düzenleyebilir, kapatabilir, yeniden açabilir, hatta sabit diskinizde dosyayla çalışabilirsiniz. Siz dosyayı iade edene kadar diğer kullanıcılar dosyayı değiştiremez ve sizin yaptığınız değişiklikleri göremez.

Bu makalede

Genel bakış

SharePoint kitaplığından dosya kullanıma alma

Bir SharePoint kitaplığına dosya iade et

Teslim dosyalar üzerinde çalıştığınız konumu değiştirme

Genel bakış

Dosyalarla çalışmadan önce bunları kullanıma almak, aynı dosya kümesi üzerinde çalışan birden çok kişi olduğunda çakışmaların ve karışıklığın önlenmesine yardımcı olur. Dosyayı kullanıma aldığınızda, dosyada yalnızca siz değişiklik yapabilirsiniz. İzniniz olan bir SharePoint sitesindeki herhangi bir dosyayı kullanıma alabilirsiz ve dosyaları şu 2007 Microsoft Office sistemi programlarından doğrudan kullanıma alabilirsiniz: Word, Excel, PowerPoint ve Visio.

Dosyayı iade ederken, dosyada yaptığınız değişiklikler hakkında açıklamalar yazabilirsiniz. Bu, kullanıcıların dosyanın bir sürümünden diğerine nelerin değiştiğini anlamalarına yardımcı olur. Dosya üzerinde birkaç kişi çalışıyorsa veya dosya birkaç düzeltme aşamasından geçecekse, bu işlem özellikle yararlı olacaktır. Kitaplığınız dosyaların sürümlerini izliyorsa, açıklamalarınız dosyanın sürüm geçmişinin bir parçası olur; ve bu da kullanıcılar önceki bir sürümü görmek veya geri yüklemek istediklerinde yararlı olur.

Kuruluşunuzda, dosyayı düzenlemek için önce kullanıma almanız gerekli olabilir. Kullanıma alma gerekli olduğunda, kitaplıkta dosya oluşturduğunuzda veya kitaplığa karşıdan dosya yüklediğinizde, bu dosyayı iade etmeniz gerekir.

Dosyayı kullanıma aldığınızda, dosyada yaptığınız değişiklikler siz dosyayı geri iade edene kadar başkaları tarafından görülemez. Kimi durumlarda, başkalarının değişikliklerinizi görmesi için dosyayı iade etmek ancak dosya üzerinde çalışmaya devam etmek için de dosyayı kullanımınızda tutmak isteyebilirsiniz. Dosyayı iade ettiğinizde, kitaplığınızın hem ana hem de alt sürümleri izlediği ve sizin de ana sürümü iade ettiğiniz durumlar dışında, dosya üzerinde çalışmayı sürdürmeyi seçebilirsiniz. Ana sürüm bir önceki ana sürüme göre çoğunlukla önemli ölçüde değişirken, alt sürüm bir önceki alt sürüme göre çoğunlukla çok az değişir. Örneğin, ana sürümde büyük bir parça yeni içerik bulunabilir, oysa alt sürüm yalnızca yazım hatalarının düzeltmelerini içerebilir.

Windows SharePoint Services 3.0 sitesinde dosyayı kullanıma almak için Office programlarından birini kullanırsanız, dosya varsayılan olarak sabit diskinizde Belgelerim klasöründe yer alan bir taslaklar klasöründe depolanır. Bu konumu sabit diskinizdeki veya ağdaki başka bir konumla değiştirebilir veya kullanıma alınan dosyaların siz üzerlerinde çalıştığınız sırada Web sunucusunda depolanacağını belirtebilirsiniz. Kuruluşunuzun gereksinimlerine uygun olarak yöneticiniz özel bir konum belirtebilir veya bu konumun değiştirilmesini engelleyebilir.

Microsoft Windows SharePoint Services 2.0 sitesinden bir dosyayı kullanıma aldığınızda, dosya siz üzerinde çalışırken sunucuda depolanır, ancak başkalarının yaptığınız değişiklikleri görebilmesi için yine de önce dosyayı iade etmeniz gerekir. Çoğu durumda, Windows SharePoint Services 3.0 sitesinden dosyayı kullanıma aldığınızda, dosyanın kullanımınızdayken nerede depolanacağını bildiren bir ileti alırsınız. Windows SharePoint Services 2.0 sitesinden bir dosya kullanıma aldığınızda böyle bir ileti almazsınız.

Belge kullanıma alındığında, Office programınızdaki Belge Yönetimi görev bölmesi dosyayı geri iade etmeniz için bir komut sağlar.

Dosyaların hem ana hem de alt sürümleri izleniyorsa, ana sürümü mü yoksa alt sürümü mü iade ettiğinizi seçmeniz istenebilir.

Sayfanın Başı

SharePoint kitaplığından dosyayı kullanıma alma

Office programında zaten açık olan bir dosyayı kullanıma almak için bu yordamı kullanın. Dosyayı SharePoint sitesindeki kitaplıktan da kullanıma alabilirsiniz.

Şu 2007 Office sürümü programlarında aşağıdaki işlemleri yapın:

Word, Excel veya PowerPoint

  1. düğme resmi Microsoft Office düğmesi' ı tıklatın, Server' ı tıklatın ve ardından Kullanıma Al'ıtıklatın.

    Word belgeleri çoğunlukla varsayılan olarak Tam Ekran Okuma görünümünde açılır. Bu durumda, bu adımı tamamlamadan önce Yazdırma Düzeni görünümüne geçmek için Yazdırma Düzeni'ni tıklatmanız gerekebilir.

  2. Kullanıma alındığı sırasında belgenin nerede depolandığını belirten bir ileti gösterilirse Tamam'ı tıklatın.

    Çoğu durumda, bu ileti Windows SharePoint Services 3.0 sitesinden bir dosyayı kullanıma aldığınızda gösterilir.

    İpucu : Kullanıma alındığı sırada dosyanızın nerede depolandığını belirten iletide, kullanıma alınan dosyalarla çalışmaya yönelik seçenekleri değiştirebilirsiniz.

Visio

  1. Dosya menüsünde Kullanıma Al'ı tıklatın.

  2. Kullanıma alındığı sırasında belgenin nerede depolandığını belirten bir ileti gösterilirse Tamam'ı tıklatın.

    Çoğu durumda, bu ileti Windows SharePoint Services 3.0 sitesinden bir dosyayı kullanıma aldığınızda gösterilir.

    İpucu : Kullanıma alındığı sırada dosyanızın nerede depolandığını belirten iletide, kullanıma alınan dosyalarla çalışmaya yönelik seçenekleri değiştirebilirsiniz.

Sayfanın Başı

SharePoint kitaplığına dosyayı iade etme

Office programında açık olduğunda dosyayı iade etmek için bu yordamı kullanın. Dosyayı SharePoint sitesindeki kitaplıktan da iade edebilirsiniz.

Şu 2007 Office sürümü programlarında aşağıdaki işlemleri yapın:

Word, Excel veya PowerPoint

  1. düğme resmi Microsoft Office düğmesi' ı tıklatın, Server' ı tıklatın ve sonra İade Et'Etıklayın.

    Word belgeleri çoğunlukla varsayılan olarak Tam Ekran Okuma görünümünde açılır. Bu durumda, bu adımı tamamlamadan önce Yazdırma Düzeni görünümüne geçmek için Yazdırma Düzeni'ni tıklatmanız gerekebilir.

  2. Ana sürümü mü yoksa alt sürümü mü iade edeceğiniz sorulursa, alt sürüm oluşturduysanız Alt sürüm'ü, ana sürüm oluşturduysanız Ana sürüm'ü tıklatın.

  3. Sürüm Açıklamaları kutusuna, değişiklikleriniz hakkında istediğiniz açıklamaları yazın.

    Bu açıklamalar, SharePoint kitaplığında dosyanın sürüm geçmişinin bir parçası olarak gösterilir ve başka biri önceki sürümler hakkında bilgi görüntülemek istediğinde yararlı olabilir.

  4. Bu sürüm iade edildikten sonra belge kullanımda tutulsun onay kutusu kullanılabiliyorsa, dosya üzerinde çalışmaya devam etmeyi planladığınız durumlarda bu onay kutusunu seçebilirsiniz.

    Kitaplığınız sürümleri izlemiyorsa, tüm sürümleri aynı yolla izliyorsa veya alt sürümü iade ediyorsanız bu seçeneği kullanabilirsiniz. Ana sürüm iade ediyorsanız veya dosya yayımlıyorsanız bu seçenek kullanılamaz.

Visio

  1. Dosya menüsünde İade Et'i tıklatın.

  2. Ana sürümü mü yoksa alt sürümü mü iade edeceğiniz sorulursa, alt sürüm oluşturduysanız Alt sürüm'ü, ana sürüm oluşturduysanız Ana sürüm'ü tıklatın.

  3. Sürüm Açıklamaları kutusuna, değişiklikleriniz hakkında istediğiniz açıklamaları yazın.

    Bu açıklamalar, SharePoint kitaplığında dosyanın sürüm geçmişinin bir parçası olarak gösterilir ve başka biri önceki sürümler hakkında bilgi görüntülemek istediğinde yararlı olabilir.

  4. Bu sürüm iade edildikten sonra belge kullanımda tutulsun onay kutusu kullanılabiliyorsa, dosya üzerinde çalışmaya devam etmeyi planladığınız durumlarda bu onay kutusunu seçebilirsiniz.

    Kitaplığınız sürümleri izlemiyorsa, tüm sürümleri aynı yolla izliyorsa veya alt sürümü iade ediyorsanız bu seçeneği kullanabilirsiniz. Ana sürüm iade ediyorsanız veya dosya yayımlıyorsanız bu seçenek kullanılamaz.

Sayfanın Başı

Kullanıma alınan dosyalarla çalıştığınız konumu değiştirme

Bu ayar, kullanıma aldığınız bir sonraki dosyayla çalıştığınız konumu değiştirir. Şu anda kullanıma alınmış bir dosyayla çalışıyorsanız, bu yordam söz konusu dosyanın konumunu değiştirmez.

Şu 2007 Office sürümü programlarında aşağıdaki işlemleri yapın:

Word, Excel veya PowerPoint

  1. Microsoft Office düğmesi düğme resmi tıklatın ve programınıza yönelik Seçenekler'i tıklatın: Word Seçenekleri, Excel Seçenekleriveya PowerPoint Seçenekleri.

  2. Görüntülenen iletişim kutusunda Kaydet'i tıklatın.

  3. Belge yönetim sunucusu dosyaları için çevrimdışı düzenleme seçenekleri bölümünde aşağıdakilerden birini yapın:

    • Kullanıma alınan dosyalarla sabit diskinizde veya ağ konumunda çalışmak için aşağıdaki yordamı kullanın:

      1. Kullanıma alınan dosyaların kaydedileceği konum altında Bu bilgisayarda sunucu taslaklarının konumu'nu tıklatın.

      2. Sunucu taslakları konumu kutusunda, sabit diskinizde kullanıma alınan dosyalarla çalışmak istediğiniz konumu yazın veya konum bulmak için Gözat'ı tıklatın.

    • Kullanıma alınan dosyalarla Web sunucusunda çalışmak için, Kullanıma alınan dosyaların kaydedileceği konum altında Web sunucusu'nu tıklatın.

      Bu seçeneği belirttiğinizde, kullanıma alınan dosyalarla, dosyalarınızın depolandığı Web sunucusunda veya sitede çalışırsınız. Belirlenen konumu özelleştiremezsiniz.

  4. Tamam'ı tıklatın.

Visio

  1. Araçlar menüsünde Seçenekler'i tıklatın.

  2. Seçenekler iletişim kutusunda Genel sekmesini tıklatın ve sonra da Hizmet Seçenekleri'ni tıklatın.

  3. Görüntülenen iletişim kutusunda Çevrimdışı Düzenleme Seçenekleri'ni tıklatın.

  4. Belge yönetim sunucusu dosyaları için çevrimdışı düzenleme seçenekleri bölümünde aşağıdakilerden birini yapın:

    • Kullanıma alınan dosyalarla sabit diskinizde veya ağ konumunda çalışmak için aşağıdaki yordamı kullanın:

      1. Kullanıma alınan dosyalarla sabit diskinizde çalışmak için, Kullanıma alınan dosyaların kaydedileceği konum altında Bu bilgisayarda sunucu taslaklarının konumu'nu tıklatın.

      2. Sunucu taslakları konumu altında, sabit diskinizde kullanıma alınan dosyalarla çalışmak istediğiniz konumu yazın veya konum bulmak için Gözat'ı tıklatın.

    • Kullanıma alınan dosyalarla sunucu konumunda çalışmak için, Kullanıma alınan dosyaların kaydedileceği konum altında Web sunucusu'nu tıklatın.

      Bu seçeneği belirttiğinizde, kullanıma alınan dosyalarla, dosyalarınızın depolandığı Web sunucusunda veya sitede çalışırsınız. Belirlenen konumu özelleştiremezsiniz.

  5. Tamam'ı tıklatın.

Sayfanın Başı

Not : Makine Çevirisi Yasal Uyarısı: Bu makale, insan müdahalesi olmadan bir bilgisayar sistemi tarafından çevrilmiştir. Microsoft bu makine çevirilerini İngilizce bilmeyen kullanıcıların Microsoft ürünleri, hizmetleri ve teknolojileriyle ilgili içeriklerden yararlanmasına yardımcı olmak için sunar. Bu makale makine çevirisi olduğundan sözcük, cümle dizilimi ve gramer hataları içerebilir.

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×