Bozulan bir çalışma kitabını onarma

Microsoft Excel, açıldıktan sonra bozuk bir çalışma kitabı algılarsa, otomatik olarak Dosya Kurtarma modunu başlatır ve çalışma kitabını onarmaya çalışır. Dosya Kurtarma modu başlamazsa, çalışma kitabınızı kurtarmak için bu kılavuzu kullanmayı deneyin.

  1. Dosya > 'ı tıklatın.

  2. Bozuk çalışma kitabının bulunduğu konumu ve klasörü tıklatın.

  3. iletişim kutusunda, bozuk çalışma kitabını seçin.

  4. düğmesinin yanındaki oku, daha sonra Aç ve Onar'ı tıklatın.

    Aç ve Onar komutu

  5. Olabildiğince fazla çalışma kitabı verisi kurtarmak için Onar'ı seçin.

    Onar komutu verilerinizi onaramazsa, çalışma kitabındaki değerleri ve formülleri ayıklamak için Veri Ayıkla'yı tıklatın.

Otomatik ve elle onarım işlemleri işe yaramazsa, verilerinizi kurtarmaya yardımcı olabilecek bazı kurtarma yöntemleri vardır. Çalışmalarınızı kaybetmeyi önlemek için çalışma kitabınızın otomatik bir kopyasını kaydetme ya da zaman zaman kurtarma dosyası oluşturma gibi önleyici önlemler de alabilirsiniz.

Bozulan bir çalışma kitabından veri kurtarma

Çalışma kitabının yedek kopyasını otomatik olarak kaydetme

Belirli aralıklarla otomatik olarak kurtarma dosyası oluşturma

Bozulan bir çalışma kitabından veri kurtarma

Verilerinizi kurtarmaya yardımcı olması için aşağıdaki yöntemlerden birini seçin.Bir yöntem başarısız olursa, bir diğerini deneyebilirsiniz. Çalışma kitabını kurtarmak için üçüncü taraf yazılım çözümlerini de deneyebilirsiniz.

Önemli : Bir disk hatası veya ağ hatası çalışma kitabını açmanızı engelliyorsa, aşağıdaki kurtarma seçeneklerinden herhangi birini denemeden önce, çalışma kitabını farklı bir sabit disk sürücüsüne veya yerel diske taşıyın.

Çalışma kitabı Excel'de açık durumdayken veri kurtarma

  • Çalışma kitabını en son kayıtlı sürüme döndürme     Çalışırken değişikliklerinizi kaydetmeden önce çalışma kitabı bozulursa, çalışma kitabınızı son kayıtlı sürüme döndürebilirsiniz.

    1. Dosya > 'ı tıklatın.

    2. Excel'de açık olan çalışma kitabının adını çift tıklatın.

    3. Çalışma kitabını yeniden açmak için Evet'i tıklatın.

      Çalışma kitabı, yaptığınız ve bozulmasına yol açmış olabilecek hiçbir değişiklik olmadan açılır.

Çalışma kitabını Excel'de açamadığınızda verileri kurtarma

  • Excel'de hesaplama seçeneğini el ile ayarlama    Hesaplama ayarını otomatik yerine el ile olarak değiştirmeyi deneyin. Çalışma kitabı yeniden hesaplanmayacağı için açılabilir.

    1. Dosya > Yeni'yi tıklatın.

    2. Yeni altında. Boş çalışma kitabı'nı tıklatın.

    3. Dosya > Seçenekler'i tıklatın.

    4. Formüller kategorisinde, Hesaplama seçenekleri'nin altında El ile seçeneğini belirleyin ve ardından Tamam'ı tıklatın.

    5. Dosya > 'ı tıklatın.

    6. Bozuk çalışma kitabını bulun ve açmak için çift tıklatın.

  • Bozuk çalışma kitabına bağlanmak için dış başvuruları kullanma    Çalışma kitabından formülleri veya değerleri değil, yalnızca verileri almak için, bozuk çalışma kitabına bağlanmak için dış başvuruları kullanmayı deneyebilirsiniz.

    1. Dosya > 'ı tıklatın.

    2. Bozuk çalışma kitabını içeren klasöre gidin.

    3. Bozuk çalışma kitabının dosya adını sağ tıklatın, Kopyala'yı tıklatın ve ardından İptal'i tıklatın.

    4. Dosya > Yeni'yi tıklatın.

    5. Yeni altında Boş çalışma kitabı'nı tıklatın.

    6. Yeni çalışma kitabının A1 hücresine =Dosya Adı!A1 (burada, Dosya Adı 3. adımda kopyaladığınız bozuk çalışma kitabının adıdır) ve Enter tuşuna basın.

      Not : Yalnızca çalışma kitabının adını girmeniz yeterlidir; dosya adı uzantısını yazmanız gerekmez.

    7. Değerleri Güncelleştir iletişim kutusu görünürse, bozuk çalışma kitabını seçin ve ardından Tamam'ı tıklatın.

    8. Sayfa Seç iletişim kutusu görünürse, uygun sayfayı seçin ve ardından Tamam'ı tıklatın.

    9. A1 hücresini seçin.

    10. Giriş > Kopyala'yı tıklatın ya da Ctrl+C tuşlarına basın.

    11. A1 hücresinden başlayarak, bozuk çalışma kitabındaki verileri içeren hücre aralığının boyutuyla hemen hemen aynı olan bir alan seçin.

    12. Giriş > Yapıştır'ı tıklatın ya da Ctrl+V tuşlarına basın.

    13. Hücre aralığı halen seçili durumdayken, tekrar Giriş > Kopyala'yı tıklatın ya da Ctrl+C tuşlarına basın.

    14. Giriş > Yapıştır'ın altındaki oku tıklatın ve ardından Değerleri Yapıştır'ın altında Değerler'i tıklatın.

      Değerleri yapıştırma, bozuk dosyaya olan bağlantıları kaldırıp geriye yalnızca verileri bırakır.

  • Bozuk bir çalışma kitabından veri ayıklamak için makro kullanma    Bozuk çalışma kitabıyla bağlantılı bir grafik varsa, grafiğin kaynak verilerini ayıklamak için bir makro kullanmayı deneyin.

    1. Aşağıdaki makro kodunu bir modül sayfasına kopyalayıp yapıştırın:

      Sub GetChartValues()

      Dim NumberOfRows As Integer

      Dim X As Object

      Counter = 2

      ' Verilerin satır sayısını hesaplayın.

      NumberOfRows = UBound(ActiveChart.SeriesCollection(1).Values)

      Worksheets("GrafikVerileri").Cells(1, 1) = "X Değerleri"

      ' Çalışma sayfasına x ekseni değerlerini yazın.

      With Worksheets("GrafikVerileri")

      .Range(.Cells(2, 1), _

      .Cells(NumberOfRows + 1, 1)) = _

      Application.Transpose(ActiveChart.SeriesCollection(1).XValues)

      End With

      ' Grafikteki tüm serilerde döngü yapın ve değerlerini

      ' çalışma sayfasına yazın.

      For Each X In ActiveChart.SeriesCollection

      Worksheets("GrafikVerileri").Cells(1, Counter) = X.Name

      With Worksheets("GrafikVerileri")

      .Range(.Cells(2, Counter), _

      .Cells(NumberOfRows + 1, Counter)) = _

      Application.Transpose(X.Values)

      End With

      Counter = Counter + 1

      Next

      End Sub

    2. Çalışma kitabınıza yeni bir çalışma sayfası ekleyin veya silin, sayfa sekmesine sağ tıklayın ve ardından GrafikVerileri olarak yeniden adlandırın.

    3. Temel veri değerlerini ayıklamak istediğiniz grafiği seçin.

      Not : Grafik, çalışma sayfasına veya ayrı bir grafik sayfasına eklenebilir.

    4. GetChartValues makrosunu çalıştırın.

    5. Grafikteki veriler, GrafikVerileri çalışma sayfasına yerleştirilir.

Sayfanın Başı

Çalışma kitabının yedek kopyasını otomatik olarak kaydetme

Çalışma kitabınızın yedek kopyası ile, yanlışlıkla silindiğinde veya bozulduğunda her zaman çalışma kitabınıza erişebilirsiniz.

  1. Dosya > Farklı Kaydet'i tıklatın.

  2. Bilgisayar'ı tıklatın ve ardından Gözat düğmesini tıklatın.

    Gözat düğmesi

  3. Farklı Kaydet iletişim kutusunda Araçlar'ın yanındaki oka tıklayın ve ardından Genel Seçenekler'e tıklayın.

    Araçlar menüsünde Genel Seçenekler

  4. Genel Seçenekler iletişim kutusunda Her zaman yedekle kutusunu seçin.

    Her zaman Genel Seçenekler iletişim kutusunda yedekleme seçeneği oluşturun

Sayfanın Başı

Belirli aralıklarla otomatik olarak kurtarma dosyası oluşturma

Çalışma kitabınızın kurtarma dosyası, çalışma kitabınız yanlışlıkla silindiğinde veya bozulduğunda verilerinize erişebilmenizi sağlar.

  1. Dosya > Seçenekler'i tıklatın.

  2. Kaydet kategorisinde, Çalışma kitaplarını kaydet'in altında, Otomatik Kurtarma bilgilerini kaydetme sıklığı kutusunu işaretleyin ve dakika sayısını girin. (Varsayılan 10.)

    Excel Seçenekleri iletişim kutusunda Kaydetme sekmesinde Otomatik Kurtarma seçeneği

  3. Otomatik Kurtarma dosyası konumu kutusuna kurtarma dosyasını kaydetmek istediğiniz konumu girin.

  4. Otomatik Kurtarma'yı yalnızca bu çalışma kitabı için devre dışı bırak onay kutusunun işaretli olmadığından emin olun.

Sayfanın Başı

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×