Bozuk formülleri önleme

Önemli : Bu makale makine çevisidir. Bkz. yasal uyarı. Bu makalenin İngilizce sürümüne buradan ulaşabilirsiniz.

Formüllerin beklenmedik sonuçlar veya hatalar vermesi, özellikle bundan sonra ne yapacağınızı bilmediğiniz durumlarda çok rahatsız edici olabilir.

Çeşitli yanlışlıklar yapılmış olabilir. Örneğin, eşleşmeyen parantezler, yazım hataları ve var olmayan aralıklardaki verilere başvurular bulunabilir. Aşağıdaki en iyi yöntemler, formüllerinizi oluşturur veya düzeltmeniz gerekirken sık yapılan hataları önlemenize veya çözmenize yardımcı olabilir.

Bu en iyi yöntemi kullanın:

Bu sık yapılan hatayı önleyin:

Tüm işlevlere eşittir işaretiyle (=) başlayın

Girdiniz eşittir işaretiyle başlamıyorsa, bir formül değildir ve hesaplanmaz; çok kolay yapılabilecek yaygın bir hata.

Örneğin TOPLA(A1:A10) gibi bir şey yazdığınızda, Excel Online formül sonucu yerine TOPLA(A1:A10) metin dizesini gösterir. Öte yandan 11/2 yazarsanız, 11’in 2’ye bölümü yerine 2-Kas veya 02/11/2009 gibi bir tarih görürsünüz.

Bu beklenmeyen sonuçları önlemek için, her zaman eşittir işaretiyle başlayın. Örneğin, şöyle yazın: =TOPLA(A1:A10) ve =11/2

Tüm açma ve kapatma parantezlerini eşleştirin

Tüm parantezlerin, eşleşen bir çiftin parçası olduğundan emin olun. İşlev kullanılan bir formülde, işlevin doğru çalışması için her açma parantezinin bir de kapatma parantezi olmalıdır.

Örneğin, =EĞER(B5<0);"Geçerli değil";B5*1,05) formülü iki kapatma parantezi varken yalnızca bir açma parantezi olduğundan çalışmayacaktır.

Doğru formül şöyle görünebilir: =EĞER(B5<0,"Geçerli değil",B5*1,05).

Gerekli tüm bağımsız değişkenleri girin

Çoğu işlevde, bağımsız değişkenler gerekir; bunlar, işlevin çalışması için sağlamanız gereken değerlerdir. Hiçbir bağımsız değişken almayan yalnızca birkaç işlev vardır ( veya BUGÜN gibi). Eşittir işareti koyarak başladığınız ve arkasından bir işlev gelen formül sözdizimini denetleyerek tüm gereken bağımsız değişkenleri (ne fazla ne de az) girdiğinizden emin olun.

Örneğin, BÜYÜKHARF işlevi kendi bağımsız değişkeni olarak yalnızca bir metin dizesi veya hücre başvurusu kabul eder: =BÜYÜKHARF("merhaba") veya =BÜYÜKHARF(C2)

Ayrıca TOPLA gibi bazı işlevlere yalnızca sayısal bağımsız değişkenler gerekirken DEĞİŞTİR gibi diğer işlevlere bağımsız değişkenlerinin en az biri için bir metin değeri gerekir. Yanlış veri türü kullanırsanız bazı işlevler beklenmeyen sonuçlar döndürebilir veya #DEĞER! hatası gösterebilir.

Formüllerde biçimlendirilmemiş sayılar kullanın

Formüllere dolar işaretleriyle ($) veya ondalık ayırıcılarla (,) biçimlendirilmiş sayılar girmeyin, çünkü dolar işaretleri mutlak başvuruları gösterir ve virgüller de bağımsız değişken ayırıcılarıdır. Formül hesaplamasında biçimlendirilmiş sayılar kullanılmaz. Formülde $1,000 yerine 1000 girin.

Bağımsız değişkenlerde biçimlendirilmiş sayılar kullanırsanız, beklenmeyen hesaplama sonuçları alabileceğiniz gibi #SAYI! hatası da görebilirsiniz. Örneğin, -2134’ün mutlak değerini bulmak için =MUTLAK(-2,134) girerseniz, Excel Online #SAYI! hatasını gösterir çünkü MUTLAK işlevi tek bir bağımsız değişken kabul eder.

Biçimlendirilmemiş sayılar kullanıp formülü girdikten sonra, bir sayı biçimi uygulayarak formül sonucunu ondalık ayırıcılar ve para birimi simgeleriyle biçimlendirebilirsiniz.

Hücre için doğru veri türünü kullanın

Hücrenin veri türü hesaplamalarda kullanılamıyorsa, formülünüz beklenen sonuçları döndürmeyebilir.

Örneğin, metin olarak biçimlendirilmiş bir hücreye =2+3 gibi basit bir formül girerseniz, Excel Online girdiğiniz verileri hesaplayamaz. Hücrede yalnızca =2+3 metnini görürsünüz.

Bunu düzeltmek için, hücrenin Metin olan veri türünü Genel olarak değiştirin; şöyle:

  1. Hücreyi seçin.

  2. Giriş > Sayı Biçimi okunu tıklatın ve Genel’i seçin.

  3. Hücreyi Düzenleme moduna geçirmek için F2 tuşuna basın ve formülü kabul etmek için ENTER tuşuna basın.

Sayı veri türündeki bir hücreye tarih girdiğinizde, tarih olarak değil de sayısal bir tarih değeri olarak gösterilebilir. Bu sayıyı tarih olarak göstermek için, Sayı Biçimi galerisinden bir Tarih biçimi seçin.

Sayıları çarpmak için * simgesini kullanın

Formülde çarpma işleci olarak x kullanmak isteyebilirsiniz; ancak bunun yerine yıldız işareti (*) kullanmalısınız.

Formülünüzde x kullandığınızda, Excel Online sonucu hesaplayamaz ve bunun yerine hücrede formülü gösterir. Formül hatası olduğunu belirtmek için de hücrenin çevresine kırmızı noktalı bir çerçeve yerleştirir.

Formüllerin içindeki metinleri çift tırnak içine alın

Metin içeren bir formül oluşturuyorsanız metni çift tırnak işareti içine alın.

Örneğin, ="Bugün " & METİN(BUGÜN(),"gg aaaa gggg") formülü, "Bugün " metnini METİN ve BUGÜN işlevlerinin sonuçlarıyla birleştirir ve hücrede Bugün 30 Mayıs Pazartesi metnini döndürür.

Formülde, Bugün sözcüğüyle 30 Mayıs Pazartesi sözcükleri arasında bir boşluk sağlamak için "Bugün " metnindeki kapatma tırnak işaretinden önce bir boşluk eklenmiştir. Metin tırnak içine alınmadığında formül #AD? hatası gösterebilir.

Formülde 64’ten fazla işlevi iç içe yerleştirmeyin

Formülün içinde en çok 64 işlev düzeyini birleştirebilir veya iç içe kullanabilirsiniz.

Örneğin =EĞER(KAREKÖK(Pİ())<2,"İkiden küçük!","İkiden büyük!") formülünde 3 işlev düzeyi vardır: Pİ işlevi, KAREKÖK işlevinin içine ve bu işlev de EĞER işlevinin içine yerleştirilmiştir.

Sayısal değerleri sıfıra bölmekten kaçının

Bir hücrenin sıfır (0) içeren veya hiç değer içermeyen bir hücreye bölünmesi, #BÖL/0! hatasıyla sonuçlanır.

Bu hatadan kaçınmak için, bölme işleminizi EĞERHATA işlevinin içine yerleştirin. Örneğin, çalışma sayfasındaki hücrelere aşağıdaki iki formülü girin:

=EĞERHATA(3/0,0)

=EĞERHATA(3/7,0)

İlk formülde, EĞERHATA işlevi sıfıra bölme işleminin hatayla sonuçlanacağını fark ettiğinden 0 sonucunu döndürür. İkinci formülde 3/7 işleminin sonucu döndürülür; sıfıra bölmediğiniz için burada hata yoktur.

Formüllerinizi oluşturmayı kolaylaştırmak için, şu formül ipuçlarını ve püf noktalarını da öğrenmek isteyebilirsiniz.

Not : Makine Çevirisi Yasal Uyarısı: Bu makale, insan müdahalesi olmadan bir bilgisayar sistemi tarafından çevrilmiştir. Microsoft bu makine çevirilerini İngilizce bilmeyen kullanıcıların Microsoft ürünleri, hizmetleri ve teknolojileriyle ilgili içeriklerden yararlanmasına yardımcı olmak için sunar. Bu makale makine çevirisi olduğundan sözcük, cümle dizilimi ve gramer hataları içerebilir.

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×