Birden çok koşula dayalı olarak değerleri toplama

Verileri birden çok koşula dayalı olarak toplamak, örneğin belirli bir ürünün belirli bir bölgedeki satış toplamını öğrenmek istiyorsanız, formülde ÇOKETOPLA işlevini kullanabilirsiniz.

Buradaki örneğimizde iki koşulumuz var: Güney bölgesinde (A sütunundan) Et satışlarının (C sütunundan) toplamını almak istiyoruz.

Excel çalışma sayfasındaki veriler

İşte kullanacağınız formül:

=ÇOKETOPLA(D2:D11,A2:A11,”Güney”,C2:C11,”Et”)Sonuç 14719 çıkar. Şimdi de formülün nasıl çalıştığını görelim.

=ÇOKETOPLA aritmetik bir formüldür ve sayıları toplar. Bu örnekte sayılarımız D sütunundadır. Öyleyse öncelikle formüle sayıların yerini bildirelim:

  • =ÇOKETOPLA(D2:D11,

Bir başka deyişle, formülün, bu sütunda olup koşulları karşılayan sayıları toplamasını istiyoruz. Bu hücre aralığı ilk bağımsız değişkeniniz (işlevin çalışması için gerekli veri parçası) olur.

İki koşulu karşılayan verileri bulmak istiyoruz. Öyleyse, ilk koşulumuzu girmek için formüle verilerin bulunduğu yeri (A2:A11) ve koşulumuzu (yani "Güney") bildirelim. Bağımsız değişkenler arasında noktalı virgül olduğuna dikkat edin.

  • =ÇOKETOPLA(D2:D11;A2:A11;”Güney”;

“Güney” sözcüğünün tırnak içine alınması Excel'e burada metin verisi kullanıldığını söyler.

Son olarak, ikinci koşul için bağımsız değişkenleri, yani "et" sözcüğünü içeren hücre aralığını (C2:C11) ve Excel'in eşleştirebilmesi için sözcüğün kendisini (tırnaklar içinde) girin. Formülü kapanış paranteziyle ) bitirip Enter tuşuna bastığınızda 14719 sonucu elde edilir.

  • =ÇOKETOPLA(D2:D11,A2:A11,”Güney”,C2:C11,”Et”)

ÇOKETOPLA işlevini yazarken bağımsız değişkenleri hatırlayamazsanız, yardım elinizin altındadır. =ÇOKETOPLA( yazdıktan sonra formülün hemen altında beliren Formülü Otomatik Tamamlama ipucunda, olması gereken sırada bağımsız değişkenlerin listesi verilir.

Formülü Otomatik Tamamlama ve bağımsız değişken listesinin resmine baktığımızda, örneğimize göre toplam_aralığı yani D2:D11, toplamını almak istediğimiz sayıların bulunduğu sütundur; ölçüt_aralığı1 yani A2:A11, ölçüt1 yani “Güney” ölçütünün bulunduğu veri sütunudur.

ÇOKETOPLA işlevini girmek için Formülü Otomatik Tamamlama ipucunu kullanma

Siz yazarken, Formülü Otomatik Tamamlama'da bağımsız değişkenlerin kalanı da belirir; ölçüt_aralığı2 yani C2:C11, ölçüt2 yani “Et ürünleri” ölçütünün bulunduğu veri sütunudur.

Bir de kendiniz deneyin

Aşağıdaki tabloda yer alan tüm verileri kopyalayın ve yeni bir çalışma sayfasında A1 hücresine yapıştırın. Formülleri daha iyi görebilmek için sütun genişliklerini ayarlayabilirsiniz.

Bölge

Satış Elemanı

Yazılan metin

Satışlar

Güney

Ito

İçecekler

3571

Batı

Lannin

Süt ürünleri

3338

Doğu

Makovec

İçecekler

5122

Kuzey

Makovec

Süt ürünleri

6239

Güney

Jordan

Ürün

8677

Güney

Lannin

Et ürünleri

450

Güney

Lannin

Et ürünleri

7673

Doğu

Makovec

Ürün

664

Kuzey

Lannin

Ürün

1500

Güney

Jordan

Et ürünleri

6596

Formül

 

Açıklama

Sonuç

'=ÇOKETOPLA(D2:D11,A2:A11,
"Güney", C2:C11,"Et ürünleri")

Güney bölgesindeki
C Sütunundaki
Et Satışlarını A Sütununda toplar (sonuç 14719'dur).

=ÇOKETOPLA(D2:D11,A2:A11,
"Güney", C2:C11,"Et ürünleri")

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×