Bir veya daha fazla dizideki ilgili değerlerin çarpımını toplamak için TOPLA.ÇARPIM kullanma

Önemli : Bu makale makine çevisidir. Bkz. yasal uyarı. Bu makalenin İngilizce sürümüne buradan ulaşabilirsiniz.

TOPLA.ÇARPIM işlevi bağımsız değişken (formülün çalışmasını sağlayan bölümleri) olarak hücre aralıklarını (veya dizileri) kullanır. Dizideki öğeleri birbiriyle çarpar ve sonra sonucu toplar.

Buradaki örnek bir market alışveriş listesidir; bir dizide her öğenin fiyatı listelenir ve diğer dizide de satın alınacak öğelerin sayısı listelenir.

Çarpılıp toplanacak fiyatlar ve miktarlar

  1. Formülü oluşturmak için, =TOPLA.ÇARPIM(B3:B6,C3:C6) yazıp Enter tuşuna basın.

B sütunundaki her hücre, aynı satırın C sütununda kendisine karşılık gelen hücreyle çarpılır ve sonuçlar toplanır. Market alışverişinin toplam tutarı 21,60 ABD Dolarıdır.

  1. Uzun bir formül yazmak için siz aynı sonucu, türü veren = B3 * C3 + B4 * C4 + B5 * C5 + B6 * C6 yazıp Enter tuşuna basın.

Enter tuşuna basıldığında sonuç aynı olacaktır: 21,60 ABD Doları. B3 hücresi C3 ile çarpılır ve sonucu B4 hücresiyle C4 hücresinin çarpımına eklenir ve bu şekilde ilerler. Yüzlerce (hatta binlerce) satırınız olduğunu düşünürseniz, TOPLA.ÇARPIM işlevini kullanmanın işinizi ne kadar kolaylaştıracağını anlayabilirsiniz.

Notlar : 

  • Sütunlar veya satırlar (diziler) eşit uzunlukta olmalıdır.

  • Bir hücrede sayı yerine metin varsa, bunun değeri sıfır kabul edilir.

Örnek

TOPLA ÇARPIM ve dizilerle alıştırma yapmak isterseniz bu makaledeki farklı verileri kullanan bu Excel Online çalışma kitabına göz atabilirsiniz.

Aşağıdaki tabloda yer alan örnek verileri kopyalayın ve yeni bir Excel çalışma sayfasının A1 hücresine yapıştırın. Formüllerin sonuçları göstermesi için, bunları seçin, F2'ye basın ve sonra da Enter tuşuna basın. Gerek duyarsanız, verilerin tümünü görmek için sütun genişliklerini ayarlayabilirsiniz.

Bir

B

İ

E

3

4

2

7

8

6

6

7

1

9

5

3

Formül

Sonuç

'=TOPLA.ÇARPIM(A2:B4,D2:E4)

=TOPLA.ÇARPIM(A2:B4, D2:E4)

İki dizide (A2:B4 ve D2:E4) yer alan tüm bileşenleri çarpar; sonra da çarpımları toplar: 3*2 + 4*7 + 8*6 + 6*7 + 1*5 + 9*3 (156)

Daha eksiksiz bir deneyim için bu çalışma kitabını Excel'de de açabilirsiniz. Bunun için tek yapmanız gereken çalışma kitabının sağ alt köşesindeki Excel simgesini   Excel Web App'teki Excel simgesi tıklatmak ve bilgisayarınızda uygun bir yere kaydettikten sonra dosyayı açmaktır.

Sayfanın Başı

Not : Makine Çevirisi Yasal Uyarısı: Bu makale, insan müdahalesi olmadan bir bilgisayar sistemi tarafından çevrilmiştir. Microsoft bu makine çevirilerini İngilizce bilmeyen kullanıcıların Microsoft ürünleri, hizmetleri ve teknolojileriyle ilgili içeriklerden yararlanmasına yardımcı olmak için sunar. Bu makale makine çevirisi olduğundan sözcük, cümle dizilimi ve gramer hataları içerebilir.

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×