Bir liste kutusunu, açılan liste kutusunu veya açılan kutuyu doldurmak için SQL Server veritabanından gelen değerleri kullanma

Önemli : Bu makale makine çevisidir. Bkz. yasal uyarı. Bu makalenin İngilizce sürümüne buradan ulaşabilirsiniz.

Microsoft SQL Server veritabanına yönelik bir sorgu veri bağlantısından gelen verilerle liste kutusunu, açılan liste kutusunu veya açılan kutuyu doldurabilirsiniz.

Bu makalede

Genel bakış

Başlamadan önce

Adım 1: sorgu veri bağlantısı ekleme

Adım 2: denetimi yapılandırma

Genel Bakış

Liste kutusu, açılan liste kutusu veya açılan kutu, form şablonunuzu temel alan bir formu doldururken bir kullanıcının seçebileceği öğeleri görüntüler. Microsoft SQL Server veritabanına yönelik ikincil bir veri bağlantısından gelen verileri göstermek için bu denetim türlerini yapılandırabilirsiniz. İkincil veri bağlantısı, bu form şablonunu temel alan bir formu dolduran kullanıcıların Web hizmeti gibi bir dış veri kaynağından veri alabilmesini ya da bu dış kaynağa veri gönderebilmesini sağlamak için form şablonuna eklediğiniz dış kaynağa yönelik herhangi bir veri bağlantısıdır.

Yaptığınız gibi veri karşılık gelen bir ikincil veri bağlantısını form şablonunuzda, Microsoft Office InfoPath sorguları veri veri kaynağı bir ikincil veri alanlarını ve gruplarla oluşturur eklediğinizde veritabanında depolanır. Sorgu veri bağlantısını Web hizmetinden alınan verileri alır ve bu verileri form ikincil veri kaynağı depolar. Varsayılan olarak, kullanıcılar bir ağına bağlıyken ikincil veri kaynağındaki veriler kullanılabilir. Böylece formlarına ağa bağlı değilken verilere erişimleri sorgunun sonuçlarını kullanıcılarınızın bilgisayarlarda kaydetmek için ikincil veri bağlantısını yapılandırabilirsiniz.

Güvenlik Notu : Dış veri kaynağından önemli verileri almak için ikincil bir veri bağlantısı kullanıyorsanız, bilgisayarın kaybolması veya çalınması durumunda verilerin yetkisiz kullanıma karşı korunmasına yardımcı olmak için, bu özelliği devre dışı bırakmak isteyebilirsiniz. Bu özelliği devre dışı bırakırsanız, veriler ancak kullanıcı ağa bağlı olduğunda kullanılabilecektir.

İkincil veri kaynağındaki veri yapısının ve verilerin veritabanında depolanma biçiminin eşleşmesi gerektiğinden dolayı, ikincil veri kaynağında varolan alanları veya grupları değiştirmezsiniz. Ayrıca Bkz. bölümünde veri bağlantıları ve veri kaynakları hakkında daha fazla bilgi için bağlantılar bulabilirsiniz.

Sayfanın Başı

Başlamadan önce

Form şablonunuzdaki bir denetimi doldurmak amacıyla SQL Server veritabanını kullanabilmek için önce veritabanı yöneticinizden aşağıdaki bilgileri edinmeniz gerekir:

  • Bu form şablonuyla kullanacağınız veritabanını içeren sunucunun adı.

  • Bu form şablonuyla kullanacağınız veritabanının adı.

  • Veritabanının gerektirdiği kimlik doğrulaması. Veritabanı, kullanıcıların veritabanına nasıl erişeceğini belirlemek için Microsoft Windows kimlik doğrulamasını veya SQL Server kimlik doğrulamasını kullanır.

  • Forma göndermek istediğiniz verileri içeren tablonun adı. Buna birincil tablo adı verilir. Veritabanında birden çok tablo kullanmayı planlıyorsanız, diğer alt tabloların adını bilmeniz gerekir. Ayrıca, birincil tablodaki alanlarla ilişkisi bulunan alt tablodaki alanların adını da bilmeniz gerekir.

  • Çevrimdışı kullanım için sorgu sonuçlarını kullanıcılarınız bilgisayarlarında güvenli bir şekilde depolayıp depolayamayacağınız.

Sayfanın Başı

Adım 1: Sorgu veri bağlantısı ekleme

Form şablonunuzdaki kullanabileceğiniz varolan bir sorgu veri kaynağını yoksa, bu sorgular verileri form şablonunuz için ikincil veri bağlantısı eklemek için aşağıdaki adımları izleyin. Form şablonunuzu kullanabileceğiniz bir ikincil veri bağlantısı zaten varsa, bu bölümü atlayabilir ve gidin Adım 2: denetimi yapılandırma.

  1. Araçlar menüsünde Veri Bağlantıları'nı tıklatın.

  2. Veri Bağlantıları iletişim kutusunda Ekle'yi tıklatın.

  3. Veri Bağlantı Sihirbazı'nda Yani bir bağlantı oluştur'u, Veri al'ı, ardından İleri'yi tıklatın.

  4. Sihirbazın bir sonraki sayfasında, Veritabanı (Yalnızca Microsoft SQL Server veya Microsoft Office Access) seçeneğini ve ardından İleri'yi tıklatın.

  5. Sihirbazın bir sonraki sayfasında, Veritabanı Seç'i tıklatın.

  6. Veri Kaynağı Seç iletişim kutusunda Yeni Kaynak seçeneğini tıklatın.

  7. Sihirbazın bir sonraki sayfasında, Bağlanmak istediğiniz veri kaynağı türü listesinde, Microsoft SQL Server'ı tıklatın ve ardından İleri'yi tıklatın.

  8. Sunucu adı kutusuna, SQL Server veritabanını içeren sunucunun adını tıklatın.

  9. Oturum açma kimlik bilgileri'nin altında, aşağıdakilerden birini yapın:

    • Veritabanı, Microsoft Windows ağında kullanılan kimlik bilgilerine göre kimlerin erişimi bulunduğunu belirliyorsa, Windows Kimlik Doğrulamasını Kullan seçeneğini tıklatın.

    • Veritabanı kimlerin erişimi bulunduğunu, veritabanı yöneticisinden aldığınız belirli bir kullanıcı adı ve parolasına bağlı olarak belirliyorsa Bu Kullanıcı Adını ve Parolasını kullan'ı tıklatın ve ardından Kullanıcı Adı ve Parola kutularına kullanıcı adınızı ve parolanızı yazın.

  10. İleri'yi tıklatın.

  11. İstediğiniz verileri içeren veritabanını seçin listesinde, kullanmak istediğiniz veritabanının adını tıklatın, Belirli bir tabloya bağlan'ı tıklatın, birincil tablonun adını ve ardından İleri'yi tıklatın.

  12. Sihirbazın bir sonraki sayfasında, Dosya Adı kutusuna, veri bağlantısı bilgilerini depolayan dosya için bir ad yazın ve ardından bu ayarları kaydetmek için Son'u tıklatın.

    Sorgu veri bağlantısında başka tablolar kullanmayı planlıyorsanız, ilgili tabloları sihirbazın bu sayfasında ekleyebilirsiniz.

    Diğer tablolar ekleme

    1. Tablo Ekle'yi tıklatın.

    2. Tablo veya Sorgu Ekle iletişim kutusunda, alt tablo adını tıklatın ve sonra İleri' yi tıklatın. İlişkileri her iki tablodaki alan adları eşleşen göre ayarlamak InfoPath çalışır. Önerilen ilişki kullanmak istemiyorsanız, ilişkiyi seçin ve İlişki Kaldır'ıtıklatın. İlişki eklemek için İlişki Ekle'ıtıklatın. İlişki Ekle iletişim kutusunda, ilgili her alana karşılık gelen sütun adını tıklatın ve sonra da Tamam' ı tıklatın.

    3. Son öğesini tıklatın.

    4. Ek bir alt tablo eklemek için bu adımları tekrar edin.

  13. İleri'yi tıklatın.

  14. Sorgu sonuçlarını form şablonuyla depolamak için, Form şablonunda verilerin bir kopyasını depola onay kutusunu işaretleyin. Bu onay kutusu işaretlenince sorgu sonuçları form şablonuna depolanır. Veriler form şablonunda depolandığı için, kullanıcıların bilgisayarları ağa bağlı olmasa bile, veriler, doldurdukları formlarda bulunur.

    Güvenlik Notu : Bu onay kutusu seçilmesi, sorgu sonuçlarının form şablonunda depolanmasını sağlar. Veriler form şablonunda depolandığından, formları dolduran kullanıcıların bilgisayarları ağa bağlı olmasa bile, kullanıcılar bu verileri kullanabilir. Bu veri bağlantısından önemli veriler alıyorsanız, bilgisayarın kaybolması veya çalınması durumunda verilerin korunmasına yardımcı olmak için bu özelliği devre dışı bırakmak isteyebilirsiniz.

  15. İleri'yi tıklatın.

  16. Sihirbazın bir sonraki sayfasında, bu ikincil veri bağlantısı için açıklayıcı bir ad yazın. Formun açılırken verileri otomatik olarak almasını istiyorsanız, Form açıldığında verileri otomatik olarak al onay kutusunu işaretleyin.

Sayfanın Başı

Adım 2: Denetimi yapılandırma

  1. Form şablonu birden çok görünüm varsa, ikincil veri kaynağından verileri görüntülemek istediğiniz denetimle görünümüne gitmek için Görünüm menüsünde Görünüm adını tıklatın.

  2. Doldurmak istediğiniz liste kutusu, açılan liste kutusu veya açılan kutu denetimini çift tıklatın.

  3. Veri sekmesini tıklatın.

  4. Liste kutusu girdileri öğesinin altında, Değerleri dış veri kaynağında ara seçeneğini tıklatın.

  5. Veri Kaynağı listesinden, kullanmak istediğiniz veri kaynağını tıklatın.

  6. Girdileri kutusunun yanındaki Düğme görüntüsü XPath Seç' i tıklatın.

  7. Alan veya Grup Seç iletişim kutusunda, aşağıdakini yaparak hangi verilerin kullanıcıya gösterileceğini ve hangi bilgilerin dış veri kaynağına gönderileceğini belirtin.

    Kullanıcının göreceği verileri kullanıcı göndereceğiniz aynı verileri mı olduğunu belirtin

    • Bir alanı tıklatın ve ardından Tamam'ı tıklatın.

    Kullanıcının göreceği verilerin kullanıcı göndereceğiniz verilerinden farklı olduğunu belirtin

    Not : Bu senaryoda, kullanıcının göreceği veriler gruptaki alanlardan birinden gelmektedir ve kullanıcının göndereceği veriler aynı gruptaki başka bir alandadır.

    1. Bir grubu tıklatın ve ardından Tamam'ı tıklatın.

    2. Denetim Özellikleri iletişim kutusunda, değeri kutusunun yanındaki Düğme görüntüsü XPath Seç' i tıklatın.

    3. Alan veya Grup Seç iletişim kutusunda, kullanıcının dış veri kaynağına göndereceği verileri içeren alanı tıklatın ve ardından Tamam'ı tıklatın.

    4. Denetim Özellikleri iletişim kutusunda, görünen ad kutusunun yanındaki Düğme görüntüsü XPath Seç' i tıklatın.

    5. Alan veya Grup Seç iletişim kutusundan, denetimde görünecek verileri içeren alanı tıklatın ve ardından Tamam'ı tıklatın.

  8. Görüntü adı kutusundaki alan, benzer görüntü adları değerleri içeriyorsa ve yalnızca benzersiz adları görüntülemek istiyorsanız, Yalnızca benzersiz görüntü adına sahip girdileri göster onay kutusunu işaretleyin.

Sayfanın Başı

Not : Makine Çevirisi Yasal Uyarısı: Bu makale, insan müdahalesi olmadan bir bilgisayar sistemi tarafından çevrilmiştir. Microsoft bu makine çevirilerini İngilizce bilmeyen kullanıcıların Microsoft ürünleri, hizmetleri ve teknolojileriyle ilgili içeriklerden yararlanmasına yardımcı olmak için sunar. Bu makale makine çevirisi olduğundan sözcük, cümle dizilimi ve gramer hataları içerebilir.

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×