Bir form şablonunda kaynak dosyalarını ekleme, kaldırma veya güncelleştirme

Not:  En güncel yardım içeriklerini, mümkün olduğunca hızlı biçimde kendi dilinizde size sunmak için çalışıyoruz. Bu sayfanın çevirisi otomasyon aracılığıyla yapılmıştır ve bu nedenle hatalı veya yanlış dil bilgisi kullanımları içerebilir. Amacımız, bu içeriğin sizin için faydalı olabilmesini sağlamaktır. Buradaki bilgilerin faydalı olup olmadığını bu sayfanın sonunda bize bildirebilir misiniz? Kolayca başvurabilmek için İngilizce makaleye buradan ulaşabilirsiniz .

Kaynak dosya bir form şablonunda ek bilgileri görüntülemek için kullanılan bir dosyadır. Herhangi bir kaynak dosyaları kaydetme veya form şablonunu yayımlama, form şablonunda eklenir.

Form şablonunuz için aşağıdaki kaynak dosya türleri ekleyebilirsiniz:

HTML dosyaları    İçinde bir özel görev bölmesibilgileri görüntülemek için HTML dosyalarını kullanabilirsiniz.

Not: Form şablonuna kaynak dosyası olarak bir HTML dosyası eklediğinizde, ayrıca HTML dosyasını, diğer HTML dosyalarının, stil sayfaları veya grafik dosyaları gibi gerekli olan tüm dosyaları eklemeniz gerekir.

XML dosyaları    Liste kutusu denetimleri, birleşik giriş kutusu denetimi veya açılan liste kutusu denetimleri doldurmak için XML dosyalarını kullanabilirsiniz. Bir liste kutusu, birleşik giriş kutusu veya açılan liste kutusu denetimi verileri sabit varsa, bu verileri bir XML dosyasına yerleştirin ve bu dosya kaynak dosyası veri bağlantısı bu denetimler doldurmak için kullanmak yerine form şablonuna ekleme. Kaynak dosya kullandığınızda, bu denetimler doldurmak için bir veri bağlantısını kullanmak formları daha hızlı form şablonunu temel alan formları açın. Veri kaynağı dosyadaki form şablonunu bir parçası olarak kabul edilir ve verileri almak için bir veri bağlantısı almaz olmasıdır. Formu dış veri kaynağından verileri depolayan böylece form şablonu yapılandırılmamışsa, form ağa gerekli verileri almak için bağlı olmanız gerekir. Veri formu parçası olduğundan kaynak dosya bir veri bağlantısı gerek yoktur.

Ne yapmak istiyorsunuz?

Kaynak dosya bir form şablonuna ekleme

Kaynak dosya bir form şablonundan kaldırma

Form şablonunda kaynak dosyayı güncelleştirme

Kaynak dosya bir form şablonuna ekleme

  1. Araçlar menüsünde, Kaynak dosyalar' ı tıklatın.

  2. Kaynak dosya iletişim kutusunda, Ekle'yitıklatın.

  3. Dosya Ekle iletişim kutusunda, eklemek istediğiniz dosyayı seçin.

Sayfanın Başı

Kaynak dosya bir form şablonundan kaldırma

  1. Araçlar menüsünde, Kaynak dosyalar' ı tıklatın.

  2. Form şablonunda kaynak dosyalarını listesinde Kaynak dosyaları iletişim kutusunda, form şablonundan kaldırmak istediğiniz kaynak dosyayı seçin.

  3. Kaldır'ı tıklatın.

Sayfanın Başı

Form şablonunda kaynak dosyayı güncelleştirme

Form şablonu yayımlandıktan sonra form şablonunda kaynak dosyayı güncelleştirebilirsiniz. Örneğin, bir liste kutusu denetimi form şablonunuzdaki doldurmak için kullanmakta olduğunuz bir kaynak dosyadaki varolan öğeleri yeni öğeler ekleme veya silme isteyebilirsiniz. Kaynak dosyayı güncelleştirmek için kaynak dosyanın bir kopyasını değiştirin ve sonra güncelleştirilmiş kaynak dosyayı form şablonuna ekleyin. Form şablonunuzu güncelleştirilmiş kaynak dosya eklediğinizde, aslında var olan kaynak dosyayı değiştireceğiniz. Form şablonunun güncelleştirilmiş kaynak dosyayı ekledikten sonra yeniden yayımlayın. Form şablonunu temel alan yeni, boş bir form açtığınızda kullanıcılarınız sonra güncelleştirilmiş kaynak dosyayı alın.

  1. Kaynak dosyanın yerel bir kopyasını gerekli değişiklikleri yapın.

    İpucu: Kaynak dosyanın yerel bir kopyasını yoksa, bir kopyasını form şablonundaki ayıklayabilirsiniz. Ayrıca bkz bölümündeki form şablonunda dosyaları ayıklama hakkında daha fazla bilgi için bağlantılar bulabilirsiniz.

  2. Kaynak dosyayı ilişkili olduğu form şablonunu InfoPath tasarım modunda açın.

  3. Araçlar menüsünde, Kaynak dosyalar' ı tıklatın.

  4. Kaynak dosya iletişim kutusunda, Ekle'yitıklatın.

  5. Dosya Ekle iletişim kutusunda, güncelleştirdiğiniz dosyasını seçin ve sonra da Tamam' ı tıklatın.

  6. Microsoft Office InfoPath iletişim kutusunda, Varolan dosyayı değiştir' i tıklatın ve sonra da Tamam' ı tıklatın.

  7. Kaynak dosyaları iletişim kutusunda Tamam' ı tıklatın.

  8. Dosya menüsünde, form şablonunu yayımlamak için Yayımla' yı tıklatın ve sonra Yayımlama Sihirbazı'ndaki adımları tamamlayın.

Sayfanın Başı

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×