Bir arama işlevinde tablo_dizisi bağımsız değişkenini kullanma

Önemli : Bu makale makine çevisidir. Bkz. yasal uyarı. Bu makalenin İngilizce sürümüne buradan ulaşabilirsiniz.

DÜŞEYARA veya YATAYARA işlevlerini kullanarak bir formül oluşturduğunuzda D2:F39 gibi bir hücre aralığı olan bir tablo_dizisi bağımsız değişkeni girersiniz. İşlev, bulmak istediğiniz veriyi bu hücre aralığında arar.

Tablo_dizisi bağımsız değişkeni, bir DÜŞEYARA veya YATAYARA işlevinde her zaman ikinci bağımsız değişkendir (birincisi, bulmak istediğiniz değerdir). tablo_dizisi bağımsız değişkeni olmadan bu işlevler çalışmaz.

İlk bağımsız değişkeniniz “41” veya “demirci” gibi belli bir değer ya da F2 gibi bir hücre başvurusu olabilir Birinci bağımsız değişken şöyle görünür:

=DÜŞEYARA(F2,...

Tablo_dizisi bağımsız değişkeni her zaman düşeyara değerini şu şekilde takip eder:

=DÜŞEYARA(F2,B4:D39, ...

Tablo_dizisi bağımsız değişkeninde listelenen hücre aralığı göreli veya mutlak hücre başvuruları kullanabilir. Formülünüzü başka hücrelere kopyalayacaksınız şu şekilde mutlak hücre başvuruları kullanmanız gerekir ($ işaretlerine dikkat edin):

=DÜŞEYARA(F2,$B$2:BD$39, ...

tablo_dizisi bağımsız değişkenindeki hücreler çalışma kitabınızın başka bir çalışma sayfasındaysa bağımsız değişkene sayfa adını yazıp sonuna ünlem işareti ekleyin. Söz dizimi şu şekilde görünür:

=DÜŞEYARA(F2,Sheet2!$C$14:E$42, ...

Bulmak istediğiniz değerleri içinde aradığınız sütun gireceğiniz üçüncü bağımsız değişkendir. Buna arama sütunu denir. Görmek istediğiniz değerler D sütunundaysa (tablo_dizisinde üçüncü sütun) son bağımsız değişken 3’tür.

=DÜŞEYARA(F2,B4:D39,3)

İsteğe bağlı olsa da dördüncü bir bağımsız değişken, Yanlış veya Doğru, kullanmanız önerilir. Tam eşleşme arıyorsanız Yanlış değişkenini kullanın.

=DÜŞEYARA(F2,B4:D39,3,False)

Doğru değişkenini kullanır veya dördüncü bağımsız değişkeni boş bırakırsanız, işlev ilk bağımsız değişkeninizdeki değerle yaklaşık bir eşleşme verir. Yani ilk bağımsız değişkeniniz "demirci" ise ve Doğru değişkenini kullanırsanız, DÜŞEYARA "Demirci", "Demirciler" vb. sonuçlar verir. Ancak Yanlış değişkenini kullanırsanız işlev, tam eşleşme olan "Demirci" sonucunu verir ve çoğu zaman da istenen budur.

Doğru değişkeninin daha kafa karıştırıcı bir kullanımına baktığımızda, arama sütununuz (üçüncü bağımsız değişkende belirttiğiniz sütun) artan düzende (A - Z veya en küçük sayıdan en büyüye doğru) sıralanmamışsa yanlış sonuç alabilirsiniz.

DÜŞEYARA ve YATAYARA işlevleriyle ilgili daha fazla bilgi için Arama ve başvuru işlevlerine (başvuru) bakın.

Not : Makine Çevirisi Yasal Uyarısı: Bu makale, insan müdahalesi olmadan bir bilgisayar sistemi tarafından çevrilmiştir. Microsoft bu makine çevirilerini İngilizce bilmeyen kullanıcıların Microsoft ürünleri, hizmetleri ve teknolojileriyle ilgili içeriklerden yararlanmasına yardımcı olmak için sunar. Bu makale makine çevirisi olduğundan sözcük, cümle dizilimi ve gramer hataları içerebilir.

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×