Basit rapor oluşturma

Access'te basitten karmaşığa kadar çok çeşitli raporlar oluşturabilirsiniz. Başlangıç olarak raporunuzun kayıt kaynağını düşünün. Raporunuz ister basit bir kayıt listesi isterse bölgeye göre gruplandırılmış bir satış özeti olsun, öncelikle raporunuzda görmek istediğiniz verilerin hangi alanlarda bulunduğunu ve bu alanların hangi tablo veya sorgularda yer aldığını saptamalısınız.

Kayıt kaynağınızı seçtikten sonra, çoğu durumda raporunuzu oluşturmanın en kolay yolunun Rapor Sihirbazı'nı kullanmak olduğunu göreceksiniz. Rapor Sihirbazı, Access'te bir dizi soruyla size yol gösteren ve ardından yanıtlarınız temelinde raporu oluşturan bir özelliktir.

Ne yapmak istiyorsunuz?

Kayıt kaynağını seçme

Rapor aracını kullanarak rapor oluşturma

Rapor Sihirbazı'nı kullanarak rapor oluşturma

Etiket Sihirbazı'nı kullanarak etiket oluşturma

Boş Rapor aracını kullanarak rapor oluşturma

Rapor bölümlerini anlama

Denetimleri anlama

Düzen görünümünde raporunuzda ince ayarlamalar yapma

Tasarım görünümünde raporunuzda ince ayarlamalar yapma

Rapora denetimler ekleme

Çalışmanızı kaydetme

Raporunuzu görüntüleme, yazdırma veya e-posta iletisi olarak gönderme

Raporunuzu görüntüleme

Raporunuzu yazdırma

Raporunuzu e-posta iletisi olarak gönderme

Kayıt kaynağını seçme

Rapor, hem tablolar veya sorgulardan alınan bilgilerden, hem de rapor tasarımında depolanan etiket, üst bilgi ve grafik gibi bilgilerden oluştur. Temel verileri sağlayan tablolar veya sorgular, raporun kayıt kaynağı olarak da bilinir. Eklemek istediğiniz alanların tümü tek bir tabloda yer alıyorsa, kayıt kaynağı olarak o tabloyu kullanın. Alanlar birden çok tablodaysa, kayıt kaynağı olarak bir veya birden çok sorgu kullanmanız gerekir. Bu sorgular veritabanınızda zaten bulunuyor olabileceği gibi, özel olarak raporunuzun gereksinimlerine uygun yeni sorgular oluşturmanız da gerekebilir.

Rapor aracını kullanarak rapor oluşturma

Rapor aracı, size rapor oluşturmanın en hızlı yolunu sağlar çünkü sizden bilgi istemeden raporu hemen oluşturur. Raporda, temel tablo veya sorgudaki tüm alanlar görüntülenir. Rapor aracı sonuçta elde etmek istediğiniz gösterişli raporun son halini oluşturmayabilir, ancak temel verileri hızla gözden geçirmek için çok kullanışlı bir araçtır. Raporu kaydedebilir ve Düzen görünümünde veya Tasarım görünümünde düzenleyerek amaçlarınıza daha uygun hale getirebilirsiniz.

  1. Gezinti Bölmesi'nde, raporda temel almak istediğiniz tabloya veya sorgula tıklayın.

  2. Oluştur sekmesinin Raporlar grubunda Rapor'a tıklayın. Resim yazısı 4

    Access raporu oluşturur ve Düzen görünümünde gösterir.

  3. Raporunuzu görüntüleme ve yazdırma hakkında daha fazla bilgi için, Raporunuzu görüntüleme, yazdırma veya e-posta iletisi olarak gönderme bölümüne bakın.

Raporu görüntüledikten sonra kaydedebilir ve ardından hem raporu hem de kayıt kaynağı olarak kullandığınız temel tablo veya sorguyu kapatabilirsiniz. Raporu bir sonraki açışınızda, Access kayıt kaynağınızdan en son verileri görüntüler.

Rapor Sihirbazı'nı kullanarak rapor oluşturma

Raporunuzda hangi alanların gösterileceği konusunda daha seçici olabilmek istiyorsanız, Rapor Sihirbazı'nı kullanabilirsiniz. Ayrıca verilerin nasıl gruplandırılacağını ve sıralanacağı belirtebilir ve önceden tablolarla sorgular arasındaki ilişkileri belirtmiş olmanız koşuluyla, birden çok tablo veya sorgudan alanlar kullanabilirsiniz.

  • Oluştur sekmesinin Raporlar grubunda Rapor Sihirbazı'nı tıklatın.

  • Rapor Sihirbazı sayfalarındaki yönergeleri izleyin. Son sayfada Son'a tıklayın.

    Raporun önizlemesine baktığınızda, raporu yazdırıldığında görüneceği şekilde görürsünüz. Ayrıca, ayrıntıların yakından görünmesi için yakınlaştırma oranını artırabilirsiniz. Raporunuzu görüntüleme ve yazdırma hakkında daha fazla bilgi için, Raporunuzu görüntüleme, yazdırma veya e-posta iletisi olarak gönderme bölümüne bakın.

Not : Raporunuza birden çok tablo ve sorgudaki alanları eklemek istiyorsanız, Rapor Sihirbazı'nın ilk sayfasında, ilk tablodaki veya sorgudaki alanları seçtikten sonra İleri'ye veya Son'a tıklamayın. Bunun yerine, tablo veya sorgu seçmek için adımları yineleyin ve rapora eklemek istediğiniz ek alanlara tıklayın. Sonra da devam etmek için İleri'ye veya Son'a tıklayın.

Etiket Sihirbazı'nı kullanarak etiket oluşturma

Etiket Sihirbazı'nı kullanarak kolayca çok çeşitli standart etiket boyutlarında etiketler oluşturabilirsiniz.

  1. Gezinti Bölmesi'nde, etiketlerinizin kayıt kaynağı olacak tabloyu veya sorguyu çift tıklayarak açın.

  2. Oluştur sekmesinin Raporlar grubunda Etiketler'e tıklayın.

  3. Etiket Sihirbazı'nın sayfalardaki yönergeleri izleyin. Son sayfada Son'a tıklayın.

Access etiketlerinizi Baskı Önizleme görünümde gösterir; böylelikle, bunları yazdırıldığında görünecekleri şekilde görebilirsiniz. Ayrıntıları yakınlaştırmak için Access durum çubuğundaki kaydırıcı denetimini kullanabilirsiniz. Raporunuzu görüntüleme ve yazdırma hakkında daha fazla bilgi için, Raporunuzu görüntüleme, yazdırma veya e-posta iletisi olarak gönderme bölümüne bakın.

Not : Birden çok sütunu görmek için yalnızca Baskı Önizleme görünümünü kullanabilirsiniz; diğer görünümler verileri tek sütunda görüntüler.

Boş Rapor aracını kullanarak rapor oluşturma

Rapor aracını veya Rapor Sihirbazı'nı kullanmak ilginizi çekmiyorsa, sıfırdan bir rapor oluşturmak için Boş Rapor aracını kullanabilirsiniz. Özellikle raporunuza yalnızca birkaç alan eklemeyi planlıyorsanız, bu araç rapor oluşturmak için çok hızlı bir yol sağlayabilir. Aşağıdaki yordamda Boş Rapor aracının nasıl kullanıldığı açıklanır:

  • Oluştur sekmesinin Raporlar grubunda Boş Rapor'a tıklayın. Düğme resmi

    Düzen görünümünde boş bir rapor görüntülenir ve Access penceresinin sağ tarafında Alan Listesi bölmesi gösterilir.

  • Alan Listesi bölmesinde, raporda görmek istediğiniz alanları içeren tablonun veya tabloların yanındaki artı işaretine tıklayın.

  • Rapora alanları tek tek sürükleyin veya CTRL tuşunu basılı tutarak birkaç alan seçin ve ardından bunları aynı anda rapora sürükleyin.

  • Rapora logo, başlık, sayfa numarası veya tarih ve saat eklemek için, Tasarım sekmesinin Üst Bilgi/Alt Bilgi grubundaki araçları kullanın. Access 2007 kullanıyorsanız, bu araçların Biçim sekmesinin Denetimler grubunda yer aldığını aklınızda bulundurun.

Rapor bölümlerini anlama

Access'te, raporun tasarımı bölümlere ayrılır. Raporu Tasarım görünümünde göstererek bölümlerini görebilirsiniz. Kullanışlı raporlar oluşturmak için, her bölümün nasıl çalıştığını anlamalısınız. Örneğin, bir hesaplanan denetim yerleştirmeyi seçtiğiniz bölüm, Access'in sonuçları nasıl hesaplayacağını belirler. Aşağıda, bölüm türleri ve bunların kullanımları özetlenmiştir:

  • Rapor Üst Bilgisi     Bu bölüm tek bir kez, raporun en başında yazdırılır. Rapor üst bilgisini, logo, başlık veya tarih gibi normalde kapak sayfasında gösterilen bilgiler için kullanın. Rapor üst bilgisine Topla toplama işlevini kullanan bir hesaplanan denetim yerleştirdiğinizde, raporun tamamı için toplam hesaplanır. Rapor üst bilgisi, sayfa üst bilgisinden önce yazdırılır.

  • Sayfa Üst Bilgisi     Bu bölüm, her sayfanın en üstüne yazdırılır. Örneğin, rapor başlığının her sayfada tekrarlanması için sayfa üst bilgisini kullanın.

  • Grup Üst Bilgisi     Bu bölüm, her yeni kayıt grubunun başlangıcında yazdırılır. Grup adını yazdırmak için grup üst bilgisini kullanın. Örneğin, ürüne göre gruplandırılmış bir raporda ürün adını yazdırmak için grup üst bilgisini kullanın. Grup üst bilgisine Topla işlevini kullanan bir hesaplanan denetim yerleştirdiğinizde, toplama işlemi geçerli grup içindir.

  • Ayrıntı     Bu bölüm, kayıt kaynağındaki her satır için bir kez yazdırılır. Burası, raporun ana gövdesini oluşturan denetimleri yerleştirdiğiniz yerdir.

  • Grup Alt Bilgisi     Bu bölüm, her kayıt grubunun sonunda yazdırılır. Grubun özet bilgilerini yazdırmak için grup alt bilgisini kullanın.

  • Sayfa Alt Bilgisi     Bu bölüm, her sayfanın sonunda yazdırılır. Sayfa numaralarını veya her sayfaya ilişkin bilgileri yazdırmak için sayfa alt bilgisini kullanın.

  • Rapor Alt Bilgisi     Bu bölüm tek bir kez, raporun sonunda yazdırılır. Rapor toplamlarını veya raporun tamamına ilişkin özet bilgileri yazdırmak için rapor alt bilgisini kullanın.

    Not : Tasarım görünümünde, rapor alt bilgisi sayfa alt bilgisinin altında gösterilir. Bununla birlikte, rapor yazdırıldığında veya önizlemesi görüntülendiğinde, rapor alt bilgisi sayfa alt bilgisinin üstünde, son sayfadaki son grup alt bilgisinden veya ayrıntı satırından hemen sonra görünür.

Sayfanın Başı

Denetimleri anlama

Denetimler, veri görüntüleyen, eylem gerçekleştiren, etiketler ve resimler gibi kullanıcı arabirimini geliştiren bilgileri görüntülemenizi ve bu bilgilerle çalışmanızı sağlayan nesnelerdir. Access üç tür denetimi destekler: ilişkili, ilişkisiz ve hesaplanan:

  • İlişkili denetim     Veri kaynağı tablo veya sorgudaki bir alan olan denetim, ilişkili denetimdir. İlişkili denetimleri, veritabanınızda bulunan alanlardaki değerleri görüntülemek için kullanırsınız. Bu değerler metinler, tarihler, sayılar, Evet/Hayır değerleri, resimler veya grafikler olabilir. En yaygın ilişkili denetim türü metin kutusudur. Örneğin, formda bir çalışanın soyadını görüntüleyen metin kutusu, bu bilgiyi Çalışanlar tablosunun Soyadı alanından alabilir.

  • İlişkisiz denetim     Veri kaynağı (alan veya ifade) olmayan bir denetim, ilişkisiz denetimdir. İlişkisiz denetimleri, bilgileri, çizgileri, dikdörtgenleri ve resimleri görüntülemek için kullanırsınız. Örneğin, raporun başlığını gösteren etiket bir ilişkisiz denetimdir.

  • Hesaplanan denetim     Veri kaynağı bir alan değil bir ifade olan denetim, hesaplanan denetimdir. Denetimin veri kaynağı olarak bir ifade tanımlayarak, denetimde bulunmasını istediğiniz değeri belirtirsiniz. İfade, işleçlerin (= ve + gibi), denetim adlarının, alan adlarının, tek değer döndüren işlevlerin ve sabit değerlerin bir bileşimidir. Örneğin, aşağıdaki ifade Birim Fiyat alanındaki değeri bir sabit değerle (0,75) çarparak bir öğenin yüzde 25 indirimli fiyatını hesaplar.

    = [Birim Fiyat] * 0,75

    İfadede, raporun temel tablo veya sorgusundaki bir alandan veya rapordaki bir denetimden değerler kullanılabilir.

Rapor oluştururken, büyük olasılıkla en verimli yöntem önce tüm ilişkili denetimleri (özellikle de bunlar rapordaki denetimlerin çoğunluğunu oluşturuyorsa) eklemek ve yerleştirmektir. Ardından, Tasarım sekmesinin Denetimler grubundaki araçları kullanarak, tasarımı tamamlayan ilişkisiz ve hesaplanan denetimleri ekleyebilirsiniz.

Denetimi bir alanla ilişkilendirmek için, denetimin verilerini alacağı alanı tanımlarsınız. Bir alanı Alan Listesi bölmesinden rapora sürükleyerek, seçilen alanla ilişkili bir denetim oluşturabilirsiniz. Alan Listesi bölmesinde, raporun temel tablosu veya sorgusundaki alanlar görüntülenir. Alan Listesi bölmesini görüntülemek için, Tasarım sekmesinin Denetimler grubunda Varolan Alanı Ekle'ye tıklayın.

Alternatif olarak, alanı bir denetimle ilişkilendirmek için alan adını denetimin kendisine veya denetimin özellik sayfasındaki ControlSource değerinin kutusuna yazabilirsiniz. Özellik sayfası bir denetimin adı, veri kaynağı ve biçimi gibi özelliklerini tanımlar.

Şu iki nedenle, denetim oluşturmanın en iyi yolu Alan Listesi bölmesinin kullanılmasıdır:

  • İlişkili denetime eklenmiş bir etiket vardır ve bu etiket varsayılan alt yazısı olarak alanın adını (veya temel tablo veya sorguda söz konusu alan için tanımlanmış alt yazıyı) alır. Bu nedenle alt yazıyı kendiniz yazmanız gerekmez.

  • İlişkili denetim, temel tablo veya sorgudaki alanın özelliklerinden birçoğunu devralır (örneğin, Biçim, OndalıkBasamaklar ve GirişMaskesi özellikleri). Bu nedenle, alanla ilişkili bir denetim oluşturduğunuzda, her seferinde alanın bu özelliklerinin aynı kalacağından emin olabilirsiniz.

Zaten bir ilişkisiz denetim oluşturduysanız ve bunu bir alanla ilişkilendirmek istiyorsanız, denetimin DenetimKaynağı özelliğini alanın adına ayarlayabilirsiniz. DenetimKaynağı özelliği hakkındaki ayrıntılar için, Yardım'da "DenetimKaynağı" araması yapın.

Sayfanın Başı

Düzen görünümünde raporunuzda ince ayarlamalar yapma

Raporu oluşturduktan sonra, Düzen görünümünde çalışarak kolayca tasarımında ince ayarlamalar yapabilirsiniz. Gerçek rapor verilerinin rehberliğinde sütun genişliklerini ayarlayabilir, sütunları yeniden yerleştirebilir ve gruplandırma düzeyleriyle toplamlar ekleyebilirsiniz. Rapor tasarımına yeni alanlar yerleştirebilir, raporun ve denetimlerinin özelliklerini ayarlayabilirsiniz.

Düzen görünümüne geçmek için, Gezinti Bölmesi'nde raporun adına sağ tıklayın ve sonra da Düzen Görünümü Resim yazısı 4 öğesine tıklayın.

Access raporu Düzen görünümünde gösterir.

Özellik sayfasını kullanarak raporun, denetimlerinin ve bölümlerinin özelliklerini değiştirebilirsiniz. Özellik sayfasını görüntülemek için F4 tuşuna basın.

Alan Listesi bölmesini kullanarak, temel tablo veya sorgudaki alanları rapor tasarımınıza ekleyebilirsiniz. Alan Listesi bölmesini görüntülemek için aşağıdakilerden birini yapın:

  • Tasarım sekmesinin Araçlar grubunda Varolan Alanları Ekle Resim yazısı 4 öğesine tıklayın. Access 2007 kullanıyorsanız, Varolan Alanları Ekle komutunun Biçim sekmesinin Denetimler grubunda yer aldığını aklınızda bulundurun.

  • ALT+F8 tuşlarına basın.

Ardından, alanları Alan Listesi bölmesinden rapora sürükleyerek ekleyebilirsiniz.

Sayfanın Başı

Tasarım görünümünde raporunuzda ince ayarlamalar yapma

Tasarım görünümünde çalışarak da raporunuzun tasarımında ince ayarlamalar yapabilirsiniz. Rapora yeni denetimler ve alanlar eklemek için, bunları tasarım kılavuzuna ekleyebilirsiniz. Özellik sayfası, raporunuzu özelleştirmek için ayarlayabileceğiniz çok sayıda özelliğe erişebilmenizi sağlar.

Tasarım görünümüne geçmek için, Gezinti Bölmesi'nde raporun adına sağ tıklayın ve sonra da Tasarım Görünümü düğme görüntüsü öğesine tıklayın.

Access raporu Tasarım görünümünde gösterir.

Özellik sayfasını kullanarak raporun kendisinin ve içerdiği denetimlerle bölümlerin özelliklerini değiştirebilirsiniz. Özellik sayfasını görüntülemek için F4 tuşuna basın.

Alan Listesi bölmesini kullanarak, temel tablo veya sorgudaki alanları rapor tasarımınıza ekleyebilirsiniz. Alan Listesi bölmesini görüntülemek için aşağıdakilerden birini yapın:

  • Biçim sekmesinin Denetimler grubunda Varolan Alanları Ekle Resim yazısı 4 öğesine tıklayın. Access 2007 kullanıyorsanız, Varolan Alanları Ekle komutunun Biçim sekmesinin Denetimler grubunda yer aldığını aklınızda bulundurun.

  • ALT+F8 tuşlarına basın.

Ardından, alanları Alan Listesi bölmesinden rapora sürükleyerek ekleyebilirsiniz.

Sayfanın Başı

Alan Listesi bölmesinden alan ekleme

  • Tek bir alan eklemek için, alanı Alan Listesi bölmesinden raporda görüntülenmesini istediğiniz bölüme sürükleyin.

  • Bir kerede birkaç alan eklemek için, CTRL tuşunu basılı tutun ve istediğiniz alanlara tıklayın. Sonra, seçilen alanları rapora sürükleyin.

Alanları rapor bölümüne bıraktığınızda, Access her alan için bir ilişkili metin kutusu denetimi oluşturur ve her alanın yanına otomatik olarak bir etiket denetimi yerleştirir.

Sayfanın Başı

Rapora denetimler ekleme

Bazı denetimler otomatik olarak oluşturulur. Örneğin, Alan Listesi bölmesinden raporunuza bir alan eklediğinizde oluşturulan ilişkili metin kutusu denetimi böyle bir denetimdir. Diğer denetimlerden birçoğu Tasarım görünümünde, Tasarım sekmesinin Denetimler grubundaki araçlar kullanılarak oluşturulabilir.

Bir aracın adını belirleme

  • Fare işaretçisini aracın üzerine getirin.

    Access aracın adını görüntüler.

Denetimler grubundaki araçları kullanarak denetim oluşturma

  1. Eklemek istediğiniz denetim türünün aracına tıklayın. Örneğin, onay kutusu oluşturmak için Onay Kutusu Resim yazısı 4 aracına tıklayın.

  2. Raporun tasarım kılavuzunda, denetimin sol üst köşesini yerleştirmek istediğiniz konuma tıklayın. Varsayılan boyutta bir denetim eklemek için bir kez tıklayın veya istediğiniz boyutta bir denetim oluşturmak için araca tıklayın ve rapor tasarım kılavuzuna sürükleyin.

  3. İlk denemede denetimi tam olarak istediğiniz gibi konumlandıramazsanız, aşağıdaki yordamı kullanarak taşıyabilirsiniz:

    1. Denetimini tıklayarak seçin.

    2. Fare işaretçisini denetimin kenarına getirin ve dört başlı oka taşıma işaretçisi dönüşmesini bekleyin.

    3. Denetimi istediğiniz konuma sürükleyin.

Bu yordam, "ilişkisiz" bir denetim oluşturur. Veri görüntüleyebilen bir denetim türü söz konusuysa (örneğin, metin kutusu veya onay kutusu), herhangi bir veri görüntüleyebilmesi için önce denetimin DenetimKaynağı özelliğine bir alan adı veya ifade girmelisiniz. Daha fazla bilgi için bu makalenin Denetimleri anlama bölümüne bakın.

Özellik sayfasını görüntüleme

Tasarım görünümünde özellik sayfasını görüntülemek için aşağıdakilerden birini yapın:

  • Tasarım sekmesinin Araçlar grubunda Özellik Sayfası'na tıklayın. Access 2007 kullanıyorsanız, Özellik Sayfası komutunun Tasarım sekmesinin Göster/Gizle grubunda yer aldığını aklınızda bulundurun.

  • F4 tuşuna basın.

Sayfanın Başı

Çalışmanızı kaydetme

Rapor tasarımınızı kaydettikten sonra, raporu size gereken sıklıkta çalıştırabilirsiniz. Raporun tasarımı aynı kalır, ama raporu her yazdırdığınızda veya görüntülediğinizde güncel verileri alırsınız. Raporlama gereksinimleriniz değişirse, rapor tasarımını değiştirebilir veya ilk raporu temel alan yeni ve benzer bir rapor oluşturabilirsiniz.

Rapor tasarımınızı kaydetme

  • Dosya > Kaydet'e tıklayın veya CTRL+S tuşlarına basın. Access 2007 kullanıyorsanız, Microsoft Office Düğmesi’ne tıklayın ve ardından Kaydet’e tıklayın veya CTRL+S tuşlarına basın.

    Alternatif olarak, Hızlı Erişim Araç Çubuğu’nda Kaydet düğme görüntüsü düğmesine de tıklayabilirsiniz.

  • Raporun adı yoksa, Rapor Adı kutusuna bir ad yazın ve Tamam'a tıklayın.

Rapor tasarımınızı yeni bir adla kaydetme

  • Access 2013 veya üstünü kullanıyorsanız, Dosya > Farklı Kaydet > Nesneyi Farklı Kaydet'e tıklayın.

    Access 2010 kullanıyorsanız, Dosya > Nesneyi Farklı Kaydet'e tıklayın.

    Access 2007 kullanıyorsanız, Microsoft Office Düğmesi'ne tıklayın ve sonra da Farklı Kaydet > Nesneyi Farklı Kaydet'e tıklayın.

  • Farklı Kaydet iletişim kutusunda, Raporu Kaydet kutusuna yeni rapor için bir ad yazın ve ardından Tamam'a tıklayın.

Sayfanın Başı

Raporunuzu görüntüleme, yazdırma veya e-posta iletisi olarak gönderme

Rapor tasarımınızı kaydettikten sonra, bunu tekrar tekrar kullanabilirsiniz. Raporun tasarımı aynı kalır, ama raporu her görüntülediğinizde veya yazdırdığınızda güncel verileri alırsınız. Raporlama gereksinimleriniz değişirse, rapor tasarımını değiştirebilir veya ilk raporu temel alan yeni ve benzer bir rapor oluşturabilirsiniz.

Raporunuzu görüntüleme

Raporunuzu görüntülemenin birkaç yolu vardır. Seçeceğiniz yöntem, raporla ve verileriyle ne yapmak istediğinize bağlıdır:

  • Raporu yazdırmadan önce raporda gösterilen verilerde geçici değişiklikler yapmak istiyorsanız veya rapordaki verileri panoya kopyalamak istiyorsanız, Rapor görünümünü kullanın.

  • Verilere bakarken raporun tasarımında değişiklik yapabilmek istiyorsanız, Düzen görünümünü kullanın.

  • Yalnızca rapor yazdırıldığında nasıl görüneceğine bakmak istiyorsanız, Baskı Önizleme'yi kullanın.

Not : Raporunuz birden çok sütunla biçimlendirildiyse, sütun düzenini yalnızca Baskı Önizleme'de görebilirsiniz. Düzen görünümünde ve Rapor görünümünde, rapor tek sütunda görüntülenir.

Raporunuzu Rapor görünümünde gösterme

Rapor görünümü, Gezinti Bölmesi'nde rapora çift tıkladığınızda kullanılan varsayılan görünümdür. Rapor açık değilse, Rapor görünümünde gösterilmesi için Gezinti Bölmesi'nde rapora çift tıklayın.

Rapor zaten açıksa, Gezinti bölmesinde rapor adına sağ tıklayın ve ardından Rapor Görünümü'ne tıklayın.

Rapor görünümünde verilerinizle çalışma

Rapor görünümünde, metni seçebilir ve panoya kopyalayabilirsiniz. Satırların tamamını seçmek için, seçmek istediğiniz satırların yanında kenar boşluğuna tıklayın ve sürükleyin. Ardından, aşağıdakilerden birini yaparak bu satırları panoya kopyalayabilirsiniz:

  1. Giriş sekmesinin Pano grubunda Kopyala Resim yazısı 4 öğesine tıklayın.

  2. Seçili satırlara sağ tıklayın ve Kopyala'ya tıklayın.

  3. Klavye kısayolunu kullanın, CTRL+C tuşlarına basın.

Filtreleri kullanarak yalnızca istediğiniz satırları görüntüleme

Rapor görünümünden çıkmadan filtreleri doğrudan raporunuza uygulayabilirsiniz. Örneğin, bir "Ülke/bölge" sütununuz varsa ve yalnızca ülke/bölge değeri "Kanada" olan satırları görmek istiyorsanız, aşağıdakileri yapın:

  1. Raporda "Kanada" sözcüğünü bulun ve sağ tıklayın.

  2. Eşittir "Kanada" öğesine tıklayın.

Access filtreyi oluşturur ve uygular.

Filtreyi açma ve kapatma

Giriş sekmesinin Sırala ve Filtre Uygula grubunda Filtreyi Değiştir'e tıklayarak filtrelemiş ve filtrelenmemiş görüntüler arasında geçiş yapabilirsiniz. Bu filtreyi kaldırmaz; yalnızca açar ve kapatır.

Filtreyi kaldırma

  1. Filtreyi kaldırmak istediğiniz alana sağ tıklayın.

  2. Filtrenin Temizleneceği alan adı'na sağ tıklayın. (alan adı için asıl alanınız listelenir.)

Filtre kaldırıldıktan sonra, Filtreyi Değiştir komutunu kullanarak filtreyi yeniden açmazsınız. Önce filtreyi yeniden oluşturmanız gerekir.

Not : Rapora filtre uygular ve ardından raporu kapatırsanız, filtre kaydedilir. Öte yandan, raporu bir sonraki açışınızda Access filtreyi uygulamaz. Filtreyi yeniden uygulamak için, Giriş sekmesinin Sırala ve Filtre Uygula grubunda Filtreyi Değiştir'e tıklayın.

Baskı Önizleme'yi kullanarak raporu önizleme

Gezinti Bölmesi'nde rapora sağ tıklayın ve ardından kısayol menüsünde Baskı Önizleme'ye tıklayın.

Gezinti düğmelerini kullanarak raporun sayfalarını sırayla görüntüleyebilir veya raporda herhangi bir sayfaya atlayabilirsiniz.

Gezinti düğmeleri

1. İlk sayfayı görüntülemek için tıklayın.

2. Önceki sayfayı görüntülemek için tıklayın.

3. Sonraki sayfayı görüntülemek için tıklayın.

4. Son sayfayı görüntülemek için tıklayın.

5. Bu kutuya bir sayfa numarası yazın ve ardından o belirli sayfaya atlamak için ENTER tuşuna basın.

Baskı Önizleme'de, ayrıntıları görmek için görüntüyü yakınlaştırabilir veya verilerin sayfaya iyi yerleştirilip yerleştirilmediğini görmek için uzaklaştırabilirsiniz. İmleci raporun üzerine getirip bir kez tıklayın. Yakınlaştırma etkisini tersine çevirmek için ise yeniden tıklatın. Daha fazla yakınlaştırmak veya uzaklaştırmak için Access durum çubuğundaki yakınlaştırma denetimini de kullanabilirsiniz.

Baskı Önizleme'yi kapatmak için aşağıdakilerden birini yapın:

  • Baskı Önizleme sekmesinde Baskı Önizlemeyi Kapat'a tıklayın.

  • Gezinti Bölmesi'nde rapora sağ tıklayın ve ardından kısayol menüsünde Düzen Görünümü Resim yazısı 4 veya Tasarım Görünümü düğme görüntüsü öğesine tıklayın.

İpucu : Raporunuzun önizlemesine baktıktan sonra, sonuçları Microsoft Word, Microsoft Excel veya başka bazı Office programlarına aktarabilirsiniz. Dış Veri sekmesinin Dışarı Aktar grubunda, istediğiniz biçimin düğmesine tıklayın ve yönergeleri izleyin.

Sayfanın Başı

Raporunuzu yazdırma

Herhangi bir görünümde açık olan raporu yazdırabileceğiniz gibi, kapalı raporları bile yazdırabilirsiniz. Yazdırmadan önce sayfa ayarlarını, örneğin kenar boşluklarını ve sayfa yönlendirmesini bir kez daha denetlemeye dikkat edin. Access sayfa ayarlarını raporla birlikte kaydeder, dolayısıyla bunları bir kez ayarlamanız yeterli olur. Daha sonra yazdırma gereksinimleriniz değişirse yeniden ayarlayabilirsiniz.

Sayfa ayarlarını değiştirme

  1. Raporu Baskı Önizleme'de açın. Sayfa ayarlarını herhangi bir görünümde değiştirebilirsiniz, ama en iyisi Baskı Önizleme'dir çünkü burada her değişikliğin etkilerini hemen görebilirsiniz.

  2. Baskı Önizleme sekmesinin Sayfa Düzeni ve Sayfa Boyutu gruplarında,sayfa yönlendirmesini ayarlamak için Dikey düğme görüntüsü veya Yatay Resim yazısı 4 seçeneğine, sayfa boyutun ayarlamak için Boyut Resim yazısı 4 seçeneğine, kenar boşluklarını ayarlamak için Kenar Boşlukları Düğme resmi seçeneğine, vb. tıklayın.

  3. Değişiklik yaptıktan sonra, gezinti düğmelerini kullanarak çeşitli sayfaları görüntüleyin ve daha sonraki sayfalarda herhangi bir biçimlendirme sorunu yaratmadığınızdan emin olun.

Raporunuzu yazıcıya gönderme

  1. Raporu herhangi bir görünümde açın veya Gezinti Bölmesi'nde seçin.

  2. Dosya > Yazdır > Yazdır'a tıklayın. Unutmayın; Access 2007 kullanıyorsanız Microsoft Office Düğmesi’ne tıklayın ve ardından Yazdır > Yazdır'a tıklayın.

    Access, Yazdır iletişim kutusunu görüntüler.

  3. Yazıcı, yazdırma aralığı ve kopya sayısı gibi seçeneklerle ilgili seçimlerinizi girin.

  4. Tamam'a tıklayın.

Sayfanın Başı

Raporunuzu e-posta iletisi olarak gönderme

Raporunuzu kağıt üzerine yazdırmak yerine alıcılara e-posta iletisi olarak da gönderebilirsiniz:

  1. Gezinti Bölmesi'nde raporu tıklayarak seçin. Dış Veri sekmesinin Dışarı Aktar grubunda E-posta'ya tıklayın. Unutmayın; Access 2007 kullanıyorsanız, Gezinti Bölmesi'nde raporu tıklayarak seçin, Microsoft Office Düğmesi'ne tıklayın ve sonra da E-posta'ya tıklayın.

  2. Nesneyi Farklı Gönder iletişim kutusundaki Çıktı Biçimini Seç listesinde, kullanmak istediğiniz dosya biçimine tıklayın.

  3. Kalan tüm iletişim kutularını doldurun.

  4. E-posta uygulamanızda, iletinin ayrıntılarını yazın ve iletiyi gönderin.

Sayfanın Başı

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×