Basamaklı liste kutusu oluşturma

Önemli : Bu makale makine çevisidir. Bkz. yasal uyarı. Bu makalenin İngilizce sürümüne buradan ulaşabilirsiniz.

Basamaklı liste kutuları kullanıcıların formları daha hızlı doldurmak ve kullanıcıların verileri doğru girmesini yardımcı yardımcı olur. Bu makalede, oluşturma ve basamaklı liste kutuları verileriyle doldurmak açıklanır. Microsoft Office InfoPath içinde form, bir dış Genişletilebilir Biçimlendirme Dili (XML) belge değerlerden veya bir Microsoft Office Access veritabanından değerleri değerlerden kullanan verilerini bir listeyle doldurabilirsiniz.

Bu makalede

Basamaklı liste kutusu nedir?

Adım 1: basamaklı liste kutusu ekleme

Adım 2: veri sağlama

Basamaklı liste kutusu nedir?

Basamaklı liste kutusu Değiştir başka bir liste kutusunda bir kullanıcının seçtiği değere göre seçeneğiyle liste kutusu olur. Örneğin, aşağıdaki çizimde gösterilen Kategoriler kutusunda Condiments bir kullanıcının tıklattığı varsa, Ürün kutusuna condiments listesini görüntüler.

Basamaklı liste kutusu örneği

Aşağıdaki bölümlerde ilk liste kutusundan bir kullanıcının seçtiği değere göre ikinci liste kutusunu nerede filtrelenir iki liste kutuları içeren bir form şablonu tasarlama kullanmayı gösterir. İlk liste kutusundaki değeri değiştiğinde, filtre değerlerini değiştiren ikinci liste kutusuna, otomatik olarak uygulanır.

Uyumluluk konuları

Filtreler InfoPath'te doldurulmuş için tasarlanmış form şablonları kullanılabilir. Tarayıcı uyumlu form şablonlarını filtreleri kullanılamaz.

Sayfanın Başı

Adım 1: basamaklı liste kutusu ekleme

Basamaklı liste kutusu oluşturmak için form şablonunuzda iki liste kutusu eklemeniz gerekir.

Not : Form şablonunuzda basamaklı liste kutusu eklediğinizde, iki liste kutuları bir yinelenen bölüm veya yinelenen tabloolmadığından emin olun.

  1. Denetimler görev bölmesi görünür durumda değilse, Ekle menüsünde Diğer Denetimler’e tıklayın veya ALT+I, C tuşlarına basın.

  2. Açılan liste kutusu denetimleri ekleyin altında denetimler görev bölmesinde,'ı tıklatın. Kullanıcı form şablonunuzu temel alan bir formu doldururken seçimi bu açılan liste kutusunda, ikinci liste kutusunda kullanılabilir seçenekler belirler.

  3. Liste kutusunutıklatın. Form şablonunuz artık açılan liste kutusu ve standart liste kutusu içermelidir.

    Bir formdaki açılan liste kutusu ve liste kutusu

  4. Adım 2 form şablonunuzdaki eklediğiniz açılan liste kutusuna çift tıklayın.

  5. Açılan liste kutusu özellikleri iletişim kutusunda, veri sekmesini tıklatın.

  6. Alan adı kutusunda listBox1yazın ve Tamam' ı tıklatın.

  7. Adım 3'te form şablonunuzdaki eklediğiniz liste kutusuna çift tıklayın.

  8. Liste kutusu özellikleri iletişim kutusunda, veri sekmesini tıklatın.

  9. Alan adı kutusunda, listBox2Cascadeyazın ve Tamam' ı tıklatın.

Sayfanın Başı

Adım 2: veri sağlama

Form şablonunuzda liste kutuları eklenen kaydettiğinize göre görüntülenecek verileri sağlamanız gerekir. Böylece ikinci liste kutusundaki seçenek ilk liste kutusunda kullanıcının seçimini temel alan bir filtre uygulamanız gerekir.

Bu bölümde, üç ortak yöntemleri kullanarak liste kutuları verilere bağlanmak açıklanmaktadır: formun kendisinde; verileri ekleme form verilerini içeren varolan bir XML belgesine bağlanma; veya formu verileri içeren bir veritabanına bağlanma. Basamaklı liste kutunuzu oluşturmayı tamamlamak için aşağıdaki listede kullanmak istediğiniz yöntemi tıklatın.

Formdaki verilere bağlanma

Dış XML belgesine bağlanma

Veritabanına bağlanma

Formdaki verilere bağlanma

Bu bölümde, liste kutuları formdan veri ile doldurmak öğreneceksiniz. Her kategori için kategori adlarını ve ürün kümesi girebilirsiniz böylece bunun için önce alanları form şablonunda yapılandırmanız gerekir.

Form şablonunda alanlarını yapılandırma

  1. Veri Kaynağı görev bölmesi görünmüyorsa, Görünüm menüsünde Veri Kaynağı'nı tıklatın.

  2. Veri kaynağı görev bölmesinde, myFields grubu sağ tıklatın ve ardından Ekle'yitıklatın.

  3. Ad kutusuna, alan veya Grup Ekle iletişim kutusunda, KategorilerVeÜrünleryazın.

  4. Tür listesinde, grubutıklatın.

  5. Yinelenen onay kutusunu işaretleyin ve sonra Tamam'ı tıklatın.

  6. Veri kaynağı görev bölmesinde KategorilerVeÜrünler grubunu sağ tıklatın.

  7. Ad kutusuna, alan veya Grup Ekle iletişim kutusunda, Kategoriyazın ve Tamam' ı tıklatın. Bu alan adlarını kategorileri birinci liste kutusu içerecektir.

  8. KategorilerVeÜrünler grubunu sağ tıklatın ve ardından Ekle'yitıklatın.

  9. Ad kutusuna, alan veya Grup Ekle iletişim kutusunda, Ürünyazın.

  10. Yinelenen onay kutusunu işaretleyin ve sonra Tamam'ı tıklatın. Bu alanda ikinci liste kutusu için ürünlerin adları bulunur.

Bu liste kutusu formdaki verilerle doldurulduğundan verileri bir forma eklenmesi gerekir. Bunu yapmak için Ürün ve Kategori alanları için varsayılan değerleri oluşturmanız gerekir.

İpucu

Kullanıcıların forma yazdıkları değerleri görüntüleyen liste kutuları da oluşturabilirsiniz. Bunu yapmak için liste kutusunda, form denetimlerine bağlı alanları ile ilişkilendirin. Bir kullanıcı bu denetimlere değerler girdiğinde, liste kutusundaki seçenek değiştirin.

Varsayılan değerleri oluşturma

  1. Araçlar menüsünde Varsayılan Değerler'i tıklatın.

  2. Varsayılan değerleri Düzenle iletişim kutusunda, KategorilerVeÜrünler grubunda, Category alanını seçin (onay kutusunu temizleyin değil), ve Deniz ürünleriVarsayılan değer kutusuna yazın.

  3. Ürün alanını seçin (onay kutusunu temizlemeyin) ve sonra Varsayılan değer kutusuna Yengeç yazın.

  4. Ürün alanını sağ tıklatın ve sonra Yukarıdaki başka bir ürün Ekle'yitıklatın. Bu varsayılan değer olarak Deniz ürünleri için ikinci bir ürün eklemenize olanak sağlar.

  5. İkinci örneğini Ürün alanını sağ tıklatın (onay kutusunu temizleyin değil), ve SOMVarsayılan değer kutusuna yazın.

  6. KategorilerVeÜrünler grubunu sağ tıklatın ve sonra Aşağıya başka bir KategorilerVeÜrünler Ekleseçeneğini tıklatın. Bu varsayılan değer olarak ikinci bir kategori eklemenize olanak sağlar.

  7. İkinci örneğini süt ürünleri, Kaşar Peynirive çikolata sütlü, Kategori ve Ürün alanları için varsayılan değerleri sırasıyla belirtmek için önceki adımları kullanın.

  8. Tamam düğmesini tıklatın.

Ürün ve Kategori alanları için varsayılan değerleri girdiğiniz kaydettiğinize göre az önce girdiğiniz veriler için ilk liste kutusunu bağlanabilirsiniz.

İlk liste kutusunu verilere bağlanma

  1. Form şablonunda, önceden eklediğiniz açılır liste kutusunu çift tıklatın.

  2. Veri sekmesini tıklatın.

  3. Açılan liste kutusu özellikleri iletişim kutusunda, liste kutusu girdileri'ninaltında değerleri formun veri kaynağında ara' yı tıklatın.

  4. Girdiler kutusunun yanındaki XPath Seç düğme görüntüsü simgesini tıklatın.

  5. Alan veya Grup Seç iletişim kutusunda, KategorilerVeÜrünler grubunda, Category alanını tıklatın ve sonra iki kez Tamam ' ı tıklatın.

Şimdi ikinci liste kutusunu verilere bağlanmak gerekir. Bu veri bağlantısıyaparken, ikinci liste kutusuna filtre uygulamak istediğiniz. Bu filtre ilk liste kutusunda seçilen kategoriye göre uygun ürünleriyle ikinci liste kutusunu doldurmak. Filtreyi ilk liste kutusunda (listBox1 alanı) listesiyle (Kategori alanı) biçiminde kaydettiğiniz kategorilerinin seçilen değer karşılaştırır.

İkinci liste kutusunu verilere bağlanma

  1. Form şablonunda, önceden eklediğiniz standart liste kutusunu çift tıklatın.

  2. Veri sekmesini tıklatın.

  3. Liste kutusu özellikleri iletişim kutusunda, liste kutusu girdileri'ninaltında değerleri formun veri kaynağında ara' yı tıklatın.

  4. Girdiler kutusunun yanındaki XPath Seç düğme görüntüsü simgesini tıklatın.

  5. Alan veya Grup Seç iletişim kutusunda, KategorilerVeÜrünler grubunda, Ürün alanını tıklatın ve sonra Verilere filtretıklatın.

  6. Veriye Filtre Uygula iletişim kutusunda Ekle'yi tıklatın.

  7. Filtre Koşullarını Belirle iletişim kutusunda, ilk kutuda alan veya Grup Seç ' i tıklatın.

  8. Alan veya Grup Seç iletişim kutusunda, listBox1'i tıklatın ve sonra Tamam'ı tıklatın.

  9. Filtre Koşullarını Belirle iletişim kutusunda, üçüncü kutusunda bir alan veya Grup Seç ' i tıklatın.

  10. Alan veya Grup Seç iletişim kutusunda, Category alanını tıklatın ve ardından tüm açık iletişim kutularını kapatmak için Tamam ' ı tıklatın.

Artık ikinci liste kutusunu verilere bağlamış ve filtre uygulamış olduğunuzdan, doğru çalıştıklarını sınamak için liste kutularını sınayabilirsiniz.

Liste kutuları test etme

  1. Yaptığınız değişiklikleri test etmek için, Standart araç çubuğunda Önizleme’ye tıklayın veya CTRL+SHIFT+B tuşlarına basın.

  2. Açılan liste kutusunda, Deniz ürünleri' ı tıklatın. Standart liste kutusunda bir boş satır, Yengeçve SOMgöstermelidir.

    Not : Boş satır kullanıcıların kendi seçim liste kutusundan temizleyin olanak tanır.

Liste kutuları düzgün çalışmazsa, ikinci liste kutusunun listBox1 alanını Kategori alanıyla karşılaştırdığından emin olmak için ikinci liste kutusunun filtresini inceleyin.

Bölüm başı

Dış XML belgesine bağlanma

Bu bölümde, ürün ve kategori değerleri içeren bir XML belgesi veri bağlantısı oluşturmak öğreneceksiniz. XML belgesi ikincil veri kaynağınız olacaktır. Bu veri bağlantısı oluşturmak için XML belgesi oluşturma, form şablonunda liste kutuları XML belgesi ile ilişkilendirmeniz ve böylece ürün listesinin uygun şekilde değişir ikinci liste kutusuna filtre uygulama gerekir.

Bir ikincil veri kaynağı ile form ilişkilendirebilirsiniz önce XML belgesi oluşturmanız gerekir.

XML belgesi oluşturma

  1. Not Defteri veya başka bir metin Düzenleyicisi'ni başlatın.

  2. Aşağıdaki XML verilerini kopyalayıp metin düzenleyicisine yapıştırın:

    <?xml version="1.0" encoding="UTF-8"?>
    <ListBoxData>
    <CategoriesAndProducts>
    <Categories>Seafood</Categories>
    <Products>
    <Product>Crab meat</Product>
    </Products>
    <Products>
    <Product>Salmon</Product>
    </Products>
    </CategoriesAndProducts>
    <CategoriesAndProducts>
    <Categories>Dairy</Categories>
    <Products>
    <Product>Chocolate milk</Product>
    </Products>
    <Products>
    <Product>Cheddar</Product>
    </Products>
    </CategoriesAndProducts>
    </ListBoxData>
  3. Bilgisayarınızdaki dosyayı listBoxData.xmlkaydedin.

XML belgesi oluşturduysanız, form şablonuna bağlanabilirsiniz. Bu ikincil veri kaynağı oluşturur.

Form şablonuna XML belgesi bağlanma

  1. Araçlar menüsünde Veri Bağlantıları'nı tıklatın.

  2. Veri Bağlantıları iletişim kutusunda Ekle'yi tıklatın.

  3. Veri Bağlantı Sihirbazı'nda Veri al'ı, ardından İleri'yi tıklatın.

  4. Sihirbazın sonraki sayfasında, XML belgesi seçeneğini, ardından da İleri'yi tıklatın.

  5. Sihirbazın sonraki sayfasında, Gözat' ı tıklatın, bilgisayarınıza kaydettiğiniz listBoxData.xml dosyayı seçin ve ' ı tıklatın.

  6. Sihirbazın sonraki sayfasında, veri kaynağı dosyası form şablonuna veya şablon parçası olarak Ekle' ı tıklatın ve sonra İleri' yi tıklatın.

  7. Bu veri bağlantısı için bir ad girin kutusuna, sihirbazın sonraki sayfasında listBoxDataXMLFileyazın.

  8. Form açıldığında verileri otomatik olarak Al onay kutusunu seçin. Bu liste kutusu veri formu açıldığında, sorgu kullanıcıya gerek kalmadan yerine her zaman kullanılabilir durumda olmasını sağlar.

  9. Son'u tıklatın.

  10. Veri Bağlantıları iletişim kutusunda Kapat'ı tıklatın.

Form şablonu ilk liste kutusunda XML belgesindeki verileri bağlanmak artık hazırsınız.

İlk liste kutusunu verilere bağlanma

  1. Form şablonunda, önceden eklediğiniz açılır liste kutusunu çift tıklatın.

  2. Veri sekmesini tıklatın.

  3. Açılan liste kutusu özellikleri iletişim kutusunda, liste kutusu girdileri'ninaltında değerleri dış veri kaynağından Ara' yı tıklatın.

  4. Veri kaynağı kutusunda listBoxDataXMLFiletıklatın.

  5. Girdiler kutusunun yanındaki XPath Seç düğme görüntüsü simgesini tıklatın.

  6. Alan veya Grup Seç iletişim kutusunda, KategorilerVeÜrünler grubunda, Kategori alanı tıklatın.

    Not : Alan veya Grup Seç iletişim kutusundaki sarı arka plan ikincil veri kaynağıyla çalıştığınızı gösterir.

  7. İki kez Tamam'ı tıklatın.

Şimdi ikinci liste kutusunu XML belgesine bağlanma gerekecektir. Bu veri bağlantısını yaparken, ikinci liste kutusuna filtre uygulamak istediğiniz. Bu filtre ilk liste kutusunda seçilen kategoriye göre uygun ürünleriyle ikinci liste kutusunu doldurmak. Filtreyi ilk liste kutusunda (listBox1 alanı) listesiyle (Kategori alanı) biçiminde kaydettiğiniz kategorilerinin seçilen değer karşılaştırır.

İkinci liste kutusunu verilere bağlanma

  1. Form şablonunda, önceden eklediğiniz standart liste kutusunu çift tıklatın.

  2. Veri sekmesini tıklatın.

  3. Liste kutusu özellikleri iletişim kutusunda, liste kutusu girdileri'ninaltında değerleri dış veri kaynağından Ara' yı tıklatın.

  4. Veri kaynağı kutusunda listBoxDataXMLFiletıklatın.

  5. Girdiler kutusunun yanındaki XPath Seç düğme görüntüsü simgesini tıklatın.

  6. Alan veya Grup Seç iletişim kutusunda, KategorilerVeÜrünler grubunda Ürünler grubu genişletin ve sonra Ürün alanını tıklatın.

  7. Veriye Filtre Uygula seçeneğini tıklatın.

  8. Veriye Filtre Uygula iletişim kutusunda Ekle'yi tıklatın.

  9. Filtre Koşullarını Belirle iletişim kutusunda, ilk kutuda alan veya Grup Seç ' i tıklatın.

  10. Veri kaynağı kutusunda, alan veya Grup Seç iletişim kutusunda, ana' ı tıklatın.

  11. listBox1'i tıklatın ve sonra Tamam'ı tıklatın.

  12. Filtre Koşullarını Belirle iletişim kutusunda, üçüncü kutusunda bir alan veya Grup Seç ' i tıklatın.

  13. Alan veya Grup Seç iletişim kutusunda, veri kaynağını kutusunda listBoxDataXMLFile (ikincil)tıklatın ve ardından Kategoriler'itıklatın.

  14. Tüm açık iletişim kutularını kapatmak için Tamam'ı tıklatın.

İkinci liste kutusunu XML belgesine bağlı ve filtre uygulanmış olduğunu, bunların düzgün çalıştığından emin olmak için liste kutuları sınamaya hazırsınız.

Liste kutuları test etme

  1. Yaptığınız değişiklikleri test etmek için, Standart araç çubuğunda Önizleme’ye tıklayın veya CTRL+SHIFT+B tuşlarına basın.

  2. Açılan liste kutusunda, Deniz ürünleri' ı tıklatın. Standart liste kutusunda yalnızca bir boş satır, Yengeç ve SOM göstermelidir.

    Not : Boş satır kullanıcıların kendi seçim liste kutusundan temizleyin olanak tanır.

Liste kutuları düzgün çalışmazsa, ikinci liste kutusunun listBox1 alanını Kategori alanıyla karşılaştırdığından emin olmak için ikinci liste kutusunun filtresini inceleyin.

Bölüm başı

Veritabanına bağlanma

Bu bölümde, Access veritabanında iki tablodan veri bağlantısı oluşturmak öğreneceksiniz. Bunu yapmak için form şablonunda liste kutuları veritabanı ile ilişkilendirmeniz ve böylece ikinci liste kutusu değişiklikleri uygun şekilde görüntülenen listede ilk liste kutusunda seçilen değer temel ikinci liste kutusuna filtre uygulayın. Bu örnekte, biz Access veritabanını kategoriler ve ürünler adlı iki tablo içerdiğinden ve iki tablo birbirine her tablosunda kullanılan CategoryID alanına göre ilişkili olduğunu varsayar.

Kategoriler tablosu   

KategoriNo

CategoryName

1

Seafood

2

Süt Ürünleri

Ürünler tablosu   

ProductID

KategoriNo

ÜrünAdı

1

1

' Nin et ürünleri

2

1

SOM

3

2

Çikolata sütlü

4

2

Kaşar Peyniri

Form şablonunun veri kaynağına bağlanma

İlk olarak, form şablonu ve tablolar arasında bir veri bağlantısı veritabanında oluşturmanız gerekir. Veritabanından verileri doğrudan, değiştirmek yerine, yalnızca görüntülediğinizden Access veritabanını form şablonu için ikincil veri kaynağı olacaktır.

  1. Araçlar menüsünde Veri Bağlantıları'nı tıklatın.

  2. Veri Bağlantıları iletişim kutusunda Ekle'yi tıklatın.

  3. Veri Bağlantı Sihirbazı'nda Veri al'ı, ardından İleri'yi tıklatın.

  4. Sihirbazın bir sonraki sayfasında, Veritabanı (Yalnızca Microsoft SQL Server veya Microsoft Office Access) seçeneğini ve ardından İleri'yi tıklatın.

  5. Sihirbazın sonraki sayfasında, Veritabanı Seç' i tıklatın ve sonra göz atın ve sabit diskinizde Access veritabanını çift tıklatın.

  6. Tablo Seç iletişim kutusunda, ilk listesinde (Bu örnekte, Kategoriler tablosuyla) göstermek istediğiniz verileri içeren tabloyu tıklatın ve sonra da Tamam' ı tıklatın. Bu tabloyu veri bağlantısı için birincil tablo olarak belirler.

  7. Sihirbazda, Tablo Ekle'yi tıklatın.

  8. Tablo veya Sorgu Ekle iletişim kutusunda, ikinci listesinde (Bu örnekte, ürünler tablosunu) göstermek istediğiniz verileri içeren tabloyu tıklatın ve sonra İleri' yi tıklatın.

  9. İlişkileri Düzenle iletişim kutusunda, bağlantı alanının doğru olduğundan emin olun. Bu örnekte, tablolar KategoriKimliği alana göre birbiriyle ilişkilidir.

    İpucu : Bağlantı alanları yanlış ise, alanları seçin ve sonra İlişki Kaldır'ıtıklatın. Ardından, İlişki Ekle'ıtıklatın, doğru alanları seçin ve Tamam' ı tıklatın.

  10. Son'u tıklatın.

    Not : Bu örnekte, kategorileri tablo her bir kategori için olabileceğini birçok ürün gelir ürünler tablosuyla bir-çok ilişkisi vardır. Veritabanında, anahtar alanlarını kullanarak bu tür bir ilişki genellikle kurulur. Bu durumda, KategoriKimliği anahtar alanını doğru ürün grubunu uygun kategoriyle ilişkilendirmek erişim sağlar.

  11. Sihirbazda, veri kaynağının yapısını gözden geçirin. Birbirine bağlı iki tablo görmelisiniz: tablonun birincil ve ikincil tablo. Tablodaki tek tek alanları görmek için Tablo Sütunları Göster onay kutusunu seçin. Veri yapısı gözden geçirmeyi bitirdiğinizde, İleri' yi tıklatın.

  12. Form şablonunda verilerin bir kopyasını depola onay kutusunu temizleyin ve İleri'yi tıklatın.

  13. Bu veri bağlantısı için bir ad girin kutusuna sihirbazın sonraki sayfasında, veri bağlantısı için bir ad yazın.

  14. Form açıldığında verileri otomatik olarak al onay kutusunu seçin.

  15. Son'utıklatın ve sonra Kapat iletişim kutusunda Veri bağlantıları tıklatın.

İlk liste kutusunu verilere bağlanma

İkincil veri kaynağı için bir veri bağlantısı oluşturduysanız, form şablonu ilk liste kutusunda veritabanındaki tabloları bağlanabilirsiniz.

  1. Form şablonunda, daha önce eklediğiniz açılır liste kutusunu çift tıklatın.

  2. Veri sekmesini tıklatın.

  3. Açılan liste kutusu özellikleri iletişim kutusunda, liste kutusu girdileri'ninaltında değerleri dış veri kaynağından Ara' yı tıklatın.

  4. Veri kaynağı kutusunda, oluşturduğunuz veri bağlantısı seçili olduğundan emin olun.

  5. Girdiler kutusunun yanındaki XPath Seç düğme görüntüsü simgesini tıklatın.

  6. Alan veya Grup Seç iletişim kutusunda, aşağı açılan listesinde (Bu örnekte, d: Kategoriler ) göstermek istediğiniz verileri içeren tablonun adını tıklatın ve sonra da Tamam' ı tıklatın.

    Not : Alan veya Grup Seç iletişim kutusundaki sarı arka plan ikincil veri kaynağıyla çalıştığınızı gösterir.

  7. Değer kutusunun yanındaki düğme görüntüsü XPath Seç' i tıklatın.

  8. Alan veya Grup Seç iletişim kutusunda, emin olun bağlantı alanı (Bu örnekte, : KategoriKimliği) seçilir ve ardından Tamam' ı tıklatın. Bu kullanıcıyı bir seçim liste kutusunda yaptığında kaydedilecek değerdir.

  9. Görünen ad kutusunun yanındaki düğme görüntüsü XPath Seç' i tıklatın.

  10. Alan veya Grup Seç iletişim kutusunda, açılan listede görüntülenmesini istediğiniz alanın adını tıklatın (Bu örnekte, : CategoryName).

  11. İki kez Tamam'ı tıklatın.

İkinci liste kutusunu verilere bağlanma

Şimdi, ikinci liste kutusunu veritabanına bağlanmak gerekir. Bu veri bağlantısını yaparken, ikinci liste kutusuna filtre uygulamak istediğiniz. Bu filtre ilk liste kutusunda seçili olan değeri temelinde uygun değerlerle, ikinci liste kutusunu doldurmak.

  1. Form şablonunda standart liste kutusunu çift tıklatın.

  2. Veri sekmesini tıklatın.

  3. Liste kutusu özellikleri iletişim kutusunda, liste kutusu girdileri'ninaltında değerleri dış veri kaynağından Ara' yı tıklatın.

  4. Veri kaynağı kutusunda, oluşturduğunuz veri bağlantısı seçili olduğundan emin olun.

  5. Girdiler kutusunun yanındaki XPath Seç düğme görüntüsü simgesini tıklatın.

  6. Alan veya Grup Seç iletişim kutusunda (Bu örnekte, d: Kategoriler) birincil grubu genişletin ve sonra basamaklı liste kutusunda (Bu örnekte, Ürünler) görüntülenmesini istediğiniz verileri içeren tablonun karşılık gelen ikincil grubu tıklatın.

  7. Veriye Filtre Uygula seçeneğini tıklatın.

  8. Veriye Filtre Uygula iletişim kutusunda Ekle'yi tıklatın.

  9. Filtre Koşullarını Belirle iletişim kutusunda, ilk kutusunda (Bu örnekte, Ürünler), ikincil tablosundan bağlantı alanı seçili olduğundan emin olun.

    Önemli : Bağlantı alanları her iki tabloda da aynı ada sahip, doğrusunu seçtiğinizden emin olun. Her tablonun alanlarını listede birlikte sıralanır. Bu nedenle, çevresindeki alan adlarını doğrusunu türünü saptamak için kullanabilirsiniz. Bu örnekte, biz Ürünler tablosundan görünen KategoriKimliği alanın diğer alanlara sahip seçin.

  10. Üçüncü kutuda, Alan veya grup seçin seçeneğini tıklatın.

  11. Veri kaynağı kutusunda, alan veya Grup Seç iletişim kutusunda, anatıklatın, listBox1 alanını tıklatın ve sonra da Tamam' ı tıklatın.

    Standart liste kutusunda değerlerin listesi ile açılan liste kutusunda (listBox1 alanı) seçilen değerle karşılaştıran filtre şimdi yapılandırdınız.

  12. Liste Kutusu Özellikleri iletişim kutusuna dönmek için Tamam'ı üç kez tıklatın.

  13. Değer kutusunun yanındaki düğme görüntüsü XPath Seç' i tıklatın.

  14. Alan veya Grup Seç iletişim kutusunda, kullanıcı liste kutusunda bir seçim yaptığında kaydetmek istediğiniz değeri seçin. Bu örnekte, Ürünkimliği alanı daha sonra kullanmak üzere kaydetmek istiyoruz. Bu nedenle biz seçeneğini : Ürünkimliği gruplandırma ve sonra da Tamam' ı tıklatın.

  15. Görünen ad kutusunun yanındaki düğme görüntüsü XPath Seç' i tıklatın.

  16. Alan veya Grup Seç iletişim kutusunda, liste kutusunda göstermek istediğiniz alanın adını tıklatın (Bu örnekte, : ProductName).

  17. İki kez Tamam'ı tıklatın.

Liste kutuları test etme

Artık ikinci liste kutusunu veritabanına bağlamış ve filtre uygulamış olduğunuzdan, doğru çalıştıklarını görmek için liste kutularını sınayabilirsiniz.

  1. Yaptığınız değişiklikleri test etmek için, Standart araç çubuğunda Önizleme’ye tıklayın veya CTRL+SHIFT+B tuşlarına basın.

  2. Açılan liste kutusunda bir değer seçin. Standart liste kutusunda seçtiğiniz bağlantı alanı bağlı olarak ikincil tablosundan uygun değerleri göstermelidir.

İpucu : Liste kutuları düzgün çalışmazsa, ikinci liste kutusu için filtrenin listBox1 alanını CategoryID alanıyla karşılaştırdığından emin olun.

Bölüm başı

Sayfanın Başı

Not : Makine Çevirisi Yasal Uyarısı: Bu makale, insan müdahalesi olmadan bir bilgisayar sistemi tarafından çevrilmiştir. Microsoft bu makine çevirilerini İngilizce bilmeyen kullanıcıların Microsoft ürünleri, hizmetleri ve teknolojileriyle ilgili içeriklerden yararlanmasına yardımcı olmak için sunar. Bu makale makine çevirisi olduğundan sözcük, cümle dizilimi ve gramer hataları içerebilir.

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×