Başka bir çalışma kitabındaki bir hücreye dış başvuru (bağlantı) oluşturma

Dış başvuru oluşturarak başka bir çalışma kitabındaki hücre içeriklerine başvuruda bulunabilirsiniz. Dış başvuru (bağlantı olarak da bilinir), başka bir Excel çalışma kitabında bulunan çalışma sayfasındaki bir hücreye veya aralığa yönelik veya başka bir çalışma kitabındaki tanımlanmış bir ada yönelik başvurudur. Bir hücreye veya aynı çalışma kitabındaki bir hücre aralığına ya da başka bir çalışma kitabındaki bir hücre veya hücre aralığına bağlantı oluşturabilirsiniz. Belirli hücre aralığına, hücre aralığının tanımlanmış adına başvuruda bulunabilir veya dış başvuru için bir ad tanımlayabilirsiniz.

Ne yapmak istiyorsunuz?

Dış başvurular hakkında daha fazla bilgi edinin

Farklı çalışma kitaplarındaki hücreler arasında dış başvuru oluşturma

Başka bir çalışma kitabındaki tanımlı ada bir dış başvuru oluşturma

Başka bir çalışma kitabındaki hücrelere yönelik dış başvuru içeren bir ad tanımlama

Dış başvurular hakkında daha fazla bilgi edinme

Dış başvurularla hücre başvurularının benzer olmasına rağmen, önemli farklılıklar bulunmaktadır. Dış başvuruları, büyük hacimdeki verilerle veya birkaç çalışma kitabına yayılmış karmaşık formüllerle çalışırken kullanırsınız. Dış başvuruları farklı bir yolla oluşturursunuz ve bunlar hücre içerisinde veya formül çubuğunda farklı görünürler.

Dış başvuruların etkin kullanıldığı yerler

Büyük çalışma sayfası modellerini aynı çalışma kitabında tutmanın kullanışlı olmadığı durumlarda, dış başvurular özellikle yararlıdır.

  • Birden fazla çalışma kitabındaki verileri birleştirme      Birçok kullanıcının veya bölümün çalışma kitapları arasında bağlantı kurabilir ve sonra kalıcı verileri bir özet çalışma kitabında tümleştirebilirsiniz. Böylece, kaynak çalışma kitapları değiştirildiğinde, özet çalışma kitabını el ile değiştirmeniz gerekmez.

  • Verilerinizin farklı görünümlerini oluşturma    Verilerinizin tümünü bir veya daha çok kaynak çalışma kitabına girebilir ve sonra yalnızca kalıcı verilere dış başvurular içeren bir rapor çalışma kitabı oluşturabilirsiniz.

  • Büyük, karmaşık modelleri yükleme    Karmaşık bir modeli, bağımsız bir çalışma kitapları serisine bölerek, model üzerinde, ilgili bütün sayfalarını açmadan çalışabilirsiniz. Küçük çalışma kitaplarını değiştirmek daha kolaydır, çok fazla bellek gerektirmezler ve daha hızlı açılabilir, kaydedilebilir ve hesaplanabilirler.

Dış başvuru oluşturma yolları

Dış başvuru oluşturmak için hücre başvurusu kullanırsanız, bilgilere formül de uygulayabilirsiniz. Çeşitli hücre başvuru türleri arasında geçiş yaparak, dış başvuruyu taşıdığınızda hangi hücrelere bağlanılacağını da denetleyebilirsiniz. Örneğin bir göreli başvuru kullanırsanız, dış başvuruyu taşıdığınızda, bunun bağlı olduğu hücre veya hücreler, çalışma sayfasındaki yeni konumlarını yansıtacak şekilde değişir.

Bir çalışma kitabından diğerine dış başvuru oluşturduğunuzda, bağlantı kurduğunuz hücrelere başvuruda bulunmak üzere bir ad kullanmanız gerekir. Önceden tanımlanmış bir ad kullanarak bir dış başvuru oluşturabilir veya dış başvuruyu oluştururken adı tanımlayabilirsiniz. Bir ad kullandığınızda bağlantı kurmakta olduğunuz hücrelerin içeriğini hatırlamak daha kolay olacaktır. Tanımlanmış adların kullanıldığı dış başvurular taşınsalar dahi değişmezler, çünkü ad belirli bir hücre veya hücre aralığını temsil eder. Tanımlanmış adın kullanıldığı bir dış başvurunun taşınırken değişmesini istiyorsanız, dış başvuruda kullanılan adı veya adın temsil ettiği hücreleri değiştirebilirsiniz.

Başka bir çalışma kitabına yönelik dış başvurunun görünümü

Diğer çalışma kitaplarına dış başvurular içeren formüller, kaynak çalışma kitabının (formüle veri sağlayan çalışma kitabı) açık veya kapalı olmasına bağlı olarak iki ayrı biçimde görüntülenir.  

Kaynak açık olduğunda, dış başvuru köşeli parantez ([ ]) içinde çalışma kitabı adını içerir, bunu çalışma sayfası adı, bir ünlem işareti (!) ve formülün bağlı olduğu hücreler izler. Örneğin aşağıdaki formül, Bütçe.xls adlı çalışma kitabındaki C10:C25 arasındaki hücreleri toplar.

Dış başvuru

=TOPLA([Bütçe.xlsx]Yıllık!C10:C25).

Kaynak açık değilse, dış başvuru tüm yolu içerir.

Dış başvuru

=TOPLA('C:\Raporlar\[Bütçe.xlsx]Yıllık'!C10:C25)

Not : Diğer çalışma sayfasının veya çalışma kitabının adı alfabetik olmayan karakter içeriyorsa, adı (veya yolu) çift tırnak işareti arasına almanız gerekir.

Başka bir çalışma kitabındaki tanımlı adbağlantı kuran formüller, ardında bir ünlem işareti (!) ile birlikte çalışma kitabının adını ve adı kullanır. Örneğin aşağıdaki formül, Bütçe.xlsx adlı çalışma kitabının Satışlar adlı aralığındaki hücreleri toplar.

Dış başvuru

=TOPLA(Bütçe.xlsx!Satışlar)

Sayfanın Başı

Farklı çalışma kitaplarındaki hücreler arasında dış başvuru oluşturma

  1. Dış başvuruyu içeren çalışma kitabını (hedef çalışma kitabı) ve bağlantı kurmak istediğiniz veriyi içeren çalışma kitabını (kaynak çalışma kitabı) açın.

  2. Kaynak çalışma kitabında, Hızlı Erişim Araç Çubuğu'ndan Kaydet Düğme görüntüsü ’e tıklayın.

  3. İçerisinde dış başvuru oluşturmak istediğiniz hücre veya hücreleri seçin.

  4. = (eşittir işareti) yazın. Dış başvuru değerinde hesaplama veya işlev gerçekleştirmek isterseniz, dış başvurudan önce gelmesini istediğiniz işleç veya işlevi yazın.

  5. Kaynak çalışma kitabına geçin ve sonra bağlantı kurmak istediğiniz hücreleri içeren çalışma sayfasını tıklatın.

  6. Bağlanmak istediğiniz hücre veya hücreleri seçin.

  7. Hedef çalışma kitabına geri dönün ve Excel'in başvuruları kaynak çalışma kitabına ve bir önceki adımda seçtiğiniz hücrelere eklediğinden emin olun.

  8. İsterseniz, hedef çalışma sayfasında formülü düzenleyin veya değiştirin.

  9. CTRL+SHIFT+ENTER tuşlarına basın.

Sayfanın Başı

Başka bir çalışma kitabındaki tanımlanmış ada bir dış başvuru oluşturma

  1. Dış başvuruyu içeren çalışma kitabını (hedef çalışma kitabı) ve bağlantı kurmak istediğiniz veriyi içeren çalışma kitabını (kaynak çalışma kitabı) açın.

  2. Kaynak çalışma kitabında, Hızlı Erişim Araç Çubuğu'ndan Kaydet Düğme görüntüsü ’e tıklayın.

  3. İçerisinde dış başvuru oluşturmak istediğiniz hücre veya hücreleri seçin.

  4. = (eşittir işareti) girin. Dış başvuru değerinde hesaplama veya işlev gerçekleştirmek isterseniz, dış başvurudan önce gelmesini istediğiniz işleci veya işlevi yazın.

  5. Görünüm sekmesinde, Pencere grubunda Pencereleri Değiştir seçeneğini tıklatın, kaynak çalışma kitabını ve sonra bağlantı kurmak istediğiniz hücreleri içeren çalışma sayfasını tıklatın.

    Görünüm sekmesindeki Pencere grubu

  6. F3 tuşuna basın ve ardından bağlamak istediğiniz adı seçin.

Sayfanın Başı

Başka çalışma sayfasındaki hücrelere yönelik dış başvuru içeren bir ad tanımlama

  1. Hedef çalışma kitabını ve kaynak çalışma kitabını açın.

  2. Hedef çalışma kitabında, Formüller sekmesinin Tanımlı Adlar grubunda Ad Tanımla'yı tıklatın.

    Excel Şerit resmi

  3. Yeni Ad iletişim kutusunda, Ad kutusuna aralık için bir ad yazın.

  4. Başvuru yeri kutusunda, içeriği silip ekleme imlecini kutuda tutun.

    Ad bir formül içeriyorsa, formülü yazın ve imleci, dış başvurunun olmasını istediğiniz yere konumlayın. Örneğin,=TOPLA() yazın ve imleci ayraçların arasına konumlayın.

  5. Görünüm sekmesinde, Pencere grubunda Pencereleri Değiştir seçeneğini tıklatın, kaynak çalışma kitabını ve sonra bağlantı kurmak istediğiniz hücreleri içeren çalışma sayfasını tıklatın.

    Görünüm sekmesindeki Pencere grubu

  6. Bağlanmak istediğiniz hücre veya hücre aralığını seçin.

  7. Yeni Ad iletişim kutusunda Tamam'ı tıklatın.

Sayfanın Başı

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×